Asus RT-AC1750 - New/locked down version of RT-AC66U?

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
SleepyBum
DD-WRT Novice


Joined: 10 Nov 2014
Posts: 26

PostPosted: Sun May 29, 2016 11:05    Post subject: Asus RT-AC1750 - New/locked down version of RT-AC66U? Reply with quote
Picked this up while out shopping at a retail store. Thought I was buying a RT-AC66U, but it looks like the new locked down versions have started shipping with a new box and model number for the retail version RT-AC66R?. It doesn't mention RT-AC66U at all except for the FCC ID/IC ID, which is still the same.

The web config page shows:

Product ID RT-AC1750
Firmware Version 3.0.0.4.378_9533-g2949056

The box label states H/W Ver: B1
Made in 2016.

There's some talk of regular RT-AC66U, not accepting flash. Just wondering if this model is the exact same. nopper mentioned H/W Version: B0, though.

I did back up the cfe and took a look. These might be values of interest. Using a Zentel NAND flash as previously mentioned.
Code:
hw_version=1.5
bl_version=1.0.2.0
bootflags=1
nflash_swecc=1
serial_no=CAIxxxxxxxx1
model=RT-AC66U
ATEMODE=0
regulation_domain=US
regulation_domain_5G=Q2
wait_time=3
pci/2/1/regrev=33
odmpid=RT-AC1750
territory_code=US/02
Sponsor
SleepyBum
DD-WRT Novice


Joined: 10 Nov 2014
Posts: 26

PostPosted: Sun May 29, 2016 11:10    Post subject: Reply with quote
Still doing research, comparing cfe, before trying to downgrade.

Did some testing. Like the other thread reported, router will not accept any mainline BS dd-wrt builds. Flashing from stock fw admin page reports successful, but upon rebooting shows the Recovery Page.

I was able to successfully flash and run Kong's dd-wrt.v24_K3_AC.bin 25015-SP1 build and Shibby's TomatoUSB (RT-AC66U_RT-AC6x--132-VPN-64K) as previously reported. Had to do that from the Recovery Page. It would NOT flash from stock admin page as it would report unsuccessful, "incorrect image".

Hope the devs can figure out the new requirements for this new hardware/cfe version.



RT-AC1750 admin.png
 Description:
Stock admin config/firmware version
 Filesize:  342.87 KB
 Viewed:  17404 Time(s)

RT-AC1750 admin.png



AsusRT-AC1750_cfe.zip
 Description:
Asus RT-AC1750 CFE

Download
 Filename:  AsusRT-AC1750_cfe.zip
 Filesize:  115.85 KB
 Downloaded:  314 Time(s)


Asus RT-AC1750-startuplog.txt
 Description:
Startup log message

Download
 Filename:  Asus RT-AC1750-startuplog.txt
 Filesize:  7.72 KB
 Downloaded:  747 Time(s)

timxirish
DD-WRT Novice


Joined: 17 Sep 2009
Posts: 4

PostPosted: Tue Jun 06, 2017 6:31    Post subject: Reply with quote
Hi, stumbled upon this through Google while attempting to figure out how to get AsusWRT-Merlin flashed to my RT-AC1750. I'm not sure how much of use this post will be for DD-WRT users, but it certainly could be of use to a AsusWRT-Merlin user.

Like SleepyBum was able to do, I also was able to flash Shibby's TomatoUSB (RT-AC66U_RT-AC6x--132-VPN-64K) to my RT-AC1750 from Recovery. FYI for those who don't know, you enter Recovery mode by holding the reset button for at least 5 seconds, powering on the router and then releasing the reset button.

Unlike SleepyBum, my goal was different: to get AsusWRT-Merlin installed. Before I continue, I should make my order of operations clear.

My router came with FW version 3.0.0.4.378_9533. First step was to upgrade to a newer version of the official AsusWRT as a safety precaution. I did this due to a note I read on the AsusWRT-Merlin Wiki:

AsusWRT-Merlin Wiki wrote:
Starting with Asus's 3.0.0.4.380_3000 and upward, a new firmware format is used. To flash Asuswrt-Merlin on one of these newer firmwares, you will need 380.61 or newer. Likewise, downgrading to an older version is not supported (try firmware recovery mode if you really need to downgrade)


With that in mind, the first thing I did with this router was I flashed official AsusWRT 3.0.0.4.380.7266. Again, I did this as a safety precaution.

Currently the AsusWRT-Merlin Wiki recommends to "use the RT-AC68U firmware" for the RT-AC1750. So I tried flashing AsusWRT-Merlin RT-AC68U_380.66_4. I got an error message claiming that the firmware was invalid (or something of that nature), so I tried flashing from Recovery Mode... No luck. I decided that I might have more success if I flashed Shibby's TomatoUSB first.

I then entered Recovery Mode again and successfully flashed Shibby's TomatoUSB (RT-AC66U_RT-AC6x--132-VPN-64K) . It was successful, so I then once again tried to flash AsusWRT-Merlin RT-AC68U_380.66_4. TomatoUSB was kind enough to inform me that the file was too large. I thought that was a little bit strange. I shrugged it off until re-reading SleepyBum's first post in this thread.

Considering the FCC ID/IC ID is the same as the RT-AC66U, and also considering that the TomatoUSB build I flashed was an RT-AC66U/RT-AC6x build, I decided to enter Recovery Mode once more and flash the RT-AC66U build of AsusWRT-Merlin 380.66_4 to my RT-AC1750 (RT-AC66U_380.66_4). Success.

After the successful flash and subsequent reboot, I was welcomed to the AsusWRT-Merlin web interface, where it correctly identified my router model as a RT-AC1750. This RT-AC66U firmware idea didn't seem so bad after all.

Still, the stubborn side of me who CAN READ remembered what the AsusWRT-Merlin wiki said: "use the RT-AC68U firmware". So I finally decided to try to, once again, flash the RT-AC68U build of AsusWRT-Merlin 380.66_4 (RT-AC68U_380.66_4). I was thrown yet another error message saying the file was either too large or invalid.

At this point I have given up, but now have concluded that, unlike the AsusWRT-Merlin wiki states, the RT-AC1750 should use the RT-AC66U firmware and NOT the RT-AC68U firmware. I am on the latest version of AsusWRT-Merlin, it works, and it identifies properly as an RT-AC1750 on the web interface. I guess you could say I'm happy now.

I'm no expert/guru when it comes to routers and alternate firmwares, so forgive me if I've made any noob mistakes in my endeavors, but I certainly hope my information will help someone else like this information helped me. (regardless of which alternate firmware you desire)
Val D.
DD-WRT Novice


Joined: 09 Nov 2014
Posts: 3

PostPosted: Tue Aug 08, 2017 21:36    Post subject: Reply with quote
Asus RT-AC1750 comes in two hardware versions:

RT-AC1750 B1 = RT-AC66U B1 -> Merlin RT-AC68U firmware
RT-AC1750 = RT-AC66U -> Merlin RT-AC66U firmware

The newer B1 version is bigger, thicker and has 1 x USB 3.0 port at the front and 1 x USB 2.0 port at the back. It's a RT-AC68U similar hardware with dual core CPU. The older one is smaller, thinner and has 2 x USB 2.0 ports at the back. It's a RT-N66U similar hardware with single core CPU.

The newer B1 comes with 3 x non-removable antennas, the older one has 3 x removable antennas.

Hope this helps and prevents random firmware flashing.

BTW, RT-AC1750 B1 is in fact AC1900 router, just like RT-AC68U. It supports TurboQAM on 2.4GHz, so max 600MBps on 2.4GHz + max 1300Mbps on 5GHz = max 1900Mbps. Something ASUS don't want you to know about. Merlin firmware unlocks this feature.
kcsierradad
DD-WRT Novice


Joined: 10 Jul 2012
Posts: 1

PostPosted: Sun Jan 07, 2018 19:52    Post subject: Reply with quote
Thanks all for the RT AC1750 tutorial.
Flashed Asus-Merlin successfully from the the Asuswrt page(192.168.1.1) and used the recommended '66' firmware version 380.69. Now some Merlin-learnin'...
1BadBoy
DD-WRT Novice


Joined: 14 Nov 2012
Posts: 4

PostPosted: Sun Jul 19, 2020 9:49    Post subject: Reply with quote
Just a follow up as this thread is years old and others may still find it. I spent the last 2 days getting my Asus RT-AC1750_B1 installed and setup with AsusWRT-Merlin.

Based on the above instructions, I tried to use the "66" firmware as others before me. However, I was having trouble. Not sure what the issue was, but I could never get the firmware applied, and thought I had bricked the router. I finally tried the "68" firmware, and was successful getting it installed.

Though the 66 firmware may have worked for the initial installers above, that version did not work for me. If you find this thread, my suggestion is to try the 68 firmware first (I used "RT-AC68U_384.18_0").
Display posts from previous:    Page 1 of 1
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum