Can't enable Beamforming 5G WRT1200AC V1

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
alfaquillo
DD-WRT Novice


Joined: 30 Jun 2020
Posts: 1

PostPosted: Tue Jun 30, 2020 8:35    Post subject: Can't enable Beamforming 5G WRT1200AC V1 Reply with quote
Hi there.

I am trying to enable Beamforming on my router, but when i apply changes the radio changes the channel as Unknown.

There was a topic 2 years ago, but i see it didn't fix the problem.

I'm using v.43516 and tested with factory settings and it shown the same problem.


SU beamforming un-ticked in 5GHZ worked ok and broadcast with radio channel, but without range improvement technology.

Does anyone know how to fix the problem,bug, issue?
Sponsor
zakaron
DD-WRT User


Joined: 03 Jun 2016
Posts: 90

PostPosted: Wed Jul 01, 2020 19:44    Post subject: Reply with quote
Unfortunately I have not found a fix for this yet. I've been hopeful for a couple years now that maybe the next firmware will fix this, but it never does. If I want to use the 5GHz radio, I've learned to live with the fact that beamforming cannot be used. I've even tried a brand new clean config, but as soon as I turn beamforming on, the 5 radio channel goes to "unknown" and stops broadcasting. I have the same hardware as you, a 1200AC v1.

I once captured the following dmesg output when the radios are reset showing that ath0 (5GHz radio) goes into disabled state and never enters forwarding state like the rest of the interfaces:

[ 184.961790] br0: port 1(eth1) entered learning state
[ 198.725730] br1: port 1(ath0) entered blocking state
[ 198.730725] br1: port 1(ath0) entered disabled state
[ 198.735867] device ath0 entered promiscuous mode
[ 198.781834] device ath0 left promiscuous mode
[ 198.786236] br1: port 1(ath0) entered disabled state
[ 199.392068] br1: port 1(ath1) entered blocking state
[ 199.397071] br1: port 1(ath1) entered disabled state
[ 199.402219] device ath1 entered promiscuous mode
[ 199.630828] br1: port 1(ath1) entered blocking state
[ 199.635833] br1: port 1(ath1) entered forwarding state
[ 199.678530] br2: port 1(ath1.1) entered blocking state
[ 199.684167] br2: port 1(ath1.1) entered disabled state
[ 199.689472] device ath1.1 entered promiscuous mode
[ 199.747034] br2: port 1(ath1.1) entered blocking state
[ 199.752216] br2: port 1(ath1.1) entered forwarding state
[ 200.161807] br0: port 1(eth1) entered forwarding state
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum