New Build - 06-25-2020-r43516

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4
Author Message
paradoiley
DD-WRT Novice


Joined: 23 May 2020
Posts: 12

PostPosted: Sat Jul 04, 2020 13:21    Post subject: Re: RT-AC5300 Exp No 5GHz - I Lied a bit Reply with quote
paradoiley wrote:
Router/Version: ASUS RT-AC5300
File/Kernel: asus_rt-ac5300-firmware.trx
Previous/Reset: r43516 std (06-25-2020), reset
Mode/Status: AP
Issues/Errors: 5GHz Radios do not work
Firmware: DD-WRT v3.0-r43516 std (06/25/20)

I had this working with the standard build, but I was trying to solve some issues with VAPs that appear to be related to channel interference with my other routers.

The GUI says the radios are working, but a wireless scan shows that they are not, and no clients are connecting.

I have attached the dmesg log.


I played around with it a bit more.

Radio 1 will work if I set it to a narrower channel. HT40 will work if I have channel overlapping set to disable. HT20 works.

Radio 2 doesn't work.

Both radios work fine with the standard build, but I have other problems which I will ask about in a different thread.
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7181
Location: Texas, USA

PostPosted: Sat Jul 04, 2020 14:09    Post subject: Reply with quote
If you are not using the recommended wireless settings per the wiki, you are going to have issues. Disregard the Atheros/Ralink-MediaTek/Marvell-ized additions that are irrelevant.

https://wiki.dd-wrt.com/wiki/index.php/Basic_Wireless_Settings

https://wiki.dd-wrt.com/wiki/index.php/Advanced_wireless_settings

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
paradoiley
DD-WRT Novice


Joined: 23 May 2020
Posts: 12

PostPosted: Sat Jul 04, 2020 19:34    Post subject: Reply with quote
kernel-panic69 wrote:
If you are not using the recommended wireless settings per the wiki, you are going to have issues. Disregard the Atheros/Ralink-MediaTek/Marvell-ized additions that are irrelevant.

https://wiki.dd-wrt.com/wiki/index.php/Basic_Wireless_Settings

https://wiki.dd-wrt.com/wiki/index.php/Advanced_wireless_settings


I fiddled around a bit with the settings according to the links you provided.

I actually was just using the defaults. I even reset the router via nvram erase and rebooted. Only one of the 5 GHz radios came up.

I've switched back to the standard build. All three radios immediately came back up.

The one curiousity I have noticed is that vlan2 has a mac address of 00:00:00:00:00:01 and wl0/eth0 has a mac address of 00:00:00:00:00:02.

Now back to my original fight, which was to get vlans and vaps working on this machine. If I have trouble I'll create a new thread.

Thanks,
Jared
Steffen M.
DD-WRT Novice


Joined: 23 Jan 2008
Posts: 44
Location: Ulm, Germany

PostPosted: Sun Jul 05, 2020 9:33    Post subject: Reply with quote
Router/Version: 3 x Netgear R7000P and 2 x Netgear R7000
File/Kernel: netgear-r7000p-webflash.bin / netgear-r7000-webflash.bin
Previous/Reset: r43502 / no
Mode/Status: 1 R7000P acts as Gateway and AP, 2 x R7000P act as APs, 2 x R7000 act as Client-Bridge-APs.
Issues/Errors: Up 20 hours. All run stable.

There is one problem/error (which has been present for some time):

ip6tables does not know about the target "REJECT". While it is no problem to set a REJECT rule in "iptables", the IPv6 version "ip6tables" is only able to DROP or ACCEPT. Loading explicitly all IPv6 related Netfilter modules does not help, either. Interestingly, when doing a "strings /usr/sbin/ip6tables", one won't find any occurrence of REJECT, but in /usr/bin/iptables", there is. Maybe the ip6tables binary itself is incomplete or broken?
graemev
DD-WRT Novice


Joined: 18 Jun 2020
Posts: 15

PostPosted: Thu Jul 09, 2020 18:05    Post subject: Needed new CFE Reply with quote
After installing this my 5Ghz radio was fine but the 2.4Ghz was absent.

The solution was to install CFE 1.0.1.9 .

(I suspect simply a newer one would have worked)

Also, probably not an issue specific to this build, but certainly an older build [40599 ] did work (both Radios)
egosumumbravir
DD-WRT Novice


Joined: 19 Jun 2020
Posts: 15

PostPosted: Wed Jul 22, 2020 3:05    Post subject: Reply with quote
Possibly outdated, but are you sure you quite fixed the /jffs diskspace issue?



USB is setup with four partitions
/Optware (4g, EXT2)
/jffs (4g, EXT2)
[swap] (1g, SWAP)
/SAMBA (50G, FAT32)
Goto page Previous  1, 2, 3, 4 Display posts from previous:    Page 4 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum