Internet connection lost intermittently

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
tech2016
DD-WRT Novice


Joined: 14 Oct 2016
Posts: 23

PostPosted: Sat Jun 06, 2020 21:06    Post subject: Internet connection lost intermittently Reply with quote
DD-WRT v3.0-r43266 std (05/27/20)
TP-Link C1900 router

My tp-link router was working fine with Comcast 75mbps connection. I recently upgraded to ATT fiber gigabit service and I've been having intermittent internet connection issues. Multiple laptops in the house loose internet connection at the same time and then get it back few seconds later and it happens 5 or 6 times a day. Not sure whether this is caused by tp-link router or AT&T modem. How can I diagnose this issue further.
Sponsor
Wildlion
DD-WRT Guru


Joined: 24 May 2016
Posts: 811

PostPosted: Sun Jun 07, 2020 2:15    Post subject: Reply with quote
Have you checked the resource usage on the router?

Do you have any QOS on?

One thing to note is that sometimes ISPs will give you a burst of bandwidth initially and then level you off. THe intent is to get you the content quickly so it feels faster to you as well as get you off the connection for others.

Have you tried a speed test to see what the router's max is?

ISP modems have diagnostic pages you can check for uptimes and errors.
MichaelC
DD-WRT Novice


Joined: 11 Apr 2019
Posts: 18

PostPosted: Sun Jun 07, 2020 3:50    Post subject: Reply with quote
I've had a similar problem with my C1900 and haven't found a solution yet:

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=325083
tech2016
DD-WRT Novice


Joined: 14 Oct 2016
Posts: 23

PostPosted: Sun Jun 07, 2020 3:51    Post subject: Reply with quote
I'll check the cpu/memory usage next time it happens.

I enabled QoS and the problem still happened. I turned it off.

The ISP modem log shows messages like this-
192.168.2.63 23.199.248.27 TCP IP Source Address
23.199.250.75 70.252.19.41 TCP Generic Discards
192.168.10.65 17.253.3.209 TCP Invalid IP Packet
Most of the messages say 'Generic Discards' and some other messages. Not sure whether it indicates any issue with modem or these are expected normal messages.

I did speed test with fast.com on a desktop connected to router with ethernet and it showed download and upload speed of about 800mbps.

The speed test page on router itself showed internet speed of only 72Mbps which is strange.
I also did speed test using ISP modem and it showed 990mpbs.
WouldRatherBeFOSS
DD-WRT User


Joined: 09 Nov 2019
Posts: 86

PostPosted: Mon Jun 08, 2020 15:46    Post subject: Reply with quote
Compare perhaps this thread of mine.
_________________
My router: Asus RT-AC66U

Operating systems on devices that I use with that router: GNU-Linux; Windows 10; Android Lollipop
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 11472
Location: Wherever the wind blows- North America

PostPosted: Mon Jun 08, 2020 16:00    Post subject: Reply with quote
Recently, I had similar issues on my R7000. Here are the settings that fixed it for me.

redhawk


Setup>>Setup

Shortcut Forwarding Engine - DISABLED

Use DNSMasq for DNS - Checked
DHCP-Authoritative - Checked
Recursive DNS Resolving (Unbound) - Checked
Forced DNS Redirection - Checked

Services>>Services

SmartDNS Resolver - Enable
Dualstack IP Selection -Disable
Prefetch Domain -Enable
Serve Expired -Enable

_________________
I do NOT provide personal assistance through chat or phone....so please don't ask.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum