NTP broken - had to go back several months for working ver?

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
inetquestion
DD-WRT Novice


Joined: 24 Sep 2015
Posts: 20

PostPosted: Mon Jun 08, 2020 13:46    Post subject: NTP broken - had to go back several months for working ver? Reply with quote
Observed this was broken on build 43334, had to go all the way back to build 42681 to get NTP working again. Is this already on the radar to be fixed?

Did some wolf fencing with the versions and found it broke between these builds:

03-13-2020-r42681 (NTP Working)
...
04-10-2020-r42872 (NTP Broken)


Btw: This was on: Linksys WRT3200ACM


-Inet


Last edited by inetquestion on Mon Jun 08, 2020 13:52; edited 1 time in total
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6153
Location: Netherlands

PostPosted: Mon Jun 08, 2020 13:51    Post subject: Reply with quote
A lot of things depend on an accurate time so if it was really broken there would have been more reports.

It could be for your specific router type or your specific setup.

So enlighten us with your specific setup and syslog messages Smile

NTP works best if you leave it blank

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
inetquestion
DD-WRT Novice


Joined: 24 Sep 2015
Posts: 20

PostPosted: Mon Jun 08, 2020 13:55    Post subject: Reply with quote
Sorry, this is on a Linksys ACM3200..

I dont have access to the syslog where it is broken now that I'm on a different working version, but can goto a broken version to get them again if this helps. While it was broken, tried several NTP servers (google, Nist, apple)... After all those failed, started going back versions to find a working one.

Originally found this issue reported on redit while looking for a fix:

https://www.reddit.com/r/DDWRT/comments/gfjwll/ntp_issues_with_recent_version/
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6153
Location: Netherlands

PostPosted: Mon Jun 08, 2020 14:09    Post subject: Reply with quote
That poster mentions and R6400v1, I have one running usually upgrading when a new build arrives and have never had any problem.
But like I said, ntp works best if you use the built-in time server (so leave it blank).

So it can be something in your specific setup, I have seen some reports, if the router is setup as a bridge and local DNS and Gateway were not setup correctly and the WAN was not disabled that the router did not get the right time.

So therefore it helps if we know your specific setup Smile

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
inetquestion
DD-WRT Novice


Joined: 24 Sep 2015
Posts: 20

PostPosted: Mon Jun 08, 2020 14:44    Post subject: Reply with quote
Going to latest version, still fails with any user specified server. As you mentioned, it works leaving it blank. Leaving it blank is a work around, but something is actually broken if you cannot specify an NTP server. Will leave on this version for now if you would like additional debug info.


===Using build 43334 with NTP server: time.google.com (same result with other user specified servers)

Dec 31 19:01:03 apu-3200 daemon.err ntpclient[1681]: Failed resolving address to hostname time.google.com: Try again
Dec 31 19:01:03 apu-3200 daemon.err ntpclient[1681]: Failed resolving server time.google.com: Network is down
Dec 31 19:01:03 apu-3200 daemon.err process_monitor[1680]: cyclic NTP Update failed (servers time.google.com)
Dec 31 19:01:03 apu-3200 daemon.err process_monitor[1680]: Last update failed, we need to re-update after 30 seconds


===Using build 43334 with NTP server: <blank>
Dec 31 19:06:35 apu-3200 daemon.notice ntpclient[2405]: Network up, resolved address to hostname 212.18.3.19
Dec 31 19:06:35 apu-3200 daemon.debug ntpclient[2405]: Connecting to 212.18.3.19 [212.18.3.19] ...
Jun 8 10:39:22 apu-3200 daemon.info ntpclient[2405]: Time set from 212.18.3.19 [212.18.3.19].
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6153
Location: Netherlands

PostPosted: Mon Jun 08, 2020 14:53    Post subject: Reply with quote
Thanks I will look into, will run some tests also and make a bug report if necessary.
_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7178
Location: Texas, USA

PostPosted: Mon Jun 08, 2020 14:59    Post subject: Reply with quote
I'm about to reset my R9000 and re-configure client bridged (routed) from scratch again to test it. Not sure why it's balking on correct time with no user-specified NTP server.
_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6153
Location: Netherlands

PostPosted: Mon Jun 08, 2020 15:20    Post subject: Reply with quote
I have set a time server nearby and this one works:
Code:
root@R6400v2:~# grep -i ntp /var/log/messages
Jan  1 01:00:37 R6400v2 daemon.debug ntpclient[1719]: Connecting to nl.pool.ntp.org [129.250.35.251] ...
Jan  1 01:00:40 R6400v2 daemon.debug ntpclient[1719]: Timed out waiting for nl.pool.ntp.org [129.250.35.251].
Jan  1 01:00:40 R6400v2 daemon.err process_monitor[1718]: cyclic NTP Update failed (servers nl.pool.ntp.org)
Jan  1 01:00:40 R6400v2 daemon.info process_monitor[1718]: process_monitor : set timer: 3600 seconds, callback: ntp_main()
Jan  1 01:01:10 R6400v2 daemon.debug ntpclient[2005]: Connecting to nl.pool.ntp.org [37.218.247.55] ...
Jun  8 17:13:16 R6400v2 daemon.info ntpclient[2005]: Time set from nl.pool.ntp.org [37.218.247.55].
Jun  8 17:13:16 R6400v2 daemon.info process_monitor[1718]: cyclic NTP Update success (servers nl.pool.ntp.org)
Jun  8 17:13:17 R6400v2 daemon.info process_monitor[2096]: process_monitor : set timer: 3600 seconds, callback: ntp_main()
root@R6400v2:~#


I am a bit ahead build wise but I have not seen any commits about ntp
Code:
DD-WRT v3.0-r43365 Community Build (c) 2020 NewMedia-NET GmbH
Release: 06/08/20
Board: Netgear R6400 v2


Will test some more

This one also works:
Code:
root@R6400v2:~# grep -i ntp /var/log/messages
Jan  1 01:00:38 R6400v2 daemon.debug ntpclient[1722]: Connecting to ntp.time.nl [94.198.159.10] ...
Jun  8 17:24:37 R6400v2 daemon.info ntpclient[1722]: Time set from ntp.time.nl [94.198.159.10].
Jun  8 17:24:37 R6400v2 daemon.info process_monitor[1721]: cyclic NTP Update success (servers ntp.time.nl)
Jun  8 17:24:38 R6400v2 daemon.info process_monitor[1814]: process_monitor : set timer: 3600 seconds, callback: ntp_main()
root@R6400v2:~#


time.google.com also works:
Code:
root@R6400v2:~# grep -i ntp /var/log/messages
Jan  1 01:00:37 R6400v2 daemon.debug ntpclient[1719]: Connecting to time.google.com [216.239.35.8] ...
Jun  8 17:33:15 R6400v2 daemon.info ntpclient[1719]: Time set from time.google.com [216.239.35.8].
Jun  8 17:33:15 R6400v2 daemon.info process_monitor[1718]: cyclic NTP Update success (servers time.google.com)
Jun  8 17:33:15 R6400v2 daemon.info process_monitor[1811]: process_monitor : set timer: 3600 seconds, callback: ntp_main()
root@R6400v2:~#


So the problem must be something specific in your setup/router/?

Or it is just me using a different build Smile

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087


Last edited by egc on Mon Jun 08, 2020 15:38; edited 1 time in total
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7178
Location: Texas, USA

PostPosted: Mon Jun 08, 2020 15:34    Post subject: Reply with quote
On r43334, R9000, client bridged mode; process_monitor is not starting up. I have not checked in default configuration out-of-the-box. I had to add sleep 10; restart process monitor to my startup script for it to work and NTP to update with a blank server entry. I guess both issues need to be looked into.
_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
inetquestion
DD-WRT Novice


Joined: 24 Sep 2015
Posts: 20

PostPosted: Mon Jun 08, 2020 17:02    Post subject: Reply with quote
Seems this may be more specific to 3200ACM, as others have reported the issue with that model specifically. What additional information would you like to see to dig further?

With no server specified, I'm still seeing these occasionally. Shortly thereafter it starts working. There are other machines behind this router which also use the same NTP servers and those are working without issue.

Jun 8 12:39:31 apu-3200 daemon.err ntpclient[3337]: Failed resolving address to hostname 2.pool.ntp.org: Try again
Jun 8 12:39:31 apu-3200 daemon.err ntpclient[3337]: Failed resolving server 2.pool.ntp.org: Network is down
Jun 8 12:39:31 apu-3200 daemon.notice ntpclient[3337]: Network up, resolved address to hostname 212.18.3.19
Jun 8 12:39:31 apu-3200 daemon.debug ntpclient[3337]: Connecting to 212.18.3.19 [212.18.3.19] ...
Jun 8 12:39:30 apu-3200 daemon.info ntpclient[3337]: Time set from 212.18.3.19 [212.18.3.19].
Jun 8 12:39:30 apu-3200 daemon.info process_monitor[2560]: cyclic NTP Update success (servers 2.pool.ntp.org 212.18.3.19 88.99.174.22)
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7178
Location: Texas, USA

PostPosted: Mon Jun 08, 2020 17:40    Post subject: Reply with quote
The builds you are initially referring to might be during dnsmasq updates that may have resulted in DNS resolution issues - and DNS resolution issues aren't necessarily that something is "broken", per se. I've had those messages before, but NTP wasn't "broken". The situation I am referring to on my R9000 is the time is completely wrong, like it half-ass syncs to an 18:00 time, no matter what time of day or night it is.

I'm more curious about how your 3200 is configured, specifically DNS/dnsmasq. I only have one set of the failed resolving messages prior to NTP update on my E4200v1. I don't have my R7800 up at the moment, nor my R7000P, for comparison.

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
inetquestion
DD-WRT Novice


Joined: 24 Sep 2015
Posts: 20

PostPosted: Mon Jun 08, 2020 18:14    Post subject: Reply with quote
Settings attached...
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Tue Jun 09, 2020 6:22    Post subject: Reply with quote
inetquestion wrote:
Failed resolving address to hostname


as you can see by yourself, your problem is not NTP but DNS...

I strongly suggest you to use IP adress of NTP servers instead of hostname... problem can occur if your DNS server needs correct time because of lets say certificates, and it is not up and running and your ntp client tries first to resolves hostname... but your NS is not up...
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6153
Location: Netherlands

PostPosted: Tue Jun 09, 2020 7:11    Post subject: Reply with quote
Indeed, "Use DNSMAsq for DNS" is disabled that might explain it?
_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
inetquestion
DD-WRT Novice


Joined: 24 Sep 2015
Posts: 20

PostPosted: Wed Jun 10, 2020 13:07    Post subject: Reply with quote
Thank you for the investigation, recommendations, and clarification. Enabled dnsmasq and am able to specify a time server accordingly without any issues.

Admittedly only come here when experiencing a problem, curious if there is a sticky for recommended best practices for setup/config in one place? found this one, but asking if there is a more comprehensive set...

https://wiki.dd-wrt.com/wiki/index.php/Basic_Wireless_Settings

Thanks again!
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum