[Solved] RCS not working using DD-WRT

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
buffpatel
DD-WRT User


Joined: 22 Feb 2011
Posts: 100

PostPosted: Wed Sep 16, 2020 12:31    Post subject: [Solved] RCS not working using DD-WRT Reply with quote
Hello,

I have an android phone and am using the Google messages application for texting. I have RCS (Relay Chat Service) enabled on my phone and have gotten it to work everywhere except in my house when I'm connected to my DD-WRT router (R8000 and running 9/10/20 build: R44340). What's crazy is if I turn off wifi on my phone (and it switches to mobile data), then RCS works immediately. As soon as I enable wifi and connect to my DD-WRT network, RCS just says "Connection in progress" for its status. My phone's RCS also works when on other wifi networks, hotspots, etc... so I think it's more of a configuration issue with my router.

I wanted to see if anyone has RCS enabled on their phone and has gotten it to work while on their wifi. Did you have to do any special configuration? Modify your firewall? I searched numerous forums and googled a ton without much luck on this issue. The closest thing I found was this post that mentioned open-wrt firewalls causing issues with RCS and it had a solution of turning off a filter in the firewall.

https://support.google.com/messages/thread/11640370?hl=en

After reading that, I disabled the SPI firewall on my router, but RCS still did not work. So I'm not sure what else to try, and that's why I posted this message. Fingers crossed someone out there is able to help!

Thanks in advance!


PS - For people who aren't familiar, RCS is a service that allows people without iPhones to have a similar experience to iMessage (with a typing indicator, Read notifications, etc...) and to also send messages through a wifi connection. If you have an Android phone, you can google "Enable RCS Android" and find guides that can help you enable this really cool feature on your phone. I personally used this guide to get it working:

https://lifehacker.com/how-to-manually-enable-rcs-on-android-right-now-update-1839416118
Sponsor
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3858
Location: UK, London, just across the river..

PostPosted: Wed Sep 16, 2020 18:38    Post subject: Reply with quote
the only thing that comes to my mind is, if you use an ad-blocker than turn it off, or on wi-fi settings AP isolation is turned on...

on those links you provided, there are some recommendations to open particular ports... port 5061 (SIP) and 2856 (MSRP) for Samsung users, while the others ware migrated to port 443...

if turning off SPI is not solving the issue, than its a firmware bug, i guess.... try any older builds, like form 6 months or year ago, to narrow down the problem...to be honest RCS messages are not my best knowledge of...
may be someone else will chime in...
in fact RCS seems to be a common issue...

_________________
Atheros
TP-Link WR740Nv1 -----DD-WRT 44538 BS AP,NAT
TP-Link WR740Nv4 -----DD-WRT 44251 BS WAP/Switch
TP-Link WR1043NDv2 ---DD-WRT 44538 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---DD-WRT 44538 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT,VPN,VLAN
TP-Link WR1043NDv2 ---Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -----DD-WRT 44538 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -----DD-WRT 44538 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
-----------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6362
Location: Netherlands

PostPosted: Wed Sep 16, 2020 19:19    Post subject: Reply with quote
Turn on Upnp?
_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
buffpatel
DD-WRT User


Joined: 22 Feb 2011
Posts: 100

PostPosted: Thu Sep 17, 2020 18:05    Post subject: Reply with quote
Thanks so much for the suggestions! I actually solved this just now and am listing the answer for anyone else with RCS.

Looking at that post I had linked above, the person who solved this issue with open-wrt mentioned they solved it by unchecking the box for "filter useless" Well, I googled "filter useless dd-wrt" and discovered that is actually an option for dnsmasq called "filterwin2k" Here is the dnsmasq info page and lines 19-25 mention this feature and how it works:

https://svn.dd-wrt.com//browser/src/router/dnsmasq/dnsmasq.conf.example?rev=4485

Anyway, lo and behold, looking at my "additional dnsmasq options" under "services tab, I had filterwin2k enabled. Not sure why I had it there - I probably had read a post in the past and someone had recommended enabling it at that time.

I commented out filterwin2k and RCS worked immediately!

Hope this helps someone else in the future!
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum