New Build - 04/20/2020 - r42954

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 2421

PostPosted: Mon Apr 20, 2020 12:22    Post subject: New Build - 04/20/2020 - r42954 Reply with quote
[WARNING]: This thread is only for feedback on this beta release for developers and the community's benefit.
DO NOT flash this beta release unless you understand the risks involved and specific device recovery methods.
Avoid discussions! Create threads for questions, general problems or use search; this thread is not for support.
Please list router model & revision, operating & wireless mode(s) and exact filename/firmware image flashed.


Downloads: (DD-WRT website) HTTPS & FTP

CLI Flash: 'cd /tmp' then 'wget {file URL}' (or 'curl -k {file URL} -o {file}') with http (not https) or ftp. Then 'write {file} linux'.

Changelogs: Trac SVN changelog since last build: r42925 (GitHub mirror)

Notes:
• CVE-2019-14899 VPN fix from December, since then various revisions including recently 7040.
In-kernel Samba has been implemented this year and default min/max versions have changed, with WSD support.
• VAP issue is fixed! For any Wireless Mode, create a VAP and both ath0/ath1 should now function properly.
WireGuard! New GUI Tunnel options have appeared since r42872, script no longer required!

Issues:
• There may be remaining issues for Samba (for example NTFS), with frequent updates.

Important:
• If reporting issues provide applicable info: syslog output, 'dmesg', 'cat /var/log/messages', serial output etc.
• For firewall issues provide 'iptables -L', 'iptables -t nat -L' and the /tmp/.ipt file.
• Search existing SVN tickets before opening a new one. Before reporting, reset and manually setup (no nvram backup).
• Be sure to include operating and wireless modes (Gateway, AP, CB, etc.) along with any relevant configuration information.

Example Template:
Code:
[b]Router/Version: [/b]
[b]File/Kernel: [/b]
[b]Previous/Reset: [/b]
[b]Mode/Status: [/b]
[b]Issues/Errors: [/b]
Sponsor
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 529
Location: Rural Manitoba

PostPosted: Mon Apr 20, 2020 14:27    Post subject: Reply with quote
3200 Master r42926 -> r42954 OK but Ath2 disappears if enabled as with previous build
3200 WDS Station r42910 -> r42954 OK including 5Ghz VAP.

*** Update ***

Couple of hours in and lost GUI/Telnet/WAN , Complete hang.
Suspect because I tried to activate Ath2 initially and it disappeared. Rebooted, downgraded to older build, made sure Ath2 was disabled, upgraded back to r42954. Will watch to see if it dies again with Ath2 now disabled.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 36 (+6) r44048
Ath1 2.4Ghz Disabled
99 Static Leases

WRT3200acm r44048 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r44048 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r44048
2.4Ghz AP Ch1 HT20 Mixed

(SPARE)WRT1900AC V1 r44048 On LAN
5Ghz WDS AP Ch149(+6) 80Mghz
2.4Ghz Ch 6 20Mhz N/G Mixed

WRT1200AC V1 r44048 LAN
2.4Ghz 20Mhz Ch 6 Mixed
5 Ghz 80Mhz Ch 149 (UUU+6) WDS AP

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1200 V1 -> WDS 5Ghz -> 1900 V1 & 1900V1
3200 Master -> WDS -> 3200 Slave


Last edited by WENED on Tue Apr 21, 2020 4:49; edited 1 time in total
kodtaku
DD-WRT Novice


Joined: 19 Oct 2015
Posts: 39

PostPosted: Tue Apr 21, 2020 3:45    Post subject: Reply with quote
Router/Version: Linksys WRT3200ACM
File/Kernel: DD-WRT v3.0-r42954 std (04/20/20)
Previous/Reset: No/2020.04.18-r42925/No
Mode/Status: AP
Issues/Errors: everything working see notes below

- Flash is fast!
- Needed to save the wirelesse security to get the 5Ghz to come up.
- NAS USB (NTFS) when df -h the numbers are wrong.

//192.168.1.1/NAS 22T 22T 364G 99%

I wish I had a 22T drive. Surprised
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 338
Location: South Carolina

PostPosted: Tue Apr 21, 2020 22:31    Post subject: DD-WRT v3.0-r42954 std (04/20/20) Reply with quote
WRT3200ACM V1 r42954 Firefox 75.0 (64-bit) webflash

OpenVPN CLIENT seems fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES) Seems fine 40MHz N
2.4GHz wpa2 CCMP-128 (AES) Seems fine 20MHz N
NAS via USB Samba conditional

** Edit: Ok folks, started asking me for credentials that don't exists again on NAS. <SAVE> and <APPLY SETTINGS> resolved. Client is a current windows 10 machine.


Last edited by scar1943 on Sat Apr 25, 2020 16:43; edited 1 time in total
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 240
Location: FL

PostPosted: Wed Apr 22, 2020 14:56    Post subject: Reply with quote
working great on my old hunk of junk it rebooted yesterday due to a storm knocking the power off other then that it has been up since release
_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2020
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv. NOTE: this is now just a wireless access point so to speak but all settings still apply to what ever wireless person connects.
Argenis
DD-WRT User


Joined: 18 Feb 2019
Posts: 108

PostPosted: Fri Apr 24, 2020 4:15    Post subject: Re: DD-WRT v3.0-r42954 std (04/20/20) Reply with quote
scar1943 wrote:
WRT3200ACM V1 r42954 Firefox 75.0 (64-bit) webflash

OpenVPN CLIENT seems fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES) Seems fine 40MHz N
2.4GHz wpa2 CCMP-128 (AES) Seems fine 20MHz N
NAS via USB Samba Seems fine right now


I'm interested to know if it's still working.

I decided to upgrade my routers, but only the 32x worked, the 3200acm I have (there's really only one version that I know of) is still having issues where it doesn't even fully come up when flashing and have to revert.


Is the configuration shared by both partitions?

If it is, it should work unless I have a bad partition.

If it's not, I'm going to have to reset the configuration and that's my issue.

_________________
Router: Linksys WRT3200ACM WLAN0 and 1 have same SSID
88W8964 802.11ac WLAN0 Mode AP VHT80 80MHz Mixed Mode Channel and Extension Channel Auto Extension LL-6
88W8964 802.11ac WLAN1 Mode AP 20 MHz Mixed Mode Channel Auto
SD8887 802.11ac disabled but visible on GUI and CLI
TX Power 19 dBm
Antenna Gain 0 dBi
U-APSD (Automatic Power Save)Enabled 
Protection Mode None
RTS Threshold Disabled
Short Preamble Disabled 
Short GI Enabled
Single User Beamforming Enabled
Multi User Beamforming Enabled 
AP Isolation Disabled
Beacon Interval 100
DTIM Interval 2
WMM Support Enabled 
Radar Detection Disabled 
ScanList default
Sensitivity Range (ACK Timing) 500 (Default: 500 meters)
Max Associated Clients 256 (Default: 256 Clients)
Minimum Signal for authenticate -128
Minimum Signal for connection -128
Poll Time for signal lookup 10
Amount of allowed low signals 3
Wireless security is WPA2 Personal CCMP-128 only
QAM256 is off
Argenis
DD-WRT User


Joined: 18 Feb 2019
Posts: 108

PostPosted: Fri Apr 24, 2020 8:05    Post subject: Found an issue with the 3200ACM on this build Reply with quote
I have two routers with the same settings, one is a WRT3200ACM and the other one a WRT32x.

I fount that on the 3200ACM it works wonderfully until I disable the access to the web management interface through http and enable through https (this doesn't happen in the 32x though).

So as of right now, I am not upgrading from the 28-Feb-2020 build at all because that's a security feature I use for wireless management.

There's also an issue that the last wireless antenna disappears with this update (which is OK because I always have it disabled anyways).

I verified twice, including a clean wipe install and a reset after install.

Upgrading it with that https only web management makes it not boot as well.

_________________
Router: Linksys WRT3200ACM WLAN0 and 1 have same SSID
88W8964 802.11ac WLAN0 Mode AP VHT80 80MHz Mixed Mode Channel and Extension Channel Auto Extension LL-6
88W8964 802.11ac WLAN1 Mode AP 20 MHz Mixed Mode Channel Auto
SD8887 802.11ac disabled but visible on GUI and CLI
TX Power 19 dBm
Antenna Gain 0 dBi
U-APSD (Automatic Power Save)Enabled 
Protection Mode None
RTS Threshold Disabled
Short Preamble Disabled 
Short GI Enabled
Single User Beamforming Enabled
Multi User Beamforming Enabled 
AP Isolation Disabled
Beacon Interval 100
DTIM Interval 2
WMM Support Enabled 
Radar Detection Disabled 
ScanList default
Sensitivity Range (ACK Timing) 500 (Default: 500 meters)
Max Associated Clients 256 (Default: 256 Clients)
Minimum Signal for authenticate -128
Minimum Signal for connection -128
Poll Time for signal lookup 10
Amount of allowed low signals 3
Wireless security is WPA2 Personal CCMP-128 only
QAM256 is off
SurprisedItWorks
DD-WRT Guru


Joined: 04 Aug 2018
Posts: 1089
Location: Appalachian mountains, USA

PostPosted: Fri Apr 24, 2020 15:20    Post subject: Re: DD-WRT v3.0-r42954 std (04/20/20) Reply with quote
Argenis wrote:
Is the configuration shared by both partitions?

It certainly is shared on the WRT1900ACSv2. I assume the architecture is similar on the other modern WRT routers, like yours. [Edit: @blkt confirmed to me that it's shared on all Marvell WRT routers.]

_________________
Five WRT1900ACSv2's on 42926, 44048.
VLANs, VAPs, NAS, client-mode travel router, OpenVPN client (AirVPN), DDNS, wireguard servers, wireguard clients (AzireVPN), two DNSCrypt DNS providers (incl Quad9) via OpenVPN/wireguard clients.
PavelVD
DD-WRT User


Joined: 26 Jul 2019
Posts: 70

PostPosted: Sun Apr 26, 2020 18:19    Post subject: Reply with quote
I tried to switch from r42054 to r42954.
After a successful reboot, it executed "nvram erase && reboot" and set it all up again.
For me, SMB1 support for the WinXP client is critical. The minimum version, NT1.0, is not compatible with SMB1. (LANMAN 1.0 protocol from firmware r42054 coped successfully.)
I tried to get around the restrictions using an NFS server, but even then I failed.
WinXP Client Installs "Windows Services for UNIX"

From the client I have a conclusion:
Code:
showmount -e 192.168.1.1
/tmp/mnt/HomeHDD          192.168.1.1/24

While the router on SSH outputs:
Code:
cat /etc/exports
/mnt/HomeHDD//  192.168.1.1/24(rw,no_subtree_check,no_root_squash,fsid=0)

I think that in this situation there is nothing and can not work out.

In addition, on the Win10 client (with SMB1 disabled), I ran into the difficulty of deleting folders on the server - deletion does not occur, the network drive suddenly disconnects, and then a reboot is required.
Disk Details:
Block device, size 931.5 GiB (1000204886016 bytes)
DOS/MBR partition map
Partition 1: 926.0 GiB (994287248384 bytes, 1941967282 sectors from 2048)
Type 0x07 (NTFS/HPFS)
Windows bootmg boot loader
NTFS file system


I observed the oddities of connecting clients to the Wi-Fi point of the AP 5G:
I use AC/N-Mixed Dynamic (20/40 Mhz). Some channels from the list become unavailable for connection, for example: 48-5240Mhz - visible to clients, and 52-5260Mhz - not; the access point is simply not visible. Moreover, if you change the "Extension Channel" for the channel, for example, from "Lower" to "Upper", the point will become unavailable after "Apply Setting".
It is interesting to note that on channels 36-64, “TX Power” is always below 30 dBm, and “Channel Quality” is affected accordingly. The channel 161-5805MHz turned out to be the best indicator for me. It is also interesting that a few minutes after the start, the signal level decreases by about 8-10dBm, this is on all channels (direct visibility 6 meters). I thought that the "U-APSD (Automatic Power Save)" option might affect this, but I didn’t notice the difference.
Perhaps this is how it should be, I just don’t know the subtleties.
Apparently I'll be back on r42054.

_________________
Linksys WRT1900ACSv2 DD-WRT v3.0-r44048 std (08/02/20)
Automatically adjustable temperature, always within the range of 59-68°С.
M
DD-WRT User


Joined: 29 Dec 2012
Posts: 169

PostPosted: Mon Apr 27, 2020 7:35    Post subject: WRT1900ACSV2 Reply with quote
Due to CoronaVirus outbreak, I cannot upgrade the router since version 03-13-2020-r42681

The 2.4Gz did not work random time suddenly. I based on the report from topic in this forum. It is the same case in 04/20/2020 - r42954. All connected devices had been disconnected. It needs to shut down the router and restart the router. If possible, could you check the scripts about 2.4Gz wifi disconnection issue in WRT1900ACSV2 please?

"Management.asp reboot click" had not worked.

High CPU usage, it has slowed down the router performance.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 8104
Location: Texas, USA

PostPosted: Mon Apr 27, 2020 13:06    Post subject: Reply with quote
^^^ I am sure somewhere in some dimension other than the one I am in, this post has relevance to the OP. I'm gonna leave it for now, but in the meantime, please re-read the OP and the entire rules and guidelines section of the forum.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 338
Location: South Carolina

PostPosted: Mon Apr 27, 2020 23:20    Post subject: Re: DD-WRT v3.0-r42954 std (04/20/20) Reply with quote
Argenis wrote:
scar1943 wrote:
WRT3200ACM V1 r42954 Firefox 75.0 (64-bit) webflash

OpenVPN CLIENT seems fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES) Seems fine 40MHz N
2.4GHz wpa2 CCMP-128 (AES) Seems fine 20MHz N
NAS via USB Samba Seems fine right now


I'm interested to know if it's still working.

I decided to upgrade my routers, but only the 32x worked, the 3200acm I have (there's really only one version that I know of) is still having issues where it doesn't even fully come up when flashing and have to revert.


Is the configuration shared by both partitions?

If it is, it should work unless I have a bad partition.

If it's not, I'm going to have to reset the configuration and that's my issue.


*** No. NAS started asking for credentials that don't exist.
samythebull64
DD-WRT Novice


Joined: 28 Apr 2020
Posts: 1

PostPosted: Wed Apr 29, 2020 16:57    Post subject: WRT1900AC v1 with build 42954 Reply with quote
Finally was able to upgrade from r36570 to r42954 directly after missing around with several older releases that were not working.

OpenVPN is working fine with a policy.
2.4 and 5 GHz wireless radios are working fine.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum