Archer C9/C1900 -5533 Error Flashing DD-WRT

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5
Author Message
xpact
DD-WRT Novice


Joined: 25 Jan 2010
Posts: 15

PostPosted: Sat Feb 01, 2020 18:23    Post subject: Reply with quote
Quote:


I did modified Bricked Router steps:
Install Solarwinds TFTP software (this was the first one I tried and it just worked)
Switch off the router
Plug in an ethernet cable into your pc and into an ethernet port on the router (not the wan port)
Download the original v1 firmware from tp-link
Rename the downloaded firmware as: archerc9v1_tp_recovery.bin
Put the firmware file in the TFTP path (check the tftp settings after installation, but I think it was c:\tftp)
Change your nic ip address to: 192.168.0.66
Switch on the router, holding the RESET button for 2-4 seconds (may need a few seconds more)
The firmware will be automatically downloaded and installed by the router.

This worked for me after numerous failed revert attempts.
I tried to use dd-wrt but the tp-link router was never connecting to the internet.
Reverting and going thru the tp-link setup just worked...in about 2 minutes.
Then I was able to upgrade the tp-link firmware to the latest version.


I did the same thing, the only difference was maybe I hold the "reset" button for 5 seconds.

Anyway I am using tftpd64.exe and I actually see the file uploading (there are blue bars filling in).

And after the reboot it is still the dd-wrt and I can not factory reset it.

Any advise will be welcome.

_________________
===========================
ActionTek MI424WR v D dd-wrt
D-Link DIR 300 Rev B dd-wrt
Linksys NSLU2 v2 OpenWrt
Linksys WRT54GS v2 dd-wrt
Linksys WRT54GS v5 dd-wrt
TP-Link Archer C9 v1 dd-wrt
TP-Link WR1043ND v1.6 OpenWrt
TP-Link WR841N v8 OpenWrt
Sponsor
Renegade_R
DD-WRT Novice


Joined: 20 Feb 2020
Posts: 1

PostPosted: Thu Feb 20, 2020 4:58    Post subject: Archer C9 and C1900 with Error 5533 Reply with quote
Okay so I have been pulling my hair out over this for the past week and I have been able to come to a solution, particularly for the Archer C1900 v1 (Canadian version) users and C9 users who have locked firmware.

Whenever you try to flash DD-WRT or downgrade any kind of firmware on the C1900 v1, it gives the error 5533 because the firmware is locked. There is no technical way around this in the firmware. If you tried to do the tftp recovery and tried to feed it a different firmware other than the latest one, it would just discard the firmware entirely and ignore the flash.

So I was able convert my Canadian TP-Link Archer C1900 v1with locked firmware to a TP-Link Archer C9 with firmware that is unlocked.

I followed this video here:
https://www.youtube.com/watch?v=jHONx_yrrKs&list=LL_FcOtXwiukzShTH96t3uGw

This is instructions on how to unbrick a C9 router using a stock US C9 firmware and sending commends using a USB to Serial cable, and combining it with tftp to serve the files to the router.

Using this same method, you can convert a perfectly functioning C1900 to a C9. After the reboot, make sure you disconnect the serial cable or it might not boot and perform a factory reset. The web UI will show C9 instead of C1900 and you are free to flash whatever firmware you like.

You must ensure the FCC ID on the back is TE7C9, any others and you could potentially permabrick the router.

WARNING DO NOT FLASH THE LATEST US FIRMWARE OR IT WILL RELOCK YOUR ROUTER FIRMWARE.
rkboni
DD-WRT Novice


Joined: 04 Mar 2016
Posts: 49

PostPosted: Wed Apr 08, 2020 3:20    Post subject: Reply with quote
EDIT: I picked up a second C9v1 as a spare for my primary router and a testbed for some other things I've been playing with. Getting DD-WRT on it was even less fun than what I recall of the initial install... I'm pretty sure there tftp saved me, but that didn't work for the new router.

xmind wrote:
Just created this account to follow up that I was running into the same issue with the 5533 error and not being able to flash from the latest stock TP firmware.

I ended up finding a test file on a page where someone posted with the same issue here: https://community.tp-link.com/en/home/forum/topic/151501

The TP link for the file didn't work, but the Mega one did.

Flashed my router with this test file and once rebooted, it accepted the DD-WRT factory to wrt bin without issues.


Bump and thank you for this. I too was getting error -5533 / error 18005 trying to upload either older Archer C9 firmware or DD-WRT factory-to-ddwrt.bin files. I'd tried tftp recovery and found the router would fetch (but ignore) files it didn't approve of as well. In other words, tftp transfer would work fine, but the router would come up running the same version: 3.17.1 20180125-rel56387

I'd gotten the C9 disassembled and then realized there was no serial header and that I didn't have any posts to solder on nor any wires of the right thickness I could fake it with (and my eyes are bad enough at that distance that I didn't think I could get the job done with the thin stranded wires I did have).

I flashed the c9v1_un-up-ver4-1-0-P12002[20180223-rel35954].bin file linked above successfully, and once the router came up with ver 4.1.0 TEST release, I was then able to flash DD-WRT factory-to-ddwrt.bin just fine.

Router's now running DD-WRT v3.0-r42514 happily!

Cheers!
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 6427
Location: Texas, USA

PostPosted: Mon Apr 20, 2020 0:31    Post subject: Reply with quote
This topic was split from the Archer C9 Thread for reference for those experiencing this error flashing.
_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
RTFM/STFW - TL;DR is NOT an excuse.
Why Should I Care What Color the Bikeshed Is?

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
“Suitcase” v5: 4x (2x Intel® E5645) on Intel® S5500HV
“Suitcase” v1: 4xQuad P6pro-200 SL25A SMP Proliant 7000s
Goto page Previous  1, 2, 3, 4, 5 Display posts from previous:    Page 5 of 5
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum