Nanostation M5 XW No conecta como Cliente

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Hardware basado en Atheros
Goto page Previous  1, 2, 3  Next
Author Message
kny
DD-WRT Novice


Joined: 15 Apr 2020
Posts: 24

PostPosted: Wed Apr 15, 2020 13:36    Post subject: Reply with quote
feliciano wrote:
Para ayudarnos a ofrecer sugerencias, por favor recordar colocar el build que se está usando en cada conjunto de pruebas.

De igual manera, como indicó kernel-panic69, se puede probar con otros builds, más nuevos o más viejos, para descartar si se trata de alguna falla de alguna serie en particular.

Por último, ¿Hay alguna configuración que sí funcione, por ejemplo, desactivando superchannel y otras funciones avanzadas? ¿Por ejemplo haciendo la conexión más básica posible (para probar)? Si se logra acotar lo que está fallando en particular, sería más fácil buscar una solución o paliativo.


La falla es en todas las Build, no conecta a los AP de mi ISP que se encuentran en los canales 5500, 5520 y 5540, pero si se conecto a un AP ajeno al de mi proveedor que se encuentra en el 5180. No soy un experto en el tema pero esto me pinta a que se trata de algun problema relacionado con DFS o el controlador. Actualmente tengo la ultima Build 42872...

Index of /dd-wrtv2/downloads/betas/2020/04-10-2020-r42872/ubnt_NanoStation_M5-XW/ubnt_NanoStation_M5-XW-webflash-firmware.bin

Como les decia no soy experto en el tema, asi que si hay alguna otra informacion que les pueda enviar diganme los comandos que debo ejecutar y les dejo los resultados pa su analisis.

Gracias.
Sponsor
kny
DD-WRT Novice


Joined: 15 Apr 2020
Posts: 24

PostPosted: Wed Apr 15, 2020 15:59    Post subject: Reply with quote
Hola amigos, hice downgrade a V24sp2 Build r25139.

Aca tengo este mensaje de error en los log.

833.860000] ath0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded

Saludos
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 9000
Location: Texas, USA

PostPosted: Wed Apr 15, 2020 16:16    Post subject: Reply with quote
¿Qué dominio regulatorio ha seleccionado? ¿El modo regulador está desactivado?
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
kny
DD-WRT Novice


Joined: 15 Apr 2020
Posts: 24

PostPosted: Wed Apr 15, 2020 16:40    Post subject: Reply with quote
kernel-panic69 wrote:
¿Qué dominio regulatorio ha seleccionado? ¿El modo regulador está desactivado?



root@DD-WRT:/# iw reg get
country US: DFS-FCC
(2402 - 2472 @ 40), (N/A, 30), (N/A)
(5170 - 5250 @ 80), (N/A, 17), (N/A)
(5250 - 5330 @ 80), (N/A, 23), (N/A)
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 63720 @ 2160), (N/A, 40), (N/A)



PD: No soy experto, asi que si hay que correr algun comando para mas informacion indicarlo en sus comentarios.


Gracias
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 9000
Location: Texas, USA

PostPosted: Wed Apr 15, 2020 16:44    Post subject: Reply with quote
Me refería a la configuración inalámbrica en la página web del enrutador. ¿Dónde se encuentra? UU., Entonces necesita establecer el dominio regulatorio adecuado, porque obviamente DFS no está funcionando. Por qué su ISP usaría canales DFS, no lo sé, pero ese parece ser el problema. También podría ser un problema con la selección de ancho de canal.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
kny
DD-WRT Novice


Joined: 15 Apr 2020
Posts: 24

PostPosted: Wed Apr 15, 2020 17:03    Post subject: Nanostation M5 XW No conecta como Cliente Reply with quote
kernel-panic69 wrote:
Me refería a la configuración inalámbrica en la página web del enrutador. ¿Dónde se encuentra? UU., Entonces necesita establecer el dominio regulatorio adecuado, porque obviamente DFS no está funcionando. Por qué su ISP usaría canales DFS, no lo sé, pero ese parece ser el problema. También podría ser un problema con la selección de ancho de canal.



No veo esa opcion amigo.. alguna sugerencia ?



Captura de pantalla_2020-04-15_13-01-38.png
 Description:
 Filesize:  29.37 KB
 Viewed:  3094 Time(s)

Captura de pantalla_2020-04-15_13-01-38.png


kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 9000
Location: Texas, USA

PostPosted: Wed Apr 15, 2020 18:09    Post subject: Reply with quote
Ok, el ancho del canal solo se puede seleccionar cuando está en modo AP, mi error. A veces lo cambio antes de seleccionar el modo de puente cliente o cliente, pero ese puede no ser el problema. ¿Son sus AP ISP Mikrotik? Puede probar la opción de compatibilidad MTik habilitada, así como la opción Banda al aire libre habilitada. Esto realmente está empezando a ser un problema interesante. ¿Estás seguro de que no es un AP de 2.4 GHz al que intentas conectarte? Debo admitir que no estoy familiarizado con su dispositivo, en cuanto a si es de banda única o doble o qué.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
kny
DD-WRT Novice


Joined: 15 Apr 2020
Posts: 24

PostPosted: Wed Apr 15, 2020 18:22    Post subject: Nanostation M5 XW No conecta como Cliente Reply with quote
kernel-panic69 wrote:
Ok, el ancho del canal solo se puede seleccionar cuando está en modo AP, mi error. A veces lo cambio antes de seleccionar el modo de puente cliente o cliente, pero ese puede no ser el problema. ¿Son sus AP ISP Mikrotik? Puede probar la opción de compatibilidad MTik habilitada, así como la opción Banda al aire libre habilitada. Esto realmente está empezando a ser un problema interesante. ¿Estás seguro de que no es un AP de 2.4 GHz al que intentas conectarte? Debo admitir que no estoy familiarizado con su dispositivo, en cuanto a si es de banda única o doble o qué.


Los 3 AP que usa mi ISP son 5 GHz... Me conectaba sin problemas con el firmware original del Ubiquiti Nanostation M5 XW (Airos).

En cuanto a la marca de los AP son Huawei. Y transmiten con ancho de canal de 20 MHz, sin encriptacion

He habilitado la Outdoor y Mikrotik sin resultados positivos... sigo sin poner conectar a esas frecuencias 5500, 5520 5540. (Conecta por un segundo y se desconecta).

Hay otro AP abierto en el Canal 5180 (No es de mi ISP )y conecta sin problemas.

Como le comentaba al principio, el tema esta interesante.

Mi equipo esta 100% funcional, sin problemas, asi que esta descartado la posibilidad de problemas de hardware.

Saludos.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 9000
Location: Texas, USA

PostPosted: Wed Apr 15, 2020 18:42    Post subject: Reply with quote
Ok, entonces. Lo único que puedo pensar es que el controlador inalámbrico en DD-WRT no funciona bien con esos canales DFS. Es posible que tenga que volver al firmware de stock ya que DD-WRT no parece querer funcionar. Supongo que podrías intentar volver a habilitar la detección de radar DFS, pero ya sabemos que eso no parece querer funcionar. Hay caramba
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
kny
DD-WRT Novice


Joined: 15 Apr 2020
Posts: 24

PostPosted: Wed Apr 15, 2020 18:50    Post subject: Reply with quote
kernel-panic69 wrote:
Ok, entonces. Lo único que puedo pensar es que el controlador inalámbrico en DD-WRT no funciona bien con esos canales DFS. Es posible que tenga que volver al firmware de stock ya que DD-WRT no parece querer funcionar. Supongo que podrías intentar volver a habilitar la detección de radar DFS, pero ya sabemos que eso no parece querer funcionar. Hay caramba



La verdad regresar a mi Stock Firmware es mi ultima opcion, necesito implementar algunos servicios en dd-wrt que no me es posible usarlos en Airos.

Ojala y alguno de los desarrolladores para Ubiquiti tomen cartas en el asunto y quieran cooperar con este problemita.

Mientras tanto seguire subiendo firmwares, leyendo log y viendo posibles soluciones.

Gracias
kny
DD-WRT Novice


Joined: 15 Apr 2020
Posts: 24

PostPosted: Wed Apr 15, 2020 20:13    Post subject: Nanostation M5 XW No conecta como Cliente Reply with quote
Como dato curioso en modo AP funciona perfecto, el problema es solo en modo cliente.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 9000
Location: Texas, USA

PostPosted: Wed Apr 15, 2020 20:22    Post subject: Reply with quote
Una nueva versión de compilación publicada hoy. No estoy seguro de si solucionará sus problemas o no, pero vale la pena intentarlo.

https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/04-15-2020-r42910/ubnt_NanoStation_M5-XW/

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
feliciano
DD-WRT Guru


Joined: 24 Oct 2008
Posts: 1003
Location: Latin America

PostPosted: Thu Apr 16, 2020 0:23    Post subject: Re: Nanostation M5 XW No conecta como Cliente Reply with quote
kny wrote:
Tengo un Nanostation M5 XW...

kny wrote:
PD: No soy experto, asi que si hay que correr algun comando para mas informacion indicarlo en sus comentarios.

kny wrote:
He habilitado la Outdoor y Mikrotik sin resultados positivos... sigo sin poner conectar a esas frecuencias 5500, 5520 5540. (Conecta por un segundo y se desconecta).

Hay otro AP abierto en el Canal 5180 (No es de mi ISP )y conecta sin problemas.

Como le comentaba al principio, el tema esta interesante.

kny wrote:
En cuanto a la marca de los AP son Huawei. Y transmiten con ancho de canal de 20 MHz, sin encriptacion

¿Y por qué no probar con los canales cifrados WPA2-PSK? Supongo que si los canales van abiertos, al menos debería haber una lista blanca de MAC address. ¿Se verificó que la MAC del Cliente están declaradas en la lista blanca del AP?

¿Y sí es capaz de conectarse como Cliente en la frecuencia 5180, pero no en las frecuencias 5500, 5520, 5540? (supongo que estamos hablando de frecuencias centrales más que de canales).¿Se verificó en la página de ubiquiti que ese modelo en particular soporte esos canales? En caso afirmativo, solo por descartar, ¿tanto en los Huawei como en este equipo se tiene seleccionado el Dominio Regulatorio USA? ¿Se podría probar con otros?

Porque si se conecta como Cliente a un AP tercero, pero no a los Huawei, podría haber un tema de compatibilidad. ¿No se dispone de otro router de 5Ghz no-Huawei para probar?

¿Y se está intentando como Cliente, o como Cliente-Repetidor? ¿Y si se configuran ambos lados como WDS qué pasaría?

_________________
If you want support, please read first the announcements and forum rules.
Si usted desea ayuda, por favor lea primero los anuncios y las reglas del foro.
kny
DD-WRT Novice


Joined: 15 Apr 2020
Posts: 24

PostPosted: Thu Apr 16, 2020 0:50    Post subject: Nanostation M5 XW No conecta como Cliente Reply with quote
kernel-panic69 wrote:
Una nueva versión de compilación publicada hoy. No estoy seguro de si solucionará sus problemas o no, pero vale la pena intentarlo.

https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/04-15-2020-r42910/ubnt_NanoStation_M5-XW/



Acabo de instalar la ultima que publicaron hoy Build 42910 y sigue igual, no hay resultados positivos.

Ahora tenemos nueva informacion en los log:

<6>[ 497.580000] ath0: associate with 04:25:c5:5d:7c:90 (try 1/3)
<6>[ 497.580000] ath0: RX AssocResp from 04:25:c5:5d:7c:90 (capab=0x1401 status=18 aid=1595)
<6>[ 497.590000] ath0: 04:25:c5:5d:7c:90 denied association (code=1Cool
<6>[ 498.800000] ath0: authenticate with 04:25:c5:12:05:70
<6>[ 498.820000] ath0: send auth to 04:25:c5:12:05:70 (try 1/3)
<6>[ 498.860000] ath0: authenticated
<6>[ 498.870000] ath0: associate with 04:25:c5:12:05:70 (try 1/3)
<6>[ 499.010000] ath0: associate with 04:25:c5:12:05:70 (try 2/3)
<6>[ 499.020000] ath0: deauthenticated from 04:25:c5:12:05:70 while associating (Reason: 9=STA_REQ_ASSOC_WITHOUT_AUTH)
<6>[ 499.280000] ath0: authenticate with 04:25:c5:5d:7a:b0
<6>[ 499.300000] ath0: send auth to 04:25:c5:5d:7a:b0 (try 1/3)
<6>[ 499.310000] ath0: authenticated
<6>[ 499.320000] ath0: associate with 04:25:c5:5d:7a:b0 (try 1/3)
<6>[ 499.320000] ath0: RX AssocResp from 04:25:c5:5d:7a:b0 (capab=0x1401 status=18 aid=10922)
<6>[ 499.330000] ath0: 04:25:c5:5d:7a:b0 denied association (code=1Cool
<6>[ 500.430000] ath0: authenticate with 04:25:c5:12:05:d0
<6>[ 500.450000] ath0: send auth to 04:25:c5:12:05:d0 (try 1/3)
<6>[ 500.460000] ath0: authenticated
<6>[ 500.470000] ath0: associate with 04:25:c5:12:05:d0 (try 1/3)
<6>[ 500.640000] ath0: associate with 04:25:c5:12:05:d0 (try 2/3)
<6>[ 500.810000] ath0: associate with 04:25:c5:12:05:d0 (try 3/3)
<6>[ 500.820000] ath0: deauthenticated from 04:25:c5:12:05:d0 while associating (Reason: 9=STA_REQ_ASSOC_WITHOUT_AUTH)
<6>[ 503.770000] ath0: authenticate with 04:25:c5:2a:6e:30
<6>[ 503.790000] ath0: send auth to 04:25:c5:2a:6e:30 (try 1/3)
<6>[ 503.800000] ath0: authenticated
<6>[ 503.820000] ath0: associate with 04:25:c5:2a:6e:30 (try 1/3)
<6>[ 503.820000] ath0: RX AssocResp from 04:25:c5:2a:6e:30 (capab=0x1401 status=18 aid=1623)
<6>[ 503.830000] ath0: 04:25:c5:2a:6e:30 denied association (code=1Cool
<6>[ 514.060000] ath0: authenticate with 04:25:c5:2a:70:90
kny
DD-WRT Novice


Joined: 15 Apr 2020
Posts: 24

PostPosted: Thu Apr 16, 2020 1:06    Post subject: Re: Nanostation M5 XW No conecta como Cliente Reply with quote
feliciano wrote:
kny wrote:
Tengo un Nanostation M5 XW...

kny wrote:
PD: No soy experto, asi que si hay que correr algun comando para mas informacion indicarlo en sus comentarios.

kny wrote:
He habilitado la Outdoor y Mikrotik sin resultados positivos... sigo sin poner conectar a esas frecuencias 5500, 5520 5540. (Conecta por un segundo y se desconecta).

Hay otro AP abierto en el Canal 5180 (No es de mi ISP )y conecta sin problemas.

Como le comentaba al principio, el tema esta interesante.

kny wrote:
En cuanto a la marca de los AP son Huawei. Y transmiten con ancho de canal de 20 MHz, sin encriptacion

¿Y por qué no probar con los canales cifrados WPA2-PSK? Supongo que si los canales van abiertos, al menos debería haber una lista blanca de MAC address. ¿Se verificó que la MAC del Cliente están declaradas en la lista blanca del AP?

¿Y sí es capaz de conectarse como Cliente en la frecuencia 5180, pero no en las frecuencias 5500, 5520, 5540? (supongo que estamos hablando de frecuencias centrales más que de canales).¿Se verificó en la página de ubiquiti que ese modelo en particular soporte esos canales? En caso afirmativo, solo por descartar, ¿tanto en los Huawei como en este equipo se tiene seleccionado el Dominio Regulatorio USA? ¿Se podría probar con otros?

Porque si se conecta como Cliente a un AP tercero, pero no a los Huawei, podría haber un tema de compatibilidad. ¿No se dispone de otro router de 5Ghz no-Huawei para probar?

¿Y se está intentando como Cliente, o como Cliente-Repetidor? ¿Y si se configuran ambos lados como WDS qué pasaría?



Hola amigo, los canales estan abiertos pq es un Hotspot en cual no hay filtrado MAC. Una vez te conectas a ellos, te redirecciona al un portal captivo.

Con respecto a las frecuencias... esta confirmado que que los Ubiquiti NSM5 XW la soportan, de hecho como comentaba anteriormente... me conectaba a este mismo Hotspot con este mismo equipo lo que en su version de firmware original (Airos)

Probe conectar a otro equipo con la configuracion similar a los huawei, misma frecuencia y ancho de canal... pero no se conecta, todo apunta a que el problema esta relacionado con DFS y Regulatory Domain.

Cuando hago los test, siempre pruebo client, client bridge y WDS Station..... hasta ahora en ninguna de las configuraciones se conecta (Especifico que SI se conecta por una fraccion de segundo y se vuelve a desconectar)
Goto page Previous  1, 2, 3  Next Display posts from previous:    Page 2 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Hardware basado en Atheros All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum