2.4Ghz Problems

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 564
Location: Rural Manitoba

PostPosted: Mon Mar 23, 2020 16:02    Post subject: 2.4Ghz Problems Reply with quote
Without going into great detail (review my other posts about these problems) Here are some interesting results.
Three different Routers 1200V1, 1900V1, 3200
Build r42681
Kernel Linux 4.9.216 #1676 SMP Fri Mar 13 05:32:12 +03 2020 armv7l
2.4Ghz 20Mhz Selected channel N/G Mode All other settings default

1 - Android Connectivity
Tab4 8.1.0 - Will connect without problem to 3200
-Won't connect to 1200 or 1900
Zenphones 8.0.0 - Connection on all routers OK but will get occasional start/stop Kernel errors.
- Actually prefer connection to 1200 or 3200

2 - ESP8266 Connectivity
No connection to 3200 unless G only and wmm disabled
Nothing new here 1200 and 1900 work fine

3 - IP WLAN Cameras
For the most part don't seem to care which router to connect

4 - Remote Client/Bridged Router
As long as the load is kept to a minimal level (# of Devices or feeds) no problems occur. If however the load is increased (Multiple feeds from IP cameras etc.) considerable Disconnects/Re-connects De-authorized/Authorized events increase dramatically.
At present my remote runs 5 WLAN IP cameras, 2 IP LAN Cameras & 5 ESP8266 Sonoff's. With only one desktop accessing the cameras all works fine with only the expected drops caused by environmental factors (Chicken Barn).
If however I access all the cameras from a second source (creates dual feeds from cameras) the drop outs go nuts.

5 - As a side effect my 1900 will reboot randomly dependent on the volume of connection errors. Example with maximum load a couple of hours, with minimal load a couple of days.
Have also noticed that following a random reboot, a hard reboot is required or random reboots will continue almost hourly.

Have considered installing a known good build on the 1900 (r31924 as per the sticky) but cannot find the build. Have tried a few from earlier this year and last year but all have the same reboot problem. Point of interest is the V1 has half the amount of ram as any of the other WRT's.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r47608
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r47608 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r47608 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r47608
2.4Ghz AP Ch1 HT20 Mixed

WRT1900ACS SPARE r47608

WRT1900AC V1 5Ghz AC 80Mhz WDS-AP r47608
2.4Ghz AP Ch1 HT20 Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900ACS -> WDS 5Ghz -> 1900 V1 (X2)
3200 Master -> WDS -> 3200 Slave & 1900V1
Sponsor
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 564
Location: Rural Manitoba

PostPosted: Mon Mar 23, 2020 23:00    Post subject: Reply with quote
Many thanks to Spuriousoffspring for posting r31924 on the board. It took me a while to find but well worth the effort.

I downgraded my two operational 1900's to r31924.
I can now run WDS on these units where with later builds it did not work.
After installing r31924 I fired up my second desktop to monitor my cameras. Even with the additional load I am getting no disconnects. Don't know about reboots but even if it still does so, I can live with that as the performance is so much better now.
I also downgraded my 1200V1 to r32170 and it's performance is much improved with no Kernel Start/Stop entries in the log.

As a bonus I tried my TAB4 Android on all interfaces and now it can connect to all routers.

I realize that at these old builds many security features and other things may not work but for my application it is a breath of fresh air to not see continuous logging and dropping of devices.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r47608
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r47608 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r47608 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r47608
2.4Ghz AP Ch1 HT20 Mixed

WRT1900ACS SPARE r47608

WRT1900AC V1 5Ghz AC 80Mhz WDS-AP r47608
2.4Ghz AP Ch1 HT20 Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900ACS -> WDS 5Ghz -> 1900 V1 (X2)
3200 Master -> WDS -> 3200 Slave & 1900V1
ad19
DD-WRT User


Joined: 19 May 2017
Posts: 261

PostPosted: Tue Mar 24, 2020 2:01    Post subject: Reply with quote
Totally in agreement with your approach. I have downgraded the wrt3200acm to r35681 from April 2018.
Rather frustrating that I have not been able for find a later stable build for such a long time. But, nothing I can complain about. It's a free firmware and comes with a take it or leave it feature bundled in.

_________________
WRT3200ACM - Firmware: DD-WRT v3.0-r35681 std (04/06/18).
WRT160N - Repeater - Firmware: DD-WRT v24-sp2 (02/02/15) mini.
Toombstone
DD-WRT Novice


Joined: 02 Feb 2020
Posts: 22

PostPosted: Tue Mar 24, 2020 2:53    Post subject: Reply with quote
ad19 wrote:
Totally in agreement with your approach. I have downgraded the wrt3200acm to r35681 from April 2018.
Rather frustrating that I have not been able for find a later stable build for such a long time. But, nothing I can complain about. It's a free firmware and comes with a take it or leave it feature bundled in.


Have you tested 42054 im pretty satisfied with that build atleast for my purposes. You usecase maybe different
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3441

PostPosted: Wed Mar 25, 2020 0:08    Post subject: Reply with quote
https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1197041#1196865

https://svn.dd-wrt.com/changeset/42803

Today we have a revert to a previous wifi driver firmware binary blob for WRT3200ACM.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 11800
Location: Texas, USA

PostPosted: Wed Mar 25, 2020 0:31    Post subject: Reply with quote
The 1200s and 1900s have the same wireless hardware. The 3200 and the 32x have the same wireless hardware. Trying to mix and match any of the 1900 stuff with the 3200 don't make much sense, but I have no blue glue clue.
_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Display posts from previous:    Page 1 of 1
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum