New Build 42542: 02-27-2020-r42542

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12472
Location: Texas, USA

PostPosted: Thu Feb 27, 2020 14:05    Post subject: New Build 42542: 02-27-2020-r42542 Reply with quote
WARNING: DO NOT flash this experimental test build unless you know the risks and recovery methods. Report here to provide important info for developers and users. Always state your hardware model & version, mode (e.g. Repeater) and SPECIFIC build (e.g. netgear-r7000-webflash). Avoid discussions and create a new thread for specific problems or questions as this thread is not for support, and posts may be deleted or moved.

Downloads: if a link does not work, try another (alternative @DD-WRT website)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/02-27-2020-r42542/
ftp://ftp.dd-wrt.com/betas/2020/02-27-2020-r42542/
Note: for wget (or curl) with CLI flash (`write {f/w} linux`), change the https to http, use `curl -k {link} -o {file}`, or ftp

Changelogs:
SVN* changelog since last build: 42514
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Important: if reporting any issues, provide applicable info (GUI syslog, `dmesg`, `cat /var/log/messages`, etc.)
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Template example to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b][u]Router/Version: [/u][/b]
[b]Mode: [/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Status: [/b]

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
Sponsor
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 350
Location: South Carolina

PostPosted: Thu Feb 27, 2020 14:17    Post subject: DD-WRT v3.0-r42542 std (02/27/20) Reply with quote
WRT3200ACM V1 r42542 Firefox 73.0.1 (64-bit) webflash

OpenVPN CLIENT works fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES)working fine 40MHz Mixed
2.4GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
NAS via USB Samba 3.11 also working fine

*** I thought there was still the VPN client throughput problem on the first reset. But I've reset several times now to test, and it seems to be coming up ok now.
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 243
Location: FL

PostPosted: Thu Feb 27, 2020 15:27    Post subject: Reply with quote
This one for me Breaks the Client mode ( my bridge ) and Also if my VAP for the 2.4ghz atho.1 is on then it disables the Ath0 Radio 2.4ghz

I tried to disable the VAP for right now and restore the settings file that did not make it connect. but it does say atho radio is on with 2.4 VAP disabled.

Restored back to previous build for now.

PS @ K-Panic69 since everyone else seems to be harping on you I BLAME YOU! Very Happy

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2021
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv. NOTE: this is now just a wireless access point so to speak but all settings still apply to what ever wireless person connects.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12472
Location: Texas, USA

PostPosted: Thu Feb 27, 2020 15:39    Post subject: Reply with quote
PIZZEDMEOFF wrote:
PS @ K-Panic69 since everyone else seems to be harping on you I BLAME YOU! Very Happy


Shocked Embarassed Laughing I say blame Canada, but that might get me in more trouble saying that around here. Wink Cool Laughing It's okay, I am used to being the shot messenger. Shit happens.

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 350
Location: South Carolina

PostPosted: Thu Feb 27, 2020 16:18    Post subject: Reply with quote
PIZZEDMEOFF wrote:
This one for me Breaks the Client mode ( my bridge ) and Also if my VAP for the 2.4ghz atho.1 is on then it disables the Ath0 Radio 2.4ghz

I tried to disable the VAP for right now and restore the settings file that did not make it connect. but it does say atho radio is on with 2.4 VAP disabled.

Restored back to previous build for now.

PS @ K-Panic69 since everyone else seems to be harping on you I BLAME YOU! Very Happy


Pizz,

Yeah, first boot for me was bad as well. I had originally entered a message that it was still broken, but messed with it for a time first. Once I did the ole' save-apply trick on areas I had issues with, it seemed to settle down. I'm starting to believe seriously in a flush out nvram with flash changes. Problem is, my config is complex enough I don't really want to deal with it on EVERY flash update. So... I'll blame K-Panic as well on this one...
Smile
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12472
Location: Texas, USA

PostPosted: Thu Feb 27, 2020 16:25    Post subject: Reply with quote
scar1943 wrote:
So... I'll blame K-Panic as well on this one...Smile


Is there a doctor in the house? I've been wounded. Twice! Shocked Laughing

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3897

PostPosted: Thu Feb 27, 2020 16:28    Post subject: Reply with quote
Blame Canada, they're not even a real country anyway.

If the problems continue to be intermittent such as either radio not functioning until restart or save/apply trick you can be sure that flushing nvram and reconfiguring won't solve the problem. Eventually a new build will fix it. Confused
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 350
Location: South Carolina

PostPosted: Thu Feb 27, 2020 16:38    Post subject: Reply with quote
blkt wrote:
Blame Canada, it's not even a real country anyway.

If the problems continue to be intermittent such as either radio not coming up until restart or save/apply trick you can be sure that flushing nvram and reconfiguring won't solve the problem. Eventually a new build will fix it. Confused


Yeah, I'm kinda' amazed at how odd problems just vanish or appear from release to release when I don't really see a fix applied in an area that (in my head anyway) logically seems to be related. That's really the only theory I have for the ram flushing. In the mean time, I'll continue to be a masochist and flash my router aimlessly each release as I have for years now to see what pops up next. Smile
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 243
Location: FL

PostPosted: Thu Feb 27, 2020 16:49    Post subject: Reply with quote
scar1943 wrote:


Pizz,

Yeah, first boot for me was bad as well. I had originally entered a message that it was still broken, but messed with it for a time first. Once I did the ole' save-apply trick on areas I had issues with, it seemed to settle down. I'm starting to believe seriously in a flush out nvram with flash changes. Problem is, my config is complex enough I don't really want to deal with it on EVERY flash update. So... I'll blame K-Panic as well on this one...
Smile


I tried a reset and just doing the bridge again with out any luck it just says radio is on thats it.
about far as im willing to go with it right now.

always the next one. i did make a ticket to let him know though

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2021
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv. NOTE: this is now just a wireless access point so to speak but all settings still apply to what ever wireless person connects.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12472
Location: Texas, USA

PostPosted: Thu Feb 27, 2020 16:59    Post subject: Reply with quote
PIZZEDMEOFF wrote:
I tried a reset and just doing the bridge again with out any luck it just says radio is on thats it.
about far as im willing to go with it right now.

always the next one. i did make a ticket to let him know though


Ok, are you configuring client or client bridged? BS has said in the past that bridged modes are a hack fake bridge and they either work or they don't.

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 243
Location: FL

PostPosted: Thu Feb 27, 2020 19:31    Post subject: Reply with quote
i do client, so i have my own subnet over here and its all static after i make the connect i set it all up
_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2021
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv. NOTE: this is now just a wireless access point so to speak but all settings still apply to what ever wireless person connects.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12472
Location: Texas, USA

PostPosted: Thu Feb 27, 2020 23:13    Post subject: Reply with quote
PIZZEDMEOFF wrote:
i do client, so i have my own subnet over here and its all static after i make the connect i set it all up


As far as I know of, you aren't supposed to be able to run a vap on the radio that is in client modes. How it was working before, I do not know.

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 564
Location: Rural Manitoba

PostPosted: Fri Feb 28, 2020 0:11    Post subject: Reply with quote
kernel-panic69 wrote:
PIZZEDMEOFF wrote:
i do client, so i have my own subnet over here and its all static after i make the connect i set it all up


As far as I know of, you aren't supposed to be able to run a vap on the radio that is in client modes. How it was working before, I do not know.


Don't know about client as I have never used it, but client bridge fully supports vap's. The only quirk I have ever found is that if I set up a vap on my Client Bridged 3200 the only channel that will work is 100. Since I like my 160Mhz spectrum and am restricted here in CANADA I only run on 36+. But whenever I did tryout the vap for assisting people it always worked as long as I set my AP to channel 100+. The other reason I am reluctant to use a vap is as I understand it, the operation is basically emulating a repeater and cuts my transmission rate in half as it can only be communicating on one radio with two paths.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r48567
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r48567 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r48567 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT1900ACS SPARE r47608

WRT1900AC V1 5Ghz AC 80Mhz WDS-AP r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900ACS -> WDS 5Ghz -> 1900 V1 (X2)
3200 Master -> WDS -> 3200 Slave & 1900V1
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 564
Location: Rural Manitoba

PostPosted: Fri Feb 28, 2020 0:31    Post subject: Reply with quote
Just upgraded my Client Bridged 1900 V1 r42514 -> r42542

No problem upgrading, no reset done over wireless on the bridge with IE11.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r48567
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r48567 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r48567 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT1900ACS SPARE r47608

WRT1900AC V1 5Ghz AC 80Mhz WDS-AP r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900ACS -> WDS 5Ghz -> 1900 V1 (X2)
3200 Master -> WDS -> 3200 Slave & 1900V1
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 243
Location: FL

PostPosted: Fri Feb 28, 2020 0:48    Post subject: Reply with quote
interesting, ok ill reflash it and play with it some.

Ok so i am on it, I flashed to stock, then back to kongs build way back when, then to this firmware all with resets ofcourse.

And its working IF i add a VAP in Client Mode. bam same problem happens, IF i disable it still dont work but if i delete the whole VAP and reboot it comes back on....

Client Bridged Does not allow a seperated subnet so that wouldnt do me no good anyway but im about to test that out. whew lawd that was a mess i have to much static stuff to mess with that right now it works currently with out a VAP

wened, dont suppose you have seperated sub nets on client bridged do you?

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2021
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &

WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: WPA2 Personal: "CCMP-128 (AES)" Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv. NOTE: this is now just a wireless access point so to speak but all settings still apply to what ever wireless person connects.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum