Linksys 1900AC V1 Wifi issues

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3897

PostPosted: Tue Feb 25, 2020 14:34    Post subject: Reply with quote
The repeated "auth request" and "deauthenticated due to inactivity" are what you are looking for.

https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1192140#1192044

New build is out today. Smile

https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/02-25-2020-r42514/linksys-wrt1900ac/
Sponsor
Neil1454
DD-WRT User


Joined: 29 Jan 2012
Posts: 63

PostPosted: Wed Feb 26, 2020 23:41    Post subject: Reply with quote
So impressed with the stability of my wifi connection in general now. Smile

My wifi has been failing almost daily or with 48 hour uptime max in the past for hmmm 4 years. Since I had the 1900.
I had every intention to look further into it but with previous attempts failing in the past just accepted it.

So wanted to say a MASSIVE thank you to everyone who took time to help me.

P.s running the new build too.
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 564
Location: Rural Manitoba

PostPosted: Wed Feb 26, 2020 23:51    Post subject: Reply with quote
Neil1454 wrote:
So impressed with the stability of my wifi connection in general now. Smile

My wifi has been failing almost daily or with 48 hour uptime max in the past for hmmm 4 years. Since I had the 1900.
I had every intention to look further into it but with previous attempts failing in the past just accepted it.

So wanted to say a MASSIVE thank you to everyone who took time to help me.

P.s running the new build too.


So glad to hear you have achieved a working unit.
Incidentally I also installed the latest build on my remote 1900. I tried setting it up with wmm and mixed mode. It ran for 24 hours extremely well and when it sis the Key Renewal (set to 24 hours) it all went to hell. The router rebooted after a trying to renew and subsequently rebooted about an hour later. I have since put the 2.4Ghz back to G only and wmm disabled.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r48567
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r48567 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r48567 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT1900ACS SPARE r47608

WRT1900AC V1 5Ghz AC 80Mhz WDS-AP r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900ACS -> WDS 5Ghz -> 1900 V1 (X2)
3200 Master -> WDS -> 3200 Slave & 1900V1
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3897

PostPosted: Thu Feb 27, 2020 0:21    Post subject: Reply with quote
Nice one. If for whatever reason you need audio/video prioritization, power save functionality or have a device that just plain refuses to connect you can enable WMM and set the Wireless Network Mode to BG-Mixed or G-Only.

Otherwise, if everything just plain works never mind.
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 564
Location: Rural Manitoba

PostPosted: Thu Feb 27, 2020 2:54    Post subject: Reply with quote
blkt wrote:
Nice one. If for whatever reason you need audio/video prioritization, power save functionality or have a device that just plain refuses to connect you can enable WMM and set the Wireless Network Mode to BG-Mixed or G-Only.

Otherwise, if everything just plain works never mind.


I discovered this off the wall fix when helping Neil1454 if you remember. When I set the mode to G only and disabled wmm I ran four days without a reboot on r42410. I was initially impressed with the way r42514 came up with all enabled but when it rebooted today, I didn't hesitate to go to the minimum settings. I don't require any of the enhanced features of 80211e for my cameras or Sonoff devices so the minor drop in speed <20% is meaningless. Besides, the 1900 in question is a client running on 5Ghz 80Mhz A/C only which will automatically prioritize the Video/Data accordingly. I know the basic problem is that all the cameras are Chinese knockoffs and of course I need not say any more about the Sonoff stuff after all the grief I went through with my 3200's. There is no doubt that all these devices may be claimed as 80211e compatible, I seriously doubt that and the proof is in the troubles everyone is experiencing. I truly believe that having the 80211e protocol on the 2.4Ghz band was an afterthought that was never designed to handle all the variations of the band. It is no wonder that there are numerous recomendations to rid oneself of 2.4Ghz devices and jump to 5Ghz. As you said, if it all works well, great. Same as if it ain't broke don't fix it.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r48567
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r48567 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r48567 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT1900ACS SPARE r47608

WRT1900AC V1 5Ghz AC 80Mhz WDS-AP r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900ACS -> WDS 5Ghz -> 1900 V1 (X2)
3200 Master -> WDS -> 3200 Slave & 1900V1
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3897

PostPosted: Thu Feb 27, 2020 4:01    Post subject: Reply with quote
WMM deals with prioritization for latency, not bandwidth.

Again, it's not 802.11e WMM that's triggering the problem but the 802.11n data rates.

The whole reason disabling WMM works is because it breaks wireless N standard. Disable WMM and you are immediately limited to 54G data rates.

If you keep WMM enabled and set Wireless Network Mode from Mixed to BG-Mixed or G-Only you are again limited to the same 54G data rates.

See for yourself, as soon as you enable legacy rates the authentication and key renewal problems disappear.

This is the entire reason I said applying both workarounds is overkill; you are killing a bird with a stone and then smashing it.

It's a problem inherent in the open source mwlwifi driver and interaction with the fullmac binary blob.

Stock Linksys firmware's wifi driver can handle ESP8266, IoT, smart devices, door bells, cameras etc without these workarounds even though it uses the same binary blob which is sad.

Linksys and Marvell will never fix the bugs to gracefully handle these interoperability issues for open source as they ran off with the keys to the castle.

We got screwed because of two major sales: Linksys from Belkin to Foxconn and Marvell's wifi assets to NXP.

Also the push for AX standard stole engineering time.
Neil1454
DD-WRT User


Joined: 29 Jan 2012
Posts: 63

PostPosted: Thu Feb 27, 2020 10:55    Post subject: Reply with quote
blkt wrote:
Nice one. If for whatever reason you need audio/video prioritization, power save functionality or have a device that just plain refuses to connect you can enable WMM and set the Wireless Network Mode to BG-Mixed or G-Only.

Otherwise, if everything just plain works never mind.


I set to BG mixed as mentioned. Enabled wmm.
Problem reoccured.
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3897

PostPosted: Thu Feb 27, 2020 14:54    Post subject: Reply with quote
Really? Wow, I stand corrected (twice).

I didn't believe the 1900 series was affected because there were only reports on mwlwifi driver for wrt3200acm except one guy claiming that it worked on his 1900, but there are four variants of this router.

Even WENED started in this thread claiming not to have experienced the problem on his 1900V1's but luckily he quickly changed his tune after seeing your logs (thanks for that).

On a side note, usually these problematic client devices insist on trying to use TKIP.
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 564
Location: Rural Manitoba

PostPosted: Thu Feb 27, 2020 23:52    Post subject: Reply with quote
blkt wrote:
Really? Wow, I stand corrected (twice).

I didn't believe the 1900 series was affected because there were only reports on mwlwifi driver for wrt3200acm except one guy claiming that it worked on his 1900, but there are four variants of this router.

Even WENED started in this thread claiming not to have experienced the problem on his 1900V1's but luckily he quickly changed his tune after seeing your logs (thanks for that).

On a side note, usually these problematic client devices insist on trying to use TKIP.


As I had said quite some time ago, the problem I was having with my 1900 V1 was that it would periodically reboot. After installing the revision and trying to help out Neil1454 I noticed that my reboots would still occur even though the connections and operation were excellent. During my testing when I disabled wmm and used G only I was surprised to find that I no linger got random reboots. Recently when I upgraded to r42514 I enabled wmm and set mode to Mixed. I also had the key renewal set to 46400 or I day. The first time key renewal activated it caused a reboot and then again an hour later. I reverted to disable wmm and set to G only, yesterday. Today when the key renewal activated, there was virtually no entries in the log except for group handshake completed on each of the 2.4Ghz devices. Will continue to monitor this but for now it is almost frustrating when I remember everything I had tried to fix the random reboots. Power supply replacement, Power supply enhancement with extra filtering, UPS, router replacement, but none fixed the problem.
As a side note, I have never used tkip since my 54G days.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r48567
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r48567 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r48567 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT1900ACS SPARE r47608

WRT1900AC V1 5Ghz AC 80Mhz WDS-AP r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900ACS -> WDS 5Ghz -> 1900 V1 (X2)
3200 Master -> WDS -> 3200 Slave & 1900V1
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3897

PostPosted: Fri Feb 28, 2020 1:28    Post subject: Reply with quote
For TKIP I am referring to IoT, smart devices etc and not router settings. Sometimes they are hardcoded to attempt old stuff.

Anyway, nothing new here and problem solved (never to be solved properly, thanks Marvell).
Neil1454
DD-WRT User


Joined: 29 Jan 2012
Posts: 63

PostPosted: Fri Feb 28, 2020 10:47    Post subject: Reply with quote
Is G as high stability wise considering the issues I'm facing, that I am going to see on 2.4ghz for now?

Tried wireless N only (wmm off) and I was not able to connect directly to the 2.4ghz from the router but was from a new extender connected to the same ssid I'd tried to connect to.
Not stable however.

Is N one that with wmm off can be made workable with specific settings ?

Thanks
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 564
Location: Rural Manitoba

PostPosted: Fri Feb 28, 2020 12:06    Post subject: Reply with quote
Neil1454 wrote:
Is G as high stability wise considering the issues I'm facing, that I am going to see on 2.4ghz for now?

Tried wireless N only (wmm off) and I was not able to connect directly to the 2.4ghz from the router but was from a new extender connected to the same ssid I'd tried to connect to.
Not stable however.

Is N one that with wmm off can be made workable with specific settings ?

Thanks


During all my messing around, I found that the only reliable way to run was G only with wmm off. Any time I've used an extender I have always only used 5Ghz for the extension and 2.4Ghz active for the remote devices. I currently don't use any extenders but I guess ny configuration with Client Bridge is much the same except I have more control over the network and remote devices. When I did use a EX7000 I would setup fast lane for 5Ghz link to the connector and 2.$Ghz to the devices. Any time you extend a single frequency you are cutting your effective speed in half as there is only one radio and it cannot be doing both linking to your master and communicating with your devices at the same time. I've noted that when I run G only it does not reduce my throughput to any extent as most of my devices are only capable of about 72m anyway so being restricted down a bit to 54 is not really noticeable. I have upgraded to the latest build but still find that G only wmm disabled is the only reliable method.
I must thank you for getting me involved in your problems as otherwise I would likely never have solved my ancient problem with my remote 1900 periodically rebooting and for that matter my devices are much more stable with this setup.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r48567
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r48567 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r48567 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT1900ACS SPARE r47608

WRT1900AC V1 5Ghz AC 80Mhz WDS-AP r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900ACS -> WDS 5Ghz -> 1900 V1 (X2)
3200 Master -> WDS -> 3200 Slave & 1900V1
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 3897

PostPosted: Fri Feb 28, 2020 15:39    Post subject: Reply with quote
It's a problem with the open source driver and proprietary binary blob provided by Marvell to Linksys. Development halted early last year, so it will never be resolved. We are stuck with 54G rates and apparently no WMM as well with affected client devices.

The only two solutions we have outside of the above is to disable the internal 2.4 radio interface and buy an external access point (ubiquiti long range as an example).

The other is to remove the problematic B/G/N devices from your Marvell WRT entirely (IoT, ESP8266, Sonoff, home automation, smart devices, security camera, doorbell etc). A spare old router would work, just isolate the trouble makers.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 12472
Location: Texas, USA

PostPosted: Fri Feb 28, 2020 17:05    Post subject: Reply with quote
blkt wrote:
It's a problem with the open source driver and proprietary binary blob provided by Marvell to Linksys. Development halted early last year, so it will never be resolved. We are stuck with 54G rates and apparently no WMM as well with affected client devices.

The only two solutions we have outside of the above is to disable the internal 2.4 radio interface and buy an external access point (ubiquiti long range as an example).

The other is to remove the problematic B/G/N devices from your Marvell WRT entirely (IoT, ESP8266, Sonoff, home automation, smart devices, security camera, doorbell etc). A spare old router would work, just isolate the trouble makers.


I've recommended a separate AP if people MUST have IoT (or legacy) crap on their network, Marvell or not. They just wreak havoc unless you're using Z-wave with a hub wired into your network. Personally, I don't like any of it because I'd rather not have the added security issues involved, but that is another story altogether Wink

_________________
Official Forum Rules, Guidelines & Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware‽
DON'T use Chromium-based browsersRTFM/STFW TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is‽
Please DO NOT PM me with questions; Ask in the forum. ---------------------- Linux User #377467 counter.li.org / linuxcounter.net
WENED
DD-WRT Guru


Joined: 30 May 2017
Posts: 564
Location: Rural Manitoba

PostPosted: Fri Feb 28, 2020 20:26    Post subject: Reply with quote
kernel-panic69 wrote:
blkt wrote:
It's a problem with the open source driver and proprietary binary blob provided by Marvell to Linksys. Development halted early last year, so it will never be resolved. We are stuck with 54G rates and apparently no WMM as well with affected client devices.

The only two solutions we have outside of the above is to disable the internal 2.4 radio interface and buy an external access point (ubiquiti long range as an example).

The other is to remove the problematic B/G/N devices from your Marvell WRT entirely (IoT, ESP8266, Sonoff, home automation, smart devices, security camera, doorbell etc). A spare old router would work, just isolate the trouble makers.


I've recommended a separate AP if people MUST have IoT (or legacy) crap on their network, Marvell or not. They just wreak havoc unless you're using Z-wave with a hub wired into your network. Personally, I don't like any of it because I'd rather not have the added security issues involved, but that is another story altogether Wink


Gentlemen,

There is no doubt that these problems will never get fixed but rather only masked. The switch to 80211e has created a mess with 2.4Ghz. Although many manufacturers have tried to make their equipment compatible, the basic hardware has not changed. The majority of people using these devices are likely unaware that they are problematic. Here with DD-WRT it is an advantage that we can see the various reactions of these devices, but to the average consumer they are invisible.
With most 2.4Ghz devices they are only capable of 72M in other than G mode so setting the AP to G and disabling wmm will likely not have any effect on performance as with the enhanced mode and wmm there is considerable extra communication to deal with QOS and PowerSave.
For devices which do require the higher speed links they usually are equipped with a 5Ghz band option. If the link is so distorted that 5Ghz is not viable, going to 2.4Ghz may help as it does have better range, but even if link can be established it will likely be substantially reduced anyway.
It is posted numerous times over the web, if you are having problems with 2.4Ghz due to interference or any other go to 5Ghz.
The suggestion to add a separate AP makes no sense whatsoever. Why not just put the existing AP into G only and disable wmm especially if the new AP is an older router that didn't support wmm and N.
Adding a VAP to the existing router was an idea I also suggested but in doing so one immediately degrades the network by 50% since the radio can only be running on one AP at any given time.
There are of course a number of low end devices which expect to use the 80211e spec and can cause problems if an AP is set to G only,and they do not have 5Ghz capability , I have a couple of these, but since I don't require a turbo type performance from them, their intermittent dropouts does not matter.
Getting rid of the offending devices is a ridiculous suggestion as in the wired world they are so prevalent. They may appear to work fine on other than Marvell hardware but I'll bet the hardware/software has managed to isolate into G mode or at least mask the problems.
In tests that I have made using a vap was not only bad idea because of the reduction in speed by 50% but because both the AP and VAP were sharing many common settings, it was at best just a makeshift fix which didn't always work as the network overall was still trying to deal with the mix.
I apologize for being so long winded and constantly repeating in numerous posts, but I do agree with you it is time to get over this and in future simply suggest putting AP's on 2.4Ghz into G only and disabling wmm.

_________________
WRT3200acm Master WDS 5GHz 80Mhz CH 100 (+6) r48567
Ath1 2.4Ghz Disabled
99 Static Leases
ExpressVPN

WRT3200acm r48567 WDS Station 5Ghz
Ath1 AP N/G Mixed Channel 11 HT40

WRT1900Ac V1 5Ghz r48567 WDS Station
(Defective, no 2.4Ghz but 5Ghz works great)

WRT1900AC V1 5Ghz AC 80Mhz WDS Station r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT1900ACS SPARE r47608

WRT1900AC V1 5Ghz AC 80Mhz WDS-AP r48567
2.4Ghz AP Ch1 HT20 Mixed

WRT54G DD-WRT v3.0-r37305 micro AP CH 6 Mixed - Not in use

3200 Master -> LAN -> 1900ACS -> WDS 5Ghz -> 1900 V1 (X2)
3200 Master -> WDS -> 3200 Slave & 1900V1
Goto page Previous  1, 2, 3, 4, 5, 6  Next Display posts from previous:    Page 5 of 6
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum