No WAN MAC address

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
DD-WRT Novice

Joined: 13 Oct 2013
Posts: 1

PostPosted: Sun Oct 13, 2013 4:35    Post subject: No WAN MAC address Reply with quote
I recently got an Asus RT-AC66U. It works well with the stock firmware but I need DHCP forwarding which isn't supported, so I thought I'd try DD-WRT, which I last used in pre-N days with a WRT54G.

I found that with both the 21676 build flashed from the .trx file, and the v24-K3 build, that I had no WAN connectivity. The MAC address field for the WAN was blank in the status page. I tried MAC address cloning but that made no difference. This was with a simple static IP setup, as the RT is behind another router I control (I have coax egress, and want a DMZ anyway).

For now I have gone back to the stock firmware to stop the wife from going ballistic, but if there is a simple fix to this I'd be interested.

Something else that was off was that I could not telnet in; I kept getting an invalid password response. I was using the same username/password as for the web admin interface, which I assume is what I was supposed to be using. So I wasn't able to clear the NVRAM from the command line, although I did select the option to reset all settings when flashing.

Joined: 22 Sep 2008
Posts: 12675

PostPosted: Mon Oct 14, 2013 13:28    Post subject: Reply with quote
Read peacock announcement.
I'm trying to teach you to fish, not give you a fish. If you just want a fish, wait for a fisherman who hands them out. I'm more of a fishing instructor.
LOM: "If you show that you have not bothered to read the forum announcements or to follow the advices in them then the level of help available for you will drop substantially, also known as Murrkf's law.."
DD-WRT Novice

Joined: 23 Aug 2014
Posts: 5

PostPosted: Sat Aug 23, 2014 2:38    Post subject: No MAC on WAN port ASUS Reply with quote
Did you ever figure this out?
I've tried several versions from 2013 to 2014, none have worked - still no MAC address on WAN port.
DD-WRT Novice

Joined: 23 Aug 2014
Posts: 5

PostPosted: Sat Aug 23, 2014 5:01    Post subject: Reply with quote
got it figured out, the NVRAM is not cleared on a hard reset (go figure).
The solution is to telnet in (after enabling it) and make sure your user name you type in is 'root' as, no matter what you changed it to in the GUI it will always be 'root' on the telnet - (took me 2 hours of hair-pulling to figure that out!)
Once logged in, type "erase nvram", wait, then type "reboot". Once rebooted, you should see a WAN MAC and a DHCP assigned IP Address.
That works so far, unfortunately, there is still some bug that shows the exact same MAC address for the WAN, LAN, & WLAN ports (which is a really bad situation - that I am trying to solve in another post).

Joined: 11 Jun 2012
Posts: 1038

PostPosted: Mon Aug 25, 2014 16:34    Post subject: Reply with quote
this thread might have some answers to your questions

Please state what make and model router plus the build number and type of DD-WRT you are using. Screen prints and a network diagram can are also helpful. Before you create a new post, use the search function. Chances are your issue has happened to someone else.

Common F.A.Q.
Where can I get the latest test Firmware or older ones?

Asus RT-N16 on 2.6 Kong 22000M with OTRW2
Asus RT-AC66R on 3.x 28072 Giga
TP-Link Archer C9 on 3.x 28493 STD

Joined: 08 Jun 2006
Posts: 125
Location: PA, USA

PostPosted: Thu Feb 16, 2017 2:59    Post subject: Reply with quote
So was just fighting with my router and finally noticed my WAN MAC was missing in the status (Sys-Info, Info.htm) page. Google turned up this thread as the first hit, but the information wasn't *exactly* complete in my opinion. So, for others that may need help here I'm filling the gaps a bit...

For starters, the peacock thread:
Item #14 has info about a missing MAC, but I'm not entirely certain it is accurate. Mainly because nvram value et0macaddr is my router's internal MAC, not the WAN MAC. So, heads up with those instructions. Maybe once you set the et0 MAC the rest just fall in order automatically?

I also managed to get my problem corrected, and the steps used may not be entirely necessary.
1. Got a list of nvram values that currently had one of my router's MACs assigned. Did this by telnetting into the router, issuing the command "nvram show | grep F0" (that's the first octet of my MACs) and noted the results.
2. Backed up (again, doesn't hurt to keep current) the configuration via the Administration/Backup utility in the web interface.
3. Reset the router to defaults via telnet as mentioned in this thread.
4. Reconnected, telnetted in, again pulled the nvram MAC entries that matched F0.
This is where I noticed that the value that previously held my WAN MAC was gone. I believe it was named "wan0_hwaddr". (Not to be confused with the wireless MAC entry, "wl0_hwaddr".) The entry that now existed was simply named "wan_hwaddr" with no "0" in it. I also noted that my WAN MAC now correctly showed in the Sys-Info page.
5. Having seen the corrections needed, I restored the backed up configuration. I figured it would be easier to correct just the WAN MAC than rebuild all the other areas of my config.
At this point I expected to have to telnet in and "nvram set" the proper wan_hwaddr value, and if I was doing proper cleanup delete the wan0_hwaddr one. But to my surprise the proper one was now in place and the useless one was gone... no further changes needed.

So instead of all my steps, I have two theories on ways to correct the issue.

Option 1, shorten up my steps by simply doing backup, erase, restore. In a nutshell that is what fixed me.

Option 2, do an "nvram set wan_hwaddr=XX:XX:XX:XX:XX:XX" to create the proper value with your WAN interface's MAC address. "nvram commit" the change. A reboot may be necessary after, I don't know.

I've got a nagging feeling I had seen the wan0/wan discrepancy around here somewhere before but it isn't ringing that solid a bell.

Hopefully these steps help someone else out, given that this thread seems to be the first search hit. For the record, I've currently got v24-sp2 (02/04/15) mega (SVN revision 26138M) on an ASUS RT-N66 and that is what I was working with here.
DD-WRT Novice

Joined: 13 Dec 2019
Posts: 2

PostPosted: Fri Dec 13, 2019 15:43    Post subject: same Reply with quote
uff I hace problems with that, but I dont understand english very well, could anyone help me??
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT


Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum