[F7D4302] Internetzugang über LAN

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC basierende Hardware
Author Message
f7d4302
DD-WRT Novice


Joined: 12 Sep 2019
Posts: 3

PostPosted: Thu Sep 12, 2019 14:37    Post subject: [F7D4302] Internetzugang über LAN Reply with quote
Liebes Forum,

ich betreibe DD-WRT v3.0-r40559 mega (08/06/19) mit Kernel Linux 2.6.24.111 #9518 Tue Aug 6 00:31:40 +04 2019 mips auf einem Belkin Play (F7D4302) WLAN-Router.
Ich möchte ihn nicht als Gateway betreiben, da bereits ein NAT-Router meines Internet-Providers im gleichen Netzwerk existiert. Der DD-WRT-Router selbst benötigt jedoch einen Internet-Zugang, damit ich z.B. über Entware Pakete auf dem DD-WRT-Router installieren kann. Daher soll der DD-WRT-Router seinen Internet-Zugang über die LAN-Schnittstelle erhalten.

Um dies zu erreichen, habe ich am DD-WRT-Router die WAN-Verbindung im Web-Interface deaktiviert, den DHCP-Server ausgeschaltet und dem DD-WRT-Router eine statische IP-Adresse zugewiesen, die im gleichen Subnetz wie der Router meines Internet-Providers liegt (jedoch natürlich außerhalb dessen DHCP-Bereichs) und die IP-Adresse des Routers meines Internet-Providers als Standard-Gateway und Local DNS-Server eingetragen. Außerdem habe ich unter Setup -> Advanced Routing den Operating Mode von Gateway auf Router umgestellt.

Der Router meines Internet-Providers ist über die LAN-Schnittstelle mit dem DD-WRT-Router verbunden. Der Eintrag für das Standard-Gateway in der Routing-Tabelle des DD-WRT-Routers sieht ebenfalls korrekt aus.

Trotzdem habe ich am DD-WRT-Router keinen Internet-Zugang, da ich z.B. (wenn ich mich über SSH zum DD-WRT-Router verbinde) keine Sachen über wget herunterladen kann. Ich kann vom DD-WRT-Router aus zwar IP-Adressen von Geräten, die sich im lokalen Netzwerk befinden, anpingen, die IP-Adresse des Standard-Gateways aber nicht (von anderen Geräten im lokalen Netzwerk kann ich sie anpingen) und Hosts/IP-Adressen im Internet ebenfalls nicht. Das Ping-Kommando gibt in diesem Fall auch keine Fehlermeldung aus, warum es fehlschlägt. Erst, wenn ich das Ping-Kommando über Strg+C abbreche, steht dann "x Packets lost, 100 % loss" - aber keine Meldung, warum der Ping nicht erfolgreich war.

Einen Factory-Reset und ein Update auf die aktuellste angebotene DD-WRT-Version habe ich bereits (ohne Veränderung) durchgeführt. Was mache ich noch falsch?

Besten Dank und beste Grüße
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2686
Location: Texas, USA

PostPosted: Thu Sep 12, 2019 14:46    Post subject: Reply with quote
Deaktivieren Sie die SPI-Firewall auf der Registerkarte "Sicherheit" der Weboberfläche. Ich glaube nicht, dass Sie Ihren ISP-Router als lokales DNS festlegen müssen, und alles, was mit dnsmasq zusammenhängt, kann höchstwahrscheinlich ausgeschaltet werden, da udhcpc die richtigen Informationen erhält und Ihre mit DD-WRT verbundenen Clients die richtigen DHCP-Informationen von erhalten der ISP-Router.

https://wiki.dd-wrt.com/wiki/index.php/Linking_Routers

-----

Disable the SPI firewall under 'Security' tab of the web interface. I do not think you need to set your ISP router as the local DNS, and everything related to dnsmasq can be turned off most likely as udhcpc will get the correct information, and your clients connected to DD-WRT will get the correct dhcp information from the ISP router.

https://wiki.dd-wrt.com/wiki/index.php/Linking_Routers
f7d4302
DD-WRT Novice


Joined: 12 Sep 2019
Posts: 3

PostPosted: Sat Sep 14, 2019 6:48    Post subject: Reply with quote
Das hat leider nichts geändert.
Das Problem bleibt gleich: Es haben zwar alle anderen Geräte im Netzwerk Internetzugriff, der DD-WRT-Router aber selbst immer noch nicht. Das Problem mit dem "Ping ohne Fehlermeldung" ist ebenfalls geblieben.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2686
Location: Texas, USA

PostPosted: Sat Sep 14, 2019 7:14    Post subject: Reply with quote
Sorry, ich muss müde gewesen sein und einen Fehler gemacht haben. Haben Sie den router-Modus von gateway zu router auf der Registerkarte Setup - > Advanced Routing geändert?

https://wiki.dd-wrt.com/wiki/index.php/Wireless_access_point

https://wiki.dd-wrt.com/wiki/index.php/Switch
-----

Sorry, I must've been tired and made a mistake. Did you change the router mode from gateway to router on the Setup -> Advanced Routing tab?
f7d4302
DD-WRT Novice


Joined: 12 Sep 2019
Posts: 3

PostPosted: Sat Sep 14, 2019 13:13    Post subject: Reply with quote
Vielen Dank, das hat mein Problem gelöst. Jetzt funktioniert es wunderbar. Very Happy

Ich hatte den Router-Modus vorher schon einmal umgestellt. Dann habe ich jedoch die Anleitung https://wiki.dd-wrt.com/wiki/index.php/Switch Schritt für Schritt befolgt und nicht dabei bedacht, dass sich der Router-Modus durch den 30/30/30-Reset (natürlich) wieder zurückgesetzt hat.

Etwas verwirrend fand ich auch, dass unter https://wiki.dd-wrt.com/wiki/index.php/Wireless_access_point darauf hingewiesen wird, den Routing-Modus von "Gateway" auf "Router" umzustellen, unter https://wiki.dd-wrt.com/wiki/index.php/Switch jedoch nicht - obwohl es offensichtlich in beiden Fällen erforderlich ist.
Hier ist das Wiki scheinbar (noch) ungenau oder nicht ganz vollständig. Wink
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2686
Location: Texas, USA

PostPosted: Sat Sep 14, 2019 13:22    Post subject: Reply with quote
Sie sind willkommen. Schön zu hören, dass Sie eine Lösung gefunden haben.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC basierende Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum