New BrainSlayer Build: 2019-10-01 r41218

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2, 3, 4  Next
Author Message
bdg2
DD-WRT User


Joined: 18 Apr 2013
Posts: 319

PostPosted: Tue Oct 01, 2019 14:02    Post subject: New BrainSlayer Build: 2019-10-01 r41218 Reply with quote
New BrainSlayer Build: 2019-10-01 r41218

ftp://ftp.dd-wrt.com/betas/2019/10-01-2019-r41218/
or
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/10-01-2019-r41218/

Please report errors or other changes with this new build release.


Change Log:
http://svn.dd-wrt.com/timeline

Router Model:

Status:
Reset:
Errors:
Sponsor
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5404
Location: Texas

PostPosted: Tue Oct 01, 2019 16:06    Post subject: Reply with quote
EA8500
DD-WRT v3.0-r41218 std (10/01/19)
Linux 4.9.194 #474 SMP Mon Sep 30 03:10:28 CEST 2019 armv7l
GUI install over r41212
no problems -- all good

#

WNDR3700v4
DD-WRT v3.0-r41218 std (10/01/19)
Linux 3.18.140 #56044 Tue Oct 1 04:42:25 +04 2019 mips
GUI install over r41212
all good

#

WRT160NL
DD-WRT v3.0-r41218 std (10/01/19)
Linux 3.10.108-d8 #24170 Tue Oct 1 03:10:50 +04 2019 mips
GUI install over r41212
all good
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7465
Location: YWG, Canada

PostPosted: Tue Oct 01, 2019 17:08    Post subject: Reply with quote
Router Model: dir-862L, dir-862L, wndr4300

Status: well it runs..
Reset: no
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5817
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6481 *
https://svn.dd-wrt.com/ticket/6495 *
https://svn.dd-wrt.com/ticket/6511
https://svn.dd-wrt.com/ticket/6555 *
https://svn.dd-wrt.com/ticket/6655
https://svn.dd-wrt.com/ticket/6755 *

the ticket list shrunk a bit not cause things are fixed, but cause no one seems to care to fix them, they are all "invalid"..

see https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320097 for latest post of full actual issues..

still qos/latency issues on ipq806x forever since k4.x switch...

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
▲ ACTIVE / INACTIVE ▼
[QUALCOMM] WNDR4300 v1 --------------------------> r46350 std
[BROADCOM] DIR-860L A1 ----------------------------> r46329 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
robbbaxley
DD-WRT Novice


Joined: 12 Apr 2013
Posts: 25

PostPosted: Tue Oct 01, 2019 17:09    Post subject: Netgear X10 r90 Reply with quote
Router/Version: Netgear X10 r9000
File: Firmware: DD-WRT v3.0-r41218 std (10/01/19)
Kernel: Linux 4.9.194 #387 SMP Mon Sep 30 02:27:24 CEST 2019 armv7l
Mode: AP
Status: Operational (with issues)
Upgraded from: r41174
Reset: No

NOTES: I didn't enable the 60Ghz radio so I don't know whether it would work or not. I don’t use QoS due to having a synchronous gigabit fiber connection.

EDITED TO ADD: The built-in speed test seems a bit underwhelming for testing high-speed connections. The test generally tops out in the mid to upper 200 MB/s range. I do get very close to actual speeds when using other speedtest sites.

ISSUES:

Issue #1: Privoxy @ ip 10.0.0.1:8118 returns error: "Maximum number of open connections reached."

Issue #2: SAMBA is not started automatically upon reboot. It is enabled but stopped. Need to 'apply' then 'save' 2 times to make it stick.

Issue #3: Syslog shows a lot of errors such as the following:

YELLOW Warnings:
Oct 1 08:24:27 r9000 daemon.warn dnsmasq[2352]: cache size greater than 10000 may cause performance issues, and is unlikely to be useful.
Oct 1 08:24:27 r9000 daemon.warn radvd[2082]: exiting, 1 sigterm(s) received


RED Warnings:
Lot’s of 404 error codes...missing gif’s:


Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/top_left.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/top_mid.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/top_right.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/center_right.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/center_left.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/bottom_left.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/bottom_mid.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/bottom_right.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/sizer.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/close.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/minimize.gif not found.
Oct 1 08:24:47 r9000 daemon.err httpd[2257]: httpd : Request Error Code 404: File style/pwc/default/maximize.gif not found.
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2196
Location: Canada

PostPosted: Tue Oct 01, 2019 17:42    Post subject: Upgrades Reply with quote
Router/Version: TP-Link Archer C7 v2 x2
Firmware: 41218
Previous: 40900
Mode/Status: WDS AP, WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: D-Link DIR-862L A1 x2
Firmware: 41218
Previous: 40627, 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: D-Link DIR-825 B1
Firmware: 41218
Previous: 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: TP-Link WR841ND v8
Firmware: 41218
Previous: 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: TP-Link WDR3600 v1
Firmware: 41218
Previous: 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: D-Link WNDR-3700 v2
Firmware: 41218
Previous: 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
Netgear R7800 - gateway, DHCP, QoS, VPN
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
UBNT loco M2 x2 - airOS

Broadcom
Linksys EA6400 - Gateway
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - not used
Jovan
DD-WRT User


Joined: 06 Nov 2018
Posts: 107

PostPosted: Tue Oct 01, 2019 19:50    Post subject: Reply with quote
Router Model TP-Link TL-WR841ND v11
Firmware Version DD-WRT v3.0-r41218 std (10/01/19)
Kernel Version Linux 3.18.140 #56006 Tue Oct 1 03:55:43 +04 2019 mips

Update from r41212 via telnet.

Reset: yes, from telnet after reboot.

Status: Working OK as AP, HT40, NG-mixed.

Errors: (Same as with r41212)

1. WebGUI reset to factory (still) doesn't work. Only via telnet I can reset.

2. In Wireless->Advanced the new setting "QCA Q-Boost / TDMA" - I can't turn it on, it reverts back to disabled. Possibly not applicable to my router or is a WebGUI error. I would try to enable it via telnet but I don't know how.

3. Sometimes after a reset to factory settings the WebUI default theme is "blue" instead of "elegant". A second reset to factory after that turns it back to "elegant" (sometimes not). This happened a few times now in last weeks firmwares, including r41218. Not a problem really, I set the theme back to "elegant" and that's it. But I don't know what to make of this, might be something wrong with my router nvram?
vortex05
DD-WRT User


Joined: 14 Mar 2014
Posts: 210

PostPosted: Tue Oct 01, 2019 23:18    Post subject: Reply with quote
Router Model: WNDR4300v1

Status: OK
Reset: No
Errors: None


Router Model: WR841N V9

Status: Errors
Reset: No
Errors: Cannot upgrade from web ui
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7465
Location: YWG, Canada

PostPosted: Tue Oct 01, 2019 23:56    Post subject: Re: Upgrades Reply with quote
ian5142 wrote:
Router/Version: TP-Link Archer C7 v2 x2
Firmware: 41218
Previous: 40900
Mode/Status: WDS AP, WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: D-Link DIR-862L A1 x2
Firmware: 41218
Previous: 40627, 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: D-Link DIR-825 B1
Firmware: 41218
Previous: 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: TP-Link WR841ND v8
Firmware: 41218
Previous: 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: TP-Link WDR3600 v1
Firmware: 41218
Previous: 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: D-Link WNDR-3700 v2
Firmware: 41218
Previous: 40900
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far.


does archer c7 have wpa3 now? its magically appeared on dir-862L over one of the builds in the past 10 days

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
▲ ACTIVE / INACTIVE ▼
[QUALCOMM] WNDR4300 v1 --------------------------> r46350 std
[BROADCOM] DIR-860L A1 ----------------------------> r46329 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
htismaqe
DD-WRT User


Joined: 05 Nov 2015
Posts: 471

PostPosted: Wed Oct 02, 2019 4:01    Post subject: Reply with quote
Any reason for me to upgrade? I'm on BS 40900 still and have been up and stable for 26 days.
_________________
Routing:.......Asus RT-AX88U (Asuswrt-Merlin 384.14)
Switching:....Netgear GS608_V3 & GS605_V4, TrendNet TEG-S82G & TEG-S50G
Cyntil8ing
DD-WRT Novice


Joined: 19 Apr 2010
Posts: 10

PostPosted: Wed Oct 02, 2019 15:14    Post subject: CPU Load 100% Reply with quote
TP-Link TL-WDR4300

My CPU load consistently rises to 100% even after repeated restarts. My usage has been consistent and CPU load usually didn't rise above 5-10%.

Anybody else getting increased CPU load?
robbbaxley
DD-WRT Novice


Joined: 12 Apr 2013
Posts: 25

PostPosted: Wed Oct 02, 2019 17:25    Post subject: CPU % Reply with quote
My CPU is holding at around 3% which is higher than normal. Usually I am sitting at 1% or less.
el-guapin
DD-WRT Novice


Joined: 25 Aug 2019
Posts: 16

PostPosted: Wed Oct 02, 2019 21:49    Post subject: Reply with quote

Router Model:
Netgear R7800

Firmware Version: DD-WRT v3.0-r41218 std (10/01/19)

Kernel Version:
Linux 4.9.194 #474 SMP Mon Sep 30 03:10:28 CEST 2019 armv7l

Upgraded from: DD-WRT v3.0-r41135 std (09/25/19)

Reset: No

Status: Up and running for 30 minutes. No issues

_________________
Netgear R7800
sgobiraj
DD-WRT Novice


Joined: 23 Jul 2009
Posts: 18

PostPosted: Wed Oct 02, 2019 21:56    Post subject: Prospective IPQ80x buyer Reply with quote
I am looking to get an r7800 or ea8500 to add to my AP setup. With the latest BS builds are there any routing/throughput issues related to the CPU with the linux kernel? I read about how Kong builds were the go to for the IPQ8x chips due to it using the older kernel. Is that no longer the case and everything is well with these builds?
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7465
Location: YWG, Canada

PostPosted: Wed Oct 02, 2019 22:22    Post subject: Re: Prospective IPQ80x buyer Reply with quote
sgobiraj wrote:
I am looking to get an r7800 or ea8500 to add to my AP setup. With the latest BS builds are there any routing/throughput issues related to the CPU with the linux kernel? I read about how Kong builds were the go to for the IPQ8x chips due to it using the older kernel. Is that no longer the case and everything is well with these builds?


keep the cpu at max freq and its MOSTLY okay.. assuming u arent using qos at speeds over 100-150mbps, or at all (on those devices, some other device ahead of them is fine)

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
[QUALCOMM] DIR-862L --------------------------------> r46450 std
▲ ACTIVE / INACTIVE ▼
[QUALCOMM] WNDR4300 v1 --------------------------> r46350 std
[BROADCOM] DIR-860L A1 ----------------------------> r46329 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
robbbaxley
DD-WRT Novice


Joined: 12 Apr 2013
Posts: 25

PostPosted: Thu Oct 03, 2019 2:11    Post subject: Netgear X10 r9000 Reply with quote
Additional testing has revealed very poor performance with DNSMasq enabled. Websites load slooooooly or not at all and streaming sites struggle to load or stream. Turning DNSMasq off returns performance to expected levels.

Sometimes DD-WRT pages need to be refreshed to fully load.

In addition to my earlier report regarding the error message from Privoxy (Maximum number of open connections reached), Privoxy does not appear to be functional at all. I am no longer receiving any blocked page notices for sites that I know used to be blocked.
Goto page 1, 2, 3, 4  Next Display posts from previous:    Page 1 of 4
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum