Some tips for installing DD-WRT on D-Link DIR-825 vB1 NA

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
esliu
DD-WRT Novice


Joined: 06 Sep 2017
Posts: 1

PostPosted: Thu Sep 07, 2017 0:18    Post subject: Some tips for installing DD-WRT on D-Link DIR-825 vB1 NA Reply with quote
I just installed DD-WRT on my D-Link DIR-825B1 NA version. At the time of this posting, the version on the instructions page is "ftp://ftp.dd-wrt.com/betas/2017/08-03-2017-r33006/dlink-dir825-revb/factory-to-ddwrt_NA.bin"

Some comments to share.

First, if your factory firmware is older than 2.07, I recommend upgrading to 2.07 first. Note that if you are older than 2.05, you must install v2.05 before the router will upgrade to 2.07. If you try to jump from, say 2.03 to 2.07, the upgrade will fail. Note that there are two BIN files included with 2.05, you have to install them both first, then install 2.07.

Second, I had massive problems trying to install from my laptop that had Windows 10 on it. The factory firmware recovery page kept rejecting the BIN once uploaded, saying "Incorrect hardware ID image, Please check !" By the way, I was only able to get this message in Firefox. In Chrome and Internet Explorer (11), the file would upload and nothing would happen. Same results in Opera and Edge too, FWIW.

I tried everything, but in the end, the way I got the DD-WRT firmware to take was to switch to my Windows 7 PC. From there, using Firefox, the BIN uploaded and the upgrade process started immediately, first try. The page with the progress counter didn't load, but the router itself behaved exactly as described in the instructions--the power light turned off so I knew it was progressing.

Once it came back on, I was able to access the DD-WRT admin console with no problems.

Hope this information may be of use to someone in the future. If the DD-WRT BIN won't take, there may be a bunch of things going on. I don't know what the difference was between my Windows 10 PC and my Windows 7 PC. Keep trying different things until it works!
Sponsor
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2032
Location: Canada

PostPosted: Thu Sep 07, 2017 2:02    Post subject: PM tatsuya46 Reply with quote
PM tatsuya46 and ask him to update the wiki page for that router.
_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
Linksys WRT400N - bricked
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
TP-Link 1043nd v1, inactive, unstable hardware
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - Gateway, DHCP, QoS
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7123
Location: YWG, Canada

PostPosted: Thu Sep 07, 2017 2:10    Post subject: Reply with quote
the wiki page assumes dlink recovery method is used, it was found over the years things kept switching back and forth, going from stock -> ddwrt worked fine in gui, then broke like u have, then started working again. when u use dlink emergency rom (recovery method, tftp, gui tftp etc all the same), it doesnt matter what version of stock fw u have on it
_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

[X86-64] Haswell i3-4150 ------------> DD-WRT v3.0-r41491 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r40270M kongat
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41491 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41491 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41491 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r40634 std

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
phuzzyday
DD-WRT Novice


Joined: 20 Jun 2013
Posts: 1

PostPosted: Sun Aug 11, 2019 21:41    Post subject: DIR-825 An option for Windows 10!! PALE MOON BROWSER! Reply with quote
So I had one of these situations as mentioned by the OP, no Windows 7 machines, but I tried two Linux machines even, to no avail. Almost.

I learned about a browser in Linux called Pale Moon, and I was just trying all the decent browsers I could find mention of, so I downloaded it next, and.. things got different!! Real different! The power light stopped blinking, but no data transfer happened. The router just sat there.

The power light not blinking was the best result I had found, but I figured at this point, I was hooped as far as further progress was considered.
But Pale Moon is also available in Windows, so for a final kick I installed it, back on my main Win10 64 Bit machine, with great curiosity, and KABOOM. Everything went EXACTLY as expected.

So if anyone finds one of these little gems, I hope this helps you! I found it at a Goodwill, Pretty much new in box. Bought it because I had one already and I liked DD-WRT, and I thought this was the newer revision. It wasn't, but it was only 10 bucks. For that much, It's worth having around!
Almost wish I was back at stock now, I would have tried Android next! (Almost.)
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2248
Location: Texas, USA

PostPosted: Sun Aug 11, 2019 23:50    Post subject: Reply with quote
Firefox ESR with no extensions installed is your friend.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum