TP-Link TL-WR2543ND upgrade failed [Solved]

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
idokorro
DD-WRT Novice


Joined: 04 Mar 2014
Posts: 3

PostPosted: Fri Aug 09, 2019 17:50    Post subject: TP-Link TL-WR2543ND upgrade failed [Solved] Reply with quote
Hi. I'm having a problem upgrading dd-wrt firmware.

I have a TP-Link TL-WR2543ND router currently on the 24461 build.

I tried installing build 40559 and 37305. Almost every time I get the "upgrade failed" message. Two times it said "upgrade successful" but when the router rebooted it was again the 24461 build.

I followed the instructions for the upgrade. Also disabled the antivirus, tried different browsers, cables, etc.

I read that the build 24461 has the problem with reverting to factory image and that installing older image might help. I thought to try that, but I can't find the older build.

Do you have any suggestions what should I do?

I really need the firmware with fast NAT because I upgraded my connection and my router just can't keep up.


Last edited by idokorro on Sun Aug 11, 2019 16:39; edited 1 time in total
Sponsor
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2000
Location: Canada

PostPosted: Sun Aug 11, 2019 11:04    Post subject: Builds Reply with quote
Download links to builds are here: https://wiki.dd-wrt.com/wiki/index.php/Index:FAQ#Where_do_I_download_firmware.3F

Also, try Command line upgrading / downgrading: https://wiki.dd-wrt.com/wiki/index.php/Installation#Method_3:_Flashing_with_Command_Line

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
Linksys WRT400N - bricked
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
TP-Link 1043nd v1, inactive, unstable hardware
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - Gateway, DHCP, QoS
idokorro
DD-WRT Novice


Joined: 04 Mar 2014
Posts: 3

PostPosted: Sun Aug 11, 2019 16:34    Post subject: Solved Reply with quote
Thank you very much. Command line upgrading did the trick.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum