Avahi-daemon is not starting

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
dirnt
DD-WRT Novice


Joined: 01 Oct 2018
Posts: 6

PostPosted: Fri Aug 02, 2019 15:06    Post subject: Avahi-daemon is not starting Reply with quote
Avahi-daemon is show error to start: failed to create runtime directory /opt/var/run/avahi-daemon/.

root@PND-DD-WRT:/opt/etc/init.d# ./rc.unslung check
Checking dbus-daemon... alive.
Checking avahi-daemon... dead.

root@PND-DD-WRT:/opt# cat /etc/passwd
root:xxxxxx
reboot:xxxx
nobody:x:99:99:Nobody:/:/bin/false
nobody:*:114:114:avahi:/opt/sbin/avahi-daemon:/bin/false

root@PND-DD-WRT:/opt# cat /etc/group
root:x:0:
nobody:x:99:
netdev:x:1:
nogroup:x:114:nobody

Commands -> Startup
echo "netdev:x:1:" >> /tmp/etc/group
echo "nogroup:x:114:nobody" >> /etc/group
echo "nobody:*:114:114:avahi:/opt/sbin/avahi- daemon:/bin/false" >> /etc/passwd
Sponsor
Mr.R™
DD-WRT Novice


Joined: 01 Jun 2010
Posts: 27

PostPosted: Sun Dec 22, 2019 23:04    Post subject: Reply with quote
I have the opposite problem, avahi-daemon works, dbus does not, maybe we can help each other?
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3332
Location: UK, London, just across the river..

PostPosted: Mon Dec 23, 2019 8:11    Post subject: Re: Avahi-daemon is not starting Reply with quote
dirnt wrote:
Avahi-daemon is show error to start: failed to create runtime directory /opt/var/run/avahi-daemon/.

root@PND-DD-WRT:/opt/etc/init.d# ./rc.unslung check
Checking dbus-daemon... alive.
Checking avahi-daemon... dead.

root@PND-DD-WRT:/opt# cat /etc/passwd
root:xxxxxx
reboot:xxxx
nobody:x:99:99:Nobody:/:/bin/false
nobody:*:114:114:avahi:/opt/sbin/avahi-daemon:/bin/false

root@PND-DD-WRT:/opt# cat /etc/group
root:x:0:
nobody:x:99:
netdev:x:1:
nogroup:x:114:nobody

Commands -> Startup
echo "netdev:x:1:" >> /tmp/etc/group
echo "nogroup:x:114:nobody" >> /etc/group
echo "nobody:*:114:114:avahi:/opt/sbin/avahi- daemon:/bin/false" >> /etc/passwd



what is the reason you are using those...? i know what this is for but just asking ??
not bad to mention router model and current build running...

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 42514 BS WAP/Switch
TP-Link WR740Nv4 ------DD-WRT 42514 BS AP, NAT
TP-Link WR1043NDv2 ----DD-WRT 42287 BS AP,NAT,AD Block,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----DD-WRT 42514 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 42514 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT,VPN
Broadcom
Netgear R7000 -------DD-WRT 42054 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 via Entware by mac913
Mr.R™
DD-WRT Novice


Joined: 01 Jun 2010
Posts: 27

PostPosted: Mon Dec 23, 2019 23:15    Post subject: Reply with quote
So i did a reinstall of entware today as i had previously used lanchons secure patch to install, everything was working but dbus was not, thinking that this may be the issue as you experienced the opposite i used the default entware method
Code:
On ARM devices:
wget -O - http://pkg.entware.net/binaries/armv7/installer/entware_install.sh | sh
On MIPS devices:
wget -O - http://pkg.entware.net/binaries/mipsel/installer/installer.sh | sh

(incase you used a different method)

and proceeded to install avahi and dbus, dbus works but avahi seems to start then dies, to rectify this do the following:

open
Code:
/opt/etc/avahi/avahi-daemon.conf
​ with a txt editor (i installed and used nano) and add this at the bottom of the server section:

Code:
enable-dbus=no


then
Code:
/opt/etc/init.d/S42avahi-daemon restart​
and you should be good to go, avahi and dbus both working on arm, for me at least
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum