New KONG ddwrt build - 07/11/2019

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2, 3, 4, 5  Next
Author Message
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1293

PostPosted: Wed Jul 10, 2019 23:39    Post subject: New KONG ddwrt build - 07/11/2019 Reply with quote
New KONG ddwrt build - 07/11/2019

http://desipro.de/ddwrt/K3-AC-IPQ806X/Test/

Please report errors on this topic.

Release Notes:
http://svn.dd-wrt.com/timeline (with a grain of salt, kong doesnt always add all commits)

Router Model:

Status:
Reset:
Errors:
Sponsor
pandemonium420
DD-WRT Novice


Joined: 21 Nov 2013
Posts: 36
Location: Cathedral City, CA, USA

PostPosted: Thu Jul 11, 2019 0:10    Post subject: Reply with quote
Hello Everyone,

Router Model: R7800, using 7/11/2019 Build.

Status: Not working correctly.
Reset: No (will try full reset in a bit)
Errors: Yes

Wireless Physical Interface ath0 [5 GHz/802.11ac] - QCA9984 802.11ac did not come up properly, showed Unknown on Channel screen ( Status ), went to wireless config ( basic settings ) and there were a bunch of buttons with "undefined" on the screen and no way to select functions.

Flashed back to DD-WRT v3.0-r39830M kongat ( 05/23/19 ) and everything back to normal.

Printing my config out and will do a full reset and enter everything from scratch and see if problem continues.

Thanks Kong & BS for your great work

_________________
Netgear R7800 x3 -> DD-WRT Kong r39830M
Netgear R7000 x3 -> DD-WRT Kong r39830M
Buffalo WRZ-HP-G450H -> BS r31924
Linksys WRT54G-ver2 -> BS r23320



https://www.speedtest.net/results?sh=9f7c362db2fafa93115e4c942ef29e76
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1293

PostPosted: Thu Jul 11, 2019 1:56    Post subject: Reply with quote
^ reset needed coming from <40000 build. there are nvram params changed/added

Last edited by jerrytouille on Thu Jul 11, 2019 3:45; edited 1 time in total
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4865
Location: Texas

PostPosted: Thu Jul 11, 2019 2:46    Post subject: Reply with quote
EA8500
DD-WRT v3.0-r40270M kongat (07/11/19)
Linux 4.9.185 #444 SMP Thu Jul 11 00:22:19 CEST 2019 armv7l
No reset --- GUI install over BS r40260
It's just used as a switch / ovpn server / samba share / couple ports are in a VLAN
yea, I enabled both its radios and they worky good ....using one now Smile
ovpn server good & so is samba

just iffin anybody tis wondering ...'this new Kong build---
ath10k firmware ver 10.4.1.00030-1
dnsmasq-2.80-40-gc406fd6
unbound 1.9.1
OpenVPN 2.4.7
OpenSSL 1.1.1c

BS r40260---
ath10k firmware ver 10.4-3.5.3-00050 BS used the 10.4.1.00030-1 for couple builds then reverted backSmile
dnsmasq-2.80
unbound 1.9.2
OpenVPN 2.4.7
OpenSSL 1.1.1c
'bout all I know Twisted Evil
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3079
Location: UK, London, just across the river..

PostPosted: Thu Jul 11, 2019 6:03    Post subject: Reply with quote
jerrytouille wrote:
^ reset needed coming from <40000 build. there are nvram params changed/added


I did it ddup with NO RESET ...all is working as it should...but i did clear the browser cache instead
will report later if any issues, so far so good..

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 33772 BS WAP/Switch (wired)
TP-Link WR1043NDv2 ----DD-WRT 41659 BS (AP,PPPoE,NAT,AD Blocking,AP Isolation,Firewall,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----DD-WRT 41686 BS (AP,NAT,AD Blocking,Firewall,Wi-Fi OFF,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----Gargoyle OS 1.11.0 (AP,NAT,QoS,Quotas)
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 41686 BS (AP,NAT,AD-Blocking,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT,VPN)
Broadcom
Netgear R7000 -------DD-WRT 40270M Kong (AP,NAT,VLAN,AD-Blocking,Firewall,Local DNS,Forced DNS,DoT)
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 via Entware by mac913
rawd
DD-WRT User


Joined: 06 Jan 2014
Posts: 186

PostPosted: Thu Jul 11, 2019 11:27    Post subject: Reply with quote
jerrytouille wrote:
^ reset needed coming from <40000 build. there are nvram params changed/added


Thanks for the heads up

edit:

Flashed 39855 to 40270, reset and re-entered all config settings.

No issues right away, uptime 3 hrs. jffs/QoS/OpenVPN tunnnels all working.

Weird Copy/Paste GUI buttons in Wireless settings underneath Radio Scheduling. Didn't press them to try Very Happy

_________________
R7800 AP - KONG 19 2019-Q2 / LuCI openwrt-19.07
R7800 AP - r40270M kongat
R7000 CB - r40270M kongac
PiHole 4.3.2 - dnscrypt-proxy 2.0.25 - RPi 3 B+
Synology DS216J - DSM 6.2.2
vit5421
DD-WRT User


Joined: 12 Nov 2015
Posts: 423

PostPosted: Thu Jul 11, 2019 20:25    Post subject: Reply with quote
Flashed 3xxxx to 40270, no reset, no issues so far
_________________
Netgear R7800
htismaqe
DD-WRT User


Joined: 05 Nov 2015
Posts: 471

PostPosted: Thu Jul 11, 2019 21:54    Post subject: Reply with quote
Flashed r39855M to r40270M, no reset, no issues so far.
_________________
Routing:.......Asus RT-AC86U (Asuswrt-Merlin 384.14_beta2)
Switching:....Netgear GS608_V3 & GS605_V4, TrendNet TEG-S82G & TEG-S50G
nickant
DD-WRT User


Joined: 09 Feb 2016
Posts: 151

PostPosted: Thu Jul 11, 2019 23:50    Post subject: Reply with quote
EA8500
Flashed r40270M over r39855M via GUI with no reset.
Came up as successfull, but no internet access (desktop/ethernet).
Rebooted EA8500 - still no internet.
Flashed r39855M over r40270M - internet now working.
Looks like I'll be staying on r39855M a bit longer - I don't want to spend an hour retyping all my settings and 20 static IP's...
I flashed r40270M and reset it, then tried to restore via r39855M backup; did not work.

_________________
------------------------------------
Linksys EA8500 DD-WRT r41686 (Gateway + OpenVPN Client)
Linksys WRT1900ACv1 DD-WRT r41686 (AP)
Netgear/Telstra V7610 (spare AP)
Billion BiPAC 7800NXL (spare AP)
Netgear WNDR3700v4 DD-WRT r41369 (spare Gateway + OpenVPN Client)
Photos: https://www.flickr.com/photos/nickant44/albums


Last edited by nickant on Fri Jul 12, 2019 0:17; edited 1 time in total
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4865
Location: Texas

PostPosted: Fri Jul 12, 2019 0:14    Post subject: Reply with quote
nickant wrote:
EA8500
Flashed r40270M over r39855M via GUI with no reset.
Came up as successfull, but no internet access (desktop/ethernet).
Rebooted EA8500 - still no internet.
Flashed r39855M over r40270M - internet now working.
Looks like I'll be staying on r39855M a bit longer - I don't want to spend an hour retyping all my settings and 20 static IP's...
Question: if I flash r40270M and reset it, can I restore via r39855M backup, or are these backups no longer compatible with >40000 firmwares?

I would think using a nvrambak.bin would put you right it the same place you were before.
Print to PDF the pages from your current setup.
I assume you can still copy text from a PDF done from a winders box.... I know I can from a print-to-PDF from my linux machine.
Anyways now days I have all my ovpn server stuff, static leases, firewall, some other goodies along with notes in a text file which makes it handy to copy/paste
Twisted Evil
nickant
DD-WRT User


Joined: 09 Feb 2016
Posts: 151

PostPosted: Fri Jul 12, 2019 0:21    Post subject: Reply with quote
Hi mrjcd.
I flashed r40270M and reset it, then tried to restore via r39855M backup; did not work.
I have printed out my settings - they're somewhere around here...
I might have to bite the bullet and retype or copy/paste everything again eventually.
Not hugely motivated - > 20 static IP + MAC addresses, as well as VPN settings etc..
r39855M has been very stable for me.

_________________
------------------------------------
Linksys EA8500 DD-WRT r41686 (Gateway + OpenVPN Client)
Linksys WRT1900ACv1 DD-WRT r41686 (AP)
Netgear/Telstra V7610 (spare AP)
Billion BiPAC 7800NXL (spare AP)
Netgear WNDR3700v4 DD-WRT r41369 (spare Gateway + OpenVPN Client)
Photos: https://www.flickr.com/photos/nickant44/albums
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4865
Location: Texas

PostPosted: Fri Jul 12, 2019 0:28    Post subject: Reply with quote
nickant wrote:
Hi mrjcd.
I flashed r40270M and reset it, then tried to restore via r39855M backup; did not work.
I have printed out my settings - they're somewhere around here...
I might have to bite the bullet and retype or copy/paste everything again eventually.
Not hugely motivated - > 20 static IP + MAC addresses, as well as VPN settings etc..
r39855M has been very stable for me.

since you have the EA8500 you can always just boot into other part iffin the one you install don't work to suit you.
Both boot_parts use the same nvram Wink
nickant
DD-WRT User


Joined: 09 Feb 2016
Posts: 151

PostPosted: Fri Jul 12, 2019 0:38    Post subject: Reply with quote
mrjcd:
yes, when r40270M didn't work I tried turning EA8500 on/off 3-4 times within a few seconds, but I couldn't bring up the other partition with r39855M on it.
This has worked for me before.
I had to press the reset button on r40270M, then flash r39855M, then restore the r39855M backup.

_________________
------------------------------------
Linksys EA8500 DD-WRT r41686 (Gateway + OpenVPN Client)
Linksys WRT1900ACv1 DD-WRT r41686 (AP)
Netgear/Telstra V7610 (spare AP)
Billion BiPAC 7800NXL (spare AP)
Netgear WNDR3700v4 DD-WRT r41369 (spare Gateway + OpenVPN Client)
Photos: https://www.flickr.com/photos/nickant44/albums
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4865
Location: Texas

PostPosted: Fri Jul 12, 2019 0:43    Post subject: Reply with quote
nickant wrote:
mrjcd:
yes, when r40270M didn't work I tried turning EA8500 on/off 3-4 times within a few seconds, but I couldn't bring up the other partition with r39855M on it.
This has worked for me before.
I had to press the reset button on r40270M, then flash r39855M, then restore the r39855M backup.

best way to change boot_part if you have ssh or telnet is --
see close to bottom of this page ---> http://mrjcd.com/EA8500_DD-WRT/
nickant
DD-WRT User


Joined: 09 Feb 2016
Posts: 151

PostPosted: Fri Jul 12, 2019 0:49    Post subject: Reply with quote
mrjcd:
Good to know.
Although a bit hard to get to that page without internet access!
I'll print it out... Smile

_________________
------------------------------------
Linksys EA8500 DD-WRT r41686 (Gateway + OpenVPN Client)
Linksys WRT1900ACv1 DD-WRT r41686 (AP)
Netgear/Telstra V7610 (spare AP)
Billion BiPAC 7800NXL (spare AP)
Netgear WNDR3700v4 DD-WRT r41369 (spare Gateway + OpenVPN Client)
Photos: https://www.flickr.com/photos/nickant44/albums
Goto page 1, 2, 3, 4, 5  Next Display posts from previous:    Page 1 of 5
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum