New Build 40189: BS 07-04-2019-r40189

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 1876
Location: Texas, USA

PostPosted: Thu Jul 04, 2019 19:12    Post subject: New Build 40189: BS 07-04-2019-r40189 Reply with quote
Another day, another build... Wink Check the changelog to see if anything is relevant to you.


Downloads: (if a link doesn't work, try another)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/07-04-2019-r40189/
ftp://ftp.dd-wrt.com/betas/2019/07-04-2019-r40189/
Alternate link: DD-WRT website
Note: to use wget (or curl) for CLI flash (`write {f/w} linux`), change the https to http (or use ftp instead)

Changelogs:
SVN* changelog since last build: 40167
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Notes:
1. SFE accelerated NAT is in 33006+ builds but only in kernel 3.2 and newer
2. 'KRACK' vulnerability fixes were completed in r33678 for Broadcom, including k26 (33655) & k24 (33656); use build 33772 or later.
3. Bridge modes on k4.4 devices may sometimes work in some configurations in certain builds but are not supported by the bcmdhd driver. Use client or repeater instead as WDS doesn't work with Broadcom ARM either (see Issues below).
4. Since 39469, udhcpd was removed and replaced with the already present dnsmasq, and PIE qdisc was added for some builds.
5. Policy-Based Routing with SFE enabled was fixed in r39556: 5986 and 5900
6. k2.4 (broadcom/) builds were fixed in 39715 (broken in 39144 through 39654)
7. SFE update (k3.10+ for BCM) was in the 39927 build.



Issues, observations, and/or workarounds reported:
1. Trendnet 81*DRU models are missing factory-to-flash
2. DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use: 6246
3. WDS does not work on Broadcom ARM devices (only MIPS<->MIPS)
4. K2.6 builds are broken since 38253(?); GUI issues: 6538
5. VAPs not working at boot; workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
This appears to be fixed for some routers (different kernels, modes, and radios) since build 39508.
6. UDP forwarding might not work with SFE Enabled see: https://svn.dd-wrt.com/ticket/6668


Important: if any issues are found, please provide log info (GUI syslog, `dmesg`, `cat /var/log/messages`).
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Template to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b]Router/Version: [/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Mode: [/b]
[b]Status: [/b]

WARNING: This thread is to report on flashing this experimental test build, providing important info for both developers and users. Always state your hardware model, version, mode (e.g. Repeater) and SPECIFIC build (e.g. 33555_NEWD-2_K3.x_mega-nv64k.bin). Please avoid discussions and create a new thread to discuss specific problems or questions, as this thread is for reporting, not support. Posts may be deleted or moved to keep this thread manageable and useful. If you don't understand the risks or what to flash and how, with a means of recovery if it bricks, do NOT flash this experimental test build.


Last edited by kernel-panic69 on Mon Jul 08, 2019 15:21; edited 2 times in total
Sponsor
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4694
Location: Texas

PostPosted: Thu Jul 04, 2019 19:59    Post subject: Reply with quote
Asus RT-N12D1
DD-WRT v3.0-r40189 mega (07/04/19)
Linux 3.10.108-d8 #25233 Thu Jul 4 16:40:27 CEST 2019 mips
[dd-wrt.v24-40189_NEWD-2_K3.x_mega.bin]
No reset -- GUI install over r40178
uptime 40 minutes
just a WAP -- NO VAP ... all worky ok
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 1876
Location: Texas, USA

PostPosted: Thu Jul 04, 2019 20:31    Post subject: Cisco Linksys E4200 v1 Reply with quote
Router/Version::Cisco Linksys E4200 v1
File: dd-wrt.v24-40189_NEWD-2_K3.x_mega-e4200.bin
Firmware: DD-WRT v3.0-r40189 mega (07/04/19)
Kernel: Linux 3.10.108-d8 #25233 Thu Jul 4 16:40:27 CEST 2019 mips
Previous: DD-WRT v3.0-r40065 mega (06/20/19)
Reset: No
Mode: Gateway/AP
Uptime: 1:15
Status: OK
Issues/Errors: Nothing new so far.


Last edited by kernel-panic69 on Fri Jul 05, 2019 9:12; edited 1 time in total
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 251

PostPosted: Thu Jul 04, 2019 21:11    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r40189 std (07/04/19)
Kernel: Linux 4.4.184 #370 SMP PREEMPT Thu Jul 4 09:13:26 CEST 2019 armv7l
Previous: r40167
Mode/Status: Gateway / working
Reset: no
Issues/Errors: Working so far.


Uptime: 16min
Temperatures: CPU 69.1 °C / WL0 48.5 °C / WL1 54.5 °C
SinCalChewy
DD-WRT User


Joined: 09 Nov 2014
Posts: 292
Location: Bakersfield, CA

PostPosted: Thu Jul 04, 2019 21:36    Post subject: Reply with quote
Router/Version: 2x Linksys E3000
Firmware: dd-wrt.v24-40189_NEWD-2_K3.x_mega-e3000.bin
Previous: dd-wrt.v24-40167_NEWD-2_K3.x_mega-e3000.bin
Kernel: Linux 3.10.108-d8 #25233 Thu Jul 4 16:40:27 CEST 2019 mips
Mode: Client Bridges
Status: Both seem to be working fine! :)

_________________

Deployed Routers:
Netgear R7000 - 3x Kong's 40270M (Gateway: USB /w Entware, Stubby, DoT & DoH, QoS)
Linksys E3000 - 2x build 40723M (Client Bridges)
Linksys E900 - 1x build 40723M (Work Client)

Spares/Backups/Collection:
Too many to list. I have old routers, bricked routers, weird routers. You name it.
Wildlion
DD-WRT User


Joined: 24 May 2016
Posts: 446

PostPosted: Fri Jul 05, 2019 2:05    Post subject: Reply with quote
Router: Buffalo WZR-1750DHP
Firmware: buffalo-wzr-1750dhp-webflash.bin (v3.0-r40189 std)
Kernel: Linux 4.4.184 #370 SMP PREEMPT Thu Jul 4 09:13:26 CEST 2019 armv7l
Status: Working
Reset: No
Notes on configuration:

    FTP server
    DNSMasq
    DNSSEC
    USB v3.0
    DHCP reservation

Errors:


    none

wuruxu
DD-WRT Novice


Joined: 17 Jun 2019
Posts: 15

PostPosted: Fri Jul 05, 2019 10:53    Post subject: Reply with quote
Router/Version: Linksys EA6300
Firmware: DD-WRT v3.0-r40189 std (07/04/19)
Kernel: Linux 4.4.184 #370 SMP PREEMPT Thu Jul 4 09:13:26 CEST 2019 armv7l
Previous:
Mode/Status: Gateway / working
Reset: no
Issues/Errors: Working so far. This release works as expect, it's GREAT, waiting for next release with wireguard update.
thommy181
DD-WRT Novice


Joined: 16 Mar 2019
Posts: 25
Location: Szczecin, Poland EU

PostPosted: Fri Jul 05, 2019 14:21    Post subject: Netgear WNR3500L v2 Reply with quote
Router/Version: Netgear WNR3500L v2
File: dd-wrt.v24-40189_NEWD-2_K3.x_mega-WNR3500Lv2
Kernel: Linux 3.10.108-d8 #25217 Thu Jul 4 16:24:16 CEST 2019
Mode: Internet Gateway and WiFi AP
Status: Rather OK, configure issues
Uptime: ~ 2 hours

When I try to configure my device in this build I have a problem in Setup -> Switch config. Here I try to configure ports manual. When I'm change options and click save and apply settings all options in this tab reverse to default settings. Now I have all ports in auto negotiation mode. I can't change config here. When I'm make first configuration after flash firmware I have problem with WAN port start. I must many times reboot router for ddwrt want activate this port.
Different issues are from #40134 build. Last stable in my tests is #40065.
Actually router want working generally OK, but earlier I have small isuess. One configuration tab won't to save my configuration.
tinkeruntilitworks
DD-WRT User


Joined: 21 May 2019
Posts: 95

PostPosted: Fri Jul 05, 2019 15:57    Post subject: Reply with quote
Router/Version: Netgear R7000P
Firmware: DD-WRT v3.0-r40189 std (07/04/19)
Kernel: Linux 4.4.184 #375 SMP PREEMPT Thu Jul 4 10:03:23 CEST 2019 armv7l
Mode: Gateway/AP
Status: working as expected
jwbraun
DD-WRT Novice


Joined: 22 Jun 2018
Posts: 15

PostPosted: Sat Jul 06, 2019 22:08    Post subject: Reply with quote
This does not boot on my Asus RT-AC1900P, it just reboots itself every 30 seconds or so.

Has to use the CFE miniWeb server to restore back to r40167 (6/30/19).
Brimmy
DD-WRT User


Joined: 29 Mar 2015
Posts: 380

PostPosted: Sun Jul 07, 2019 4:58    Post subject: Reply with quote
Router/Version: Buffalo WZR-1750DHP/DHPD
Firmware: DD-WRT v3.0-r40189 std (07/04/19
Kernel: Linux 4.4.184 #370 SMP PREEMPT Thu Jul 4 09:13:26 CEST 2019 armv7l
Previous: BSr40009 which worked great
Mode/Status: Gateway / WIFI = AP / Seems ok
CPU overclocked to 1400mhz from default 800mhz via r33006
Reset: No
Issues/Errors: Seems ok
UpTime: 0:1:14


What i have noticed:-

1) The mysterious load average is back but dissipates after about ten seconds.

Thank you for fixing the SFE, cause i have been getting full upload speed since r40009. Thanks Devs.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 1876
Location: Texas, USA

PostPosted: Mon Jul 08, 2019 0:43    Post subject: Re: Cisco Linksys E4200 v1 Reply with quote
kernel-panic69 wrote:
Router/Version::Cisco Linksys E4200 v1
File: dd-wrt.v24-40189_NEWD-2_K3.x_mega-e4200.bin
Firmware: DD-WRT v3.0-r40189 mega (07/04/19)
Kernel: Linux 3.10.108-d8 #25233 Thu Jul 4 16:40:27 CEST 2019 mips
Previous: DD-WRT v3.0-r40065 mega (06/20/19)
Reset: No
Mode: Gateway/AP
Uptime: 1:15
Status: OK
Issues/Errors: Nothing new so far.


Wound up disabling 2.4 band radio again. There is something definitely screwy about running both radios at the same time, even rolling beacon intervals back closer to what I usually have them set at (53/79).
tbrautaset
DD-WRT Novice


Joined: 21 Nov 2018
Posts: 5

PostPosted: Mon Jul 08, 2019 10:53    Post subject: Asus RT-AC3200 Reply with quote
Router/Version: Asus RT-AC3200
Firmware: DD-WRT v3.0-r40189 std (07/04/19)
Kernel: Linux 4.4.184 #375 SMP PREEMPT Thu Jul 4 10:03:23 CEST 2019 armv7l
Previous: r39956
Mode/Status: Gateway / working
Reset: no
Issues/Errors: Working so far.


Uptime: 22min
Temperatures: CPU 70.2 °C
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 1876
Location: Texas, USA

PostPosted: Mon Jul 08, 2019 15:25    Post subject: Reply with quote
Added #6 under "Issues" in the OP as it appears UDP forwarding is broken with SFE enabled, note taken from most recent <Kong> test build thread. I confirmed this with this build that it is still broken.
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 251

PostPosted: Mon Jul 08, 2019 20:56    Post subject: Reply with quote
kernel-panic69 wrote:
Added #6 under "Issues" in the OP as it appears UDP forwarding is broken with SFE enabled, note taken from most recent <Kong> test build thread. I confirmed this with this build that it is still broken.


Good to know; I thought it was at least partially fixed in 40048.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum