New BrainSlayer Build: 07-04-2019-r40189

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
MomenMamdouh
DD-WRT User


Joined: 19 Sep 2017
Posts: 53
Location: Egypt

PostPosted: Thu Jul 04, 2019 18:52    Post subject: New BrainSlayer Build: 07-04-2019-r40189 Reply with quote
New BrainSlayer Build: 07-04-2019-r40189

https://dd-wrt.com/support/other-downloads/?path=betas%2F2019%2F07-04-2019-r40189%2F

ftp://ftp.dd-wrt.com/betas/2019/07-04-2019-r40189/

Please report problems, errors or other changes on this new build release.

Change log:
http://svn.dd-wrt.com/timeline

Router Model:
Status:
Reset:
Errors:


Last edited by MomenMamdouh on Fri Jul 05, 2019 23:32; edited 3 times in total
Sponsor
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4633
Location: Texas

PostPosted: Thu Jul 04, 2019 19:54    Post subject: Reply with quote
Linksys EA8500
DD-WRT v3.0-r40188 std (07/04/19)
Linux 4.9.184 #329 SMP Mon Jul 1 01:23:59 CEST 2019 armv
No reset -- GUI install over r40134
30 static leases
ovpn server
VLAN
local DNS
QOS HFSC FQ_CODEL
all worky ok
uptime 38 minutes
http://www.dslreports.com/speedtest/51582547

Thanks BS for fixing mucked-up GUI webif Very Happy

#

Netgear WNDR3700 V4
DD-WRT v3.0-r40189 std (07/04/19)
Linux 3.18.140 #45616 Thu Jul 4 06:13:55 CEST 2019 mips
switch / smaba share EXT4 / ovpn server
all working fine
uptime 15:10

#

Linksys WRT160NL
DD-WRT v3.0-r40189 std (07/04/19)
Linux 3.10.108-d8 #13639 Thu Jul 4 04:11:51 CEST 2019 mips
No rest -- GUI install
switch / smaba share FAT32
uptime 16:45
NO longer requires a power cycle after install like many previous builds.
samba working just fine and also still good after doing a reboot.
Great build on this router.... although ---
this unit has ->Oops: flash id 0x1c2017 .
still will NOT install on my 160NL or E2100L units that have ->Oops: flash id 0xc22017 .
see difference in their MTD parts ---> 'from here' iffin anyone wants to know why.
don't remember any build that will install on them since r34311
might could maybe replace some their MTD parts or complete uboot but don't see the point since
old dd-wrt builds work very good for what I use them for anyways Twisted Evil

##
oh yea.... forgot to mention I am running unbound on the EA8500 and he's
working good like he always does Wink
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7005
Location: Winnipeg, Canada

PostPosted: Thu Jul 04, 2019 21:35    Post subject: Reply with quote
Router Model: dir-862L, dir-862L, wndr4300

Status: well it runs..
Reset: no
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5817
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6481 *
https://svn.dd-wrt.com/ticket/6495 *
https://svn.dd-wrt.com/ticket/6511
https://svn.dd-wrt.com/ticket/6555 *
https://svn.dd-wrt.com/ticket/6655
https://svn.dd-wrt.com/ticket/6666 *

the ticket list shrunk a bit not cause things are fixed, but cause no one seems to care to fix them, they are all "invalid"..

see https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320097 for latest post of full actual issues..

kong latest build with htb+fq_codel: https://www.dslreports.com/speedtest/51129155

bs builds default core affinities same qos settings: https://www.dslreports.com/speedtest/51129301 cant even get my 300 line speeds, and the latency is still bad

bs builds same affinities as kong build (all to core 0 except wan to core 1): https://www.dslreports.com/speedtest/51129346 at least fixes the speed, latency is slightly better than before, still a wreck..

kong build htb+pie: https://www.dslreports.com/speedtest/51129184

bs builds htb+pie: https://www.dslreports.com/speedtest/51129431

cpu is forced to max on both cores both builds cause of k4.9 freq broken.

no problem at all here with latency.. Rolling Eyes (still)

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

[QUALCOMM] R7800 ---------------> DD-WRT v3.0-r40270M kongat
[QUALCOMM] DIR-862L ------------> DD-WRT v3.0-r40750 std
[QUALCOMM] WNDR4300 v1 ------> DD-WRT v3.0-r40750 std
[QUALCOMM] DIR-862L ------------> DD-WRT v3.0-r40750 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 --------> DD-WRT v3.0-r40634 std

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4633
Location: Texas

PostPosted: Fri Jul 05, 2019 0:25    Post subject: Reply with quote
Just if some of yous observant people wonder why my previous post about EA8500 shows r40188
Well I reckon that's just the way it is
I downloaded the EA8500 'dd-wrt-webupgrade.bin' from the https and from the ftp
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/07-04-2019-r40189/linksys-ea8500/


ftp://ftp.dd-wrt.com/betas/2019/07-04-2019-r40189/linksys-ea8500/


and checked md5sum on both and they the same .bin file
f79134f3cc1186f0df01e277e6ee83f1 *dd-wrt-webupgrade.bin

AND
it is still doing very good Twisted Evil
Wildlion
DD-WRT User


Joined: 24 May 2016
Posts: 432

PostPosted: Fri Jul 05, 2019 2:04    Post subject: Reply with quote
Router: TL-WDR3600 v1
Firmware: tl-wdr3600_us-webflash.bin (v3.0-r40189 std)
Kernel: Linux 3.10.108-d8 #13635 Thu Jul 4 04:06:50 CEST 2019 mips
Status: working
Reset: No
Notes on configuration:

    Client

Errors:

    none


Router: DIR-615e3
Firmware: dir615e3-firmware.bin (v3.0-r40189std)
Kernel: Linux 3.10.108-d8 #13651 Thu Jul 4 04:30:27 CEST 2019 mips
Status: Buggy on gui
Reset: No
Notes on configuration:

    DNSMasq
    Virtual wireless with bridging x2
    multiple DHCP server
    QOS

Errors:

    1. Apply settings on multiple pages does not work (for example Setup->Basic Setup, Setup->Network and Security->Firewall)
    2. Firmware upgrade button does not work (I have had to use command line to upgrade/downgrade)
    3. Factory Defaults (reset) does not work (apparently broken after 33006)
    4. Firmware restore button broken (apparently broken after 33006)
    5. Switch ports can not communicate with each other (see post https://www.dd-wrt.com/phpBB2/viewtopic.php?t=312371 ) [have not tested due to wanting isolation]




Router: DIR-825 rev B1
Firmware: dir825-firmware.bin (v3.0-r40189 std)
Kernel: Linux 3.10.108-d8 #13633 Thu Jul 4 03:54:28 CEST 2019 mips
Status: Working
Reset: No
Notes on configuration:

    Media Network
    DNSMasq
    Port Forwarding
    DHCP reservation

Errors:


    none

MomenMamdouh
DD-WRT User


Joined: 19 Sep 2017
Posts: 53
Location: Egypt

PostPosted: Fri Jul 05, 2019 9:49    Post subject: Reply with quote
Router Model: TP-Link ARCHER-C7 v2
Status: Good
Reset: no
Configuration : DNSmasq, QoS, FIREWALL, VAP, USB, Mega Ad Block
UP Time: 1 day
Errors: none

_________________
Routers:
TP-Link Archer C7 v2-(EU)
TP-Link WR840n v3
TP-Link WR740n v5
eginnc
DD-WRT Novice


Joined: 23 Jul 2017
Posts: 47

PostPosted: Fri Jul 05, 2019 14:09    Post subject: Reply with quote
Router Model: TP-Link ARCHER-C7 v2 (QCA 9558v1 r1.0 720MHz & 9880-BR4A)
Firmware: DD-WRT v3.0-r40189 std (07/04/19)
Kernel: Linux 3.18.140 #45596 Thu Jul 4 05:35:46 CEST 2019 mips
Status: 2.4 and 5 GHz WAPs for Edgerouter X, 2.4 and 5 Guest VAPs on br1, switch for Roku3 streambox and Ooma VOIP.
Reset: No
Issues: None

Router Model: Trendnet TEW824DRU v1.1R (QCA 9558v1 r1.0 720MHz & 9880-BR4A)
Firmware: DD-WRT v3.0-r40189 std (07/04/19)
Kernel: Linux 3.18.140 #45614 Thu Jul 4 06:05:04 CEST 2019 mips
Status: backup router
Reset: No
Issues: PAINFULLY slow GUI response time. Something got left out of the build for this router.
Speaking of left out of the build for this router....same SoC, flash and memory size as Archer C7v2, but no WPA3 or Wireguard Sad

_________________
TP-Link Archer C7v2(US)
TP-Link Archer C9v1
Trendnet TEW824DRU
Edgerouter X
Bernadoe
DD-WRT User


Joined: 03 Dec 2014
Posts: 180

PostPosted: Fri Jul 05, 2019 14:17    Post subject: Reply with quote
Router: Netgear R7800
Firmware: DD-WRT v3.0-r40188 std (07/04/19)
Kernel: Linux 4.9.184 #329 SMP Mon Jul 1 01:23:59 CEST 2019 armv7l
Status: Working
Reset: No
Previous: 40065
Errors: No

Temperatures : CPU 49.450 °C / ath0 26 °C / ath1 26 °C

Working very well :
Router mode : DHCP
SFE Enable
STP Enable
DNSMasq
Cache DNSSEC data
Validate DNS Replies (DNSSEC)
Check unsigned DNS replies
Local DNS
No DNS Rebind
ath0, ath1
Vpn (OpenVPN Client)

BS: Thanks for all your good work!

without VPN


with VPN
roadrunner255
DD-WRT Novice


Joined: 16 Dec 2016
Posts: 3

PostPosted: Fri Jul 05, 2019 16:33    Post subject: Reply with quote
What is the best stable version for WNDR4300 v1, (saw the post above).


Can you downgrade from a newer version to an older version?

Cheers!


Last edited by roadrunner255 on Fri Jul 05, 2019 17:09; edited 1 time in total
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1261

PostPosted: Fri Jul 05, 2019 16:53    Post subject: Reply with quote
roadrunner255 wrote:
What is the best stable version?

Can you downgrade from a newer version to an older version?

Cheers!


this. yes
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4633
Location: Texas

PostPosted: Fri Jul 05, 2019 16:59    Post subject: Reply with quote
roadrunner255,
It is best not to asked this type question in a 'New Build' thread. Start you own topic ...
...you might get some replies. Maybe more replies if you state what router model/version and dd-wrt build you are currently using. We see this type question in here all time and it is really silly. You need to find out what is best for your particular setup. It might depend on what all you are doing with it, your ISP, your connection rate, and your actual knowledge of dd-wrt.
AND
Should be fine if you install a previous dd-wrt build over the current new release. It prolly won't hurt a thing, AFAIK on most routers.
Now if you install a build from 2017 over any build from this year on the EA8500 it will be just like the nvram was erased.
Doesn't hurt a thing but you must reconfig all your settings.... this is due to the change in nvram size on that particular unit
roadrunner255
DD-WRT Novice


Joined: 16 Dec 2016
Posts: 3

PostPosted: Fri Jul 05, 2019 17:12    Post subject: Reply with quote
mrjcd wrote:
roadrunner255,
It is best not to asked this type question in a 'New Build' thread. Start you own topic ...
...you might get some replies. Maybe more replies if you state what router model/version and dd-wrt build you are currently using. We see this type question in here all time and it is really silly. You need to find out what is best for your particular setup. It might depend on what all you are doing with it, your ISP, your connection rate, and your actual knowledge of dd-wrt.
AND
Should be fine if you install a previous dd-wrt build over the current new release. It prolly won't hurt a thing, AFAIK on most routers.
Now if you install a build from 2017 over any build from this year on the EA8500 it will be just like the nvram was erased.
Doesn't hurt a thing but you must reconfig all your settings.... this is due to the change in nvram size on that particular unit


Thanks, I updated my earlier post, I saw the 7/4 post that has the same router as mine (WNDR4300 v1), with errors.
Cheers!
kretex
DD-WRT Novice


Joined: 24 Apr 2019
Posts: 30

PostPosted: Sat Jul 06, 2019 17:15    Post subject: Reply with quote
Router Model: TP-LINK tl-wr940n(eu) v6.1
Firmware: DD-WRT v3.0-r40189 std (07/04/19)
Kernel Version: Linux 3.18.140 #45584 Thu Jul 4 05:20:04 CEST 2019 mips
Status: Working
Reset: No
Errors: None

Cool

Router Model: TP-Link TL-MR3420 v1
Firmware: DD-WRT v3.0-r40189 std (07/04/19)
Kernel Version: Linux 3.10.108-d8 #13683 Thu Jul 4 04:59:33 CEST 2019 mips
Status: Flash from factory working
Reset: Yes
Errors: Yes
- apply setting button not working ( only change save button become named saved botton Rolling Eyes press the saved botton and the settings was save succesfully Laughing )
- Firmware Upgrade using tl-mr3420v1-webflash.bin not working Rolling Eyes ( only show progrest bar but nothing happend Rolling Eyes )
joseg1968
DD-WRT Novice


Joined: 29 Mar 2015
Posts: 8

PostPosted: Sat Jul 06, 2019 22:33    Post subject: Buffalo DHP-_600DHP Reply with quote
firmware 07-04-2019-r40189
Router Model: WZR-600DHP
Status: active
Reset: no
Errors: no

in the version April 2019, the blocking of web pages does not work well as well as the blocking of services such as YouTube, Amazon etc.

Neither does the "Adblock" service work properly, it is activated by placing in additional configurations a route to a domain server to block and it does not work, before if it did it correctly

in this new version I have not tried yet if they already corrected it.
kretex
DD-WRT Novice


Joined: 24 Apr 2019
Posts: 30

PostPosted: Sun Jul 07, 2019 15:16    Post subject: tl-mr3420v1 Reply with quote
Sir...I flash from factory using factory-to-ddwrt.bin was succest and than try flash from webgui tl-mr3420v1-webflash.bin not working. I try flash webflash.bin using command line using winscp/putty see on picture. is this oke sir?? Rolling Eyes sorry for nob question. Smile
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum