[SOLVED] Amazon FireTV sticks will not connect...

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 88
Location: UK

PostPosted: Mon Jun 24, 2019 16:51    Post subject: [SOLVED] Amazon FireTV sticks will not connect... Reply with quote
I am currently using the latest BS 40065 firmware. All my devices connect ok except all 4 of my Amazon FireTV sticks say 'connected with problems' (as stated in the GUI of the FireTV sticks) - there is no internet connection. I have the same issue whether connected by wired or wirelsss connections.

However, once I revert back to BS 39884, with exactly the same settings as I have been using for BS 40065, everything works fine again.

Any ideas...?


Last edited by buffalo0207 on Tue Jun 25, 2019 1:05; edited 1 time in total
Sponsor
msoengineer
DD-WRT User


Joined: 21 Jan 2017
Posts: 394
Location: Illinois

PostPosted: Mon Jun 24, 2019 17:03    Post subject: Re: Amazon FireTV sticks will not connect... Reply with quote
buffalo0207 wrote:
I am currently using the latest BS 40065 firmware. All my devices connect ok except all 4 of my Amazon FireTV sticks say 'connected with problems' (as stated in the GUI of the FireTV sticks) - there is no internet connection. I have the same issue whether connected by wired or wirelsss connections.

However, once I revert back to BS 39884, with exactly the same settings as I have been using for BS 40065, everything works fine again.

Any ideas...?


I don't own a fire stick....
Not holding out hope, but you can try:

Security>Block Wan Request
uncheck the Filter Multicast.
This might help...

Are the Sticks getting an IP assigned by the router?

Are you doing any DNS things on the router? If yes, it may be that the sticks are trying to use their own DNS settings and conflicting with your DNS settings.

_________________
[r9000] running BS 40276
[EA8500] running Kong 39705
[R7800] KONG PRO [taking a nap...no qam256...]
[WDR3600] BS 36808


TIPS-A MUST READ:

Best QCA Wifi settings to use|Latency tricks|QoS Port priority

Why to NOT use MU-MIMO||Max Wifi Pwr by Country||MCS Index Speeds||Correct QCA 5Ghz chnls to use||WIFI Chnl Freq WIKI
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 88
Location: UK

PostPosted: Mon Jun 24, 2019 18:11    Post subject: Reply with quote
I unchecked the Filter Multicast in the Security>Block Wan Request settings, and though it initially seemed to work, within minutes the FireTV's dropped their connections.

They are getting IP addresses, but it says 'connected with problems' within the GUI of the FireTV's.

The DNS settings of my router are 1.1.1.1 and 1.0.0.1

What I don't understand it, my settings are exactly the same on both BS 39884 and BS 40065, but the FireTV's have the issue with the later firmware.
msoengineer
DD-WRT User


Joined: 21 Jan 2017
Posts: 394
Location: Illinois

PostPosted: Mon Jun 24, 2019 19:56    Post subject: Reply with quote
So my hunch about DNS was right...

You need to make sure to that these are checked on the main setup tab:

Use DNSMasq for DNS (Checked)
DHCP-Authoritative (Checked)
Recursive DNS Resolving (Unbound) (NOT CHECKED)(unless you know how to use Unbound)
Forced DNS Redirection (Checked)

Then on the services tab you need to make sure you have this in the DNS MASQ options window:
Code:
domain-needed
bogus-priv
no-resolv
server=9.9.9.9
server=1.0.0.1
server=1.1.1.1
no-negcache
filterwin2k


Make sure that there is a "enter/space" after the last entry.

The code has the IP's listed in reverse order vs. the setup screen because that's how it gets implemented.

If you use IPV6 Cloadflare DNS, don't forget to add those too. I didn't include them in the code above, but they would be the last two to get entered.

I use quad 9 and this is my code:
Code:
domain-needed
bogus-priv
no-resolv
server=1.1.1.1
server=149.112.112.112
server=9.9.9.9
server=2620:fe::9
server=2620:fe::fe
no-negcache
filterwin2k


_________________
[r9000] running BS 40276
[EA8500] running Kong 39705
[R7800] KONG PRO [taking a nap...no qam256...]
[WDR3600] BS 36808


TIPS-A MUST READ:

Best QCA Wifi settings to use|Latency tricks|QoS Port priority

Why to NOT use MU-MIMO||Max Wifi Pwr by Country||MCS Index Speeds||Correct QCA 5Ghz chnls to use||WIFI Chnl Freq WIKI
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 88
Location: UK

PostPosted: Mon Jun 24, 2019 20:37    Post subject: Reply with quote
I already had those settings checked in the main setup tab, and I have these settings in DNSMasq...

domain=mymain
local=/mymain/
expand-hosts
#
# Assign IP range, NetBIOS and DNS & DNSMasq Settings
log-async=5
domain-needed
bogus-priv
no-resolv
strict-order
server=1.1.1.1
server=1.0.0.1
server=9.9.9.9
no-negcache
filterwin2k
dhcp-option=br0,3,192.168.10.1
dhcp-range=br0,192.168.10.201,192.168.10.220,255.255.255.0,infinite
dhcp-option=43,01:04:00:00:00:02
#
# Set static IP addresses from USB
conf-file=/jffs/config/static_ip.cfg


Maybe the order is incorrect in my DNSMasq settings?
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 6935
Location: Winnipeg, Canada

PostPosted: Mon Jun 24, 2019 22:11    Post subject: Reply with quote
buffalo0207 wrote:
I already had those settings checked in the main setup tab, and I have these settings in DNSMasq...

domain=mymain
local=/mymain/
expand-hosts
#
# Assign IP range, NetBIOS and DNS & DNSMasq Settings
log-async=5
domain-needed
bogus-priv
no-resolv
strict-order
server=1.1.1.1
server=1.0.0.1
server=9.9.9.9
no-negcache
filterwin2k
dhcp-option=br0,3,192.168.10.1
dhcp-range=br0,192.168.10.201,192.168.10.220,255.255.255.0,infinite
dhcp-option=43,01:04:00:00:00:02
#
# Set static IP addresses from USB
conf-file=/jffs/config/static_ip.cfg


Maybe the order is incorrect in my DNSMasq settings?


why is log-async there? its not needed, neither is bogus-priv, strict-order if anything slows down dns.. given server= were examples, u dont have to use what was given in the examples, no clue why everyone does that (cloudflare is nice, quad9 falsly blocks random legit sites, their antiphishing/blocking is the lowest quality i ever seen. filterwin2k probably not needed, these are amazon devices, why is domain settings added when theres an entry in gui for a wan/lan domain?

add log-queries=extra and watch the dns requests from the devices in syslog to make sure everythings resolving

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

[QUALCOMM] R7800 ---------------> DD-WRT v3.0-r40270M kongat
[QUALCOMM] DIR-862L ------------> DD-WRT v3.0-r40347 std
[QUALCOMM] WNDR4300 v1 ------> DD-WRT v3.0-r40347 std
[QUALCOMM] DIR-862L ------------> DD-WRT v3.0-r40347 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 --------> DD-WRT v3.0-r39715 std

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 88
Location: UK

PostPosted: Tue Jun 25, 2019 0:07    Post subject: Reply with quote
@tatsuya46

Thanks for the input. I made the changes as suggested...

# Assign IP range, NetBIOS and DNS & DNSMasq Settings
domain-needed
no-resolv
strict-order
server=1.1.1.1
server=1.0.0.1
no-negcache
filterwin2k
dhcp-option=br0,3,192.168.10.1
dhcp-range=br0,192.168.10.201,192.168.10.220,255.255.255.0,infinite
dhcp-option=43,01:04:00:00:00:02
#
# Log the results of DNS queries with EXTRAs
log-queries=extra
#
# Set static IP addresses from USB
conf-file=/jffs/config/static_ip.cfg


...and now my FireTV sticks connect without any issues.

Cheers, much appreciated...
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 6935
Location: Winnipeg, Canada

PostPosted: Wed Jun 26, 2019 6:21    Post subject: Reply with quote
makes me wonder if dnsmasq was even running before..
_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

[QUALCOMM] R7800 ---------------> DD-WRT v3.0-r40270M kongat
[QUALCOMM] DIR-862L ------------> DD-WRT v3.0-r40347 std
[QUALCOMM] WNDR4300 v1 ------> DD-WRT v3.0-r40347 std
[QUALCOMM] DIR-862L ------------> DD-WRT v3.0-r40347 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 --------> DD-WRT v3.0-r39715 std

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum