New Build 06-11-2019-r40009

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 95
Location: FL

PostPosted: Wed Jun 12, 2019 2:31    Post subject: New Build 06-11-2019-r40009 Reply with quote
ftp://ftp.dd-wrt.com/betas/2019/06-11-2019-r40009/

Timeline
https://svn.dd-wrt.com/timeline

_________________
Issues:
1. VAPs not working at boot; workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
ALTERNATE for VAP issue run command ifconfig ath0.1 down then ifconfig ath0.1 up ( works better for me )

Linksys WRT1900ACv1 07-12-2019-r40276
WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv Opendns for Dns, Short Preamble Short GI
Sponsor
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 105

PostPosted: Wed Jun 12, 2019 2:43    Post subject: Reply with quote
I don't feel brave (or smart) enough to be the first. I'll be looking forward to reviews from those who are Very Happy
_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r40134 std (06/27/19)
ISP: RCN
NAS: ReadyNas314
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 187

PostPosted: Wed Jun 12, 2019 2:53    Post subject: Reply with quote
Firmware Version
DD-WRT v3.0-r40009 std (06/11/19)
Kernel Version
Linux 4.9.181-rc1 #1075 SMP Tue Jun 11 13:41:10 CEST 2019 armv7l

_________________
WRT1900ACSv2
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 131
Location: South Carolina

PostPosted: Wed Jun 12, 2019 2:53    Post subject: DD-WRT v3.0-r40009 std (06/11/19) Reply with quote
WRT3200ACM V1 r40009 Firefox 67.0.1 (64-bit) webflash

OpenVPN CLIENT works fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
2.4GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
NAS via USB Samba also working fine
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 105

PostPosted: Wed Jun 12, 2019 2:55    Post subject: Reply with quote
Thanks for the update. .
Did you retain current settings, or did you reset?

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r40134 std (06/27/19)
ISP: RCN
NAS: ReadyNas314
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 187

PostPosted: Wed Jun 12, 2019 3:00    Post subject: Reply with quote
I retained settings..

I reloaded VPN Key...

_________________
WRT1900ACSv2
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 131
Location: South Carolina

PostPosted: Wed Jun 12, 2019 3:01    Post subject: Reply with quote
giles02134 wrote:
Thanks for the update. .
Did you retain current settings, or did you reset?


Giles,

In my case, a very clean update. No changes, resets, or cleaning up parms needed except the soft reset that automatically happens after a flash. I'm using a wrt3200acm V1 router. Its typically been a very clean and forgiving. I did not have to reload any VPN keys or any setting.
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 105

PostPosted: Wed Jun 12, 2019 10:50    Post subject: Reply with quote
I am encouraged. I'll run the update later today.
Thanks for taking the plunge!

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r40134 std (06/27/19)
ISP: RCN
NAS: ReadyNas314
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 95
Location: FL

PostPosted: Wed Jun 12, 2019 12:14    Post subject: Reply with quote
8 hours good here, the problem i was having with the previous build is fixed. ( i had to leave it in g-mode on 2.4ghz ) wireless is very stable for all the devices
_________________
Issues:
1. VAPs not working at boot; workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
ALTERNATE for VAP issue run command ifconfig ath0.1 down then ifconfig ath0.1 up ( works better for me )

Linksys WRT1900ACv1 07-12-2019-r40276
WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv Opendns for Dns, Short Preamble Short GI
giles02134
DD-WRT User


Joined: 25 Feb 2007
Posts: 105

PostPosted: Wed Jun 12, 2019 14:14    Post subject: Reply with quote
Just flashed without resetting, using FF 67.0.1 x64 (Mac). No issues thus far. I'll be interested to see if the scheduled reboot works tomorrow at 3:00 a.m.

Will report any issues that emerge.

_________________
Router: Linksys WRT1900ACSv2
Modem: Arris Surfboard SB6141
DD-WRT v3.0-r40134 std (06/27/19)
ISP: RCN
NAS: ReadyNas314
SurprisedItWorks
DD-WRT User


Joined: 04 Aug 2018
Posts: 216
Location: Appalachian mountains, USA

PostPosted: Wed Jun 12, 2019 15:15    Post subject: Reply with quote
I'm very encouraged by all of your reports, and it may be time for an update. One issue for me though is DNSCrypt. I need it, as I am not yet ready to take the DNS-over-TLS plunge. I understand that the "Encrypt DNS" button is gone now from the DNSMasq configuration block in the GUI, but I don't need that. I can set it up in the DNSMasq Additional Config and the Startup Commands as long as dnscrypt-proxy still exists in the system, and it's easiest if dnscrypt-resolvers.csv is there as well. I know that these files remained in at least a few versions after the button disappeared.

In the CLI in 39144 I can see them this way:

root@DD-WRT:~# ls -l /etc/dnscrypt/dnscrypt-resolvers.csv
-rwxr-xr-x 1 root root 22309 Mar 10 22:19 /etc/dnscrypt/dnscrypt-resolvers.csv
root@DD-WRT:~# ls -l /usr/sbin/dnscrypt-proxy
-rwxr-xr-x 1 root root 262787 Mar 10 22:21 /usr/sbin/dnscrypt-proxy

Could someone have a look in this new release and see if the files are still there?

Many thanks, folks.

_________________
Five of the Linksys WRT1900ACSv2, on r39144 and r38159. On various: VLANs, client-mode travel router, two DNSCrypt DNS servers (incl Quad9), multiple VAPs, USB/NAS, OpenVPN client (random NordVPN server).

VLANs on the WRT1900ACSv2 and other two-CPU Linksys/Marvell routers:
https://www.dd-wrt.com/phpBB2/viewtopic.php?p=1091367

DNSCrypt for Quad9 DNS and/or multiple servers and/or missing DNSCrypt enable button: Sun Jan 06, 2019 post at
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318094
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 187

PostPosted: Wed Jun 12, 2019 15:28    Post subject: Reply with quote
Yep...Just telneted in...They're still there...The same as you outlined below.

-----------------------------------------
In the CLI in 39144 I can see them this way:

root@DD-WRT:~# ls -l /etc/dnscrypt/dnscrypt-resolvers.csv
-rwxr-xr-x 1 root root 22309 Mar 10 22:19 /etc/dnscrypt/dnscrypt-resolvers.csv
root@DD-WRT:~# ls -l /usr/sbin/dnscrypt-proxy
-rwxr-xr-x 1 root root 262787 Mar 10 22:21 /usr/sbin/dnscrypt-proxy

Could someone have a look in this new release and see if the files are still there?

Many thanks, folks.[/quote]

_________________
WRT1900ACSv2
SurprisedItWorks
DD-WRT User


Joined: 04 Aug 2018
Posts: 216
Location: Appalachian mountains, USA

PostPosted: Wed Jun 12, 2019 16:20    Post subject: Reply with quote
Thanks, DaveI. (If anyone wants to set up DNSCrypt in this release, give a try to the approach described in my last signature item below.)
_________________
Five of the Linksys WRT1900ACSv2, on r39144 and r38159. On various: VLANs, client-mode travel router, two DNSCrypt DNS servers (incl Quad9), multiple VAPs, USB/NAS, OpenVPN client (random NordVPN server).

VLANs on the WRT1900ACSv2 and other two-CPU Linksys/Marvell routers:
https://www.dd-wrt.com/phpBB2/viewtopic.php?p=1091367

DNSCrypt for Quad9 DNS and/or multiple servers and/or missing DNSCrypt enable button: Sun Jan 06, 2019 post at
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318094
Kailen
DD-WRT Novice


Joined: 07 Dec 2016
Posts: 7

PostPosted: Thu Jun 13, 2019 12:12    Post subject: Reply with quote
After upgrading i get a user.err with the dnscrypt resolver and have lost internet connectivity.

-user.err : No resolver named [adguard-dns-ns2] found in the [/etc/dnscrypt/dnscrypt-resolvers.csv] list, unable to read file either and does not have an a config file.

-Unable to save specific options such as disabling dnsmasq and Recursive DNS Resolving (Unbound)

_________________
------------------------
Linksys WRT1900ACv2


Last edited by Kailen on Thu Jun 13, 2019 20:05; edited 6 times in total
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 96

PostPosted: Thu Jun 13, 2019 13:15    Post subject: Reply with quote
Updated using FF 67.0.1 (64-bit). Normal reboot time. All functions working. Appears to have a slight speed improvement.
_________________
LinkSys WRT3200ACM
DD-WRT v3.0-r40134 std (06/27/19)
DNSMasq,Local DNS
CloudFlare DNS
ExpressVPN OpenVPN Client
Static Leases & DHCP
2.4 & 5GHz clients
Comcast 1Gbps/35Mbps
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum