New Build: 08-25-2019-r40784

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2, 3  Next
Author Message
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 301

PostPosted: Sun Aug 25, 2019 11:37    Post subject: New Build: 08-25-2019-r40784 Reply with quote
ftp://ftp.dd-wrt.com/betas/2019/08-25-2019-r40784/

https://dd-wrt.com/support/other-downloads/?path=betas%2F2019%2F08-25-2019-r40784%2F

Flashed to PARTITION ONE with Firefox 68.02

Firmware Version
DD-WRT v3.0-r40784 std (08/25/19)
Kernel Version
Linux 4.9.190-rc1 #1245 SMP Sun Aug 25 04:08:25 CEST 2019 armv7l

_________________
WRT1900ACSv2


Last edited by DaveI on Sun Aug 25, 2019 19:04; edited 2 times in total
Sponsor
Monza
DD-WRT User


Joined: 01 Jul 2018
Posts: 121

PostPosted: Sun Aug 25, 2019 12:37    Post subject: Reply with quote
Upgraded WRT1200AC v1 from r40723 to r40784 using Waterfox 56.2.13 (64 bit) running on Linux Mint 19.1 OS.

Ran command "ubootenv set boot_part 2" before update. Successful update and reboot. Usual OpenVPN yellows in syslog. No reset,no issues. Uptime about 45 minutes

r40723 running so well for me I hesitated to update to r40784

Kernel Version Linux 4.9.190-rc1 #1245 SMP Sun Aug 25 04:08:25 CEST 2019 armv7l

Aug 25 08:12:34 router daemon.notice openvpn[1733]: OpenVPN 2.4.7 arm-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Aug 25 2019
Aug 25 08:12:34 router daemon.notice openvpn[1733]: library versions: OpenSSL 1.1.1c 28 May 2019, LZO 2.09

Edit: Randomly dropped VPN connection a few times over the past 24 hours, reverted to r40723 The drops were the only issue I've had but not getting that with r40723


Last edited by Monza on Mon Aug 26, 2019 12:06; edited 1 time in total
gufus
DD-WRT Guru


Joined: 04 Aug 2012
Posts: 610
Location: behind the screen

PostPosted: Sun Aug 25, 2019 22:31    Post subject: Reply with quote
MAC Address60:38:E0:B7:F8:E2
Chipset 88W8964 802.11ac
RadioRadio is On
ModeWDS Station
NetworkAC/N-Mixed
SSIDgypsynet_5g
Channel157 + 155 (5785 MHz VHT80)
Busy Time77931 ms
Active Time770535 ms
Channel Quality90%
TX Power30 dBm
Rate1300 Mb/s
ACK TimingN/A
Encryption - Interface ath0Enabled, WPA2-PSK
Connected Clients1

Wireless Packet Info
Received (RX)
100%2041 OK, no error
Transmitted (TX)
100%2161 OK, no error

Wireless Nodes
Access Point
MAC Address Radioname Interface Uptime TX Rate RX Rate Info Signal Noise SNR Signal Quality
00:25:9C:13:34:6B ath0 0:12:54 1300M 877M VHT80SGI -54 -105 51
92%

_________________
WRT3200ACM openwrt 18.06.4
WRT3200ACM dd-wrt r40009
WRT54GL dd-wrt r21676
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 170

PostPosted: Sun Aug 25, 2019 23:42    Post subject: Reply with quote
Updated w/FF68.0.2x64, via WiFi. No issues, smooth upgrade. All functions, including VPN Client connection, working as expected. All looks good.
_________________
Netgear R9000 X10
DD-WRT v3.0-r41686 std (12/10/19)
AP, DNSMasq, Local DNS
CloudFlare DNS
QoS using HFSC w/CAKE
Static Leases & DHCP
2.4GHz: 3 + 7 (2422 MHz HT40)
5GHz: 161 + 155 (5805 MHz VHT80)
Xfinity 1Gbps/35Mbps
ruprect
DD-WRT Novice


Joined: 29 Sep 2016
Posts: 15

PostPosted: Sun Aug 25, 2019 23:57    Post subject: Reply with quote
anyone have a screen grab of their 2.4 and 5 working wireless setting, I have screwed something up and am struggling to see where Sad

Linksys 1900ACS
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 200
Location: South Carolina

PostPosted: Mon Aug 26, 2019 0:27    Post subject: DD-WRT v3.0-r40784 std (08/25/19) Reply with quote
WRT3200ACM V1 r40784 Firefox 68.0.2 (64-bit) webflash

OpenVPN CLIENT works fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
2.4GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
NAS via USB Samba also working fine
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 155
Location: FL

PostPosted: Mon Aug 26, 2019 1:44    Post subject: Reply with quote
Flashed this firmware just now.... seems ok... to tired to go into it after a 14hr work day...

ruprect wrote:
anyone have a screen grab of their 2.4 and 5 working wireless setting, I have screwed something up and am struggling to see where Sad

Linksys 1900ACS

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2019
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &


WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
marcox
DD-WRT Novice


Joined: 09 Mar 2019
Posts: 5

PostPosted: Mon Aug 26, 2019 9:57    Post subject: Reply with quote
Try to Upgrade WRT1900ACS v2 from r40723 to r40784. Download FW File. Updrade runns o.k.! After Upgrade the Router shows still the Version r40723! Second try, same. So what is the problem? Is the file r40784 wrong on FTP Server or what can i do?
ttowling
DD-WRT User


Joined: 01 Mar 2019
Posts: 109

PostPosted: Mon Aug 26, 2019 13:36    Post subject: Reply with quote
marcox wrote:
Try to Upgrade WRT1900ACS v2 from r40723 to r40784. Download FW File. Updrade runns o.k.! After Upgrade the Router shows still the Version r40723! Second try, same. So what is the problem? Is the file r40784 wrong on FTP Server or what can i do?


Did it fail to update because you were trying to flash it to the smaller partition?

I then boots back into the original partition.
marcox
DD-WRT Novice


Joined: 09 Mar 2019
Posts: 5

PostPosted: Mon Aug 26, 2019 14:08    Post subject: Reply with quote
So i not understand... till version Firmware: DD-WRT v3.0-r40723 std (08/21/19) i do everytime the same. Upload new FW file and ready. And now the partition is too small? in frist post he write he is upgrade to first partition on 1900acs v2. So what is the solution to make the new upgrades?

Last edited by marcox on Mon Aug 26, 2019 14:31; edited 1 time in total
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 155
Location: FL

PostPosted: Mon Aug 26, 2019 14:31    Post subject: Reply with quote
go to admin,commands and run this
ubootenv set boot_part 2
then flash to the current firmware

then from now on every time before you flash your going to want to run
ubootenv set boot_part 2
First then flash

the newer firmwares are to big for partition 2

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2019
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &


WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
marcox
DD-WRT Novice


Joined: 09 Mar 2019
Posts: 5

PostPosted: Mon Aug 26, 2019 14:48    Post subject: Reply with quote
i understand but last question:
"i suggest going to firmware 40009 flash that twice"

how to do i install the firmware 40009 flash twice?
O.k. fist is normal, but the second i need the command first?

..............

ok i see u edit ur post... so i do only this what u write above...thx
ellick
DD-WRT User


Joined: 28 Mar 2016
Posts: 240

PostPosted: Mon Aug 26, 2019 16:12    Post subject: Reply with quote
WRT1900ACS v1

Ran "ubootenv set boot_part 2" command to get back to build r40009 on the second partition then successfully upgraded to r40784.

OpenVPN still fails to start when enabled and pressing save then pressing apply. I checked in Status/openvpn and the vpn was not running. I have to press apply a second time to get it to run.

Build r40009 is still the last build I haven't had bugs. The best thing (for me) about the new builds is the addition of Cake to the list of QoS disciplines. I used it in openwrt and it works much better for me.
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 155
Location: FL

PostPosted: Mon Aug 26, 2019 17:26    Post subject: Reply with quote
marcox wrote:
i understand but last question:
"i suggest going to firmware 40009 flash that twice"

how to do i install the firmware 40009 flash twice?
O.k. fist is normal, but the second i need the command first?

..............


i assume your on partion two already with the current firmware, if its questionable if partition two is valid
ubootenv set boot_part 1 then flash 40009 that would put 40009 on partition 2, then from there you could flash the new one to partition 1

in the end you want to end up with a good firmware on partition 2 so if you run into trouble down the line with a bad flash it has something valid on partition 2 so you can recover is the whole point of it.

ubootenv get boot_part will tell you what partition you are currently on.

output would be:
a_pEnv->crc = b2121afb
crc32 = b2121afb
1

means you on partition 1 now.... if it says 2 then your currently on 2....

the point of the command
ubootenv set boot_part 2
is to fool the router into thinking you are on partition 2 during a flash so it writes to partition 1

ubootenv set boot_part 1
would then ofcourse make the flash write to partion 2

so if you have any doubt what so ever on if you have a good flash on partition two i mentioned 40009 build because i know it fits on partition 2 and it is also a pretty stable solid build.

Newer Builds are bigger then partition 2 allows

good luck and enjoy.

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2019
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &


WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
gufus
DD-WRT Guru


Joined: 04 Aug 2012
Posts: 610
Location: behind the screen

PostPosted: Mon Aug 26, 2019 20:38    Post subject: Reply with quote
got 5g WDS STA VAP working in ch104 DFS mode:Smile


----
MAC Address60:38:E0:B7:F8:E2
Chipset 88W8964 802.11ac
RadioRadio is On
ModeWDS Station
NetworkAC/N-Mixed
SSIDgypsynet_5g
Channel104 + 106 (5520 MHz VHT80)
Busy Time62457 ms
Active Time1799898 ms
Channel Quality97%
TX Power21 dBm
Rate1300 Mb/s
ACK TimingN/A
Encryption - Interface ath0Enabled, WPA2-PSK
Connected Clients1

Wireless Packet Info
Received (RX)
100%8459 OK, no error
Transmitted (TX)
100%7456 OK, no error

Wireless Nodes
Access Point & Clients
MAC Address Radioname Interface Uptime TX Rate RX Rate Info Signal Noise SNR Signal Quality
00:25:9C:13:34:6B ath0 0:30:47 1300M 1300M VHT80SGI -55 -103 48
90%
B4:6B:FC:3E:75:B5 ath0.1 0:23:12 866M 866M VHT80SGI -57 -103 46
86%

_________________
WRT3200ACM openwrt 18.06.4
WRT3200ACM dd-wrt r40009
WRT54GL dd-wrt r21676
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum