connected but no internet

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking
Goto page 1, 2  Next
Author Message
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Fri May 17, 2019 5:29    Post subject: connected but no internet Reply with quote
I followed egc' guide and was able to get connected to my openvpn server.But couldn't surf the internet. The browser's message is "server not found".

LZO Compression is disabled and I'm sure that's not the problem.

I'm completely new to vpn. I'm confused as to what the firewall code should be after reading your guide. Maybe you can post it here.

Router Model Netgear WNDR4300
Firmware Version DD-WRT v3.0-r39715 std
This is a second router behind another router which I use to connect to the broadband. I port forwarded 1194 udp from the main router to the dd-wrt router (secondary router), I wonder if that's enough.

Anyway, thank you very much. I think the guide is the best thing on the internet concerning setting up openvpn on dd-wrt routers. I was excited to get connected. Now I want the internet to work. Can you help please?
Sponsor
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5221
Location: Akershus, Norway

PostPosted: Fri May 17, 2019 7:50    Post subject: Reply with quote
Probably missing NAT for the sub-net on the primary router.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4373
Location: Netherlands

PostPosted: Fri May 17, 2019 8:24    Post subject: Reply with quote
How is the secondary router connected?
_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Sat May 18, 2019 12:34    Post subject: openvpn no traffic Reply with quote
It turns out that the issue is not the "router behind another router" setup. I decided to set up the dd-wrt router to directly connect to my ISP (using PPPOE), but the same problem persists: can get connected, but no internet.

It's frustrating and extremely time-consuming. Anyway, here's my setup and log file. Any help is appreciated.
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Sat May 18, 2019 12:36    Post subject: continued from previous post Reply with quote
continued from previous post----

here's how the firewall gets configured. I have doubts as if I have done it correctly.
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Sat May 18, 2019 12:39    Post subject: here's the log prior to any connection Reply with quote
this is the log from my DD-wrt router:
status info:
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Sat May 18, 2019 12:44    Post subject: here's the log prior to any connection Reply with quote
this is the log, and no connection has been made.
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Sat May 18, 2019 12:48    Post subject: another not Reply with quote
I checked the time on the router. It was incorrect before and the log (not in the picture above)showed an error message. I selected the correct time zone and make sure it's the same as on my computer. But this alone doesn't help much, same problem remains.
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Sat May 18, 2019 13:09    Post subject: connection is established Reply with quote
this shows the state after connection is established.
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Sat May 18, 2019 13:11    Post subject: connected:log Reply with quote
log: connection made.
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Sat May 18, 2019 13:16    Post subject: some thoughts Reply with quote
I was able to set up PPTP and L2TP on my router successfully. Just because OPENVPN is supposed to be SAFE, i decided to give it a go. It turns out to be a very very demanding task for a novice like me.
I agree that the setting should be kept at a minimum, but still, it's so tricky. Hope this thread can help me find a solution as well as helping many other who want to try out setting up an Openvpn server on DD-WRT routers.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4373
Location: Netherlands

PostPosted: Sat May 18, 2019 13:34    Post subject: Reply with quote
You log shows a valid connection with traffic flowing.

Can you ping anything on your local network like the router?
Can you ping anything outside like ping 8.8.8.8 ?

If you can, run: traceroute 8.8.8.8

Things to check, you have compression disbled and that is fine, make sure there is no reference to lzo-comp in the client setting.

Try TCP instead of UDP, especially when using cellular UDP can give problems. ISP's also can throttle port 1194, so Try port 443 with TCP

Edit: after done configurating reboot

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
abcmem
DD-WRT Novice


Joined: 16 May 2019
Posts: 11

PostPosted: Wed Oct 30, 2019 3:52    Post subject: Now it works but can't surf within company network Reply with quote
Sorry about this belated reply.
I reset the dd-wrt firmware to the factory setting and started configuration from a clean state. Openvpn started to work after this, albeit with one minor issue. Within my workplace network, connection is established but my PC can't visit websites. Firefox returns a "server not found" message. Other apps can connect to the internet. This problem only exists at my workplace network(can surf the web using workplace wifi). I use commercial VPN at work, there's no such problem. I suppose this has something to do with my company's router settings. Apparently, commercial VPNs can bypass those limits.
Is there any way I can change some configuration settings, so I can surf the net at work? Is it possible that my OPENVPN connection isn't safe enough, since it's apparently detected by company router?
Any advice is appreciated!
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4373
Location: Netherlands

PostPosted: Wed Oct 30, 2019 8:01    Post subject: Reply with quote
If you have a good connection you should be able to browse the GUI of your router

If that is the case then use this rule to get internet access:
Code:
iptables -t nat -A POSTROUTING -o $(get_wanface)-j MASQUERADE


Administration/Commands, Save as Firewall

If you are sure you are connected use TCP instead of UDP and check compression settings.

If you are not sure you are connected or if you can not browse the GUI of the router then show a picture of your OVPN Status page (whole page) and the clients log when you should have a connection.

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
loady
DD-WRT User


Joined: 22 Feb 2012
Posts: 79

PostPosted: Wed Oct 30, 2019 20:44    Post subject: Reply with quote
Exact same problem on my setup, same setup as yours..I also wonder if it's something to do with the ISP router, are you on talk talk in UK?
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum