OpenVPN server won't start

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking
Author Message
Bensie
DD-WRT Novice


Joined: 07 Sep 2019
Posts: 3

PostPosted: Sat Sep 07, 2019 6:56    Post subject: OpenVPN server won't start Reply with quote
Hello all,

Been poking around on this for a while, can't figure it out. I've followed a few guides with the same steps (namely the sticky by egc). No matter what, my server will never start (the Status->OpenVPN page is just blank).

Router is a Netgear WNDR4300, and I'm running Firmware: DD-WRT v3.0-r40559 std (08/06/19)

Is there a bug or something? Any other tricks to get this working?
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6997
Location: Netherlands

PostPosted: Sat Sep 07, 2019 9:00    Post subject: Reply with quote
If your OpenVPN status page is blank the server does not start and you probably have a major setup fault.

The usual culprit are the keys and certificates which are wrong.

My advice: reset the router to defaults and start over from step 1

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Bensie
DD-WRT Novice


Joined: 07 Sep 2019
Posts: 3

PostPosted: Sat Sep 07, 2019 15:39    Post subject: Reply with quote
Thanks for the reply. I just reset router to default config and redid your guide to the letter. It still comes up with a blank screen for server status. Is there a way to check logging or debug using some other means?
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6997
Location: Netherlands

PostPosted: Sat Sep 07, 2019 15:50    Post subject: Reply with quote
There is no logging if it does not start.
One exception is if you setup as daemon.
You should setup (config) as server.

You can always post a picture of your settings page so that we can review it.

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Bensie
DD-WRT Novice


Joined: 07 Sep 2019
Posts: 3

PostPosted: Mon Sep 09, 2019 3:13    Post subject: Reply with quote
Thanks for the help. I went to take some screen shots, and one of the key fields was completely blank. It didn't retain for some reason. I replaced it, hit apply and save twice, and the server started right up.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Advanced Networking All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum