Kong R7000 VAP Connection Failure Workground is annoying me

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
ryanbtc
DD-WRT Novice


Joined: 12 Apr 2019
Posts: 5

PostPosted: Fri Apr 12, 2019 7:32    Post subject: Kong R7000 VAP Connection Failure Workground is annoying me Reply with quote
I’m running Kong AC Build 39345M but this issue existed on previous builds. I have 2 VAP’s on my 5ghz radio and if I reboot my clients are unable to connect to them. It’s like my client is sending the wrong WPA2 AES encryption key. I see others on this forum are having the same problem.

After many frustrating and sleepless nights of nvram erases and complete rebuild's, I managed to figure out a tried and true fix to make my VAP’s connectable again.

If I go into the Basic 5Ghz Wireless Settings and choose Disable Wireless SSID broadcast on the last 5ghz VAP, hit Apply Settings, then re-enable SSID broadcast, hit Apply Settings then all will be well and my clients can connect. Initially I did this for all 5ghz VAP's, one-by-one, but then noticed that it worked if I did it for just the last one. Hitting apply and not save is crucial.

Does anyone know what is causing this bug exist and how can we get it resolved? I'm a sys/net admin not a coder. All I can do to help is offer workaround that I am able to reproduce and hope that someone more code minded can figure out a true bug fix.

Something is broken after reboot and disabling/re-enabling SSID broadcast is the only way to fix it. Curious if this resolves the issue for others?


Last edited by ryanbtc on Fri Apr 12, 2019 7:36; edited 1 time in total
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4377
Location: Netherlands

PostPosted: Fri Apr 12, 2019 7:35    Post subject: Reply with quote
Unfortunately it is a known and frustrating bug, below a snippet of earlier threads:

Quote:
From approximately mid 2018 VAP's on Broadcom units are problematic, you cannot connect or do not get an IP address. There are workarounds :
1) When VAP is not working at boot; workaround startup command Administrationn/Commands, Save as Startup:
sleep 10; stopservice nas; stopservice wlconf; startservice wlconf; startservice nas;
2) Alternative way to get VAP working: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=317181

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
ryanbtc
DD-WRT Novice


Joined: 12 Apr 2019
Posts: 5

PostPosted: Fri Apr 12, 2019 7:38    Post subject: Reply with quote
Ya on one of my sleepless nights I saw that post and tried those commands and they didn't work for me. Only the step by step disable, apply, renable, apply of the VAP SSID's work.

egc wrote:
Unfortunately it is a known and frustrating bug, below a snippet of earlier threads:

Quote:
From approximately mid 2018 VAP's on Broadcom units are problematic, you cannot connect or do not get an IP address. There are workarounds :
1) When VAP is not working at boot; workaround startup command Administrationn/Commands, Save as Startup:
sleep 10; stopservice nas; stopservice wlconf; startservice wlconf; startservice nas;
2) Alternative way to get VAP working: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=317181
ryanbtc
DD-WRT Novice


Joined: 12 Apr 2019
Posts: 5

PostPosted: Fri Apr 12, 2019 7:47    Post subject: Reply with quote
Quote:
From approximately mid 2018 VAP's on Broadcom units are problematic, you cannot connect or do not get an IP address. There are workarounds :
1) When VAP is not working at boot; workaround startup command Administrationn/Commands, Save as Startup:
sleep 10; stopservice nas; stopservice wlconf; startservice wlconf; startservice nas;


When I run those commands I get the following response from 'startservice wlfconf' :

eth1: Not supported
eth1: Not supported
eth2: Not supported
eth2: Not supported

Is this an issue preventing my VAPs from coming back up? Would really like even a scriptable work around then having to disable/renable SSID broadcast.

Bouncing wland doesn't have any effect either.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4377
Location: Netherlands

PostPosted: Fri Apr 12, 2019 8:30    Post subject: Reply with quote
It is not an issue, you can safely use it
_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
ryanbtc
DD-WRT Novice


Joined: 12 Apr 2019
Posts: 5

PostPosted: Fri Apr 12, 2019 8:45    Post subject: Reply with quote
egc wrote:
It is not an issue, you can safely use it


The command line stuff doesnt help.

I just discovered if I simply hit Apply on the Basic Setup screen it will activate my VAP's properly.

stopservice wlconf & startservice wlconf does nothing except give me grief about eth1 and eth2.

Is there any command I can run to execute the code being run when hitting apply on the basic setup screen? Thanks
ryanbtc
DD-WRT Novice


Joined: 12 Apr 2019
Posts: 5

PostPosted: Fri Apr 12, 2019 9:09    Post subject: Command Line Workaround Reply with quote
This works for me! Set as part of my startup script:

sleep 4; stopservice cron; stopservice wlconf; wlconf eth1 up; wlconf eth2 up; startservice cron;

Saw some others posts and tried with stop/start nas service and also with start wlconf.
The nas service wasn't necessary for me to include in my commands.

The key was cron being stopped first and then the interfaces being brought up individually with 'wlconf {if} up' and not using startservice wlconf .

Now if we can get the bug fixed permanently that would be great. This workaround is viable for me now.
redhawk0
DD-WRT Guru


Joined: 04 Jan 2007
Posts: 11451
Location: Wherever the wind blows- North America

PostPosted: Sat Apr 13, 2019 11:45    Post subject: Reply with quote
I have never had any luck with the provided manual commands either. But this one does work for me on both R7000 and R6300v2 units. See if this works for you as well.

sleep 20; stopservice nas; wlconf eth1 down; wlconf eth2 down; wlconf eth1 up; wlconf eth2 up; startservice nas

redhawk

_________________
I do NOT provide personal assistance through chat or phone....so please don't ask.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum