wr1043nd v1 image too big - r40559 broke it

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
gwaitsi
DD-WRT User


Joined: 11 Jan 2007
Posts: 79

PostPosted: Tue Apr 14, 2020 22:21    Post subject: wr1043nd v1 image too big - r40559 broke it Reply with quote
I can't update my tplink wr1043nd v1 by the gui, or command line.

Gui - indicates it completes, but after too remains stuck on r40559.

when using "write image.bin linux"

Image too big for partition: linux
linux: Invalid argument

my tplink wr1043nd v2 didn't work by the gui, but did with the above command line.

tried webrevert through the gui, and like the upgrade, it says successful after a few seconds but boots back into r40559
Sponsor
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3702
Location: UK, London, just across the river..

PostPosted: Wed Apr 15, 2020 5:48    Post subject: Reply with quote
40559 is bad and it seems you are another victim of the router database... have a look at new builds treads...
ftp://ftp.dd-wrt.com/betas/2020/ last firmware's...
finally you have 2 routers one is v1 and the other one is v2 ??

as far as 1043 v2 you can upgrade it via CLI im on the last firmware on it and its working...

do not load v2 on v1 as those are different routers with different hardware...

do not use save file from a different builds or different routers...redo settings manually..

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 43886 BS AP,NAT
TP-Link WR740Nv4 ------DD-WRT 43028 BS WAP/Switch
TP-Link WR1043NDv2 ----DD-WRT 44048 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----DD-WRT 43886 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 43886 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -------DD-WRT 43886 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
gwaitsi
DD-WRT User


Joined: 11 Jan 2007
Posts: 79

PostPosted: Wed Apr 15, 2020 5:54    Post subject: Reply with quote
I already said i managed to update the v2 to latest build via CLI.

my problem is, i can't even revert the v1 to factory or any other dd-wrt build.

If i found a solution by searching, i wouldn't have made a new thread. I am not suffering cabin fever and don't feel the need to create threads to fulfill my human interaction needs.

I am looking for assistance in solving a problem.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 6871
Location: Texas, USA

PostPosted: Wed Apr 15, 2020 6:03    Post subject: Reply with quote
If you found directions for the V2, you stepped past the ones for the v1: https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=441970#441970
_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
gwaitsi
DD-WRT User


Joined: 11 Jan 2007
Posts: 79

PostPosted: Wed Apr 15, 2020 8:34    Post subject: Reply with quote
kernel-panic69 wrote:
If you found directions for the V2, you stepped past the ones for the v1: https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=441970#441970


this thread is for a bricked device.
my device is not bricked. It works fine under r40559,
but obviously the build screwed something with the linux partition.

I would imagine if that was the case, a patched should have been made that could fix it to get another build on without having to got creating h/w interfaces.
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3702
Location: UK, London, just across the river..

PostPosted: Wed Apr 15, 2020 9:43    Post subject: Reply with quote
have a look here https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=311642
_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 43886 BS AP,NAT
TP-Link WR740Nv4 ------DD-WRT 43028 BS WAP/Switch
TP-Link WR1043NDv2 ----DD-WRT 44048 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----DD-WRT 43886 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 43886 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -------DD-WRT 43886 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
gwaitsi
DD-WRT User


Joined: 11 Jan 2007
Posts: 79

PostPosted: Wed Apr 15, 2020 21:54    Post subject: Reply with quote
well, it is bricked now.

I will make a serial cable and restore factory. But i am done. will use openwrt going forward.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum