New Build 39031: BS 03-02-2019-r39031

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2  Next
Author Message
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 296

PostPosted: Sat Mar 02, 2019 21:47    Post subject: New Build 39031: BS 03-02-2019-r39031 Reply with quote
Downloads: (if a link doesn't work, try another)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/03-02-2019-r39031/
ftp://ftp.dd-wrt.com/betas/2019/03-02-2019-r39031/
Alternate link: DD-WRT website
Note: to use wget (or curl) for CLI flash (`write {f/w} linux`), change the https to http, or use ftp (curl only)

Changelogs:
SVN* changelog since last build 38937
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Notes:
1. SFE accelerated NAT is in 33006+ builds but only in kernel 3.10 and newer
2. krack fixes for Broadcom were completed in r33678, including k26 (33655) & k24 (33656); use build 33772 or later.
3. Bridge modes on k4.4 devices may sometimes work in some configurations in certain builds but are not supported by the bcmdhd driver. Use client or repeater instead as WDS doesn't work with Broadcom ARM either (see Issue #4 below).
4. R6400v2 support added in r36811-36818, 36825, and 36826. R6700v3 support added in r36828-36840.

Issues, observations, and/or workarounds reported:
1. (egc) Policy-Based Routing broken if SFE enabled: 5900
quarkysg's PBR+SFE fix: 5986
2. Trendnet 81*DRU models are missing factory-to-flash
3. DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use: 6246
4. WDS does not work on ARM devices (only MIPS<->MIPS)
5. VAPs not working at boot (k3.10?); workaround startup command:
sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
6. K2.6 builds are broken since 38253(?); GUI issues: 6538

Important: if any issues are found, please provide log info (GUI syslog, `dmesg`, `cat /var/log/messages`).
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Template to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b]Router/Version: [/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Mode: [/b]
[b]Status: [/b]

WARNING: This thread is to report on flashing this experimental test build, providing important info for both developers and users. Always state your hardware model, version, mode (e.g. Repeater) and SPECIFIC build (e.g. 33555_NEWD-2_K3.x_mega-nv64k.bin). Please avoid discussions and create a new thread to discuss specific problems or questions, as this thread is for reporting, not support. Posts may be deleted or moved to keep this thread manageable and useful. If you don't understand the risks or what to flash and how, with a means of recovery if it bricks, do NOT flash this experimental test build.
Sponsor
flyzipper
DD-WRT User


Joined: 21 Feb 2016
Posts: 296

PostPosted: Sat Mar 02, 2019 21:50    Post subject: Reply with quote
Router/Version: Netgear R7000
Firmware: DD-WRT v3.0-r39031 std (03/02/19)
Kernel: Linux 4.4.176 #4965 SMP Sat Mar 2 08:02:37 CET 2019 armv7l
Previous: r38993 (version deleted)
Mode/Status: Gateway / working
Reset: no
Issues/Errors: No issues so far.

Uptime: 1h 43m
Temperatures: CPU 66.4 °C / WL0 49.5 °C / WL1 53.0 °C
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1468
Location: Belgrade

PostPosted: Sat Mar 02, 2019 22:05    Post subject: Reply with quote
Router Model Netgear R6250
Firmware Version DD-WRT v3.0-r39031 std (03/02/19)
Kernel Version Linux 4.4.176 #4965 SMP Sat Mar 2 08:02:37 CET 2019 armv7l

Status: Working rock solid (pppoe, unbound, AP 2,4&5)
Reset: No
Errors: None

Thx BS!!!

p.s. new wiki article if someone is willing to read
https://wiki.dd-wrt.com/wiki/index.php/Easy_torrenting_with_dd-wrt
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 299

PostPosted: Sat Mar 02, 2019 22:26    Post subject: Reply with quote
Successful upgrade on my old backup router WRT54G-TM. (MEGA Build)
_________________
WRT1900ACSv2
flood404
DD-WRT User


Joined: 18 Dec 2013
Posts: 184

PostPosted: Sun Mar 03, 2019 2:01    Post subject: Reply with quote
Router/Version: 3700v3
File: k3.x nv64k.bin
Kernel: k3.9
Mode: AP
Status: b] Working

Router/Version: Linksys 320N
File: k3.x 320n.bin
Kernel: k3.9
Mode: AP
Status: Works

Router/Version: x64bit duo core computer
File: 64bit public free version
Kernel: k3.9
Mode: router/gateway
Status: boots ok.

Testing the NAS Samba for a week to see if the system freezing or locking up like the last 3 builds did.

I guess the OOM utility is killing a vital process. I have not seen the HTTPd use up 100% of one core yet.
SinCalChewy
DD-WRT User


Joined: 09 Nov 2014
Posts: 296
Location: Bakersfield, CA

PostPosted: Sun Mar 03, 2019 4:31    Post subject: Reply with quote
Router/Version: 2x Linksys E3000
File: dd-wrt.v24-39031_NEWD-2_K3.x_mega-e3000.bin
Previous: dd-wrt.v24-38937_NEWD-2_K3.x_mega-e3000.bin
Kernel: Linux 3.10.108-d8 #23219 Sat Mar 2 14:56:33 CET 2019 mips
Mode: Client bridges with all settings not -required- turned off.
Status: Seems to be working great, no issues thus far. :)

_________________

Deployed Routers:
Netgear R7000 - 3x build 41517M (Gateway: Entware, Stubby DoT & DoH, CAKE)
Linksys E3000 - 2x build 41517M (Client Bridges)

Spares/Backups/Collection:
Too many to list. I have old routers, bricked routers, weird routers. You name it.
Yemble
DD-WRT Guru


Joined: 17 Feb 2010
Posts: 587
Location: Yorkshire (GOC)

PostPosted: Sun Mar 03, 2019 8:51    Post subject: Reply with quote
Working OK on TP-Link Archer C9 v1
_________________
Linksys WRT32X v1 - r41586
Linksys WRT1900AC v1 - r41586
TP-Link Archer C9 v1 - r41586
Firmware: ftp://ftp.dd-wrt.com/betas/2019/
MolaMola
DD-WRT User


Joined: 07 Mar 2013
Posts: 63

PostPosted: Sun Mar 03, 2019 9:29    Post subject: Reply with quote
Router/Version: TP-Link Archer C9 v1
File: archer-c9v1-webflash.bin
Kernel: Linux 4.4.176 #4967 SMP Sat Mar 2 08:18:06 CET 2019 armv7l
Mode: Gateway
Status: OK

Boots fine. Zero cpu load. Internet still works. Wink

Every once in a while with other recent builds my Android phone lost its connection to WAN (with wifi still connected). Will wait and see if that's fixed now.
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5215
Location: Akershus, Norway

PostPosted: Sun Mar 03, 2019 9:50    Post subject: Reply with quote
Router Model: Asus RT-AC66U A1
Firmware Version: DD-WRT v3.0-r39031M giga (03/02/19)
Kernel VersionLinux: 3.10.108-d8 #23203 Sat Mar 2 14:39:40 CET 2019 mips

Status: Working
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4318
Location: Netherlands

PostPosted: Sun Mar 03, 2019 10:27    Post subject: Reply with quote
Router Model: Linksys E2000 (converted N320)

Firmware Version: DD-WRT v3.0-r39031M mega (03/02/19)
Kernel Version: Linux 3.10.108-d8 #23219 Sat Mar 2 14:56:33 CET 2019 mips

Upgraded: from DD-WRT v3.0-r38535M Mega 31/1/19)
Reset: No

Status: Up and running for 2 hours, basic setup as Gateway, static leases, OpenVPN client (on PIA) up and running, VPN download speed 5-6 Mb/s, 2,4GHz and 5 GHz working, OpenVPN server (TUN) working.

Errors: No, Seems like a good build

Big Thanks to the devs!!

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135#1183135
SinCalChewy
DD-WRT User


Joined: 09 Nov 2014
Posts: 296
Location: Bakersfield, CA

PostPosted: Sun Mar 03, 2019 12:15    Post subject: Reply with quote
Router/Version: Trendnet TEW811DRU
Firmware: DD-WRT v3.0-r39031 mini (03/02/19)
Previous: DD-WRT v3.0-r38570 mini (02/04/19)
Kernel: Linux 4.4.176 #4968 Sat Mar 2 08:21:40 CET 2019 armv7l
Mode: AC-only Client Bridge. All settings not -required- for a bridge are turned off.
Status: Working. All my server stuff is working. So it's doing what it's meant to do so far. Lol


Router/Version: Linksys E1200v2
Firmware: dd-wrt.v24-39031_NEWD-2_K3.x_mega-e1200v2.bin
Previous: dd-wrt.v24-38570_NEWD-2_K3.x_mega-e1200v2.bin
Kernel: Linux 3.10.108-d8 #23219 Sat Mar 2 14:56:33 CET 2019 mips
Mode: Repeater for our guests, sooo it's very rarely used. It "works", but not much testing done. Lol
Status: Working as a basic repeater.


Router/Version: ASUS RT-N16
Firmware: DD-WRT v3.0-r39031M big (03/02/19)
Previous: DD-WRT v3.0-r36596 big (08/14/18)
Kernel: Linux 3.10.108-d8 #23215 Sat Mar 2 14:52:24 CET 2019 mips
Mode: Spare. Just updated, reset in the process.
Status: Seems to be working. Didn't notice any issues, but alas, this is a spare and I don't use it to notice any.

_________________

Deployed Routers:
Netgear R7000 - 3x build 41517M (Gateway: Entware, Stubby DoT & DoH, CAKE)
Linksys E3000 - 2x build 41517M (Client Bridges)

Spares/Backups/Collection:
Too many to list. I have old routers, bricked routers, weird routers. You name it.
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 585
Location: Hung Hom, Hong Kong

PostPosted: Sun Mar 03, 2019 17:46    Post subject: Reply with quote
Source: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318832&start=15

Router: Netgear WNR2000v2

flood404 wrote:

Do not flash the build r39031 it bricked the 2000v2 router. This is the latest one that works for the 2000v2

ftp://ftp.dd-wrt.com/betas/2019/02-23-2019-r38937/broadcom_K26/dd-wrt.v24-38937_NEWD-2_K2.6_mini.bin

smask wrote:
flood404 wrote:
I have two of those routers. They have excellent radio's in them. The only downside its a 10/100mbps router. I can almost access my wifi at the end of the street here with those. I am surprised the r38937 loaded. I may dig mine out and flash it to see if takes it. Does the WebGUI work? I know I had issues with a linksys 320N using the k2.6 build for it.


Web GUI works, but I haven't done any testing on it. The 2000v2 lives in my spares collection. I loaded the latest firmware to see if it still worked (r38535) Don't load -nv64k.bin firmwares because those bricks the router even if they only are 1k bytes bigger.

Loaded the plain mini r38535 by a lucky mistake. (RouterDb recommends -nv64k builds, and listed big and mega builds?)
Bricked it by loading mini r38570-nv64k. (RouterDb told me to use -nv64k)
Serial recovery to r15962 (tried the 2000v2 r38570.chk and r38535.chk but those bricked it again. Tralied builds are -nv64k)
Loaded the plain mini r38840 and then the plain mini r38937.

You might have to factory reset the settings going from a -nv64k build to a plain one. I haven't tested if -nv60k builds work.



_________________
Router: Asus RT-N18U (rev. A1)

May the Force and farces be with you! Live long and proper!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832


Last edited by mwchang on Mon Mar 04, 2019 3:16; edited 1 time in total
audia3
DD-WRT Novice


Joined: 10 Mar 2018
Posts: 21

PostPosted: Sun Mar 03, 2019 22:18    Post subject: Reply with quote
Router/Version: Asus RT-N66U
File: DD-WRT v3.0-r39031M big (03/02/19)
Kernel: Linux 3.10.108-d8 #23215 Sat Mar 2 14:52:24 CET 2019 mips
Mode: AP
Status: Working

This router is tethered by USB to my iPhone XS. No problems.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2569
Location: Texas, USA

PostPosted: Mon Mar 04, 2019 1:49    Post subject: Cisco Linksys E4200 v1 Reply with quote
Router/Version: Cisco Linksys E4200 v1
File: dd-wrt.v24-39031_NEWD-2_K3.x_mega-e4200.bin
Firmware: DD-WRT v3.0-r39031M mega (03/02/19)
Kernel: Linux 3.10.108-d8 #23219 Sat Mar 2 14:56:33 CET 2019 mips
Previous: DD-WRT v3.0-r38993M mega (02/28/19)
Reset: No
Mode: Gateway/AP
Uptime: 11:20
Status: OK
Issues/Errors:

Still testing additional dnsmasq configs, etc. to resolve wi-fi dns lookup issues, but otherwise, no new issues that haven't been previously reported numerous times.
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 585
Location: Hung Hom, Hong Kong

PostPosted: Mon Mar 04, 2019 3:04    Post subject: DD-WRT BS build 39031 and Asus RT-N18U Reply with quote
Router/Version: Asus RT-N18U
Firmware: DD-WRT v3.0-r39031 std (03/02/19)
Kernel: inux 4.4.176 #4969 Sat Mar 2 08:23:29 CET 2019 armv7l
Previous: DD-WRT v3.0-r38840 std (02/19/19)
Mode: WAN @ DHCP, Wireless @ AP
Status: Working (not 24/7 & not using IPv6, VAP, VPN, NAS nor USB)
Reset: NO reset during firmware upgrade

1. Only LAN 1 LED was working. RT-N18U has 4 LAN ports.
WAN LED was off though internet was working.

2. Error(s) logged:
Code:
grep -i err /var/log/messages

Jan  1 00:00:12 RT-N18U kern.err kernel: bcmsflash: found no supported devices
Mar  4 02:57:57 RT-N18U daemon.err httpd[987]: Request Error Code 404: File style/elegant/logo.png not found.
Mar  4 02:57:58 RT-N18U daemon.err httpd[987]: Request Error Code 401: Authorization required. please note that the default username is "root" in all newer releases
Mar  4 02:58:03 RT-N18U daemon.err httpd[987]: Request Error Code 404: File style/elegant/logo.png not found.
Mar  4 02:58:05 RT-N18U daemon.err httpd[987]: Request Error Code 404: File style/elegant/logo.png not found.


3. Warning(s) logged:
Code:
grep -i warn /var/log/messages | grep -v DROP

Jan  1 00:00:12 RT-N18U kern.warn kernel: Found a AMD NAND flash:
Jan  1 00:00:12 RT-N18U kern.warn kernel: Total size:  128MB
Jan  1 00:00:12 RT-N18U kern.warn kernel: Block size:  128KB
Jan  1 00:00:12 RT-N18U kern.warn kernel: Page Size:   2048B
Jan  1 00:00:12 RT-N18U kern.warn kernel: OOB Size:    64B
Jan  1 00:00:12 RT-N18U kern.warn kernel: Sector size: 512B
Jan  1 00:00:12 RT-N18U kern.warn kernel: Spare size:  16B
Jan  1 00:00:12 RT-N18U kern.warn kernel: ECC level:   8 (8-bit)
Jan  1 00:00:12 RT-N18U kern.warn kernel: Device ID: 0x 1 0xf1 0x 0 0x1d 0x 1 0xf1
Jan  1 00:00:12 RT-N18U kern.warn kernel: PCI: no core
Jan  1 00:00:12 RT-N18U kern.warn kernel: PCI: no core
Jan  1 00:00:12 RT-N18U kern.warn kernel: PCI: Fixing up bus 0 domain 0
Jan  1 00:00:12 RT-N18U kern.warn kernel: PCI: Fixing up bus 0 domain 1
Jan  1 00:00:12 RT-N18U kern.warn kernel: PCI: Fixing up bus 1 domain 1
Jan  1 00:00:12 RT-N18U kern.warn kernel: Boot partition size = 524288(0x80000)
Jan  1 00:00:12 RT-N18U kern.warn kernel: lookup_nflash_rootfs_offset: offset = 0x200000 size = 0x1e00000, 0x20000
Jan  1 00:00:12 RT-N18U kern.warn kernel: nf_conntrack_rtsp v0.7 loading
Jan  1 00:00:12 RT-N18U kern.warn kernel: nf_nat_rtsp v0.7 loading
Jan  1 00:00:12 RT-N18U kern.warn kernel: Spare area=64 eccbytes 56, ecc bytes located at:
Jan  1 00:00:12 RT-N18U kern.warn kernel:  2 3 4 5 6 7 8 9 10 11 12 13 14 15 18 19 20 21 22 23 24 25 26 27 28 29 30 31 34 35 36 37 38 39 40 41 42 43 44 45 46 47 50 51 52 53 54 55 56 57 58 59 60 61 62 63
Jan  1 00:00:12 RT-N18U kern.warn kernel: Available 7 bytes at (off,len):
Jan  1 00:00:12 RT-N18U kern.warn kernel: (1,1) (16,2) (32,2) (48,2) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0)
Jan  1 00:00:12 RT-N18U kern.warn kernel: Bad eraseblock 356 at 0x000002c80000
Jan  1 00:00:12 RT-N18U kern.warn kernel: Options: NO_SUBPAGE_WRITE,
Jan  1 00:00:12 RT-N18U kern.warn kernel: et: module license 'Proprietary' taints kernel.
Jan  1 00:00:12 RT-N18U kern.warn kernel: Disabling lock debugging due to kernel taint
Jan  1 00:00:12 RT-N18U kern.warn kernel: et_module_init: passivemode set to 0x0
Jan  1 00:00:12 RT-N18U kern.warn kernel: et_module_init: txworkq set to 0x0
Jan  1 00:00:12 RT-N18U kern.warn kernel: et_module_init: et_txq_thresh set to 0x400
Jan  1 00:00:12 RT-N18U kern.warn kernel: et_module_init: et_rxlazy_timeout set to 0x3e8
Jan  1 00:00:12 RT-N18U kern.warn kernel: et_module_init: et_rxlazy_framecnt set to 0x20
Jan  1 00:00:12 RT-N18U kern.warn kernel: et_module_init: et_rxlazy_dyn_thresh set to 0
Jan  1 00:00:12 RT-N18U kern.warn kernel: eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.89.21 (r524987)
Jan  1 00:00:12 RT-N18U kern.warn kernel: wl_module_init: passivemode set to 0x0
Jan  1 00:00:12 RT-N18U kern.warn kernel: wl_module_init: txworkq set to 0x0
Jan  1 00:00:12 RT-N18U kern.warn kernel: eth1: Broadcom BCM4360 802.11 Wireless Controller 7.14.89.21 (r524987)
Jan  1 00:00:12 RT-N18U kern.warn kernel: eth0: mixed HW and IP checksum settings.


Firmware Size

From 25804800 (b.38570) to 27574272 (b.38840) = 1769472 bytes
From 27574272 (b.38840) to 27774976 (b.39031) = 200704 bytes

User Comments:
- WiFi broken in k3.x editions since build 35531 for modes other than AP?
- Setting WPA re-key interval if not 99999 and rebooting router daily fixed nas (network authentication service) crash problems?
- Setting WPA re-key interval to 0 could prevent wifi clients from disconnecting?
- Change security mode of Virtual Interface wl0.1 to WPA personal, and after successfull connect change it back to WPA2 Personal.
- Manually install the kmod utilities package from the OpenWRT repository
- Anything but "auto" set in advanced wl1 settings for authentication type and are using WPA / WPA2, 5GHz NOT going to work
- VAP still not fixed by this build 36333, adding a VAP might disable the real AP
- 5GHz problem can be solved by adding delay (boot wait?) in init process?
- Restarting nas and all wireless interfaces (wl0, wl1) after seconds of delay could fix Guest WiFi & VAP issues?
Read: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=317617

Old Problems:
a. DDNS (inadyn) crashed in build 31722
b. Testing port-forwarding via WAN IP from within LAN not working in builds 34411-34760. Needed external proxy server.
c. NTP client not working in builds 34886-34876,35034 (affecting process_monitor?)
d. The ping to www.google.com increased from 2ms to 13ms after setting a defunct
WINS server in Setup->Basic Setup->DHCP->WINS (also something related to blank Source Net?)
e. The "Source Net" field in Port-Forwarding screen displayd blank field as "¸ÖÁv",
from builds 32667 to 32767. Possibly null-pointer assignment?
f. Blank Source Net in Port Forwarding cripped WAN in builds 35831-35874! Needed to be "0.0.0.0/0" or no internet!
g. Running "cat /proc/mtd" in Administration -> Commands for builds before 35916 didn't escape HTML special characters.
h. K3X BS Builds 36233 and 36242 might brick your routers (Kernel CPU patch went kaboom?). And VAP was not working. Bypass them!
i. lsmod listed only one module in some 36xxx builds and maybe some older builds
j. HTML special character "|" not escaped in build 37736 when using Admin. Command Shell
k. Bad BS Builds for RT-N18U: 37305, 37405, 38581




speedtest.net result for DD-WRT BS build 39031 and Asus RT-N18U.png
 Description:
speedtest.net result for DD-WRT BS build 39031 and Asus RT-N18U
 Filesize:  13.51 KB
 Viewed:  2010 Time(s)

speedtest.net result for DD-WRT BS build 39031 and Asus RT-N18U.png



_________________
Router: Asus RT-N18U (rev. A1)

May the Force and farces be with you! Live long and proper!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum