Problem Wan Speed

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
kowalmisiek
DD-WRT Novice


Joined: 23 Jan 2018
Posts: 30

PostPosted: Wed Mar 13, 2019 15:32    Post subject: Problem Wan Speed Reply with quote
I managed to deal with that problem somehow. I have a different problem now.
In speedtests, it shows 600Mb / s everywhere.
When I download something from a fast server on TP-LINK Archer C7 my speed is 20MB / s.
When I connect directly to the operator's modem I have 72MB / s.

Why is the maximum of 20MB / s in DD_WRT?
Of course, I did a reboot to the factory settings before uploading the firmware.
Sponsor
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3090
Location: UK, London, just across the river..

PostPosted: Wed Mar 13, 2019 16:24    Post subject: Reply with quote
please define MB/s or Mbit/s
if 600MB/s suppose to be Mbit/s this is impossible for Archer C7 even with SFE turned on i guess..
than speed depends on many things, if its WI-FI than encryption used, settings and ect. , wired must be constant and probably a touch better...
in case of you have 600Mbit ISP connection you might need a better router...
there are so many articles on the subject ask ggl
and post pic your Wi-Fi settings to be able to diagnose further ....
do we know which is the current build/firmware you have on...last doesn't give us a clear picture at all
also do you have VPN as trough VPN you will get about 15-20 Mbit with Archer C7 (ver ??) even less
its a single core router with very slow CPU suitable only for basic needs...

for decent Wi-Fi settings look here
https://wiki.dd-wrt.com/wiki/index.php/QCA_wireless_settings

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 33772 BS WAP/Switch (wired)
TP-Link WR1043NDv2 ----DD-WRT 41659 BS (AP,PPPoE,NAT,AD Blocking,AP Isolation,Firewall,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----DD-WRT 41686 BS (AP,NAT,AD Blocking,Firewall,Wi-Fi OFF,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 (AP,NAT,QoS,Quotas)
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 41686 BS (AP,NAT,AD-Blocking,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT,VPN)
Broadcom
Netgear R7000 -------DD-WRT 40270M Kong (AP,NAT,VLAN,AD-Blocking,Firewall,Local DNS,Forced DNS,DoT)
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 via Entware by mac913
kowalmisiek
DD-WRT Novice


Joined: 23 Jan 2018
Posts: 30

PostPosted: Wed Mar 13, 2019 16:49    Post subject: Reply with quote
My internet speed is of course 600Mbit / s. I'm testing the link only on the cable connection. 1Gbit network card in the computer.

My Firmware: DD-WRT v3.0-r37882 std (11/30/1Cool
The newer firmware does not work for me WIFI 5Ghz.

I have OpenVPN server enabled. When I turn off the OpenVPN server, I still have about 15-20MB / s download.

Someone from another forum wrote to me that DD-WRT does not support hardware WAN <-> LAN acceleration and that's why it's so bad. Is it possible?

If there is such a need, I can backup my configuration for checking.
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7144
Location: YWG, Canada

PostPosted: Wed Mar 13, 2019 18:22    Post subject: Reply with quote
kowalmisiek wrote:
My internet speed is of course 600Mbit / s. I'm testing the link only on the cable connection. 1Gbit network card in the computer.

My Firmware: DD-WRT v3.0-r37882 std (11/30/1Cool
The newer firmware does not work for me WIFI 5Ghz.

I have OpenVPN server enabled. When I turn off the OpenVPN server, I still have about 15-20MB / s download.

Someone from another forum wrote to me that DD-WRT does not support hardware WAN <-> LAN acceleration and that's why it's so bad. Is it possible?

If there is such a need, I can backup my configuration for checking.


u dont happen to have shaw do u..? anyway, cpu isnt fast enough.

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150 ------------> DD-WRT v3.0-r41717 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r41717 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41717 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41717 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41717 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r41631 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
kowalmisiek
DD-WRT Novice


Joined: 23 Jan 2018
Posts: 30

PostPosted: Wed Mar 13, 2019 18:56    Post subject: Reply with quote
I looked at the GUI and my processor was 12% laden when downloading at 20MB / s.
It seems that there is a reserve of power. Unless the GUI is lying.
I do not know what DSLReports is and what it is for. Can you explain how it works and where it's in the links?
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3090
Location: UK, London, just across the river..

PostPosted: Wed Mar 13, 2019 19:22    Post subject: Reply with quote
well there must be something with your set up...
do you use SFE and QoS at the same time ...
or SFE and policy based routing...
in general my 1043 v2 has the same CPU and can see around 200Mbit/s without SFE ish with SFE i had near 300 once back in the days...

but yep consider a new router if you want to utilise 600Mbit ISP WAN speed....
look for Netgear R7800 it has very decent specs...
even second hand will do...

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 33772 BS WAP/Switch (wired)
TP-Link WR1043NDv2 ----DD-WRT 41659 BS (AP,PPPoE,NAT,AD Blocking,AP Isolation,Firewall,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----DD-WRT 41686 BS (AP,NAT,AD Blocking,Firewall,Wi-Fi OFF,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 (AP,NAT,QoS,Quotas)
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 41686 BS (AP,NAT,AD-Blocking,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT,VPN)
Broadcom
Netgear R7000 -------DD-WRT 40270M Kong (AP,NAT,VLAN,AD-Blocking,Firewall,Local DNS,Forced DNS,DoT)
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 via Entware by mac913
kowalmisiek
DD-WRT Novice


Joined: 23 Jan 2018
Posts: 30

PostPosted: Wed Mar 13, 2019 19:33    Post subject: Reply with quote
I will say this. It seems to me that the TP-LINK Archer C7 V4 has enough power to let go of these 72MB / s.
I even managed to get so much. Only I do not understand why this is happening.

When I use the JDownloader download manager and premium account on the uploaded.to site.


I download 3 files (3 x single stream) speed = 20MB / s

I download 3 files (3 x 20 streams) speed = 72MB / s

I do not understand what it depends on?
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5243
Location: Akershus, Norway

PostPosted: Wed Mar 13, 2019 19:55    Post subject: Reply with quote
http://www.dslreports.com/speedtest
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3090
Location: UK, London, just across the river..

PostPosted: Wed Mar 13, 2019 22:01    Post subject: Reply with quote
if you say so 600Mibt = 75MB/s so ???
but i doubt your router is capable to translate such a speed...
the only option for this is if you use IPv6 i guess...
but i doubt..do you???

so i don't know what you need and talking about
it seems you are very unclear/unsure about speeds...
and the router CPU power...

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 33772 BS WAP/Switch (wired)
TP-Link WR1043NDv2 ----DD-WRT 41659 BS (AP,PPPoE,NAT,AD Blocking,AP Isolation,Firewall,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----DD-WRT 41686 BS (AP,NAT,AD Blocking,Firewall,Wi-Fi OFF,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 (AP,NAT,QoS,Quotas)
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 41686 BS (AP,NAT,AD-Blocking,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT,VPN)
Broadcom
Netgear R7000 -------DD-WRT 40270M Kong (AP,NAT,VLAN,AD-Blocking,Firewall,Local DNS,Forced DNS,DoT)
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 via Entware by mac913
kowalmisiek
DD-WRT Novice


Joined: 23 Jan 2018
Posts: 30

PostPosted: Thu Mar 14, 2019 6:35    Post subject: Reply with quote
As I wrote above. I reached the speed of 72MB / s when downloading but only in the download manager. When there are several simultaneous connections to one file. With a single download, it is max. 20MB / s. If the router can download a file at 72MB / s (several connections at the same time), why can not it download one file with this speed?

The 10GB file from this site muj router operator gets 72MB / s and TP-Link Archerc C7 V4 20MB / s
http://www.portnet.pl/narzedzia/pliki-testowe
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3090
Location: UK, London, just across the river..

PostPosted: Thu Mar 14, 2019 7:45    Post subject: Reply with quote
20MB/s is its max speed ...simple....
http://www.dslreports.com/speedtest

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 33772 BS WAP/Switch (wired)
TP-Link WR1043NDv2 ----DD-WRT 41659 BS (AP,PPPoE,NAT,AD Blocking,AP Isolation,Firewall,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----DD-WRT 41686 BS (AP,NAT,AD Blocking,Firewall,Wi-Fi OFF,Local DNS,Forced DNS,DoT, VPN)
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 (AP,NAT,QoS,Quotas)
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 41686 BS (AP,NAT,AD-Blocking,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT,VPN)
Broadcom
Netgear R7000 -------DD-WRT 40270M Kong (AP,NAT,VLAN,AD-Blocking,Firewall,Local DNS,Forced DNS,DoT)
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 via Entware by mac913
kowalmisiek
DD-WRT Novice


Joined: 23 Jan 2018
Posts: 30

PostPosted: Thu Mar 14, 2019 8:19    Post subject: Reply with quote
I checked this page yesterday. I had a result of 573Mb / s / 30Mb / s on it

When I'm at home, I'll share the result here. All thrones for testing the internet connection show me a result of around 600/30. Only when downloading files from the server I am limited to 20MB / s

If I find somewhere instructions on how to return to the original TP-Link software, I will download them and check how it works on the original software.
It seems to me that there is a bug in DD-WRT, that's why there is such a limitation.
Wildlion
DD-WRT Guru


Joined: 24 May 2016
Posts: 527

PostPosted: Thu Mar 14, 2019 19:58    Post subject: Reply with quote
This may not be the case but:

I have seen this before, some sites limit bandwidth of a single connection to a certain amount, but if you use things like a download manager multiple connections are used thus "increasing" you bandwidth (think serial vs parallel processing). This is defeating the intent of what the admin has set.

Other times it can be anything in between the network. I have disconnected from a site and reconnected and the TCP stream happens to have a better flow control (ie poor measurements were cleared)
kowalmisiek
DD-WRT Novice


Joined: 23 Jan 2018
Posts: 30

PostPosted: Fri Mar 15, 2019 9:06    Post subject: Reply with quote
This is another problem. As I wrote earlier.
I am downloading a file from this page: http://www.portnet.pl/narzedzia/pliki-testowe
DD-WRT transfer = 15-20MB / s
Operator Router = 72MB / s

So the restrictions on the part: NO

Today I will try to check how Archer C7 v4 behaves on the original firmware.
Wildlion
DD-WRT Guru


Joined: 24 May 2016
Posts: 527

PostPosted: Fri Mar 15, 2019 18:47    Post subject: Reply with quote
Okay... Let me summarize what I understand as the situation (if I am wrong correct me):

You have your computer wired to the DD-WRT Archer C7 V4 router on build 37882

Your ISP connection/speed is 600Mbps Down (upload should not matter in this case)

You have disabled OpenVPN

You are connecting the DD-WRT router through the ISP router (or replacing ISP router? not sure which)

When you run speedtests at sites like dsl reports you show the full 600Mbps both through the ISP router and through DDWRT

When you try to download a file (speed test example) through ISP router you get full 600Mbps (~75 MBps), but through DDWRT you only get 160 Mbps (~20MBps).

If you use a download manager to download the same file through DDWRT you get the full 600Mbps (~75 MBps) download rate.

----------------------------

If I missed something let me know

I am assuming that you have done a test where you have reverted to defaults on DDWRT and gotten same result? My thought is maybe a setting is causing it so trying to rule it out.

Could you have a bad cable (wire) that you are using?

Is there some setting such a vlan tagging that ISP is doing that you do not have (if you are replacing the isp router)

Is it possible ISP is throttling or boosting certain things? (does not seem like it from results)

I would like to hear the results from the stock firmware version... because in my experience with SFE enabled in DDWRT you should see approximately the same as stock on speeds.

Have you tried a different version of DDWRT? Maybe just that version has the problem.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum