New Build - 02/06/2019 - r38581

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
Handyone
DD-WRT User


Joined: 18 Sep 2014
Posts: 154

PostPosted: Wed Feb 06, 2019 18:29    Post subject: New Build - 02/06/2019 - r38581 Reply with quote
New Build - 02/06/2019 - r38581

ftp://ftp.dd-wrt.com/betas/2019/02-06-2019-r38581/

Please report errors on this topic.


Release Notes:
http://svn.dd-wrt.com/timeline
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=279466


Router Model:

Status:
Reset:
Errors:
Sponsor
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7373
Location: YWG, Canada

PostPosted: Wed Feb 06, 2019 18:36    Post subject: Reply with quote
Router Model: dir-862L, dir-862L, wndr4300, r7800 (delayed testing till i see commits trying to fix it)

Status: it runs.. messy
Reset: no
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5817
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5913
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/6059
https://svn.dd-wrt.com/ticket/6113 *
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6275
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6442
https://svn.dd-wrt.com/ticket/6466
https://svn.dd-wrt.com/ticket/6481 *
https://svn.dd-wrt.com/ticket/6490
https://svn.dd-wrt.com/ticket/6495 *
https://svn.dd-wrt.com/ticket/6511
https://svn.dd-wrt.com/ticket/6516
https://svn.dd-wrt.com/ticket/6555 *

typical another nothing to report build, see above..

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ----> DD-WRT v3.0-r44586 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44586 std
[QUALCOMM] WNDR4300 v1 ------------------------> DD-WRT v3.0-r44586 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44586 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 --------------------------> DD-WRT v3.0-r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..


Last edited by tatsuya46 on Thu Feb 07, 2019 23:16; edited 2 times in total
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5336
Location: Texas

PostPosted: Wed Feb 06, 2019 18:54    Post subject: Reply with quote
Router Name - 'Citadel-Switch'
Netgear WNDR3700 V4
DD-WRT v3.0-r38581 std (02/06/19)
Linux 3.18.134-rc1 #31844 Wed Feb 6 04:03:49 CET 2019 mips
No reset -- GUI upgrade over r38578

###
Router Name - 'EA8500'
Linksys EA8500
DD-WRT v3.0-r38581 std (02/06/19)
Linux 4.9.155-rc1 #255 SMP Mon Feb 4 14:10:03 CET 2019 armv7l
No reset -- GUI upgrade over r38578

Both routers are just switch / ovpn server / samba share / all same subnet...
...well the EA8500 does also have ports 1 & 2 in VLAN in the 192.168.1.0 subnet just used to fix some broken routers -- usually brcm routers Razz

all worky ok
gin-n-tonic
DD-WRT Novice


Joined: 30 Jun 2014
Posts: 32
Location: California

PostPosted: Wed Feb 06, 2019 21:34    Post subject: Reply with quote
Netgear WNDR3700 V4
DD-WRT v3.0-r38581 std (02/06/19)
Linux 3.18.134-rc1 #31844 Wed Feb 6 04:03:49 CET 2019 mips
No reset -- GUI upgrade over r38570 over r38535 over r38507...

Most working fine. (In spite of Mile-Lile's excellent guide to WireGuard set-up, I still can't stop the 2nd peer from breaking the 1st.)

And changing the Allowed IPs on my iPhone WireGuard client, enables or disables split-tunneling.
Allowed IPs: 0.0.0.0/0 All traffic goes through tunnel (except for DNS)
Allowed IPs: 192.168.1.0/24 Split tunnel, only traffic to local LAN goes through tunnel.

Note to BrainSlayer in regard to https://svn.dd-wrt.com/changeset/38580, Client still works without 0.0.0.0/0 setting. I am testing by directly editing the Allowed IPs on the iPhone, not through the dd-wrt GUI> QR code route. Maybe this is working for me since I have been upgrading without resets for quite a while.

[Edit] Learned a lot from this write-up https://www.wireguard.com/#cryptokey-routing and the lightbulb turned on. I understand a bit more and am able to get multiple peers working. Thanks for the help.


Last edited by gin-n-tonic on Sat Feb 09, 2019 19:01; edited 1 time in total
R/\ZV/\N
DD-WRT User


Joined: 04 Dec 2013
Posts: 90
Location: Râmnicu Vâlcea, România

PostPosted: Wed Feb 06, 2019 22:25    Post subject: Reply with quote
Router: TP-LINK TL-WDR3600 v1.4
Status: OK
Reset: No
Errors:
- 5GHz band LED indicator still off;
- Clone WAN MAC broken. When I press Get Current PC MAC Address all that tiny boxes become 0:0:0:0:0:0:0
Phil9992
DD-WRT Novice


Joined: 20 Mar 2017
Posts: 15

PostPosted: Thu Feb 07, 2019 2:52    Post subject: Reply with quote
Router: wr841ndv9, dd-wrt r38581
Linux 3.18.134-rc1 #31806 Wed Feb 6 03:10:53 CET 2019 mips

Error: I still get 100% cpu error caused by httpd, first seen with r38507.
Here is the way to make it happen "easily"... Just upgraded, no reset, second reboot, simple distant webif access with Firefox through ssh, here is the upright corner status
...
Firmware: DD-WRT v3.0-r38581 std (02/06/19)
Time: 19:57:58 up 3 min, load average: 1.81, 0.76, 0.29
WAN: Disabled

And output extract of "top -n 1" command
...
CPU: 45.4% usr 54.5% sys 0.0% nic 0.0% idle 0.0% io 0.0% irq 0.0% sirq
Load average: 1.85 0.83 0.32 4/36 1075
PID PPID USER STAT VSZ %VSZ CPU %CPU COMMAND
953 1 root S 2460 8.3 0 99.8 httpd -p 80
715 1 root S 1868 6.3 0 0.0 hostapd -B -P /var/run/ath0_hostap
968 1 root S 1760 5.9 0 0.0 process_monitor
530 1 root S 1760 5.9 0 0.0 watchdog
Handyone
DD-WRT User


Joined: 18 Sep 2014
Posts: 154

PostPosted: Thu Feb 07, 2019 5:03    Post subject: Reply with quote
Router TP-Link WR1043ND V2
Firmware DD-WRT v3.0-r38581 std (02/06/19)
Kernel Linux 3.18.134-rc1 #31818 Wed Feb 6 03:21:27 CET 2019 mips

httpd -p 80 100% CPU
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5336
Location: Texas

PostPosted: Thu Feb 07, 2019 7:53    Post subject: Reply with quote
Handyone wrote:
httpd -p 80 100% CPU


Tis clean for me --
Code:
Mem: 65284K used, 60568K free, 0K shrd, 6668K buff, 41484K cached
Mem: 65288K used, 60564K free, 0K shrd, 6668K buff, 41484K cached
CPU:  0.0% usr  0.0% sys  0.0% nic  100% idle  0.0% io  0.0% irq  0.0% sirq
Load average: 0.00 0.00 0.00 1/43 4235
  PID  PPID USER     STAT   VSZ %VSZ CPU %CPU COMMAND
 1097     1 root     S     4512  3.5   0  0.0 httpd -p 80
 1002     1 root     S     3180  2.5   0  0.0 /tmp/openvpnserver --config /tmp/openvpn/openvpn.conf --route-up /tmp/openvpn/route-up.sh --route-pre-do
  805     1 root     S     2792  2.2   0  0.0 /usr/sbin/smbd -D --configfile=/tmp/smb.conf
  807     1 root     S     2568  2.0   0  0.0 /usr/sbin/nmbd -D --configfile=/tmp/smb.conf
 1120     1 root     S     1836  1.4   0  0.0 process_monitor
  496     1 root     S     1836  1.4   0  0.0 watchdog
  980     1 root     S     1792  1.4   0  0.0 wland
 1099     1 root     S     1528  1.2   0  0.0 resetbutton
 4214  4213 root     S     1168  0.9   0  0.0 -sh
 4235  4214 root     R     1164  0.9   0  0.0 top -n 1
  833     1 root     S     1160  0.9   0  0.0 klogd
  887     1 root     S     1160  0.9   0  0.0 klogd
  831     1 root     S     1160  0.9   0  0.0 syslogd -L
  884     1 root     S     1160  0.9   0  0.0 telnetd
  880     1 root     S     1160  0.9   0  0.0 syslogd -L
    1     0 root     S     1148  0.9   0  0.0 /sbin/init
 4213   905 root     S     1068  0.8   0  0.0 dropbear -b /tmp/loginprompt -r /tmp/root/.ssh/ssh_host_rsa_key -p 22
  905     1 root     S     1000  0.7   0  0.0 dropbear -b /tmp/loginprompt -r /tmp/root/.ssh/ssh_host_rsa_key -p 22
  469     1 root     S      920  0.7   0  0.0 /sbin/hotplug2 --set-rules-file /etc/hotplug2.rules --persistent
 1119     1 root     S      892  0.7   0  0.0 cron
   81     2 root     SW       0  0.0   0  0.0 [kworker/0:1]
    6     2 root     SW       0  0.0   0  0.0 [kworker/u2:0]
  637     2 root     SW       0  0.0   0  0.0 [usb-storage]
    3     2 root     SW       0  0.0   0  0.0 [ksoftirqd/0]
   80     2 root     SW       0  0.0   0  0.0 [kswapd0]
  113     2 root     SW       0  0.0   0  0.0 [fsnotify_mark]
    2     0 root     SW       0  0.0   0  0.0 [kthreadd]
  636     2 root     SW<      0  0.0   0  0.0 [scsi_tmf_0]
  635     2 root     SW       0  0.0   0  0.0 [scsi_eh_0]
  552     2 root     SW<      0  0.0   0  0.0 [cfg80211]
  258     2 root     SW       0  0.0   0  0.0 [kworker/u2:2]
  611     2 root     SW       0  0.0   0  0.0 [kworker/0:2]
  672     2 root     SW<      0  0.0   0  0.0 [kworker/0:1H]
root@Citadel-Switch:~# nvram get DD_BOARD
Netgear WNDR3700 V4
root@Citadel-Switch:~# cat /tmp/loginprompt
DD-WRT v3.0-r38581 std (c) 2019 NewMedia-NET GmbH
Release: 02/06/19
root@Citadel-Switch:~# uptime
 01:45:16 up 13:07,  load average: 0.00, 0.00, 0.00
root@Citadel-Switch:~# date
Thu Feb  7 01:45:17 CST 2019
root@Citadel-Switch:~# exit
Connection to citadel-switch.mrjcd.com closed.
mrjcd@Will-Be-Was:~$
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7029
Location: Dresden, Germany

PostPosted: Thu Feb 07, 2019 10:15    Post subject: Reply with quote
gin-n-tonic wrote:
Netgear WNDR3700 V4
DD-WRT v3.0-r38581 std (02/06/19)
Linux 3.18.134-rc1 #31844 Wed Feb 6 04:03:49 CET 2019 mips
No reset -- GUI upgrade over r38570 over r38535 over r38507...

Most working fine. (In spite of Mile-Lile's excellent guide to WireGuard set-up, I still can't stop the 2nd peer from breaking the 1st.)

And changing the Allowed IPs on my iPhone WireGuard client, enables or disables split-tunneling.
Allowed IPs: 0.0.0.0/0 All traffic goes through tunnel (except for DNS)
Allowed IPs: 192.168.1.0/24 Split tunnel, only traffic to local LAN goes through tunnel.

Note to BrainSlayer in regard to https://svn.dd-wrt.com/changeset/38580, Client still works without 0.0.0.0/0 setting. I am testing by directly editing the Allowed IPs on the iPhone, not through the dd-wrt GUI> QR code route. Maybe this is working for me since I have been upgrading without resets for quite a while.


in ap side you set client ip/32 as allowed ip. the rest can be done with qr code. if you do it manually ensure that the allowed ip on the client is 0.0.0.0/0. i tested 2 simultanous peers with my iphone

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
BrainSlayer
Site Admin


Joined: 06 Jun 2006
Posts: 7029
Location: Dresden, Germany

PostPosted: Thu Feb 07, 2019 10:16    Post subject: Reply with quote
Handyone wrote:
Router TP-Link WR1043ND V2
Firmware DD-WRT v3.0-r38581 std (02/06/19)
Kernel Linux 3.18.134-rc1 #31818 Wed Feb 6 03:21:27 CET 2019 mips

httpd -p 80 100% CPU


run netstat on the router and watch for open connections

_________________
"So you tried to use the computer and it started smoking? Sounds like a Mac to me.." - Louis Rossmann https://www.youtube.com/watch?v=eL_5YDRWqGE&t=60s
Phil9992
DD-WRT Novice


Joined: 20 Mar 2017
Posts: 15

PostPosted: Thu Feb 07, 2019 13:56    Post subject: Reply with quote
wr841ndv9

About "httpd -p 80" 100% cpu

Here is abnormal netstat after webif (Firefox closed), 100% cpu
...
root@MTR-841:~# netstat
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 268 MTR-841:mysrv xx.xx.xx.xx.rev.xxx.net:23626 ESTABLISHED
tcp 0 0 MTR-841:http MTR-841:45158 CLOSE_WAIT
tcp 0 0 MTR-841:http MTR-841:45157 CLOSE_WAIT
tcp 0 0 MTR-841:45166 MTR-841:http FIN_WAIT2
tcp 0 0 MTR-841:45165 MTR-841:http FIN_WAIT2
tcp 0 0 MTR-841:http MTR-841:45166 CLOSE_WAIT
tcp 0 0 MTR-841:http MTR-841:45165 CLOSE_WAIT
tcp 0 0 MTR-841:45157 MTR-841:http FIN_WAIT2
tcp 0 0 MTR-841:45158 MTR-841:http FIN_WAIT2
Active UNIX domain sockets (w/o servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ] DGRAM 779 /var/run/hostapd/ath0
unix 2 [ ] DGRAM 1127
unix 2 [ ] DGRAM 32971
unix 2 [ ] DGRAM 1485
unix 2 [ ] DGRAM 1525
root@MTR-841:~#

And netstat after webif (Firefox closed) when ok (normal cpu)
...
root@MTR-841:~# netstat
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 268 MTR-841:mysrv xx.xx.xx.xx.rev.xxx.net:23626 ESTABLISHED
Active UNIX domain sockets (w/o servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ] DGRAM 779 /var/run/hostapd/ath0
unix 2 [ ] DGRAM 34669
unix 2 [ ] DGRAM 1127
unix 2 [ ] DGRAM 1485
unix 2 [ ] DGRAM 1525
root@MTR-841:~#
Handyone
DD-WRT User


Joined: 18 Sep 2014
Posts: 154

PostPosted: Thu Feb 07, 2019 14:30    Post subject: Reply with quote
BrainSlayer wrote:
Handyone wrote:
Router TP-Link WR1043ND V2
Firmware DD-WRT v3.0-r38581 std (02/06/19)
Kernel Linux 3.18.134-rc1 #31818 Wed Feb 6 03:21:27 CET 2019 mips

httpd -p 80 100% CPU


run netstat on the router and watch for open connections


Code:

tcp        0      0 192.168.1.1:http              192.168.2.2:50103       CLOSE_WAIT
tcp        0      0 192.168.1.1:http              192.168.2.2:50115       CLOSE_WAIT
tcp        0      0 192.168.1.1:http              192.168.2.2:50102       CLOSE_WAIT
tcp        0    132 192.168.1.1:22               192.168.1.101:2071      ESTABLISHED
tcp        0      0 192.168.1.1:http              192.168.2.2:50112       CLOSE_WAIT
tcp        0      0 192.168.1.1:http              192.168.2.2:50117       CLOSE_WAIT
tcp        0      0 192.168.1.1:http              192.168.2.2:50116       CLOSE_WAIT

192.168.2.0 is the openvpn subnet along with tcp port 443
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7373
Location: YWG, Canada

PostPosted: Thu Feb 07, 2019 19:58    Post subject: Reply with quote
BrainSlayer wrote:
Handyone wrote:
Router TP-Link WR1043ND V2
Firmware DD-WRT v3.0-r38581 std (02/06/19)
Kernel Linux 3.18.134-rc1 #31818 Wed Feb 6 03:21:27 CET 2019 mips

httpd -p 80 100% CPU


run netstat on the router and watch for open connections


dir-862L httpd is also always 100% now after disabling https..

either have fast remote access with http, but 100% cpu, or slow https remote access, 0% cpu..

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ----> DD-WRT v3.0-r44586 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44586 std
[QUALCOMM] WNDR4300 v1 ------------------------> DD-WRT v3.0-r44586 std
[QUALCOMM] DIR-862L ------------------------------> DD-WRT v3.0-r44586 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 --------------------------> DD-WRT v3.0-r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
vortex05
DD-WRT User


Joined: 14 Mar 2014
Posts: 206

PostPosted: Fri Feb 08, 2019 5:13    Post subject: Reply with quote
Router Model: WNDR4300v1

Status: Some issues
Reset: No
Errors: 503 When trying to access php files through lighttpd.
ian5142
DD-WRT Guru


Joined: 23 Oct 2013
Posts: 2154
Location: Canada

PostPosted: Sat Feb 09, 2019 3:48    Post subject: Upgrades Reply with quote
All WebGUI upgrades. The rest have not been upgraded as they are not currently in use (seasonal use only).
Router/Version: TP-Link Archer C7 v2
Firmware: 38581
Previous: 38507
Mode/Status: WDS AP, WDS Station
Reset: No
Issues/Errors: None, so far.

Router/Version: D-Link DIR-862L A1
Firmware: 38581
Previous: 38507
Mode/Status: WDS Station
Reset: No
Issues/Errors: None, so far. No WPA3.

PS: I only use HTTP, no high load on the CPU on either of these routers. Pages seem to load at a reasonable speed.

_________________
Before asking a question on the forums, update dd-wrt: Where do I download firmware? I suggest reading it all.

Some dd-wrt wiki pages are up to date, others are not. PM me if you find an old one, I am trying to update them.

Atheros:
Netgear R7800 - gateway, DHCP, QoS, VPN
TP-Link Archer C7 v2 x2 - WDS AP, WDS Station
TP-Link TL-WDR3600 v1 - WDS Station
TP-Link 841nd v8 - WDS Station
D-Link 615 C1 x 4 - not used
D-Link 615 E3 x 2 - not used
D-Link 825 B1 - WDS Station
D-Link 862L A1 x2 - WDS Station
Netgear WNDR3700v2 - WDS Station
UBNT loco M2 x2 - airOS

Broadcom
Asus N66U - backup Gateway
Netgear r6300 v1 - AP
Linksys E2500 - not used
Linksys EA2700 - not used
Linksys 160N v3 x2 - not used
Netgear WNDR3700v3 - not used
MediaTek
UBNT EdgeRouter X - not used
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum