VLAN tagging on WAN port with PPPoE, Netgear Nighthawk R7800

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
Channel11.5
DD-WRT Novice


Joined: 04 Jan 2018
Posts: 8

PostPosted: Wed Aug 14, 2019 23:34    Post subject: VLAN tagging on WAN port with PPPoE, Netgear Nighthawk R7800 Reply with quote
After updating to CenturyLink Fiber, I went down the rabbit hole trying to figure out how to get my own dd-wrt router directly connected to their ONT. This required tagging the WAN traffic with vlan id 201, and performing PPPoE to authenticate.

After not being able to figure it out from the web UI or help pages, I went to the forum and read a multitude of posts. Most of the posts were quite old and had large listings of commands to run. Thinking there must be a better way, I persevered to figure out the simplest method and share in case it's helpful:

1) Setup->Networking->VLAN Tagging, Add a VLAN interface for the WAN port with Tag Number 201. On my router 'eth0' is the WAN port and applying this configuration creates an 'eth0.201' port.

2) Setup->Networking->Port Setup, Select 'eth0.201' for the WAN Port Assignment. You may need to refresh the page until the 'eth0.201' port shows up.

I thought I'd be all set at this point. It took a lot of digging to find the last step:

3)
Code:
nvram set pppoe_wan_ifname=eth0.201


This must be run on the console (I did so via SSH login), as I found no UI setting for this.

Netgear Nighthawk R7800
DD-WRT v3.0-r40270M kongat (07/11/19)
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2331
Location: Texas, USA

PostPosted: Thu Aug 15, 2019 1:43    Post subject: Reply with quote
The R7800 is a single-band 802.1g router? I don' think there's a vlan0 ....
Channel11.5
DD-WRT Novice


Joined: 04 Jan 2018
Posts: 8

PostPosted: Thu Aug 15, 2019 5:06    Post subject: Reply with quote
The R7800 is "802.11ac Dual Band Quad Stream Gigabit":

https://www.netgear.com/home/products/networking/wifi-routers/R7800.aspx
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 2331
Location: Texas, USA

PostPosted: Thu Aug 15, 2019 9:46    Post subject: Reply with quote
Correct. The default included vlans in DD-WRT for dual-band N and AC routers are vlan1 and vlan2. Vlan0 only applies to single-band B and G routers.

https://wiki.dd-wrt.com/wiki/index.php/Default_internal_device_networks

Your WAN vlan is 2, and that is what is throwing me by the pictures in your OP.

https://wiki.dd-wrt.com/wiki/index.php/Switched_Ports

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=312045

https://wiki.dd-wrt.com/wiki/index.php/VLAN_Support
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5196
Location: Akershus, Norway

PostPosted: Sat Aug 17, 2019 8:16    Post subject: Reply with quote
There is an easy way:

swconfig dev switch0 set enable_vlan 1
swconfig dev switch0 vlan 2 set vid 201
swconfig dev switch0 vlan 2 set ports "0t 5"
swconfig dev switch0 set apply

Put it in the startup script. Keep WAN on default VLAN2
Channel11.5
DD-WRT Novice


Joined: 04 Jan 2018
Posts: 8

PostPosted: Sat Aug 31, 2019 2:48    Post subject: Reply with quote
Quote:
Your WAN vlan is 2, and that is what is throwing me by the pictures in your OP.


The VLAN is exactly as is shown in screen shot. Either the UI is displaying the wrong value or you are mistaken, but that is a screen shot after doing the steps I described on a dd-wrt after a fresh reset.
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5196
Location: Akershus, Norway

PostPosted: Sat Aug 31, 2019 13:34    Post subject: Reply with quote
Per Yngve Berg wrote:
There is an easy way:

swconfig dev switch0 set enable_vlan 1
swconfig dev switch0 vlan 2 set vid 201
swconfig dev switch0 vlan 2 set ports "0t 5"
swconfig dev switch0 set apply


The WAN will still be on eth0. There will not be any eth0.201 interface.
4Scarrs
DD-WRT Novice


Joined: 04 Sep 2019
Posts: 2

PostPosted: Wed Sep 04, 2019 14:57    Post subject: Re: VLAN tagging on WAN port with PPPoE, Netgear Nighthawk R Reply with quote
Channel11.5 wrote:
After updating to CenturyLink Fiber, I went down the rabbit hole trying to figure out how to get my own dd-wrt router directly connected to their ONT. This required tagging the WAN traffic with vlan id 201, and performing PPPoE to authenticate.

After not being able to figure it out from the web UI or help pages, I went to the forum and read a multitude of posts. Most of the posts were quite old and had large listings of commands to run. Thinking there must be a better way, I persevered to figure out the simplest method and share in case it's helpful:

1) Setup->Networking->VLAN Tagging, Add a VLAN interface for the WAN port with Tag Number 201. On my router 'eth0' is the WAN port and applying this configuration creates an 'eth0.201' port.

2) Setup->Networking->Port Setup, Select 'eth0.201' for the WAN Port Assignment. You may need to refresh the page until the 'eth0.201' port shows up.

I thought I'd be all set at this point. It took a lot of digging to find the last step:

3)
Code:
nvram set pppoe_wan_ifname=eth0.201


This must be run on the console (I did so via SSH login), as I found no UI setting for this.

Netgear Nighthawk R7800
DD-WRT v3.0-r40270M kongat (07/11/19)


I tried this and couldn't get PPoE to connect. I found you can run commands in Administration-> commands. Totally stumped on this.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum