New Build: r37961 12-12-2018

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
BobbyLee
DD-WRT User


Joined: 04 Jul 2016
Posts: 131

PostPosted: Wed Dec 12, 2018 19:58    Post subject: New Build: r37961 12-12-2018 Reply with quote
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2018/12-12-2018-r37961/

EDIT: Installed using IE and factory-to-ddwrt from the Linksys GUI without reset on my WRT3200ACM. Install went smoothly but my OpenVPN server no longer works, not acceptable. Going back to r37908 where my 2.4 GHz didn't disappear which it did in r37932 and my OpenVPN server was working. Good luck folks.

EDIT^2: Didn't do a reset going back to r37908 and now the OpenVPN server isn't working there either, won't connect to clients. Time to reset the NVRAM and input all the freaking settings again.

_________________
Linksys WRT3200ACM
Currently using Linksys Firmware until DDWRT lets my ObiTalk 202 complete calls when connected via WiFi
Last used DD-WRT Version: r38326
OpenVPN server


Last edited by BobbyLee on Wed Dec 12, 2018 21:59; edited 1 time in total
Sponsor
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 300

PostPosted: Wed Dec 12, 2018 21:02    Post subject: Reply with quote
Flashed factory from Linksys Partition.
Restored settings from R37932.

Up and running...

Kernel Version
Linux 4.9.145-rc1 #643 SMP Wed Dec 12 01:38:23 CET 2018 armv7l

_________________
WRT1900ACSv2
gainestr
DD-WRT User


Joined: 06 Jul 2017
Posts: 78

PostPosted: Thu Dec 13, 2018 9:03    Post subject: Wi-Fi driver Reply with quote
What Wi-Fi driver version is used in this build?

Edit: Just installed it and figured it out. Running smooth so far but will be testing OpenVPN server. So far so good.

_________________
DD-WRT Installation & Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117

CPU Model: Marvell Armada 385
Router: Linksys WRT1900ACSv2
Firmware: DD-WRT v3.0-r39144 std (03/11/19)
Kernel: Linux 4.9.162 #871 SMP Mon Mar 11 03:05:23 CET 2019 armv7l
WiFi Driver: 10.3.8.0-20181120 (strings /lib/modules/*.*/mwlwifi.ko | grep "^10.3")
Options: AP, OpenVPN Server, OpenVPN Client, IPv6, UPnP, QoS(Disabled), SFE (Disabled)

Others:
Linksys SE4008 WRT 8-Port Gigabit Ethernet Switch (LAN Switch)
QNAP TS-253A-8G NAS (2-bay, WD Red 4TB each)
BobbyLee
DD-WRT User


Joined: 04 Jul 2016
Posts: 131

PostPosted: Thu Dec 13, 2018 10:15    Post subject: Re: Wi-Fi driver Reply with quote
gainestr wrote:
Running smooth so far but will be testing OpenVPN server.

I'll be interested in your results because it killed my OpenVPN server.

_________________
Linksys WRT3200ACM
Currently using Linksys Firmware until DDWRT lets my ObiTalk 202 complete calls when connected via WiFi
Last used DD-WRT Version: r38326
OpenVPN server
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 155
Location: FL

PostPosted: Thu Dec 13, 2018 14:43    Post subject: Reply with quote
Seems to be working pretty good for me so far.
Not to sure about the VPN server as i dont use it.

Watching the SRC Log i see he has been hard at work since this release. the next release should be promising for anyone who may take a interest and seeing the all the work he does

https://svn.dd-wrt.com/log/src?action=stop_on_copy&mode=stop_on_copy&rev=&stop_rev=37961&limit=100&sfp_email=&sfph_mail=

_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2019
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &


WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel 6, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 80mhz channel width, channel 100+6, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", Virtual Wireless AP "2.4 + 5ghz", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
Juni0rM1nt
DD-WRT Novice


Joined: 26 Feb 2016
Posts: 27
Location: DM-Phobos

PostPosted: Thu Dec 13, 2018 15:30    Post subject: Reply with quote
In this firmware and the past 11 revisions, 5GHz WiFi won't connect with VHT 160MHz channel 149+. It says channel "unknown"
However it does connect if set to VHT 80MHz same channel.

Both 2.4GHz (channel 11) and 5GHz (channel 149) bands are in AP, mix mode.

The only driver I can get 5GHz band (VHT 160MHz, channel 149) to show up is firmware, 10-04-2018-r37139

Linksys 3200ACM
Current firmware:
12-12-2018-r37961
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 200
Location: South Carolina

PostPosted: Thu Dec 13, 2018 15:55    Post subject: DD-WRT v3.0-r37961 std (12/12/18) Reply with quote
WRT3200ACM V1 r37961 Firefox 63.0.3 (64-bit) webflash

OpenVPN CLIENT works fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
2.4GHz wpa2 CCMP-129 (AES)working fine 20MHz Mixed
NAS via USB Samba also working fine
WENED
DD-WRT User


Joined: 30 May 2017
Posts: 329
Location: Rural Manitoba

PostPosted: Thu Dec 13, 2018 16:29    Post subject: 160Mhz Channel selection Reply with quote
Juni0rM1nt wrote:
In this firmware and the past 11 revisions, 5GHz WiFi won't connect with VHT 160MHz channel 149+. It says channel "unknown"
However it does connect if set to VHT 80MHz same channel.

Both 2.4GHz (channel 11) and 5GHz (channel 149) bands are in AP, mix mode.

The only driver I can get 5GHz band (VHT 160MHz, channel 149) to show up is firmware, 10-04-2018-r37139

Linksys 3200ACM
Current firmware:
12-12-2018-r37961


Due to WiFi standards Channel 149 cannot be used for 160Mhz bandwidth.
I personally use Channel 100 (UUU)and have been ever since I got my 3200's last year. Although the poer output may be restricted on these lower channels I find it still functions properly between my 3200's which are close enough to take advantage of the increased bandwidth. My other routers/devices connect appropriately at 80Mhz bandwith since they do not support 160Mhz.
refer to numerous references to 160Mhz channel selection.
https://www.smallnetbuilder.com/wireless/wireless-features/33210-160-mhz-wi-fi-channels-friend-or-foe

_________________
WRT3200acm Master WDS 5GHz 80Mhz r41491
WRT3200acm WDS Station r41491
WRT1900Ac V1 WDS AP 5Ghz r41491 (Defective, no 2.4Ghz but 5Ghz works great)
WRT1900AC V1 WDS Station r41491
WRT1900AC V1 SPARE r41418
WRT1200AC V1 Client-Bridge r35898
WRT54G DD-WRT v3.0-r37305 micro Client-Bridged for 1 IP Camera
EX6200 DD-WRT r38535 - Spare
EX7000 Stock Firmware Spare
Devices and Cameras and Sensors
15 WiFi cameras, 4 desktops, 2 laptop, 12 Sonoff Basic/TH16, Artisan 700 Printer, Ongoing testing of other devices.
WENED
DD-WRT User


Joined: 30 May 2017
Posts: 329
Location: Rural Manitoba

PostPosted: Thu Dec 13, 2018 16:38    Post subject: WRT3200acm r37961 Reply with quote
Webflash WRT3200acm r37932 -> r37961 IE11 no reset

Appeared to upgrade successfully.
Numerous messages for "unknown password root" connections in the previous build with Telnet enabled. Disabled and no more messages. Was able to access via telnet without problem.

ESP8266 devices still require wmm disabled.

Approximately 4 hours in lost my WAN (PPOe). Reverted back to r37932.

_________________
WRT3200acm Master WDS 5GHz 80Mhz r41491
WRT3200acm WDS Station r41491
WRT1900Ac V1 WDS AP 5Ghz r41491 (Defective, no 2.4Ghz but 5Ghz works great)
WRT1900AC V1 WDS Station r41491
WRT1900AC V1 SPARE r41418
WRT1200AC V1 Client-Bridge r35898
WRT54G DD-WRT v3.0-r37305 micro Client-Bridged for 1 IP Camera
EX6200 DD-WRT r38535 - Spare
EX7000 Stock Firmware Spare
Devices and Cameras and Sensors
15 WiFi cameras, 4 desktops, 2 laptop, 12 Sonoff Basic/TH16, Artisan 700 Printer, Ongoing testing of other devices.
Juni0rM1nt
DD-WRT Novice


Joined: 26 Feb 2016
Posts: 27
Location: DM-Phobos

PostPosted: Thu Dec 13, 2018 21:41    Post subject: Reply with quote
@WENED,
Thank you. I just find it odd that it worked in the past firmware.

-JM
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 169

PostPosted: Thu Dec 13, 2018 21:57    Post subject: Reply with quote
Updated successfully. I still cannot get my Samsung Galaxy Tab A to connect to either radio. Other devices connect.
_________________
Netgear R9000 X10
DD-WRT v3.0-r41664 std (12/06/19)
AP, DNSMasq, Local DNS
CloudFlare DNS
QoS using HFSC w/FQ_CODEL_FAST
Static Leases & DHCP
2.4GHz: 3 + 7 (2422 MHz HT40)
5GHz: 161 + 155 (5805 MHz VHT80)
Xfinity 1Gbps/35Mbps
gufus
DD-WRT Guru


Joined: 04 Aug 2012
Posts: 610
Location: behind the screen

PostPosted: Thu Dec 13, 2018 22:35    Post subject: Re: Wi-Fi driver Reply with quote
gainestr wrote:
What Wi-Fi driver version is used in this build?

Edit: Just installed it and figured it out. Running smooth so far but will be testing OpenVPN server. So far so good.


Using username "root".
DD-WRT v3.0-r37961 std (c) 2018 NewMedia-NET GmbH
Release: 12/12/18
Authenticating with public key "rsa-key-20120810"
==========================================================

___ ___ _ _____ ______ ____ ___
/ _ \/ _ \___| | /| / / _ \/_ __/ _ __|_ / / _ \
/ // / // /___/ |/ |/ / , _/ / / | |/ //_ <_/ // /
/____/____/ |__/|__/_/|_| /_/ |___/____(_)___/

DD-WRT v3.0
http://www.dd-wrt.com

==========================================================


BusyBox v1.29.3 (2018-12-12 01:43:17 CET) built-in shell (ash)

root@DD-WRT b7:f8:e1:~# strings /lib/modules/*.*/mwlwifi.ko | grep "^10.3"
10.3.8.0-20181120
root@DD-WRT b7:f8:e1:~#

_________________
WRT3200ACM openwrt 18.06.4
WRT3200ACM dd-wrt r40009
WRT54GL dd-wrt r21676
WENED
DD-WRT User


Joined: 30 May 2017
Posts: 329
Location: Rural Manitoba

PostPosted: Sun Dec 16, 2018 4:04    Post subject: Re: WRT3200acm r37961 Reply with quote
WENED wrote:
Webflash WRT3200acm r37932 -> r37961 IE11 no reset

Appeared to upgrade successfully.
Numerous messages for "unknown password root" connections in the previous build with Telnet enabled. Disabled and no more messages. Was able to access via telnet without problem.

ESP8266 devices still require wmm disabled.

Approximately 4 hours in lost my WAN (PPOe). Reverted back to r37932.


***UPDATE****

As usual I am always trying to find answers.
I did a full reset on the partition with r37961 and proceeded to rebuild from scratch.
This time however I used IE11 but turned off auto fill and also Bitdefenders auto password generator.

The router has been running now for over four hours with no unusual errors "incorrect password" etc. with Telnet enabled. I also checked and double checked my WDS addressing scheme to ensure that it was accurate.
I manually entered port-forwards for my 19 camera addresses and had no loss of Internet.

What I have concluded is;
Even with a mutton reset some residuals remain in NVRAM and can conflict with new information.
Auto fill will definitely mess with settings even though you may not see it happen. WEB browsers with auto fill must have the option turned off, and any password controllers must also be blocked from entering info automatically.

I am sure that there is more ways that scramble NVRAM causing multiple errors and failures, but for now I believe I have resolved a large amount of these.

_________________
WRT3200acm Master WDS 5GHz 80Mhz r41491
WRT3200acm WDS Station r41491
WRT1900Ac V1 WDS AP 5Ghz r41491 (Defective, no 2.4Ghz but 5Ghz works great)
WRT1900AC V1 WDS Station r41491
WRT1900AC V1 SPARE r41418
WRT1200AC V1 Client-Bridge r35898
WRT54G DD-WRT v3.0-r37305 micro Client-Bridged for 1 IP Camera
EX6200 DD-WRT r38535 - Spare
EX7000 Stock Firmware Spare
Devices and Cameras and Sensors
15 WiFi cameras, 4 desktops, 2 laptop, 12 Sonoff Basic/TH16, Artisan 700 Printer, Ongoing testing of other devices.
pmckay
DD-WRT Novice


Joined: 26 Aug 2006
Posts: 30
Location: Brooklyn, NY

PostPosted: Mon Dec 17, 2018 2:22    Post subject: Reply with quote
Juni0rM1nt wrote:
In this firmware and the past 11 revisions, 5GHz WiFi won't connect with VHT 160MHz channel 149+. It says channel "unknown"
However it does connect if set to VHT 80MHz same channel.

Both 2.4GHz (channel 11) and 5GHz (channel 149) bands are in AP, mix mode.

The only driver I can get 5GHz band (VHT 160MHz, channel 149) to show up is firmware, 10-04-2018-r37139

Linksys 3200ACM
Current firmware:
12-12-2018-r37961


I was able to light up the 5GHz by setting wireless Channel:auto. Setting it to any other value left it disabled. I know its suboptimal, but it could be better than nothing.

_________________
Linksys WRT1900AC V1
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 169

PostPosted: Mon Dec 17, 2018 14:00    Post subject: Reply with quote
Just upgraded to a WRT3200ACM. While I was copying my settings (by hand) from the old router to the new, I noticed that my 2.4GHz radio's settings had the Extension Chanel set to Upper. When I changed that to Lower my Galaxy Tab A connected. I think using "Upper" is not recognized by the device.
_________________
Netgear R9000 X10
DD-WRT v3.0-r41664 std (12/06/19)
AP, DNSMasq, Local DNS
CloudFlare DNS
QoS using HFSC w/FQ_CODEL_FAST
Static Leases & DHCP
2.4GHz: 3 + 7 (2422 MHz HT40)
5GHz: 161 + 155 (5805 MHz VHT80)
Xfinity 1Gbps/35Mbps
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum