DDWRT issue with Chrome Auto Fill enabled

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions
Author Message
d0ug
DD-WRT Guru


Joined: 31 Jul 2015
Posts: 757

PostPosted: Thu Dec 06, 2018 23:19    Post subject: DDWRT issue with Chrome Auto Fill enabled Reply with quote
I found an interesting issue in both the 11/27 and the new 12/4 builds, Probably exists in other older builds as well. I am running on a WRT1200AC v2

It would appear that if you access your router's admin tab in chrome with form auto fill settings enabled, chrome will autofill the username field with a value from who knows where?

Notice that the username field is yellow in this screenshot, indicating that chrome has auto filled it.



I noticed this while changing the color scheme of the UI. Every time I would set the color scheme I could no longer login to the router, and had to factory reset with the button.

I am not sure if there are any kind of tags that can be put on those form fields to tell chrome to not auto fill them?


Last edited by d0ug on Fri Dec 07, 2018 4:26; edited 1 time in total
Sponsor
jxm
DD-WRT Guru


Joined: 23 Jul 2017
Posts: 705
Location: Brisbane, Australia

PostPosted: Fri Dec 07, 2018 3:01    Post subject: Reply with quote
That's what Autofill does. When you connect to a website using a logon and password, it stores the website and logon details. Then when you revisit the website the browser completes the logon and password details for you when it sees the Logon and Password fields, but it does not always get it right. In this case it probably recognised that the two password fields were for entering a new password, so it did not complete the two password fields with your old password.

The “bug” is not in DD-WRT, the “problem” is with Autofill and the fact that it did not do what you expected.

Cheers.
d0ug
DD-WRT Guru


Joined: 31 Jul 2015
Posts: 757

PostPosted: Fri Dec 07, 2018 4:21    Post subject: Reply with quote
jxm wrote:
That's what Autofill does. When you connect to a website using a logon and password, it stores the website and logon details. Then when you revisit the website the browser completes the logon and password details for you when it sees the Logon and Password fields, but it does not always get it right. In this case it probably recognised that the two password fields were for entering a new password, so it did not complete the two password fields with your old password.

The “bug” is not in DD-WRT, the “problem” is with Autofill and the fact that it did not do what you expected.

Cheers.


I know this is not a bug with DD-WRT, but is still a somewhat significant issue seeing as changing anything on that admin tab could cause ones username to get changed if chrome or another browser auto filled it with something else without the user noticing as I experienced earlier.

My understanding is there is an autocomplete="false" option that can be put on form fields to prevent the browser from auto filling them. This might be worth investigating having put on certain fields throughout the config pages of ddwrt
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> General Questions All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum