New Beta Build 12-03-2019-r41659

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 3115
Location: Texas, USA

PostPosted: Tue Dec 03, 2019 23:38    Post subject: New Beta Build 12-03-2019-r41659 Reply with quote
Downloads: (if a link does not work, try another)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2019/12-03-2019-r41659/
ftp://ftp.dd-wrt.com/betas/2019/12-03-2019-r41659/
Alternate link: DD-WRT website
Note: for wget (or curl) with CLI flash (`write {f/w} linux`), change the https to http, use `curl -k {link} -o {file}`, or ftp

Changelogs:
SVN* changelog since last build: 41586
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Important: if reporting any issues, provide applicable info (GUI syslog, `dmesg`, `cat /var/log/messages`, etc.)
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Template to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b]Router/Version: [/b]
[b]Mode: [/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Status: [/b]

WARNING: This thread is to report on flashing this experimental test build, providing important info for both developers and users. Always state your hardware model, version, mode (e.g. Repeater) and SPECIFIC build (e.g. 33555_NEWD-2_K3.x_mega-nv64k.bin). Please avoid discussions and create a new thread to discuss specific problems or questions, as this thread is for reporting, not support. Posts may be deleted or moved to keep this thread manageable and useful. If you don't understand the risks or what to flash and how, with a means of recovery if it bricks, do NOT flash this experimental test build.

_________________
E4200 v1 DD-WRT 41954 mega (01/09/20) (K3.x)
R7000P DD-WRT 40270M kongac
E4200 v1 FreshTomato 2019.4
E4200 v1 FreshTomato 2020.1.development
R7000 FreshTomato 2020.1.development
E4200 v1 1.0.07.development
WRT3200ACM OpenWRT 18.06.5
---------------------------------------------------------
Linux User #377467 counter.li.org / linuxcounter.net
Sponsor
DATABLOCK
DD-WRT Novice


Joined: 06 Nov 2019
Posts: 6

PostPosted: Wed Dec 04, 2019 0:05    Post subject: Reply with quote
Successful flash, all functions working as expected for me.
_________________
LinkSys WRT32X
ExpressVPN OpenVPN
2.4GHz AP Mixed Full(20MHz)
Firewall WAN_IF=`nvram get wan_iface`
WEBFlashed via macOS 10.15.2 + Safari
DaveI
DD-WRT User


Joined: 06 Jul 2009
Posts: 322

PostPosted: Wed Dec 04, 2019 1:42    Post subject: Reply with quote
Webflashed to both Partitions with Firefox 71.0

Firmware Version
DD-WRT v3.0-r41659 std (12/03/19)
Kernel Version
Linux 4.9.205 #1425 SMP Tue Dec 3 14:17:34 +03 2019 armv7l

VPN,Samba,NAS,DLNA working.

WiFi NOT tested.

_________________
WRT1900ACSv2
Bootlegninja
DD-WRT Novice


Joined: 25 Aug 2010
Posts: 3

PostPosted: Wed Dec 04, 2019 6:09    Post subject: Reply with quote
WRT3200ACM
Flashed using Chrome Version 78.0.3904.108 (Official Build) (64-bit)on Ubuntu 18.04
Firmware Version DD-WRT v3.0-r41659 std (12/03/19)
Kernel VersionLinux 4.9.205 #1425 SMP Tue Dec 3 14:17:34 +03 2019 armv7l
Previous version r41586 to r41659
WIFI no issues, NAS, transmission, and other features OK. VPN not tested.

One lingering issue I've noticed on my setup is that SSH is somewhat flaky. SFTP will not connect as it reports an error from Filezilla:
Code:
The first key-exchange algorithm supported by the server is diffie-hellman-group1-sha1, which is no longer secure. Aborting connection.

Trying to remotely connect to the transmission BT service on the router fails consistently as well regardless of any port forwarding setting.
greatmoo27
DD-WRT Novice


Joined: 22 Jan 2019
Posts: 26

PostPosted: Wed Dec 04, 2019 9:21    Post subject: Reply with quote
WRT1900ACSV2 upgraded wirelessly via Chrome. Everything seems to be working as it should and no issues accessing the GUI. Currently running QOS with HTB/CAKE configuration.
ttowling
DD-WRT User


Joined: 01 Mar 2019
Posts: 126

PostPosted: Wed Dec 04, 2019 9:57    Post subject: Reply with quote
greatmoo27 wrote:
WRT1900ACSV2 upgraded wirelessly via Chrome. Everything seems to be working as it should and no issues accessing the GUI. Currently running QOS with HTB/CAKE configuration.


Interesting. Was CAKE working for you previously? And did you do a full reset?
greatmoo27
DD-WRT Novice


Joined: 22 Jan 2019
Posts: 26

PostPosted: Wed Dec 04, 2019 10:35    Post subject: Reply with quote
ttowling wrote:
greatmoo27 wrote:
WRT1900ACSV2 upgraded wirelessly via Chrome. Everything seems to be working as it should and no issues accessing the GUI. Currently running QOS with HTB/CAKE configuration.


Interesting. Was CAKE working for you previously? And did you do a full reset?


Yup, since it was first introduced - I've used HTB/CAKE configuration. Read that its newer and better than FQ_CODEL from other forums... Prior to that, I did use HTB/FQ_CODEL which was fine too. In terms of testing, I saw significant difference between CAKE and FQ_CODEL when testing using dslreports.com: CAKE showed downloading stability at peak while FQ_CODEL showed peaks and troughs. Wanted to try out FQ_CODEL_FAST but never got around to do it yet.

I did do a full reset in one of the builds due to the GUI not being accessible.
ellick
DD-WRT User


Joined: 28 Mar 2016
Posts: 265

PostPosted: Wed Dec 04, 2019 14:46    Post subject: Reply with quote
wrt1900acs v.1

Build installed fine over the trusted r40009 build. I flashed it last night just hours before going to bed. Got up this morning and used my old Asus 7" tablet running the kiwi (chromium based) browser) . Gui was up. I closed Kiwi, reopened it, tried the router again and the GUI is now dead, It's also dead (just times out) on my wired, windows 10 pc running Firefox as I type this.

I believe something in wireless or my android tablet is causing the httpd to hang rather than completely crash as it seems to happen most often after using that device. Can other people who have this GUI hang issue chime in on whether they have android devices connecting wirelessly?

I don't have a serial cable so not sure what else I can do to figure out what causes the problem. I already enabled klog and sent my whole system log to BS in the bug report for this issue. I didn't see anything in it and the loss of GUI getting worse for me in the last few builds.
shahabkhan99
DD-WRT Novice


Joined: 19 Dec 2018
Posts: 6

PostPosted: Wed Dec 04, 2019 15:52    Post subject: Reply with quote
wrt1900acs v.2 flashed from 41586 to 41659
via windows 10 + chrome (webflash)

every things working fine except WIFI 5Ghz
when i connect my mobile(android) to 2.5Ghz it is working fine then i connect my second device to 5Ghz and in 5 to 10 seconds router restarted ... then again i did the same cycle after power off and on ...same result "router restarted after 5 to 10 seconds after connecting 5Ghz device ...i tried many times but the same.
so i reflash back to 41586 and every thing is working fine no restart issue at all
note : i dont touch any setting and my wifi setting is as :

5Ghz WiFi
AP + AC/N-Mixed + VHT80 (80 Mhz) + 140-5700Mhz + LU(-2)

2.4Ghz WiFi
AP + Mixed + Full (20Mhz) + Auto + Turbo..=disable
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 216
Location: South Carolina

PostPosted: Wed Dec 04, 2019 17:38    Post subject: DD-WRT v3.0-r41659 std (12/03/19) Reply with quote
WRT3200ACM V1 r41659 Firefox 71.0.0 (64-bit) webflash

OpenVPN CLIENT works fine (nordvpn server)
5GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
2.4GHz wpa2 CCMP-128 (AES)working fine 20MHz Mixed
NAS via USB Samba also working fine
Monza
DD-WRT User


Joined: 01 Jul 2018
Posts: 141

PostPosted: Thu Dec 05, 2019 12:47    Post subject: Reply with quote
Upgraded WRT1200AC v1 from r41586 to r41659 using Waterfox Classic 2019.10 (64 bit) running on Linux Mint 19.1 OS.

Successful update and reboot. No reset, nothing disabled prior to update, uptime about 24 hrs, wired/wireless connected, vpn up immediately. I do NOT use NAS and SFE is always disabled. OpenVPN client enabled. On install switched QoS from PIE to CAKE. Retested with same score for both PIE and CAKE. Left CAKE running and have had no issues with GUI lockup.

Kernel Version Linux 4.9.205 #1425 SMP Tue Dec 3 14:17:34 +03 2019 armv7l

Dec 3 19:09:34 router daemon.notice openvpn[2098]: OpenVPN 2.4.7 arm-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Dec 3 2019
Dec 3 19:09:34 router daemon.notice openvpn[2098]: library versions: OpenSSL 1.1.1d 10 Sep 2019, LZO 2.09
d0ug
DD-WRT Guru


Joined: 31 Jul 2015
Posts: 794

PostPosted: Thu Dec 05, 2019 18:21    Post subject: Reply with quote
Bootlegninja wrote:
WRT3200ACM
Flashed using Chrome Version 78.0.3904.108 (Official Build) (64-bit)on Ubuntu 18.04
Firmware Version DD-WRT v3.0-r41659 std (12/03/19)
Kernel VersionLinux 4.9.205 #1425 SMP Tue Dec 3 14:17:34 +03 2019 armv7l
Previous version r41586 to r41659
WIFI no issues, NAS, transmission, and other features OK. VPN not tested.

One lingering issue I've noticed on my setup is that SSH is somewhat flaky. SFTP will not connect as it reports an error from Filezilla:
Code:
The first key-exchange algorithm supported by the server is diffie-hellman-group1-sha1, which is no longer secure. Aborting connection.

Trying to remotely connect to the transmission BT service on the router fails consistently as well regardless of any port forwarding setting.


I have seen this same diffie-hellman-group1-sha1 error SSHing to the router as well for the last two builds or so. It is not just the WRT routers either. I have a few TPLink WR710N/WR810N routers that I use for travel and as WiFi to Ethernet bridges. They are all reporting the same error, even after a reset to defaults.
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 3115
Location: Texas, USA

PostPosted: Thu Dec 05, 2019 20:13    Post subject: Reply with quote
That cipher algorithm was removed quite a while back, I thought. I will have to back-track, but I could've sworn it's been removed. Are you sure it's not a client-side error?

Correction, that wasn't the cipher removed:

https://svn.dd-wrt.com/ticket/5714

The ticket is still re-opened, and references another forum thread.

_________________
E4200 v1 DD-WRT 41954 mega (01/09/20) (K3.x)
R7000P DD-WRT 40270M kongac
E4200 v1 FreshTomato 2019.4
E4200 v1 FreshTomato 2020.1.development
R7000 FreshTomato 2020.1.development
E4200 v1 1.0.07.development
WRT3200ACM OpenWRT 18.06.5
---------------------------------------------------------
Linux User #377467 counter.li.org / linuxcounter.net
7heblackwolf
DD-WRT Novice


Joined: 21 Nov 2019
Posts: 17

PostPosted: Sun Dec 08, 2019 16:41    Post subject: Reply with quote
ttowling wrote:
greatmoo27 wrote:
WRT1900ACSV2 upgraded wirelessly via Chrome. Everything seems to be working as it should and no issues accessing the GUI. Currently running QOS with HTB/CAKE configuration.


Interesting. Was CAKE working for you previously? And did you do a full reset?


CAKE was in r40559 (unusable), affected by kernel change in r40634, now stable in r41586 with shaper parameter adjusted.

Cheers.

_________________
Linksys WRT3200ACM
Firmware: DD-WRT v3.0-r41954 std (01/09/20)

Dnsmasq / VAP / DNSCrypt / DNSSEC / QoS WAN.HTB.Cake (custom netmask and svc) / Custom port setups for subnet delegation
Argenis
DD-WRT Novice


Joined: 18 Feb 2019
Posts: 11

PostPosted: Mon Dec 09, 2019 4:38    Post subject: Solid on 32x and 3200ACM Reply with quote
I'm using basic wireless and VPN client settings, but everything in that respect is working like a charm.

I am not using any storage or upnp if anyone's wondering, and GUI works fine on both devices.

It even re-acquires connectivity on most cases after a modem is reset which is really nice, something that hadn't been happening in a while.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum