Authentication failure on later builds for VAPs

Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Author Message
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5858
Location: Romerike, Norway

PostPosted: Thu Apr 04, 2019 13:15    Post subject: Reply with quote
Try the latest build from the test folder.

For what router model?
Sponsor
cristiancl
DD-WRT Novice


Joined: 04 Apr 2019
Posts: 3

PostPosted: Thu Apr 04, 2019 20:59    Post subject: Reply with quote
Per Yngve Berg wrote:
Try the latest build from the test folder.

For what router model?


My bad, i've forgot to mention the model i'm using.

I'm on R7000 and tried both builds, the test build and the stable one at this date and neither fix the issue with VAP.
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1473
Location: WCentral Indiana USA

PostPosted: Thu Apr 04, 2019 21:56    Post subject: Reply with quote
cristiancl wrote:
the last build that had VAP working?

Seems VAPs were broken around middle of 2018.
If you search the New Build threads from around that time you may find your answer.
Try something from April-May.

Old <Kong> builds for Broadcom are found at clonevince:
http://ddwrt-kong.clonevince.fr/

_________________
STUBBY DoT install guide----Forum Guide Lines (Please read!) --- How to get help the right way----Reports
Dr_K
DD-WRT User


Joined: 23 Mar 2018
Posts: 442

PostPosted: Thu Apr 04, 2019 22:56    Post subject: Reply with quote
I know r35550M kongac (03/28/18 ) VAPs work as expected for my R6300v2's. Uses the same build as your R7000 would.

I don't know for sure if it was the last one or not.....maybe 2nd or 3rd last? Can only confirm the one mentioned. ¯\_(ツ)_/¯

_________________
Location 1
R6300V2- DD-WRT v3.0-r39345M kongac (04-03-19) Gateway
WNDR3400v1 DD-WRT v3.0-r35531_mega-nv64k (03/26/18 ) Access Point
WRT160Nv3 DD-WRT ?v3?.0-r35531 mini (03/26/18 ) Access Point
WRT54GSv5 DD-WRT v24-r33555_micro_generic (10/20/17) Repeater
Location 2
R6300V2- DD-WRT v3.0-r39345M kongac (04/03/19) Gateway
R6300V2- DD-WRT v3.0-r39345M kongac (04/03/19) Access Point
WNDR3700v2 DD-WRT v3.0-r35531 std (03/26/18 ) Access Point
E1200 v2 DD-WRT v3.0-r35531 mega-nv64k (03/26/18 ) Gateway(for trivial reasons)
RBWAPG-5HACT2HND-BE RouterOS-v6.46.4 (2/21/20) Outdoor Access Point
2 devices: RBSXTG-5HPACD RouterOS-v6.46.4 (2/21/20) PTP Bridge (0.8km/0.5mi)tx/rx 866.6Mbps-1GbpsLAN
Location 3
R7000 DD-WRT v3.0-r44627 netgear-r7000 (10/22/20) Access Point
2 devices: RBWAPG-60AD RouterOS-v6.45.9 (04/30/20) PTP Bridge tx/rx 2.3Gbps-1GbpsLAN


Thank You BrainSlayer & <Kong> for ALL that you do & have done, also to "most" everyone here that shares their knowledge
cristiancl
DD-WRT Novice


Joined: 04 Apr 2019
Posts: 3

PostPosted: Fri Apr 05, 2019 0:33    Post subject: Reply with quote
bushant wrote:
cristiancl wrote:
the last build that had VAP working?

Seems VAPs were broken around middle of 2018.
If you search the New Build threads from around that time you may find your answer.
Try something from April-May.

Old <Kong> builds for Broadcom are found at clonevince:
http://ddwrt-kong.clonevince.fr/


Is that source reliable?
bkaskar
DD-WRT Novice


Joined: 15 Feb 2019
Posts: 20

PostPosted: Fri Jun 28, 2019 20:27    Post subject: Reply with quote
quarkysg wrote:
For those running ARM based Broadcom routers, if you don't mind, try the following and see if it solves your problem.
.
.
Do report back if the above works for you. It can then be used to report back to BS & Kong for further investigation.

HTH.

Router/Version: Asus RT-AC68U
File: dd-wrt.v24-K3_AC_ARM_STD.bin (TEST Build)
Firmware: DD-WRT v3.0-r39960M kongac (06/08/19)
Kernel: Linux 4.4.180 #666 SMP Sat Jun 8 11:15:19 CEST 2019 armv7l DD-WRT
Mode: AP, 2.4(Wide HT40)+5(VHT80). Both radio work simultaneously.
Setup>Networking GUI: works flawlessly
VLAN: GUI Mode works just by adding vlan.*hwname
VAP: Works on br0. But breaking out to other bridges with VLANs or independently does not connect. Even eth1 and eth2 breaking out of br0 stop connecting with authentication failure.. VAP worked on all these test builds with @quarkysg 's workaround mentioned in this post earlier in an earlier thread

Thank you @quarkysg, you rock!!

Somehow I keep posting in wrong places. Earlier I posted this message above in BS r40009 New Builds thread Embarassed

TBH I have tried both (09-26-2018 and TEST) Kong AC builds from desipro.de and r40009, r40048, r40065 from BS' Beta builds... None of them had the VAP authentication working. Both in r40048 BS and
r39960M kongac builds after running the workaround it worked.

As I'm still setting things up I have the freedom to try and and retry.. but once I put it up my family won't let me touch the equipment Laughing

Now I have questions:
1. Several other forum posts suggest that VAP doesn't work but in order to let BS and Kong know what should I do Question
2. Is there any other way to persist `quarkysg's wlconf` w/o adding jffs on USB Question

Thanks
-B
NotAutistic
DD-WRT Novice


Joined: 06 Jul 2019
Posts: 8

PostPosted: Sat Jul 06, 2019 3:15    Post subject: Reply with quote
bkaskar wrote:
quarkysg wrote:
For those running ARM based Broadcom routers, if you don't mind, try the following and see if it solves your problem.
.
.
Do report back if the above works for you. It can then be used to report back to BS & Kong for further investigation.

HTH.

Router/Version: Asus RT-AC68U
File: dd-wrt.v24-K3_AC_ARM_STD.bin (TEST Build)
Firmware: DD-WRT v3.0-r39960M kongac (06/08/19)
Kernel: Linux 4.4.180 #666 SMP Sat Jun 8 11:15:19 CEST 2019 armv7l DD-WRT
Mode: AP, 2.4(Wide HT40)+5(VHT80). Both radio work simultaneously.
Setup>Networking GUI: works flawlessly
VLAN: GUI Mode works just by adding vlan.*hwname
VAP: Works on br0. But breaking out to other bridges with VLANs or independently does not connect. Even eth1 and eth2 breaking out of br0 stop connecting with authentication failure.. VAP worked on all these test builds with @quarkysg 's workaround mentioned in this post earlier in an earlier thread

Thank you @quarkysg, you rock!!

Somehow I keep posting in wrong places. Earlier I posted this message above in BS r40009 New Builds thread Embarassed

TBH I have tried both (09-26-2018 and TEST) Kong AC builds from desipro.de and r40009, r40048, r40065 from BS' Beta builds... None of them had the VAP authentication working. Both in r40048 BS and
r39960M kongac builds after running the workaround it worked.

As I'm still setting things up I have the freedom to try and and retry.. but once I put it up my family won't let me touch the equipment Laughing

Now I have questions:
1. Several other forum posts suggest that VAP doesn't work but in order to let BS and Kong know what should I do Question
2. Is there any other way to persist `quarkysg's wlconf` w/o adding jffs on USB Question

Thanks
-B


Hello,

I think I found a fix/workaround today when I was setting up my Asus RT-AC68U with Kong build; I had the same problem as you described.

Are you still experiencing the VAP issues with
File: dd-wrt.v24-K3_AC_ARM_STD.bin (TEST Build)
Firmware: DD-WRT v3.0-r39960M kongac (06/08/19)?

Let me know and I'll post results.

Thank you
andrewcz
DD-WRT Novice


Joined: 01 Sep 2018
Posts: 2

PostPosted: Thu Aug 01, 2019 1:14    Post subject: Reply with quote
quarkysg wrote:
For those running ARM based Broadcom routers, if you don't mind, try the following and see if it solves your problem:

1. Download the attached wlconf.gz file and transfer to your router.
2. 'gunzip' the file with the following command:

Code:
gunzip wlconf.gz
chmod u+x wlconf


3. Issue the following commands in the same directory that you have uploaded the wlconf.gz file:

Code:
stopservice nas
stopservice wlconf
./wlconf eth1 up
./wlconf eth2 up
startservice nas


You can ignore all the errors shown when the 'wlconf <intf> up' commands is executed.

From the changes in the source codes for the 'wlconf' utility, it looks like the way that the MAC addresses are getting generated for the wireless interfaces have changed for newer drivers. I guess it only applies to newer Broadcom wireless chipsets, which broke older chipsets.

I changed the 'wlconf' utility behaviour back to what it was previously and it seems to work OK for the following routers which I'm using:

D-Link DIR-868L
D-Link DIR-880L
Asus RT-AC68U/W

Do report back if the above works for you. It can then be used to report back to BS & Kong for further investigation.

HTH.


Thanks for providing those! They worked great! I'm running DD-WRT on an ASUS AC68U.

There were a couple of posts in this thread mentioning making it persistant with startup commands. However, this would require that I store the binaries somewhere. Is that able to be done without attaching an external storage device? If not, is JFFS what I need to look into?
pianoquintet
DD-WRT Novice


Joined: 02 Feb 2012
Posts: 2

PostPosted: Mon Aug 05, 2019 13:14    Post subject: Reply with quote
The commands suggested by quarkysg on the first page fixed my problem on an RT-AC56U.

They are not permanent, however, so the issues arise again on reboot. Can anyone help me make them permanent?

Thank you.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 6630
Location: Netherlands

PostPosted: Mon Aug 05, 2019 13:51    Post subject: Reply with quote
pianoquintet wrote:
The commands suggested by quarkysg on the first page fixed my problem on an RT-AC56U.

They are not permanent, however, so the issues arise again on reboot. Can anyone help me make them permanent?

Thank you.


It can only be done if you have permanent storage.
Copy the unzipped files to your permanent storage like jffs make them executable like the instructions already given

and put following in administration/commands Save startup:
Code:
sleep 30
stopservice nas
stopservice wlconf
/jffs/wlconf eth1 up
/jffs/wlconf eth2 up
startservice nas   


Before putting anything in startup command test from command line first otherwise if the commands are wrong you might have to reset.

Not tested so no guarantees Smile

It is a quick and dirty solution, normally I would put the commands in a file with some additional logging and call that file from startup. But something for you to do yourself Smile

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
OpenVPN Policy Based Routing: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Server setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Wireguard Client setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324624
Wireguard Advanced setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324787
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
bkaskar
DD-WRT Novice


Joined: 15 Feb 2019
Posts: 20

PostPosted: Fri Aug 23, 2019 10:43    Post subject: Reply with quote
NotAutistic wrote:

Hello,

I think I found a fix/workaround today when I was setting up my Asus RT-AC68U with Kong build; I had the same problem as you described.

Are you still experiencing the VAP issues with
File: dd-wrt.v24-K3_AC_ARM_STD.bin (TEST Build)
Firmware: DD-WRT v3.0-r39960M kongac (06/08/19)?

Let me know and I'll post results.

Thank you


@NotAutistic, Sorry for the delayed reply. I still do have intermittent issues when I took the patched wlconf provided in this thread away. I was only using restarting cron, nas, wlconf services in LIFO as recommended in other posts.
In the latest build post I see folks reporting there is no issue of VAP restarting.. what's your workaround?
and Thanks for your reply earlier!

-B
psychotrain65
DD-WRT Novice


Joined: 02 Nov 2019
Posts: 1

PostPosted: Sat Nov 02, 2019 18:44    Post subject: Reply with quote
I tried succesfully wlconf method on Asus RT-AC56U, AP mode, with guest WAP on bridge br1, both 2,4 and 5 Ghz virtual interfaces (and vlan2, too).

Internal LAN address: 192.168.2.0/24 (+ IPv6 via tunnelbroker.net)

Guest lan address: 192.168.3.1

The firmware is v3.0-r37305 std

The gateway is a Fritz!box 7590.
bthoven
DD-WRT Novice


Joined: 23 Sep 2019
Posts: 20

PostPosted: Thu Nov 07, 2019 3:02    Post subject: Reply with quote
Just to report that no VAP connection problem with the v3.0-r41027 on TP-Link Archer C9v1., if using dhcp on dd-wrt.

The patched wlconf also solve the dd-wrt running as AP (router) mode, with wl0.1 bridging VLAN and br1 (tagged VLAN on VAP)and using dhcp on PfSense. Thanks a lot.


Last edited by bthoven on Fri Nov 08, 2019 6:09; edited 3 times in total
parco
DD-WRT User


Joined: 10 Sep 2017
Posts: 100

PostPosted: Thu Nov 07, 2019 18:12    Post subject: Reply with quote
Authentication failure now in the default real AP as well Rolling Eyes going worse and worse
https://svn.dd-wrt.com/ticket/6881
andrewcz
DD-WRT Novice


Joined: 01 Sep 2018
Posts: 2

PostPosted: Tue Nov 12, 2019 4:35    Post subject: Slow Ethernet Reply with quote
Hello all,

Can anybody please let me know if this affects ethernet speeds? I'm getting 1/10th the bandwidth that I can on my upstream router using ethernet.

I didn't benchmark before. However, my upstream router/internet gateway (pfsense) is getting ~450/50 Mbps, while my AC68U dd-wrt is getting ~35/2 Mbps. It's not even NATting, it's just routing.

If this is probably not related to `wlconf`, then I'll make a separate post about it.
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next Display posts from previous:    Page 6 of 7
Post new topic   This topic is locked: you cannot edit posts or make replies.    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum