New (KONG) Test Build - 10/25/2018 (UPDATE 7)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3 ... , 13, 14, 15  Next
Author Message
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7141
Location: YWG, Canada

PostPosted: Sun Oct 28, 2018 0:19    Post subject: Reply with quote
<Kong> wrote:
tatsuya46 wrote:
k4, at least till k4.14 anyway, is trash and should be pulled off kernel.org imo. even broadcom users starting to have our qos problem too apparently.

utter trash.

on the other hand, what about qos cake? brainslayer loves to blindly merge everything openwrt into ddwrt (broken and all), except qos... or we'd have cake. and what about k4.18, .19? anything look different in there for ipq thats worth attempting a port to test?


Cake does not work with imq, if we want to use cake we have to completely redesign qos and most likely also drop a few qos functions we currently ship.

The qos load issue on 4.x is as far as I can tell IPQ only, the R9000 has no issue.


what a shame.. is it possible to use combining queuing dis? like htb+pie on download, htb+fq_codel on upload etc?

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150 ------------> DD-WRT v3.0-r41659 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41659 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r41631 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
Sponsor
jackykoning
DD-WRT User


Joined: 15 May 2013
Posts: 218
Location: The Nederlands

PostPosted: Sun Oct 28, 2018 0:57    Post subject: Reply with quote
<Kong> wrote:
Cake does not work with imq, if we want to use cake we have to completely redesign qos and most likely also drop a few qos functions we currently ship.

The qos load issue on 4.x is as far as I can tell IPQ only, the R9000 has no issue.


So hide the UI until the user selects the QOS he wants to use then show what is supported by the selected? Or gray out the unsupported variables when Cake is selected?

What kind of complete redesign are we talking about? Might it be worth making a single build where there are only 2 options Cake and off? This to test is Cake would be a solution to our problems to begin with.
I know I am asking for a lot right here.

_________________
Hi Smile
2x Netgear R7800
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5215
Location: Akershus, Norway

PostPosted: Sun Oct 28, 2018 9:20    Post subject: Reply with quote
I have only a 50 Mbit/s Internet subscription that is not high enough to experience any problems. However I have made some observations:

1) QOS do not throttle IPv6 traffic. I always get full speed and grade B/C on Buffer Bloat.

2) IPTV/Multicast is comming in from my ISP. It's not part of the 50 Mbit/S Internet Throttling.

How is QOS handling the IPv4 over the line when IPv6 and Multicast is using the line?

I am connected to a Gigabit interface and throttling is taking place in the router that routes to Internet.
vit5421
DD-WRT User


Joined: 12 Nov 2015
Posts: 423

PostPosted: Sun Oct 28, 2018 17:31    Post subject: Reply with quote
B and C is awful bufferbloat. I would like to be at A+ with less than 30 ms and can do on 3.18 only at 500mbs internet. The new 3.18 (37495) is available in main directory
_________________
Netgear R7800
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4354
Location: Germany

PostPosted: Sun Oct 28, 2018 17:41    Post subject: Reply with quote
Just had serious issues with my throughput, took a while till I found the issue, broken switch, then exchanged it and noticed some qos issues, turns out that the new switch has some EEE features such as low power if it detects low bandwidth. Obviously this feature causes latency issues.
_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7141
Location: YWG, Canada

PostPosted: Tue Oct 30, 2018 11:40    Post subject: Reply with quote
<Kong> wrote:
Just had serious issues with my throughput, took a while till I found the issue, broken switch, then exchanged it and noticed some qos issues, turns out that the new switch has some EEE features such as low power if it detects low bandwidth. Obviously this feature causes latency issues.


have u notified BS about these ipq k4.x issues? this is bullshit, the kernel is broken. certainly something is very wrong here, but i know BS doesnt care about qos, will he revert to k3.18? hes already manually supporting 3.10 on low flash space units so...

u already seen me try to get his attention, hasnt worked ever for qos, and for most other things too, so fed up with this already. maybe he'd listen to u more than us users...

_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150 ------------> DD-WRT v3.0-r41659 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41659 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r41631 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7141
Location: YWG, Canada

PostPosted: Tue Oct 30, 2018 15:20    Post subject: Reply with quote
is current "test" folder k3.18? the test 3.18 directory is gone...
_________________
LATEST FIRMWARE(S) || Qualcomm Atheros Wi-Fi Settings Guide || Qualcomm Atheros Repeating

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150 ------------> DD-WRT v3.0-r41659 std
[QUALCOMM] R7800 -----------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] DIR-862L --------------> DD-WRT v3.0-r41659 std
[QUALCOMM] WNDR4300 v1 --------> DD-WRT v3.0-r41659 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------> DD-WRT v3.0-r41631 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
jackykoning
DD-WRT User


Joined: 15 May 2013
Posts: 218
Location: The Nederlands

PostPosted: Tue Oct 30, 2018 15:32    Post subject: Reply with quote
tatsuya46 wrote:
is current "test" folder k3.18? the test 3.18 directory is gone...


The normal builds outside of test is k3.18 the other one is k4.9

_________________
Hi Smile
2x Netgear R7800
WaterWater
DD-WRT Novice


Joined: 18 Nov 2017
Posts: 45

PostPosted: Sat Nov 03, 2018 18:46    Post subject: Reply with quote
tatsuya46 wrote:

have u notified BS about these ipq k4.x issues? this is bullshit, the kernel is broken. certainly something is very wrong here, but i know BS doesnt care about qos, will he revert to k3.18? hes already manually supporting 3.10 on low flash space units so...


Is this not an appropriate issue to bring up on the linux-wireless or netdev mailing lists? It sounds like the answer is to get it fixed upstream.

If you know the regression occurred between 4.4 and 3.18 can we not bisect? If you have the bad git commit along with confirming it's broken on 4.19 I'm sure there will be upstream interest in fixing it.
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4857
Location: Texas

PostPosted: Sun Nov 04, 2018 13:27    Post subject: Reply with quote
EA8500
DD-WRT v3.0-r37495M kongat 10/25/18
Linux 4.9.135 #253 SMP PREEMPT Thu Oct 25 02:05:21 CEST 2018 armv7l
main router
Uptime 10 days, 12:33

It's all good Cool

http://www.dslreports.com/speedtest/41319066
vit5421
DD-WRT User


Joined: 12 Nov 2015
Posts: 423

PostPosted: Sun Nov 04, 2018 16:11    Post subject: Reply with quote
You have a great bufferbloat but probably coz of slow Internet connection.
I still have a twice or even more better bufferbloat on 3.18 compare to 4.9 but on 500mbs

_________________
Netgear R7800
Per Yngve Berg
DD-WRT Guru


Joined: 13 Aug 2013
Posts: 5215
Location: Akershus, Norway

PostPosted: Sun Nov 04, 2018 16:34    Post subject: Reply with quote
stalonge wrote:
http://www.dslreports.com/speedtest/40671529
Last was in ipv6

This is in ipv4:
http://www.dslreports.com/speedtest/40671673


How did you get that good buffer-bloat on IPv6?
Are you running 6in4?

With native IPv6, the QOS settings does not have any effect. Always get full speed and terrible buffer-bloat.
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1292

PostPosted: Sun Nov 04, 2018 16:42    Post subject: Reply with quote
Per Yngve Berg wrote:
stalonge wrote:
http://www.dslreports.com/speedtest/40671529
Last was in ipv6

This is in ipv4:
http://www.dslreports.com/speedtest/40671673


How did you get that good buffer-bloat on IPv6?
Are you running 6in4?

With native IPv6, the QOS settings does not have any effect. Always get full speed and terrible buffer-bloat.


That's bad bufferbloat, this is good bufferbloat

mrjcd wrote:
EA8500
DD-WRT v3.0-r37495M kongat 10/25/18
Linux 4.9.135 #253 SMP PREEMPT Thu Oct 25 02:05:21 CEST 2018 armv7l
main router
Uptime 10 days, 12:33

It's all good Cool

http://www.dslreports.com/speedtest/41319066
htismaqe
DD-WRT User


Joined: 05 Nov 2015
Posts: 471

PostPosted: Thu Nov 08, 2018 16:24    Post subject: Reply with quote
14+ days of solid performance on r37495. I do have one issue - the lag when moving from tab to tab seems to be back. It was gone for a few releases but now I occasionally get 10-15 seconds of "hang" when moving to a new tab.
_________________
Routing:.......Asus RT-AC86U (Asuswrt-Merlin 384.14_beta2)
Switching:....Netgear GS608_V3 & GS605_V4, TrendNet TEG-S82G & TEG-S50G
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 4857
Location: Texas

PostPosted: Thu Nov 08, 2018 17:10    Post subject: Reply with quote
htismaqe wrote:
14+ days of solid performance on r37495.
Hope you can get a few more Rolling Eyes

---

Well damnit!!! The EA8500 just qiut few minutes ago after 16 days
DD-WRT v3.0-r37495M kongat 10/25/18
Linux 4.9.135 #253 SMP PREEMPT Thu Oct 25 02:05:21 CEST 2018 armv7l

Could not get anything to work. No access to it via wired/wireless/webif/SSH/Telnet/

Phone showed still connected to 5GHz Wifi but when I diabaled the phone wifi and tried to reconnect it would not although stupid phone showed it was still broadcasting SSID.

Have not really done any changes to it except when turned off 'Recursive DNS resolving' few days back here --
https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1146421#1146421

I do occaisionally change port range forwarding to diffent web server if I am working on current web server.
Last time I done that was yesterday morning --- but that aint never caused an issue before.

I just quickly done a power off/on and all is back to normal.
To many people need internet this time of day and many things are linked back to my webserver. Twisted Evil
Glad this didn't happen yesterday cause I was gone most that day but connected to its ovpn server all the time without a problem.
Don't have a clue other than something run-a-muck. Guess I need to setup a remote logger....although don't know that it would've caught anything.

Hope Mr.K will look into it Cool
Goto page Previous  1, 2, 3 ... , 13, 14, 15  Next Display posts from previous:    Page 14 of 15
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum