New (KONG) Test Build - 10/25/2018 (UPDATE 7)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3, 4, 5 ... 13, 14, 15  Next
Author Message
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Wed Oct 17, 2018 19:54    Post subject: Re: Where did FINDFS go in fw 37400M? Reply with quote
ArjenR49 wrote:
<Kong> wrote:

$(blkid | grep B298F12198F0E4AF | cut -d ':' -f 1)


THANKS, Kong! That works like a charm.

I can understand the general idea of how that works, but it would likely take me months if not years to come up with something like that myself.

I was quite happy to have gotten my startup script to do what I intended all the time navigating subtle differences in syntax of ash as compared to bash or dash, neither of which I know to any mentionable degree.

Trying out different syntax found in examples and help pages on the internet, I managed to get it working after many days of work improving and looking for syntax that works in ash (rather poorly documented as such, it seems).

So, it did feel a little like the rug was pulled from under my feet, when it suddenly stopped working ...

But all is well now and it didn't take very long at all Smile
Thanks a bunch!

I do still wonder where the findfs command went?

This is the current announcement from an SSH session. The time stamp could very well be the compile time ... only a few hours old:
BusyBox v1.29.3 (2018-10-16 23:30:58 CEST) built-in shell (ash)


This is due to changes in busybox.findfs is not enabled by default anymore in busybox and we do not need it in the firmware, thus nobody missed it, while we use blkid command in our mounting code.

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
Sponsor
zCobra
DD-WRT Novice


Joined: 04 Nov 2017
Posts: 12
Location: TX

PostPosted: Wed Oct 17, 2018 20:03    Post subject: Reply with quote
Looks like Kong just compiled a new build. Expect a new thread shortly. Btw, 37410M on R7800 with OpenVPN working great! (100 MB download VPN on Gigabit Comcast)
vit5421
DD-WRT User


Joined: 12 Nov 2015
Posts: 413

PostPosted: Wed Oct 17, 2018 20:19    Post subject: Reply with quote
<Kong> wrote:
vit5421 wrote:
I have the same issues with BS builds and different routers as well.
Dear Kong, Can you check what is wrong now with GUI update?


Already fixed.


Not completely. I was not able to load the new 10/17 build with Chrome but did it with Edge. The latency is still far behind on 4.9

_________________
Netgear R7800
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1377

PostPosted: Wed Oct 17, 2018 20:42    Post subject: Reply with quote
r7500v2 37420M
upgraded over 410 via GUI w/chromium
vaps nas and all working syslog is clean thnx
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1300

PostPosted: Wed Oct 17, 2018 20:44    Post subject: Reply with quote
Router ModelNetgear R7500v2
Firmware Version DD-WRT v3.0-r37420M kongat (10/17/18 )
Kernel VersionLinux 4.9.134-rc1 #218 SMP PREEMPT Wed Oct 17 16:46:51 CEST 2018 armv7l

QoS still bad.
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5265
Location: Texas

PostPosted: Wed Oct 17, 2018 21:08    Post subject: Reply with quote
EA8500
DD-WRT v3.0-r37420M kongat 10/17/18
Linux 4.9.134-rc1 #219 SMP PREEMPT Wed Oct 17 17:05:42 CEST 2018 armv7l
GUI install over r37410M
main router
It's all good ...prolly even better than last couple Kong builds Razz

http://www.dslreports.com/speedtest/40499716
nickant
DD-WRT User


Joined: 09 Feb 2016
Posts: 161

PostPosted: Wed Oct 17, 2018 22:22    Post subject: Reply with quote
Updated my EA8500 from r37120M to r37400M to r37410M to r37420M via GUI with no resets.
All working well.
One thing: CPU temperature now reported to 3 decimal places.

_________________
------------------------------------
Linksys EA8500 DD-WRT r44085 (Gateway + OpenVPN Client)
Linksys WRT1900ACv1 DD-WRT r44085 (AP)
Netgear/Telstra V7610 (spare AP)
Billion BiPAC 7800NXL (spare AP)
Netgear WNDR3700v4 DD-WRT r44085 (spare Gateway + OpenVPN Client)
Photos: https://www.flickr.com/photos/nickant44/albums
Alozaros
DD-WRT Guru


Joined: 16 Nov 2015
Posts: 3710
Location: UK, London, just across the river..

PostPosted: Wed Oct 17, 2018 22:51    Post subject: Reply with quote
vit5421 wrote:
<Kong> wrote:
vit5421 wrote:
I have the same issues with BS builds and different routers as well.
Dear Kong, Can you check what is wrong now with GUI update?


Already fixed.

The latency is still far behind on 4.9


for some odd reason im looking forward for 3.18 builds....
if soon

_________________
Atheros
TP-Link WR740Nv1 ------DD-WRT 44085 BS AP,NAT
TP-Link WR740Nv4 ------DD-WRT 43028 BS WAP/Switch
TP-Link WR1043NDv2 ----DD-WRT 44112 BS AP,NAT,AP Isolation,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----DD-WRT 44048 BS AP,NAT,AD Block,Firewall,Local DNS,Forced DNS,DoT,VPN
TP-Link WR1043NDv2 ----Gargoyle OS 1.12.0 AP,NAT,QoS,Quotas
Qualcomm/IPQ8065
Netgear R7800 -------DD-WRT 44112 BS AP,NAT,AD-Block,AP&Net Isolation,VLAN's,Firewall,Local DNS,DoT
Broadcom
Netgear R7000 -------DD-WRT 44112 BS AP,Wi-Fi OFF,NAT,AD-Block,Firewall,Local DNS,Forced DNS,DoT,VPN
------------------------------------------------------------------------------------------------
Stubby for DNS over TLS I DNSCrypt v2 by mac913
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1300

PostPosted: Wed Oct 17, 2018 23:07    Post subject: Reply with quote
Alozaros wrote:
vit5421 wrote:
The latency is still far behind on 4.9


for some odd reason im looking forward for 3.18 builds....
if soon


Yes please
labrok
DD-WRT User


Joined: 11 Feb 2011
Posts: 268
Location: Greece

PostPosted: Thu Oct 18, 2018 7:29    Post subject: Reply with quote
jerrytouille wrote:
Alozaros wrote:
vit5421 wrote:
The latency is still far behind on 4.9


for some odd reason im looking forward for 3.18 builds....
if soon


Yes please


i am with you, but instead of looking to turn back to a -working but already old-kernel maybe should be better to help kong fix the newer one? Neither i can be 100% sure for my EA-8500 with k4 that it will work fluently, proven that it isnt but i believe its better to help him fix the newer kernel than staying to the old one, even my old and cheap 1043ND is onb k4 without issues, even qos is perfect, its a pitty for my expensive EA-8500 to remain to the old one!
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7343
Location: YWG, Canada

PostPosted: Thu Oct 18, 2018 7:59    Post subject: Reply with quote
labrok wrote:
jerrytouille wrote:
Alozaros wrote:
vit5421 wrote:
The latency is still far behind on 4.9


for some odd reason im looking forward for 3.18 builds....
if soon


Yes please


i am with you, but instead of looking to turn back to a -working but already old-kernel maybe should be better to help kong fix the newer one? Neither i can be 100% sure for my EA-8500 with k4 that it will work fluently, proven that it isnt but i believe its better to help him fix the newer kernel than staying to the old one, even my old and cheap 1043ND is onb k4 without issues, even qos is perfect, its a pitty for my expensive EA-8500 to remain to the old one!


i been talking with and testing many builds with him for months, none are fixing k4.9 qos. the closest was when k4.4 was tried but it was only half as bad (better than 4.9, worse than 3.1Cool.

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/6174 ---> DD-WRT v3.0-r44176 std
[QUALCOMM] DIR-862L ------------------------> DD-WRT v3.0-r44112 std
[QUALCOMM] DIR-862L ------------------------> DD-WRT v3.0-r44112 std
[QUALCOMM] WNDR4300 v1 ------------------> DD-WRT v3.0-r44112 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 -------------------> DD-WRT v3.0-r44048 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
stalonge
DD-WRT Guru


Joined: 21 Jul 2006
Posts: 1865
Location: Fortaleza Ce Brazil

PostPosted: Thu Oct 18, 2018 8:51    Post subject: Reply with quote
labrok wrote:
jerrytouille wrote:
Alozaros wrote:
vit5421 wrote:
The latency is still far behind on 4.9


for some odd reason im looking forward for 3.18 builds....
if soon


Yes please


i am with you, but instead of looking to turn back to a -working but already old-kernel maybe should be better to help kong fix the newer one? Neither i can be 100% sure for my EA-8500 with k4 that it will work fluently, proven that it isnt but i believe its better to help him fix the newer kernel than staying to the old one, even my old and cheap 1043ND is onb k4 without issues, even qos is perfect, its a pitty for my expensive EA-8500 to remain to the old one!



I dont know why .. but my dsl report get sometimes A in bufferbloat and sometimes B ... Of course i know that have some work to do ..

my wan link is 240/24 ( cable ) .. i am in Brazil .. this situation could change the results ?

Very Happy Very Happy

_________________
DDwrt ...it rocks ....
1 R8500 41556 AP OpenVPN webserver RETIRED (bricked)
1 R7800 42912 AP Wireguard webserver JFFS SAMBA FTP usb HD Mesh
1 R7800 42912 Cli Mesh
1 WZR1750 42908 AP Webserver OpenVPN
1 DDx86 Vmware 40260
1 E3000 41027 K3 @500 WAP wifi client
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7343
Location: YWG, Canada

PostPosted: Thu Oct 18, 2018 9:31    Post subject: Reply with quote
stalonge wrote:
labrok wrote:
jerrytouille wrote:
Alozaros wrote:
vit5421 wrote:
The latency is still far behind on 4.9


for some odd reason im looking forward for 3.18 builds....
if soon


Yes please


i am with you, but instead of looking to turn back to a -working but already old-kernel maybe should be better to help kong fix the newer one? Neither i can be 100% sure for my EA-8500 with k4 that it will work fluently, proven that it isnt but i believe its better to help him fix the newer kernel than staying to the old one, even my old and cheap 1043ND is onb k4 without issues, even qos is perfect, its a pitty for my expensive EA-8500 to remain to the old one!



I dont know why .. but my dsl report get sometimes A in bufferbloat and sometimes B ... Of course i know that have some work to do ..

my wan link is 240/24 ( cable ) .. i am in Brazil .. this situation could change the results ?

Very Happy Very Happy


stop looking at dslreports "grading", its algorithm is terrible and pathetic, look at the actual down and upload latency. be sure hi-res bufferbloat is enabled in settings.

and if possible, make sure ur browser doesnt have a stupidly low timer precision to "protect" against spectre/meltdown (its pointless and makes browsers inaccurate, undo it if allowed to)

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/6174 ---> DD-WRT v3.0-r44176 std
[QUALCOMM] DIR-862L ------------------------> DD-WRT v3.0-r44112 std
[QUALCOMM] DIR-862L ------------------------> DD-WRT v3.0-r44112 std
[QUALCOMM] WNDR4300 v1 ------------------> DD-WRT v3.0-r44112 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 -------------------> DD-WRT v3.0-r44048 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
labrok
DD-WRT User


Joined: 11 Feb 2011
Posts: 268
Location: Greece

PostPosted: Thu Oct 18, 2018 9:50    Post subject: Reply with quote
tatsuya46 wrote:
stalonge wrote:
labrok wrote:
jerrytouille wrote:
Alozaros wrote:
vit5421 wrote:
The latency is still far behind on 4.9


for some odd reason im looking forward for 3.18 builds....
if soon


Yes please


i am with you, but instead of looking to turn back to a -working but already old-kernel maybe should be better to help kong fix the newer one? Neither i can be 100% sure for my EA-8500 with k4 that it will work fluently, proven that it isnt but i believe its better to help him fix the newer kernel than staying to the old one, even my old and cheap 1043ND is onb k4 without issues, even qos is perfect, its a pitty for my expensive EA-8500 to remain to the old one!



I dont know why .. but my dsl report get sometimes A in bufferbloat and sometimes B ... Of course i know that have some work to do ..

my wan link is 240/24 ( cable ) .. i am in Brazil .. this situation could change the results ?

Very Happy Very Happy


stop looking at dslreports "grading", its algorithm is terrible and pathetic, look at the actual down and upload latency. be sure hi-res bufferbloat is enabled in settings.

and if possible, make sure ur browser doesnt have a stupidly low timer precision to "protect" against spectre/meltdown (its pointless and makes browsers inaccurate, undo it if allowed to)


Good to know it, but how? Never have seen such setting on Mozilla which i am using!
nickant
DD-WRT User


Joined: 09 Feb 2016
Posts: 161

PostPosted: Thu Oct 18, 2018 10:04    Post subject: Reply with quote
I had briefly tried OpenWRT v18.06.1 on my EA8500 and noticed that they use Kernel 4.14.
Maybe rather than getting 4.9 to work the way people want, Kong might want to move to 4.14 and optimize for this newer kernel.

_________________
------------------------------------
Linksys EA8500 DD-WRT r44085 (Gateway + OpenVPN Client)
Linksys WRT1900ACv1 DD-WRT r44085 (AP)
Netgear/Telstra V7610 (spare AP)
Billion BiPAC 7800NXL (spare AP)
Netgear WNDR3700v4 DD-WRT r44085 (spare Gateway + OpenVPN Client)
Photos: https://www.flickr.com/photos/nickant44/albums
Goto page Previous  1, 2, 3, 4, 5 ... 13, 14, 15  Next Display posts from previous:    Page 4 of 15
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum