New Kong's DD-WRT test build v3.0-r37015M (23/09/2018)

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Goto page 1, 2, 3  Next
Author Message
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7265
Location: Netherlands

PostPosted: Sun Sep 23, 2018 7:41    Post subject: New Kong's DD-WRT test build v3.0-r37015M (23/09/2018) Reply with quote
Kong's DD-WRT test build v3.0-r37015M kongac (23/09/2018) has been released: http://desipro.de/ddwrt/K3-AC-Arm/TEST/

Your reports for Broadcom units are greatly appreciated !
Router:
Firmware:
Kernel:
Status:
Reset:
Errors:


This build thread is for reporting successes and problem with loading this experimental test build. This is important info for developers and users. Always state your hardware and SPECIFIC build (e.g. 29440_NEWD-2_K2.6_mega-nv64k.bin). Do not ask questions about your specific router or how to configure it in this thread; create your own thread to discuss any specific problems you have or need resolved. Please also do not respond to such questions. This thread is to report info, not to seek it. Posts that do not add to understanding this build will be deleted. Make sure you know how to flash properly and the risk before using this build. It is important to adhere to these requirements, to keep this thread from becoming impossibly long and useless. If you don't know what build to flash and how to flash properly and have a means of recovery if things should go wrong, do NOT flash this experimental test build.

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
Sponsor
grc
DD-WRT User


Joined: 11 Jul 2018
Posts: 98

PostPosted: Sun Sep 23, 2018 8:30    Post subject: Reply with quote
Router: Netgear r6300v2
Firmware: DD-WRT v3.0-r37015M kongac (23/09/2018 )
Status: back to r35550M kongac (03/28/18 )
Reset: no
Errors: yes

can not connect to VAP with bridged 2.4 + 5 Ghz Virtual Interfaces.
@m0eb@
DD-WRT User


Joined: 26 Dec 2015
Posts: 289

PostPosted: Sun Sep 23, 2018 10:07    Post subject: R6400 v2 with Board xxx30 Reply with quote
Router: R6400V2 with board xxx30
Firmware: DD-WRT v3.0-r37015M kongac (09/23/18 )
Kernel: Linux 4.4.157 #603 SMP Sun Sep 23 01:10:11 CEST 2018 armv7l
Status: OK
Reset: No (Direct browser upgrade from 36840 to dd-wrt.v24-K3_AC_ARM_STD_128K.bin without reset)
Errors: None. All functions that I use appear normal. Wifi-Analyzer shows steady signals of expected height.
Uptime (while posting this): 45 minutes
Other Points:
1. 5 GHz SSID seems to transmit a stronger signal. I have a room where the 5 GHz signal never showed up on WiFi Analyzer in the past. Now it pops a small signal head (a bit unstable at the far-end room - but mostly there)
2. Checked via my repeater-bridge (E900 on 36698). No Issues
Pandora-Box
DD-WRT User


Joined: 09 Mar 2008
Posts: 218
Location: USA

PostPosted: Sun Sep 23, 2018 12:18    Post subject: Reply with quote
Hello,

Router: Netgear R7000
Firmware: DD-WRT v3.0-r37015M kongac (09/23/2018)
Status: SEMI-Working: No (some things) & Yes (some other things)
Reset: Yes, multiple "erase nvram" and reboots
Previous: Kong 36070M
Errors: Yes

Still "NO-GO" with VAPs in this version Sad

Here what is of my concern and is NOT working:

VAPs 2.4GHz wl0.1 and 5.0GHz wl1.1
Version (only) Kong 36070M, I can connect to both VAPs (=working),
version Kong 37015M I canNOT connect to both VAPs (from multiple OSs and devices; =NOT working).
Regressing back to Kong 36070M.
More details in this thread:
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316313&highlight=
and opened ticket:
https://svn.dd-wrt.com/ticket/6404
Most probably it is related to authentication (without security assignments VAPs are working, clients are connecting).
Hey DEVs take a look at this what is going on, please, BITTE, por favor.
Sincerely
P-B

_________________
Netgear R7000
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1546
Location: WCentral Indiana USA

PostPosted: Sun Sep 23, 2018 14:43    Post subject: Reply with quote
bushant wrote:
Router Name 6200v2 What it is
Router Model Netgear R6250 What it ain't
Firmware Version DD-WRT v3.0-r36840M kongac 09/03/18
Kernel Version Linux 4.4.153 #598 SMP Mon Sep 3
Previous 36820
no reset
no errors
Working

I can now confirm the only method of upgrading/downgrading this unsupported unit:
You have to soft brick it. Try to upgrade/downgrade via WebGUI or ddup will do it.
Then tftp with 24170-dd-wrt-K3_R6200V2_7-Aug-2014.chk. Timing is no issue.
Then install dd-wrt.v24-K3_AC_ARM_STD.bin via WebGUI.
So now it is on 36840


All still true. Tried upgrade via cli. wget fails with:
Code:
~# wget desipro.de/ddwrt/K3-AC-Arm/TEST/dd-wrt.v24-K3_AC_ARM_STD.bin
Connecting to desipro.de (212.227.247.157:80)
wget: server returned error: HTTP/1.0 403 Forbidden


Now on 37015M
Working fine

Will try downgrade to 24170-dd-wrt-K3_R6200V2_7-Aug-2014.chk via webgui first next time.

_________________
STUBBY DoT install guide----Forum Guide Lines (Please read!) --- How to get help the right way----PIA Setup Guide by egc----
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7265
Location: Netherlands

PostPosted: Sun Sep 23, 2018 15:02    Post subject: Reply with quote
Router Model: Netgear R6400v2, board_id: U12H332T30_NETGEAR

Firmware Version: DD-WRT v3.0-r37015M kongac (09/23/2018))
Kernel Version: Linux 4.4.157 #603 SMP Sun Sep 23 01:10:11 CEST 2018 armv7l

Upgraded: from DD-WRT v3.0-r36840M via ddup --flash-latest
Reset: No not this time

Status: Up and running for 6 hours, basic setup as AP, static leases, OpenVPN client (on PIA) with Policy Based Routing up and running, 2,4GHz, 5Ghz USB storage NAS and miniDLNA working.
VAP on 2.4 GHz and 5 GHz (both bridged) working
OpenVPN server will be tested later
GUI is responsive and quick.

Errors: Yes
OpenVPN with Policy Based Routing does not forward HTTP(s) traffic to the PBR clients with SFE on see: http://svn.dd-wrt.com/ticket/5900
Possible DNS leak see: http://svn.dd-wrt.com/ticket/6020

There is a solution, to the PBR not working with SFE, @Quarkysg has made a patch for the shortcut-fe module (see: http://svn.dd-wrt.com/ticket/5986#comment:17 ).
He also compiled a shortcut-fe.ko module for testing (Arm/Broadcom , Linux 4.4) see: https://www.dd-wrt.com/phpBB2/viewtopic.php?p=1107870#1107870 , I am running that patched shortcut-fe.ko module right now and it is working with PBR.

P.S. Kong, please update the supported models file in your directory with the R6400v2 and R6700v3

Big Thanks to Kong and BrainSlayer!!

_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
eywong
DD-WRT User


Joined: 21 Jul 2010
Posts: 120
Location: USA

PostPosted: Mon Sep 24, 2018 5:12    Post subject: Asus RT-AC68U A1 Reply with quote
Router: Asus RT-AC68U (H/W Ver: A1)
Firmware: DD-WRT v3.0-r37015M kongac (09/23/18)
Previous: DD-WRT v3.0-r36840M kongac (09/03/18)
Kernel: Linux 4.4.157 #603 SMP Sun Sep 23 01:10:11 CEST 2018 armv7l
Previous: Linux 4.4.153 #598 SMP Mon Sep 3 22:38:12 CEST 2018 armv7l
Status: ok
Reset: no (ddup --flash-latest)
Errors: no
Uptime: 1:45

wl0: AP / NG-Mixed / Ch 11
Channel Width: 20 MHz
wl1: AP / AC/N-Mixed / Ch 52 + 54
Channel Width: Wide VHT80 (80 MHz)
Extension Channel: lower lower
DHCP Server: Enabled - Running
Static Leases: 4 hardwired NAS, 1 wireless printer
NTP Client: Enable
Server IP/Name: us.pool.ntp.org
IPv6: Disable
@m0eb@
DD-WRT User


Joined: 26 Dec 2015
Posts: 289

PostPosted: Mon Sep 24, 2018 13:02    Post subject: Re: R6400 v2 with Board xxx30 Reply with quote
@m0eb@ wrote:
Router: R6400V2 with board xxx30
Firmware: DD-WRT v3.0-r37015M kongac (09/23/18 )
Kernel: Linux 4.4.157 #603 SMP Sun Sep 23 01:10:11 CEST 2018 armv7l
Status: OK
Reset: No (Direct browser upgrade from 36840 to dd-wrt.v24-K3_AC_ARM_STD_128K.bin without reset)
Errors: None. All functions that I use appear normal. Wifi-Analyzer shows steady signals of expected height.
Uptime (while posting this): 45 minutes
Other Points:
1. 5 GHz SSID seems to transmit a stronger signal. I have a room where the 5 GHz signal never showed up on WiFi Analyzer in the past. Now it pops a small signal head (a bit unstable at the far-end room - but mostly there)
2. Checked via my repeater-bridge (E900 on 36698). No Issues


I had another bout of "internet lost" with this build ... something which I experienced earlier with the 36995.
https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1141898#1141898
I do not have these issues with Kong's 36840 (have tested over extended periods > 3 days), but faced this 3 times in 36-38 hours with 36695, 1 time in 13 hours with this build. I am now back to 36840 now after having to do yet another NMRP.

I see two scenarios here...
a) I am an expert at doing something wrong multiple times (likely - because I have little knowledge and that's more risky than having no knowledge)
OR
b) Some change made between release of 36840 and this build is causing this issue.

Would be glad to run commands and report here if someone tells me what to do.

My config: 2.4 GHz is separated via br1 to a different subnet and isolated using firewall. I have OpenVPN on 5GHz, OpenDNS on 2.4GHz - and a policy routing to keep some IP addresses (including all LAN connections) free on both subnets.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 7265
Location: Netherlands

PostPosted: Mon Sep 24, 2018 14:39    Post subject: Reply with quote
Anything in syslog?
_________________
Routers:Netgear R7800, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000 (converted WRT320N), WRT54GS v1.
WireGuard Documents & Guides:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327397
OpenVPN Documents & Guides: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327398
IPSET: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=327261
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
@m0eb@
DD-WRT User


Joined: 26 Dec 2015
Posts: 289

PostPosted: Mon Sep 24, 2018 19:02    Post subject: Reply with quote
egc wrote:
Anything in syslog?

Oops!! Inexperience.

I did keep syslog on (one of the first things that I had done) - but guess that's erased now. Will load again over next weekend and report if something happens...
wabe
DD-WRT Guru


Joined: 17 Jun 2006
Posts: 785

PostPosted: Thu Sep 27, 2018 7:01    Post subject: Reply with quote
Router: Asus RT-AC68U (H/W Ver: A1)
Status: ok
Reset: no (ddup --flash-latest) + power cycle
Errors: no
Uptime: 2 days

Works very well as gateway. Samba, Openvpn and USB mounting
fully functional.

_________________
AC-68U rev. C1 on Build 45863
AC-68U rev. A1 on Build 45493
AC-68U rev. A1 on Build 44340
Wannabe
DD-WRT Novice


Joined: 29 Sep 2018
Posts: 1

PostPosted: Sat Sep 29, 2018 9:04    Post subject: Reply with quote
Router: Netgear r7000
Firmware: DD-WRT v3.0-r37015M kongac (23/09/2018 )
Status: back to v3.0-r36070M kongac Release: 05/31/18
Reset: no
Errors: Was unable to associate devices on second and third SSID for both 2,4G and 5G radios. Simple setup with wpa2-psk. I don't use other features than multi-SSID and VLAN bridges, so I don't know about any other issues.

Used ddup to flash latest and flash back, no reset in between, but tried to reset wpa2-psk passwords with no luck. After downgrade all works again.
james1795
DD-WRT User


Joined: 11 Jan 2011
Posts: 160

PostPosted: Sun Sep 30, 2018 19:28    Post subject: R8000 Reply with quote
Confirmed. I have tried a reset of the router after flashing and also it will not reboot using the webcli after flashing, leaving WPA2 once it reboot wireless clients are able to connect if it is changed then those wireless clients are not able to connect. I thought that WPA3 was suppose to be included in this build looking at the svn timeline that brainslayer included.
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1546
Location: WCentral Indiana USA

PostPosted: Sun Sep 30, 2018 19:54    Post subject: Re: R8000 Reply with quote
james1795 wrote:
I thought that WPA3 was suppose to be included in this build looking at the svn timeline that brainslayer included.

Apparently on some devices. @mrjcd reports it is included on ea8500 I believe but not included on my r7500 with near same hardware.

Edit: Not sure if @mrjcd was on <Kong> or BS.

_________________
STUBBY DoT install guide----Forum Guide Lines (Please read!) --- How to get help the right way----PIA Setup Guide by egc----
avenuekievua
DD-WRT Novice


Joined: 09 Oct 2014
Posts: 2

PostPosted: Mon Oct 01, 2018 14:21    Post subject: Reply with quote
Router: Asus RT-AC68U (H/W Ver: B1)
Status: ok
Reset: no
Errors: no
Uptime: 12 days

Works very well as gateway. Samba, Openvpn and USB mounting,ipv6 fully functional.

P.S.Is it possible in the following firmware in .config (northstar) the variable # CONFIG_I2C is not set to be changed to CONFIG_I2C = m, since when you connect a separately compiled i2c-core.ko nuclear variables __i2c_board_list, __ i2c_first_dynamic_bus_num, __i2c_board_loc unknown symbol.
And you can not load the module.
Thank you in advance.
_________________
AC-68U on Build 36820M
AC-68U on Build 37015M
Goto page 1, 2, 3  Next Display posts from previous:    Page 1 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum