New Build: 09-21-2018 - r37012

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page Previous  1, 2, 3  Next
Author Message
sonoranscout
DD-WRT Novice


Joined: 01 Jun 2017
Posts: 6

PostPosted: Tue Sep 25, 2018 4:53    Post subject: Reply with quote
Here you go:
OpenVPN 2.4.6 arm-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Sep 21 2018
library versions: OpenSSL 1.1.1 11 Sep 2018, LZO 2.09
Sponsor
spuriousoffspring
DD-WRT Guru


Joined: 05 Apr 2017
Posts: 982
Location: South of Heaven, USA

PostPosted: Tue Sep 25, 2018 4:58    Post subject: Reply with quote
https://www.openssl.org/

https://openvpn.net/index.php/open-source/documentation.html

_________________
DD-WRT Installation & Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=311117

WRT32X DD-WRT Installation Procedure
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569

IPVanish OpenVPN Client Setup TUTORIAL
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=308565

FIRMWARE: OpenWrt SNAPSHOT r8217-2cc821e / LuCI Master (git-18.276.41146-280dd33)
MODEM: ARRIS SURFBoard SB8200
ROUTER: Linksys WRT32X
USB NAS: Western Digital BLACK 1 TB Hardrive + Startech USB 3.0 External SATA III Enclosure
pmckay
DD-WRT Novice


Joined: 26 Aug 2006
Posts: 30
Location: Brooklyn, NY

PostPosted: Tue Sep 25, 2018 13:34    Post subject: Reply with quote
Sam1789 wrote:
Would someone please verify the OpenVPN and OpenSSL versions that are in this r37012 build.

CLI command "openvpn --version"

Thanks
Sam


root@DD-WRT:~# openvpn --version
OpenVPN 2.4.6 arm-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Sep 21 2018
library versions: OpenSSL 1.1.1 11 Sep 2018, LZO 2.09
Originally developed by James Yonan
Copyright (C) 2002-2018 OpenVPN Inc <sales@openvpn.net>
Compile time defines: enable_async_push=no enable_comp_stub=no enable_crypto=yes enable_crypto_ofb_cfb=yes enable_debug=
no enable_def_auth=yes enable_dlopen=unknown enable_dlopen_self=unknown enable_dlopen_self_static=unknown enable_eurephi
a=no enable_fast_install=yes enable_fragment=yes enable_iproute2=no enable_libtool_lock=yes enable_lz4=yes enable_lzo=ye
s enable_management=yes enable_multihome=yes enable_pam_dlopen=no enable_password_save=yes enable_pedantic=no enable_pf=
yes enable_pkcs11=no enable_plugin_auth_pam=no enable_plugin_down_root=no enable_plugins=no enable_port_share=yes enable
_selinux=no enable_server=yes enable_shared=yes enable_shared_with_static_runtimes=no enable_small=no enable_static=yes
enable_strict=no enable_strict_options=no enable_systemd=no enable_werror=no enable_win32_dll=yes enable_x509_alt_userna
me=no with_aix_soname=aix with_crypto_library=openssl with_gnu_ld=yes with_mem_check=no with_sysroot=no

_________________
Linksys WRT1900AC V1
wiseheart
DD-WRT Novice


Joined: 24 Apr 2015
Posts: 1

PostPosted: Wed Sep 26, 2018 19:55    Post subject: WRT32x (Issues with OpenVPN Server) Reply with quote
Router/Version: Linksys WRT32X
Firmware: DD-WRT v3.0-r37012 std ( 09/21/18 )
Kernel: Linux 4.9.128 #424 SMP PREEMPT Fri Sep 21 01:44:31 CEST 2018 armv7l
Previous: DD-WRT v3.0-r36995 std ( 09/19/18 )
Mode: Access Point (AP, not using IPv6, OpenVPN Server, NAS via USB)
Reset: NO reset during firmware upgrade


Issues/Errors:

1. OpenVPN Server is not working
Before I was using Buffalo wzr-hp-g300nh2 and the same vpn config was running okay.


2. ath2 TX Power 0 dBm, Rate 78 Mb/s (poor)

TX Antenna Chains 1 ( only 1)
RX Antenna Chains 1 ( only 1)

3. empty messages log

-rw-r--r-- 1 root root 0 Jan 1 1970 /var/log/messages
MLandi
DD-WRT User


Joined: 04 Dec 2007
Posts: 312

PostPosted: Thu Sep 27, 2018 12:40    Post subject: Reply with quote
Upgraded to

Firmware: DD-WRT v3.0-r37012 std (09/21/1Cool

on a WRT1900ACv2. No problems at all
Sam1789
DD-WRT User


Joined: 14 Oct 2016
Posts: 320

PostPosted: Thu Sep 27, 2018 18:49    Post subject: Reply with quote
@pmckay,

Thanks for running that CLI command.

Nice to know that this build r37012 has the latest OpenVPN (2.4.6) & OpenSSL (1.1.1) builds in it.

Now to get the VPN services to use the right defaults at their end for the LZO setting and the router attacks like the recent Voracle style attack series will be blocked. IPVanish is dealing with it now, PIA solved it earlier; not sure about Nord or other VPN services.

regards,
Sam

_________________
multi-tier router stack
wrt 3200's for speed & cpu power, NG R6300v2's for WiFi AP's,
wrt 1200v2 for one of my secure subnets.
wrt54GLs for ad'l 3rd tier machines.
apvm
DD-WRT User


Joined: 13 May 2012
Posts: 156

PostPosted: Sun Sep 30, 2018 14:59    Post subject: Reply with quote
Unable to flash this build, after reboot still Linksys firmware. WRT1900AC V2
Sam1789
DD-WRT User


Joined: 14 Oct 2016
Posts: 320

PostPosted: Sun Sep 30, 2018 19:07    Post subject: Reply with quote
apvm,

I'd suggest that you try doing an upgrade from an earlier dd-wrt build, instead of doing the factory dd-wrt for these newer builds. Some people have reported issues with recent factory-dd-wrt installs.

Build r35531 for instance might be a good first dd-wrt build to start with. Then use upgrade to go to either of the two new builds r36995 or 37012.

That has worked decently well for me - Except for the backup page which now contains undocumented changes since r360xx. What a pain that was/is. But that's unrelated to your issue.

btw, assuming that the r35531 build works well with your 1900, I'd also suggest leaving that r35531 build in one partition & putting any newer build into the other partition. Nothing useful with the LS FW.

hth

_________________
multi-tier router stack
wrt 3200's for speed & cpu power, NG R6300v2's for WiFi AP's,
wrt 1200v2 for one of my secure subnets.
wrt54GLs for ad'l 3rd tier machines.
apvm
DD-WRT User


Joined: 13 May 2012
Posts: 156

PostPosted: Sun Sep 30, 2018 19:31    Post subject: Reply with quote
Sam1789 wrote:
apvm,

I'd suggest that you try doing an upgrade from an earlier dd-wrt build, instead of doing the factory dd-wrt for these newer builds. Some people have reported issues with recent factory-dd-wrt installs.

Build r35531 for instance might be a good first dd-wrt build to start with. Then use upgrade to go to either of the two new builds r36995 or 37012.

That has worked decently well for me - Except for the backup page which now contains undocumented changes since r360xx. What a pain that was/is. But that's unrelated to your issue.

btw, assuming that the r35531 build works well with your 1900, I'd also suggest leaving that r35531 build in one partition & putting any newer build into the other partition. Nothing useful with the LS FW.

hth


Thanks for the input, I'll try to find an older LS FW to see if it works for flashing ddwrt since I like to keep LS FW on Part 1 for the purpose of switching between DDWRT, LEDE and Gargoyle.
Sam1789
DD-WRT User


Joined: 14 Oct 2016
Posts: 320

PostPosted: Sun Sep 30, 2018 21:27    Post subject: Reply with quote
apvm,

It is not immediately apparent that you can do what I suggested and still hold onto an LS FW in one partition.

You will have to "byte the bullet" so to speak and go with dd-wrt on both partitions, in order to upgrade from dd-wrt. I think there are posts that will tell you how to revert back to an LS FW from dd-wrt, though.

_________________
multi-tier router stack
wrt 3200's for speed & cpu power, NG R6300v2's for WiFi AP's,
wrt 1200v2 for one of my secure subnets.
wrt54GLs for ad'l 3rd tier machines.
apvm
DD-WRT User


Joined: 13 May 2012
Posts: 156

PostPosted: Mon Oct 01, 2018 14:01    Post subject: Reply with quote
Sam1789 wrote:
apvm,

It is not immediately apparent that you can do what I suggested and still hold onto an LS FW in one partition.

You will have to "byte the bullet" so to speak and go with dd-wrt on both partitions, in order to upgrade from dd-wrt. I think there are posts that will tell you how to revert back to an LS FW from dd-wrt, though.


Thanks, the reason I wanted to upload ddwrt is to find out if a problem is related to the firmware I am using LEDE.

The problem is my internet connection is fine but recently clients will not have internet access within a day sometimes in minutes (router wan status is still connected), need to reboot router and it will be fine again. Just wanted to make sure if it was the firmware or the router is dying since my backup asus router has no problem. Thanks again.
AmesJainchill
DD-WRT Novice


Joined: 10 Aug 2017
Posts: 37
Location: MI, USA

PostPosted: Tue Oct 02, 2018 1:41    Post subject: Reply with quote
Sam1789 wrote:


Now to get the VPN services to use the right defaults at their end for the LZO setting and the router attacks like the recent Voracle style attack series will be blocked. IPVanish is dealing with it now, PIA solved it earlier; not sure about Nord or other VPN services.


Current status as far as I can see with regards to ExpressVPN.. Sounds like they worked around it with their apps, but still working on it with manual configs..

https://www.expressvpn.com/blog/expressvpn-fix-voracle-compression-vulnerability/

_________________
WRT3200ACM 1st Gen
DD-WRT v3.0-r33986 (12/04/17) std - SVN rev: 33986
Motorola MB8600
Comcast 600/20
ExpressVPN OpenVPN Client Manual Config
NAS and miniDLNA: 4TB Seagate USB3
apvm
DD-WRT User


Joined: 13 May 2012
Posts: 156

PostPosted: Wed Oct 03, 2018 1:18    Post subject: Reply with quote
Sam1789 wrote:
apvm,

It is not immediately apparent that you can do what I suggested and still hold onto an LS FW in one partition.

You will have to "byte the bullet" so to speak and go with dd-wrt on both partitions, in order to upgrade from dd-wrt. I think there are posts that will tell you how to revert back to an LS FW from dd-wrt, though.


r35531 success but can not update to r37012, stuck at 1% and reboot goes back to r35531. I gave up.
Sam1789
DD-WRT User


Joined: 14 Oct 2016
Posts: 320

PostPosted: Wed Oct 03, 2018 1:40    Post subject: Reply with quote
apvm wrote:
Sam1789 wrote:
apvm,

It is not immediately apparent that you can do what I suggested and still hold onto an LS FW in one partition.

You will have to "byte the bullet" so to speak and go with dd-wrt on both partitions, in order to upgrade from dd-wrt. I think there are posts that will tell you how to revert back to an LS FW from dd-wrt, though.


r35531 success but can not update to r37012, stuck at 1% and reboot goes back to r35531. I gave up.


Did you do a clean install? You will want to do that and also disconnect the router from your system = the Wan from the internet just to keep things simpler. Clean install = erase the nvram ie check the box on the dd-wrt upgrade page.

And probably a good idea to save a list of the settings from your working 35531 version = text or excel file.

do a hard reboot after the upgrade completes & enter your settings in stages.

hth
Sam

_________________
multi-tier router stack
wrt 3200's for speed & cpu power, NG R6300v2's for WiFi AP's,
wrt 1200v2 for one of my secure subnets.
wrt54GLs for ad'l 3rd tier machines.
apvm
DD-WRT User


Joined: 13 May 2012
Posts: 156

PostPosted: Wed Oct 03, 2018 11:29    Post subject: Reply with quote
Sam1789 wrote:
apvm wrote:
Sam1789 wrote:
apvm,

It is not immediately apparent that you can do what I suggested and still hold onto an LS FW in one partition.

You will have to "byte the bullet" so to speak and go with dd-wrt on both partitions, in order to upgrade from dd-wrt. I think there are posts that will tell you how to revert back to an LS FW from dd-wrt, though.


r35531 success but can not update to r37012, stuck at 1% and reboot goes back to r35531. I gave up.


Did you do a clean install? You will want to do that and also disconnect the router from your system = the Wan from the internet just to keep things simpler. Clean install = erase the nvram ie check the box on the dd-wrt upgrade page.

And probably a good idea to save a list of the settings from your working 35531 version = text or excel file.

do a hard reboot after the upgrade completes & enter your settings in stages.

hth
Sam


Flashed from Linksys stock firmware r35531 success, only changed password and then flash r37012 from r35531, 1% and after 300 seconds, reboot the linksys back to r35531 and the other part still Linksys firmware.

Tried what you recommended above, no luck.
Goto page Previous  1, 2, 3  Next Display posts from previous:    Page 2 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum