New Build - 09/19/2018 - r36995

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2  Next
Author Message
Handyone
DD-WRT User


Joined: 18 Sep 2014
Posts: 154

PostPosted: Wed Sep 19, 2018 14:54    Post subject: New Build - 09/19/2018 - r36995 Reply with quote
New Build - 09/19/2018 - r36995

ftp://ftp.dd-wrt.com/betas/2018/09-19-2018-r36995/

Please report errors on this topic.


Release Notes:
http://svn.dd-wrt.com/timeline
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=279466


Router Model:

Status:
Reset:
Errors:
Sponsor
msoengineer
DD-WRT Guru


Joined: 21 Jan 2017
Posts: 1415
Location: Illinois Moderator

PostPosted: Wed Sep 19, 2018 15:38    Post subject: Reply with quote
R9000 X10

Upgraded in Incognito mode w/o reset

Looks like we now have WPA3 options.... not presently using it.

Running the Multi-cast fix, and did not attempt to see if code is necessary or not. ticket 6319 is still open...

All else seems normal.
ramblin
DD-WRT User


Joined: 03 Nov 2015
Posts: 157
Location: Florida, USA

PostPosted: Wed Sep 19, 2018 17:47    Post subject: Reply with quote
Router:TP Link Archer C7 Ver.2 (US) WDS AP
Firmware: DD-WRT v3.0-r36995 std ( 09/19/18 )
Kernel:Linux 3.18.122 #22292 Wed Sep 19 04:56:13 CEST 2018 mips
Reset: NO
Errors: NONE

Router:TP Link TL-WR841ND Ver.9 WDS Stations (x2)
Firmware:DD-WRT v3.0-r36995 std ( 09/19/18 )
Kernel:Linux 3.18.122 #22274 Wed Sep 19 04:36:33 CEST 2018 mips
Reset: NO
Errors: NONE

Upgraded GUI from r36330 with no issues. Most builds run well for me anyway as I don`t use QOS, 5 GHz or a VPN.
Logs are clean too !!
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5358
Location: Texas

PostPosted: Wed Sep 19, 2018 18:46    Post subject: Reply with quote
Linksys EA8500
DD-WRT v3.0-r36995 std {09/19/18}
Linux 4.9.128-rc1 #157 SMP PREEMPT Tue Sep 18 10:43:01 CEST 2018 armv7l
No Reset--GUI install over r36895
some static leases on main & VLAN clients
local DNS
samba share
ovpn server
VAPs on both radio + one port VLAN via br1
HFSC FQ_CODEL on 50/50 fiber line
http://www.dslreports.com/speedtest/39131053

everything working ok
-----------

EA8500
No Reset--GUI install over Kong_r36870M
switch + VLAN + samba share + ovpn server
everything working ok
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5358
Location: Texas

PostPosted: Wed Sep 19, 2018 19:35    Post subject: Reply with quote
Linksys WRT160NL
DD-WRT v3.0-r36995 std ({09/19/18}
Linux 3.10.108-d5 #64113 Wed Sep 19 03:38:15 CEST 2018 mips
No Reset--GUI install over r36808M
switch + samba share + ovpn server
all good

EDIT: Required a power cycle on this unit.


Last edited by mrjcd on Wed Sep 19, 2018 20:00; edited 2 times in total
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7381
Location: YWG, Canada

PostPosted: Wed Sep 19, 2018 19:43    Post subject: Reply with quote
Router Model: dir-862L, dir-862L, wndr4300, r7800

Status: it runs.. with complete dogshit latency on ipq806x k4.x
Reset: no
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5279
https://svn.dd-wrt.com/ticket/5600
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5817
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5875
https://svn.dd-wrt.com/ticket/5913
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/5992
https://svn.dd-wrt.com/ticket/6036
https://svn.dd-wrt.com/ticket/6059
https://svn.dd-wrt.com/ticket/6113 *
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6214
https://svn.dd-wrt.com/ticket/6229
https://svn.dd-wrt.com/ticket/6275
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6319 *
https://svn.dd-wrt.com/ticket/6442
https://svn.dd-wrt.com/ticket/6443

before
https://www.dslreports.com/speedtest/39111523
https://www.dslreports.com/speedtest/39033779

after
https://www.dslreports.com/speedtest/39134766
https://www.dslreports.com/speedtest/39134681

complete lagfest shit. cant even get a decently flat download line let alone proper latency. bs build, that STILL doesnt have pie back in it... adm_dma is going nuts with interrupts, surely thats got something to do with this poor qos.

idk maybe k10.0 in a century will finally return proper latency. guess i return to endlessly searching through switches and other routers with different firmwares with functioning qos that doesnt add latency, has proper rate limiting, service/port priorities, while not costing both kidneys, piece of cake.

wpa3 is missing from some routers like dir-862L for some reason. wpa3 doesnt work on r7800, dont know if thats ddwrt issue or devices need os/driver updates or if new hardware is needed, wont report that yet. anything good about this build? wifi noise and signal values are fixed, thats it.

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r44849 std
[QUALCOMM] DIR-862L --------------------------------> r44849 std
[QUALCOMM] WNDR4300 v1 --------------------------> r44849 std
[QUALCOMM] DIR-862L --------------------------------> r44849 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------------------------> r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..


Last edited by tatsuya46 on Wed Sep 19, 2018 20:10; edited 1 time in total
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5358
Location: Texas

PostPosted: Wed Sep 19, 2018 19:58    Post subject: Reply with quote
Netgear WNDR3700 V4
DD-WRT v3.0-r36995 std {09/19/18}
Linux 3.18.122 #22308 Wed Sep 19 05:25:25 CEST 2018 mips
No Reset--GUI install over r36808M
switch + samba share + ovpn server
all good
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1464
Location: WCentral Indiana USA

PostPosted: Wed Sep 19, 2018 21:26    Post subject: Reply with quote
Router Model Buffalo WZR-HP-AG300H
Firmware Version DD-WRT v3.0-r36995 std 09/19/18
Kernel Version Linux 3.10.108-d5 #64093
Previous 36808
Errors none at all
WDS STA Both radios working
No WPA3 Do not care won't use it
Looks good

_________________
STUBBY DoT install guide----Forum Guide Lines (Please read!) --- How to get help the right way----Reports
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Wed Sep 19, 2018 21:30    Post subject: Reply with quote
tatsuya46 wrote:
Router Model: dir-862L, dir-862L, wndr4300, r7800

Status: it runs.. with complete dogshit latency on ipq806x k4.x
Reset: no
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5279
https://svn.dd-wrt.com/ticket/5600
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5817
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5875
https://svn.dd-wrt.com/ticket/5913
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/5992
https://svn.dd-wrt.com/ticket/6036
https://svn.dd-wrt.com/ticket/6059
https://svn.dd-wrt.com/ticket/6113 *
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6214
https://svn.dd-wrt.com/ticket/6229
https://svn.dd-wrt.com/ticket/6275
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6319 *
https://svn.dd-wrt.com/ticket/6442
https://svn.dd-wrt.com/ticket/6443

before
https://www.dslreports.com/speedtest/39111523
https://www.dslreports.com/speedtest/39033779

after
https://www.dslreports.com/speedtest/39134766
https://www.dslreports.com/speedtest/39134681

complete lagfest shit. cant even get a decently flat download line let alone proper latency. bs build, that STILL doesnt have pie back in it... adm_dma is going nuts with interrupts, surely thats got something to do with this poor qos.

idk maybe k10.0 in a century will finally return proper latency. guess i return to endlessly searching through switches and other routers with different firmwares with functioning qos that doesnt add latency, has proper rate limiting, service/port priorities, while not costing both kidneys, piece of cake.

wpa3 is missing from some routers like dir-862L for some reason. wpa3 doesnt work on r7800, dont know if thats ddwrt issue or devices need os/driver updates or if new hardware is needed, wont report that yet. anything good about this build? wifi noise and signal values are fixed, thats it.


Just for confirmation, speedtest was done with htb+fq_codel, right?

I'm currently looking at another test, that at least shows differences with the same build on two different types of ISP connections.

What result do you get with this test:

http://www.dslreports.com/tools/puma6

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7381
Location: YWG, Canada

PostPosted: Wed Sep 19, 2018 21:40    Post subject: Reply with quote
<Kong> wrote:
tatsuya46 wrote:
Router Model: dir-862L, dir-862L, wndr4300, r7800

Status: it runs.. with complete dogshit latency on ipq806x k4.x
Reset: no
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5279
https://svn.dd-wrt.com/ticket/5600
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5699
https://svn.dd-wrt.com/ticket/5817
https://svn.dd-wrt.com/ticket/5845
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5875
https://svn.dd-wrt.com/ticket/5913
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/5992
https://svn.dd-wrt.com/ticket/6036
https://svn.dd-wrt.com/ticket/6059
https://svn.dd-wrt.com/ticket/6113 *
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6214
https://svn.dd-wrt.com/ticket/6229
https://svn.dd-wrt.com/ticket/6275
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6319 *
https://svn.dd-wrt.com/ticket/6442
https://svn.dd-wrt.com/ticket/6443

before
https://www.dslreports.com/speedtest/39111523
https://www.dslreports.com/speedtest/39033779

after
https://www.dslreports.com/speedtest/39134766
https://www.dslreports.com/speedtest/39134681

complete lagfest shit. cant even get a decently flat download line let alone proper latency. bs build, that STILL doesnt have pie back in it... adm_dma is going nuts with interrupts, surely thats got something to do with this poor qos.

idk maybe k10.0 in a century will finally return proper latency. guess i return to endlessly searching through switches and other routers with different firmwares with functioning qos that doesnt add latency, has proper rate limiting, service/port priorities, while not costing both kidneys, piece of cake.

wpa3 is missing from some routers like dir-862L for some reason. wpa3 doesnt work on r7800, dont know if thats ddwrt issue or devices need os/driver updates or if new hardware is needed, wont report that yet. anything good about this build? wifi noise and signal values are fixed, thats it.


Just for confirmation, speedtest was done with htb+fq_codel, right?

I'm currently looking at another test, that at least shows differences with the same build on two different types of ISP connections.

What result do you get with this test:

http://www.dslreports.com/tools/puma6


yes cause bs removed pie, put it back in, then removed it again.. the k3.18 tests are htb+pie (hfsc+pie is identical too, fq_codel on all kernels is more throughput jittery than pie). puma 6 test WAS mostly good, i have the best modem our isp offers (all are puma 6, 1 is puma 7) so its mostly green, but now a few weeks ago something happened to routing to the dslr server in my city, 10ms became 30ms. it skews the test but its still mostly good. i think that test is flawed in that it doesnt consider latency jitter as much as actual value. if find a server where i have 95ms ~ 105ms to theres tons of orange and red and a fail. yet that jitter is excellent. meanwhile if u have a server u have 20ms ~ 105ms to, there will be much more green and it might even consider it a pass sometimes, when the latter example is bad latency.

before and after the routing change which forces me to another server, both on the same build your 36500m k3.18 and modem fw hasnt changed either since. the after routing image was done just now.

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r44849 std
[QUALCOMM] DIR-862L --------------------------------> r44849 std
[QUALCOMM] WNDR4300 v1 --------------------------> r44849 std
[QUALCOMM] DIR-862L --------------------------------> r44849 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------------------------> r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..


Last edited by tatsuya46 on Wed Sep 19, 2018 21:51; edited 1 time in total
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Wed Sep 19, 2018 21:50    Post subject: Reply with quote
Puma test ist interesting, same build did not show an issue on the R7800 at work with the same build, but at home max ping was around 100ms in this test. Thus was able to reproduce it and fix it:-)

Obviously MTU size played a role here and triggered the bug. I think just like the hwspinlock issue this issue came in when BS merged in openwrt patches.

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1301

PostPosted: Wed Sep 19, 2018 21:56    Post subject: Reply with quote
<Kong> wrote:
Puma test ist interesting, same build did not show an issue on the R7800 at work with the same build, but at home max ping was around 100ms in this test. Thus was able to reproduce it and fix it:-)

Obviously MTU size played a role here and triggered the bug. I think just like the hwspinlock issue this issue came in when BS merged in openwrt patches.


Freaking awesome! Can't wait for the updated build
<Kong>
DD-WRT Guru


Joined: 15 Dec 2010
Posts: 4339
Location: Germany

PostPosted: Wed Sep 19, 2018 22:10    Post subject: Reply with quote
jerrytouille wrote:
<Kong> wrote:
Puma test ist interesting, same build did not show an issue on the R7800 at work with the same build, but at home max ping was around 100ms in this test. Thus was able to reproduce it and fix it:-)

Obviously MTU size played a role here and triggered the bug. I think just like the hwspinlock issue this issue came in when BS merged in openwrt patches.


Freaking awesome! Can't wait for the updated build


Guess I cheered to early, right after boot it was fine and now again, shitty. Still interesting that it only shows on the ADSL line, where my R7000 delivers perfect results.

Anyways this is something I can work with.

_________________
KONG PB's: http://www.desipro.de/ddwrt/
KONG Info: http://tips.desipro.de/
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7381
Location: YWG, Canada

PostPosted: Wed Sep 19, 2018 22:20    Post subject: Reply with quote
<Kong> wrote:
jerrytouille wrote:
<Kong> wrote:
Puma test ist interesting, same build did not show an issue on the R7800 at work with the same build, but at home max ping was around 100ms in this test. Thus was able to reproduce it and fix it:-)

Obviously MTU size played a role here and triggered the bug. I think just like the hwspinlock issue this issue came in when BS merged in openwrt patches.


Freaking awesome! Can't wait for the updated build


Guess I cheered to early, right after boot it was fine and now again, shitty. Still interesting that it only shows on the ADSL line, where my R7000 delivers perfect results.

Anyways this is something I can work with.


check the adm_dma interrupts, they are like tripled that of wan. on k3.18 they are much lower, doesnt seem right.

edit: nevermind

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r44849 std
[QUALCOMM] DIR-862L --------------------------------> r44849 std
[QUALCOMM] WNDR4300 v1 --------------------------> r44849 std
[QUALCOMM] DIR-862L --------------------------------> r44849 std
▲ ACTIVE / INACTIVE ▼
[BROADCOM] DIR-860L A1 ----------------------------> r44583 std


If you use DSLReports please enable hi-res bufferbloat.


Sigh.. why do i exist anyway..
dasnick
DD-WRT User


Joined: 23 Jul 2009
Posts: 69

PostPosted: Thu Sep 20, 2018 7:50    Post subject: Reply with quote
Router Name1043ndv3
Router ModelTP-Link WR1043ND V3
Firmware Version DD-WRT v3.0-r36995 std (09/19/1Cool
Kernel VersionLinux 3.18.122 #22286 Wed Sep 19 04:47:34 CEST 2018 mips


Working as a powerline bridged AP.
upgrade via GUI with no reset.
Seems to be working fine.
No WPA3 (not sure if should be there)
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum