Trouble with Linksys E1200 V2

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
Dragnet
DD-WRT Novice


Joined: 22 Oct 2019
Posts: 3

PostPosted: Fri Oct 25, 2019 7:39    Post subject: Trouble with Linksys E1200 V2 Reply with quote
Hi all. I am new to the forum. I am having trouble connecting up a Linksys E1200 V2 router. I am new to this, 5 days ago I knew nothing of GUI and 30-30-30.I have read the peacock thread and when I uploaded my dd-wrt firm ware I probably did more hard resets than required and also waiting 2 to 3 times longer than required before proceeding between steps. Apologies for using the wrong terminologies, I have uploaded the 33986 firmware as that is what was on the installation guide I am using to connect a router to my VPN provider PIA. It looks like its all installed correctly but I cannot connect to my VPN provider. One thing I noticed is that I get the same data in the VPN logs whether or not my router is plugged into my ISP modem. Is there a way to test if my ISP is blocking a connection to a VPN? If I plug my laptop into the modem port it works fine. I have used both straight and crossover cables. VLANs are set as per thread in this forum so the ports on my router are all working. One other thing I cannot set the time on the router. I have tried doing it automatically using pool.ntp.org and also entering manually using the date command, it is always 1970. Does that indicate my firmware upload was corrupted?
I would be grateful for any suggestions. Have done some trouble shooting with PIA but we seem to have hit a wall.
One other thing , just going through my normal wireless ISP access I can ping the PIA servers ok.
Thank you.
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4705
Location: Netherlands

PostPosted: Fri Oct 25, 2019 8:45    Post subject: Re: Trouble with Linksys E1200 V2 Reply with quote
Dragnet wrote:
Hi all. I am new to the forum. I am having trouble connecting up a Linksys E1200 V2 router. I am new to this, 5 days ago I knew nothing of GUI and 30-30-30.I have read the peacock thread and when I uploaded my dd-wrt firm ware I probably did more hard resets than required and also waiting 2 to 3 times longer than required before proceeding between steps. Apologies for using the wrong terminologies, I have uploaded the 33986 firmware as that is what was on the installation guide I am using to connect a router to my VPN provider PIA. It looks like its all installed correctly but I cannot connect to my VPN provider. One thing I noticed is that I get the same data in the VPN logs whether or not my router is plugged into my ISP modem. Is there a way to test if my ISP is blocking a connection to a VPN? If I plug my laptop into the modem port it works fine. I have used both straight and crossover cables. VLANs are set as per thread in this forum so the ports on my router are all working. One other thing I cannot set the time on the router. I have tried doing it automatically using pool.ntp.org and also entering manually using the date command, it is always 1970. Does that indicate my firmware upload was corrupted?
I would be grateful for any suggestions. Have done some trouble shooting with PIA but we seem to have hit a wall.
One other thing , just going through my normal wireless ISP access I can ping the PIA servers ok.
Thank you.


First you should make sure your E1200 has a valid connection without the VPN working.
The date 1970 indicate that the time server is not working, probably because the router is not connected to the internet.

I assume you have an ISP router with wifi.
Reset the E1200 to defaults in the GUI
Connect the E1200 with a cable from its WAN port tot a LAN port of your ISP's modem.

Connect client to E1200 normally you should have internet access there is one exception that is if the ISP router has the same IP address as your E1200.
So if you do not have internet access change the IP address of the E1200 from 192.168.1.1. to 192.168.2.1
Change at Setup/Basic Setup: Local IP Address

That should work.

You are using a fairly old build but keep it at that for the moment unless someone else has a better idea
(I have an E2000 which works OK with 41328: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321699&highlight=41328, but you have to research if those two are comparable. I use the K3X builds, some K2.6 builds are broken, but the latest should work)

For completeness en excerpt of some rules:

1. Read the forum rules: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=54959 .
2. Read this: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=54845 .
3. Research your router, start with the supported devices wiki:
https://wiki.dd-wrt.com/wiki/index.php/Supported_Devices .
4. In the supported devices wiki you can see what architecture your router has and if you are lucky also an install guide/wiki.
5. Post in the right forum, from the former step you can see if your router is Broadcom, Qualcomm/Atheros, Marvell or other, use that forum to post router specific questions, for networking questions post in the Advanced Networking forum and for other things in the General Questions forum.
6. When posting always state router model, build number and when applicable the Kernel version.
7. Do NOT use the router database, builds can be found at:
https://dd-wrt.com/support/other-downloads/?path=betas%2F2019%2F
8. For older Broadcom routers (Linksys WRT series) read the peacock thread although some of it is outdated: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=51486&sid=05c269e8bc745f300278d04f3b742a98
Builds can be found in the Broadcom directory for Linux kernel 2.4 in Broadcom_K26 for Linux K2.6 and in Broadcom_K3X for Linux K3.X.
9. Before uploading a new build research the build by looking in the build threads.
This is an example of a build thread for build 41328 for Broadcom routers:
https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321699&highlight=41328
Search build threads with the search function and search on build number.
10. Use the build threads from the former step to report success or problems.
11. If you are sure you have discovered a bug, after asking and querying the forum, you can report a real bug in the bug tracker: https://svn.dd-wrt.com/

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Dragnet
DD-WRT Novice


Joined: 22 Oct 2019
Posts: 3

PostPosted: Fri Oct 25, 2019 11:35    Post subject: Reply with quote
Thank you for the fast response.
Did the factory reset and everything worked.
Re did the setup from the PIA guide and it stopped working.
Went back and used the default gateway and WAN IP address and it works again. Theres one small glitch with it not connecting after a power bump but I shall do a bit more research into it. Now I know it will work I will invest in a better router.
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 4705
Location: Netherlands

PostPosted: Fri Oct 25, 2019 12:04    Post subject: Reply with quote
Their instructions should normally work:
https://www.privateinternetaccess.com/helpdesk/guides/routers/dd-wrt-3/dd-wrt-openvpn-setup-2

I use PIA myself

Note: After setting up always reboot

But it is perhaps a good idea to invest in a better router as the max speed you will get out of this router when using VPN is around 5 Mb/s

The best Value for Money Netgear R7800(just my personal opnion) cheaper but less powerfull Netgear R6400v2 or R7000.

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Wireguard Setup guide:https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183135
Dragnet
DD-WRT Novice


Joined: 22 Oct 2019
Posts: 3

PostPosted: Sat Oct 26, 2019 11:17    Post subject: Reply with quote
Thanks for the tip, I will definitely upgrade now I know it works. And thanks again for the advice above.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum