New Build - 03-05-2020-r42617

Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware
Goto page 1, 2, 3, 4  Next
Author Message
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1304

PostPosted: Thu Mar 05, 2020 12:10    Post subject: New Build - 03-05-2020-r42617 Reply with quote
New Build - 03-05-2020-r42617

https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/03-05-2020-r42617/
ftp://ftp.dd-wrt.com/betas/2020/03-05-2020-r42617/

Please report errors on this topic.


Release Notes:
http://svn.dd-wrt.com/timeline


Router Model:

Status:
Reset:
Errors:
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 13113
Location: Texas, USA

PostPosted: Thu Mar 05, 2020 12:47    Post subject: Reply with quote
WARNING: DO NOT flash this experimental test build unless you know the risks and recovery methods. Report here to provide important info for developers and users. Always state your hardware model & version, mode (e.g. Repeater) and SPECIFIC build (e.g. netgear-r7000-webflash). Avoid discussions and create a new thread for specific problems or questions as this thread is not for support, and posts may be deleted or moved.

Downloads: if a link does not work, try another (alternative @DD-WRT website)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/03-05-2020-r42617/
ftp://ftp.dd-wrt.com/betas/2020/03-05-2020-r42617/
Note: for wget (or curl) with CLI flash (`write {f/w} linux`), change the https to http, use `curl -k {link} -o {file}`, or ftp

Changelogs:
SVN* changelog since last build: 42602
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Important: if reporting any issues, provide applicable info (GUI syslog, `dmesg`, `cat /var/log/messages`, etc.)
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Issues, observations, and/or workarounds reported:
1. DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use (without entware): 6246

Notes:
1. SFE accelerated NAT is in 33006+ builds but only in kernel 3.2 and newer
2. 'KRACK' vulnerability fixes were completed in r33555 for non-Broadcom.
3. PBR/UDP with SFE working again since r40513 (see 6729)
4. CAKE scheduler changes "completed" with r41057 (see 5796) & FQ_CODEL_FAST with r41027 (reset first!)
5. Reset button was broken in 40571; fixed in build 40750.
6. CVE-2019-14899 VPN fix (r41784: applicability depends on VPN setup) and GUI toggle (r41812): ticket 6920, 6928, 6931, 6932
7. In-kernel samba now used and default min/max versions have changed, so change them if needed: 6954, 6957
8. EA8500 w/u-boot 1.0.12 switch reset/network failure on soft reboot fixed: 6467

Template example to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b][u]Router/Version:[/u][/b]
[b]Mode: [/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Status: [/b]

_________________
"Life is but a fleeting moment, a vapor that vanishes quickly; All is vanity"
Contribute To DD-WRT
Pogo - A minimal level of ability is expected and needed...
At some point, people just get plain tired of this place.
Because they are tired of bottom-feeders and the same old hat.

----------------------
Linux User #377467 counter.li.org / linuxcounter.net
mrjcd
DD-WRT Guru


Joined: 31 Jan 2015
Posts: 5947
Location: Texas

PostPosted: Thu Mar 05, 2020 13:16    Post subject: Reply with quote
Linksys EA8500
DD-WRT v3.0-r42617 std (03/05/20)
Linux 4.9.215 #521 SMP Mon Mar 2 11:53:59 +03 2020 armv7l
GUI installed over r42607
all I use is good on this main gateway router
uptime 10:50

You EA8500 people with U-Boot ver 1.0.12 and have the problem with switch
not worky after simple reboot this build is reported to have FIXED that ...YaY!!!
Very Happy

#

Netgear WNDR3700 V4
DD-WRT v3.0-r42617 std (03/05/20)
Linux 3.18.140-d4 #72410 Thu Mar 5 04:42:04 +04 2020 mips
GUI installed over r42607
all I use is good
uptime 12:11
Bernadoe
DD-WRT User


Joined: 03 Dec 2014
Posts: 217

PostPosted: Thu Mar 05, 2020 14:28    Post subject: Reply with quote
Router: Netgear R7800
Firmware: DD-WRT v3.0-r42617 std (03/05/20)
Kernel: Linux 4.9.215 #521 SMP Mon Mar 2 11:53:59 +03 2020 armv7l
Status: Working
Reset: No
Previous: 42602
Errors: No

Temperatures : CPU 54.178 °C / ath0 50 °C / ath1 48 °C

Working very well :
Router mode : DHCP
SFE Enable
STP Enable
DNSMasq
Cache DNSSEC data
Validate DNS Replies (DNSSEC)
Check unsigned DNS replies
Local DNS
No DNS Rebind
ath0, ath1
Vpn (OpenVPN Client)

without VPN


with VPN


Last edited by Bernadoe on Sun Mar 08, 2020 7:25; edited 3 times in total
LSM
DD-WRT Novice


Joined: 08 Apr 2019
Posts: 13

PostPosted: Thu Mar 05, 2020 14:52    Post subject: Reply with quote
[quote="mrjcd"]Linksys EA8500
DD-WRT v3.0-r42617 std (03/05/20)
Linux 4.9.215 #521 SMP Mon Mar 2 11:53:59 +03 2020 armv7l
GUI installed over r42607
all I use is good on this main gateway router
uptime 10:50

You EA8500 people with U-Boot ver 1.0.12 and have the problem with switch
not worky after simple reboot this build is reported to have FIXED that ...YaY!!!
Very Happy

Confirmed!!! Three warm reboots in a row worked. At last I don't have to go downstairs 75% of the time to switch the EA8500 on and off because the warm reboot failed.

Thanks to all who contributed to the resolution of this minor, but very annoying, issue.

LSM
habeIchVergessen
DD-WRT User


Joined: 04 May 2010
Posts: 425

PostPosted: Thu Mar 05, 2020 16:29    Post subject: Reply with quote
hardware: ea8500
software: build 41813

after upgrade to 42617

solved:
switch initialization on soft reboot

issues:
doesn't execute scripts from startup command as described here

not tested issue:
cron jobs (here)

back on 41813
tatsuya46
DD-WRT Guru


Joined: 03 Jan 2010
Posts: 7535
Location: YWG, Canada

PostPosted: Thu Mar 05, 2020 17:17    Post subject: Reply with quote
Router Model: dir-862L(x2), wndr4300, r7800, x86_64

Status: well it runs..
Reset: no/yes no effect
Errors: see tickets below

https://svn.dd-wrt.com/ticket/5118 *
https://svn.dd-wrt.com/ticket/5225 *
https://svn.dd-wrt.com/ticket/5603 *
https://svn.dd-wrt.com/ticket/5848
https://svn.dd-wrt.com/ticket/5933
https://svn.dd-wrt.com/ticket/5938
https://svn.dd-wrt.com/ticket/6115 *
https://svn.dd-wrt.com/ticket/6286
https://svn.dd-wrt.com/ticket/6315
https://svn.dd-wrt.com/ticket/6481 *
https://svn.dd-wrt.com/ticket/6495 *
https://svn.dd-wrt.com/ticket/6555 *
https://svn.dd-wrt.com/ticket/6655
https://svn.dd-wrt.com/ticket/6842
https://svn.dd-wrt.com/ticket/6903 *
https://svn.dd-wrt.com/ticket/6921


huge description not currently needed, tickets say everything..

_________________
LATEST FIRMWARE(S)

BrainSlayer wrote:
we just do it since we do not like any restrictions enforced by stupid cocaine snorting managers

[x86_64] Haswell i3-4150/QCA9984/QCA9882 ------> r50963 std
[QUALCOMM] DIR-862L --------------------------------> r50963 std
[QUALCOMM] DIR-862L --------------------------------> r50963 std
▲ ACTIVE / INACTIVE ▼
[QUALCOMM] WNDR4300 v1 --------------------------> r50485 std
[BROADCOM] DIR-860L A1 ----------------------------> r50485 std


Sigh.. why do i exist anyway.. | I love you Anthony.. never forget that.. my other 99% that ill never see again..

egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10809
Location: Netherlands

PostPosted: Thu Mar 05, 2020 17:24    Post subject: Reply with quote
habeIchVergessen wrote:
hardware: ea8500
software: build 41813

after upgrade to 42617

solved:
switch initialization on soft reboot

issues:
doesn't execute scripts from startup command as described here

not tested issue:
cron jobs (here)

back on 41813


If you are starting from an USB stick you have to wait until the volume is mounted so before executing the script add:
sleep 30

_________________
Routers:Netgear R7800, R7000, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 10809
Location: Netherlands

PostPosted: Thu Mar 05, 2020 17:29    Post subject: Reply with quote
Router Model: Netgear R7800

Firmware Version: DD-WRT v3.0-r42617 std (03/05/20)
Kernel Version: Linux 4.9.215 #521 SMP Mon Mar 2 11:53:59 +03 2020 armv7l

Upgraded from: OpenWRT (my own build with 19.07.1 Smile )
Reset: Yes, nvram erase && reboot

Status: Up and running for 6 hours, basic setup as Gateway, static leases, OpenVPN client (on PIA) with Policy Based Routing up and running, 2,4GHz, 5Ghz, USB storage NAS and OpenVPN server working, Wireguard working.

Errors:
1. DNS leak see: http://svn.dd-wrt.com/ticket/6020

Otherwise build is fine

Resolved:
1. Pushed DNS servers from VPN provider are used starting with build 41120, if you do not want that, add the following to the Additional Config of the VPN client:
pull-filter ignore "dhcp-option DNS"
2. Build 41174 has an improved VPN Policy Based Routing, it is now possible to use the VPN route command i.e. to route a DNS server via the VPN (in this way you will get rid of the DNS leak), see: https://svn.dd-wrt.com/ticket/6815#comment:1 , and for DNS leaks the second posting of this thread: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318662
3. Another improvement on PBR is that local routes are now copied over to the alternate routing table so there is communication if you have unbridged VAP's and you can set the router's IP on PBR.
See: https://svn.dd-wrt.com/ticket/6821#comment:3
4. Starting with build 41174, the PBR has become more versatile, you can now use " from [IP address] to [IP address] ", so if you enter the following in the PBR field:
192.168.1.124 to 95.85.16.212 #ipleak.net, it will only route IP address 95.85.16.212 (which is ip leak.net) from my IP address 192.168.1.124 via the VPN everything else from this IP address will route via the WAN (this is just an example).
See: https://svn.dd-wrt.com/ticket/6822
Although this command itself supports routing per port this is however only available starting from K 4.17 so we have to rely on scripting for per port routing until then.
5. New OpenVPN TLS ciphers are added in 41308 see: https://svn.dd-wrt.com/changeset/41308
6. Starting with build 41304 you can now choose which TLS Key you want to use: TLS Auth or the newer/better TLS Crypt. See https://svn.dd-wrt.com/ticket/6845#comment:17
7. Builds from 41786 onwards, when using an OVPN server to connect to your local LAN clients, access might be prevented because of a patch which should solve a recent vulnerability ( see: https://svn.dd-wrt.com/ticket/6928)
This can be mitigated with the following firewall rule:
Code:
iptables -t nat -I POSTROUTING -o br0 -s $(nvram get openvpn_net)/$(nvram get openvpn_tunmask) -j MASQUERADE

When using WireGuard you can run into the same trouble,i.e. not being able to access your local LAN clients. For WireGuard this is the workaround:
Code:
iptables -t nat -I POSTROUTING -o br0 -s $(nvram get oet1_ipaddr)/$(nvram get oet1_netmask) -j MASQUERADE

This method described above also has security and logging concerns as all traffic has the same source address (your router)
An alternate method is using the following rule but it only works if the VPN or Wireguard interface is up and if your VPN or Wireguard interface goes down you have to reapply or run a continuous script checking/applying:
OpenVPN server:
Code:
iptables -t raw -I PREROUTING -i br0 -d $(nvram get openvpn_net)/$(nvram get openvpn_tunmask) -j ACCEPT

WireGuard:
Code:
iptables -t raw -I PREROUTING -i br0 -d $(nvram get oet1_ipaddr)/$(nvram get oet1_netmask) -j ACCEPT

This rule can expose your LAN side to the CVE attack, but if you have your IOT things separated and tight control over your LAN you should be good, if your LAN is hacked you have got bigger problems.

Builds starting with 41813 have an option button in OpenVPN and Wireguard for disabling the CVE-patch 14899


Big Thanks to BS!!

_________________
Routers:Netgear R7800, R7000, R6400v1, R6400v2, Linksys EA8500, EA6900 (XvortexCFE), E2000, E1200v1, WRT54GS v1.
Install guide R6400v2, R6700v3,XR300:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
Install guide R7800/XR500: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Forum Guide Lines (important read):https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=324087
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1765
Location: Canada

PostPosted: Thu Mar 05, 2020 22:25    Post subject: Reply with quote
Routers: 3x Netgear R7800

1) Gateway Router R7800
-DHCP WAN
-ISP IPv6 - Prefix Delegation for 5xVLANs via Dnsmasq
-7xVLANs + 7xBridges
-SSH -Custom Port & Key
-Telnet
-Syslog
-NTP server left blank
-QoS - Disabled
-TCP Congestion - bbr
-DDNS - Custom Script
-1xWireGuard
-Cron Jobs
-USB w/32GB USB3 Thumb Drive
-Entware DNSCrypt-Proxy V2 - IPv4/v6 Cisco Servers w/filtering
-YAMon3.4.6 w/Entware's ip-full for IPv6
-Custom Scripts
-Custom Startup,Shutdown,Firewall Scripts
-WiFi Disabled
-ttraff Disabled
-SFE Disabled

2) WiFi Router R7800
-Static WAN (double-NAT for 2xWireGuard & DNSCrypt-Proxy V2)
-8xVLANs + 8xBridges
-5xSSIDs-2xAPs+3xVAPs
-SSH -Custom Port & Key
-Telnet
-Syslog
-NTP server left blank
-TCP Congestion - bbr
-2xWireGuard
-Cron Job
-USB w/32GB USB3 Thumb Drive
-Entware DNSCrypt-Proxy V2 - IPv4 Quad9 Servers
-Custom Scripts
-Custom Startup,Shutdown,Firewall Scripts
-ttraff Disabled
-SFE Disabled

3) WireGuard Router R7800
-Static WAN (double-NAT for 3xWireGuard)
-5xVLANs + 5xBridges
-SSH -Custom Port & Key
-Telnet
-Syslog
-NTP server left blank
-TCP Congestion - bbr
-3xWireGuard
-Cron Job
-USB w/32GB USB3 Thumb Drive
-Custom Scripts
-Custom Startup,Firewall Scripts
-WiFi Disabled
-ttraff Disabled
-SFE Disabled


Firmware: DD-WRT v3.0-r42617 std (03/05/20) [from: DD-WRT v3.0-r42602 std (03/03/20)]
Linux Rel: Linux 4.9.215 #521 SMP Mon Mar 2 [from: same]
Reset: NO
Status & Uptime: Working over 4 hours
Issues/Fixes: High CPU Usage with QoS / Disabled

UPDATE Uptime: Over 91 Hours & Installed YAMon3.4.6 to Gateway Router over 38 Hours ago.

UPDATE2: Tweaking - Enabled 3rd R7800. Disabled QoS and testing ironstaff's tuning with changes to the Networking TX Queue Length from 1000 to 2. Uptimes have been reset after tweaking and manual reboot.

_________________
Home Network on Telus 1Gb PureFibre - 10GbE Copper Backbone
2x R7800 - Gateway & WiFi & 3xWireGuard - DDWRT r50963 Std
R7000 - Wired ISP 4K IPTV Gateway - DDWRT r50963 Std

Off Site 1

R7000 - Gateway & WiFi & WireGuard - DDWRT r50963 Std
E3000 - Station Bridge - DDWRT r49626 Mega K4.4

Off Site 2

R7000 - Gateway & WiFi - DDWRT r50963 Std
E2000 - Wired ISP IPTV PVR Blocker - DDWRT r35531


YAMon 3.4.6 | DNSCrypt-Proxy V2


Last edited by mac913 on Sat Mar 14, 2020 15:44; edited 9 times in total
blkt
DD-WRT Guru


Joined: 20 Jan 2019
Posts: 4585

PostPosted: Thu Mar 05, 2020 23:41    Post subject: Reply with quote
EA8500 CLI upgrade from 03-03-2020-r42602 to 03-05-2020-r42617 with no issues. Reboot after flash was flawless.

Thank you BrainSlayer for your very many efforts.
MLandi
DD-WRT Guru


Joined: 04 Dec 2007
Posts: 805

PostPosted: Fri Mar 06, 2020 1:42    Post subject: Reply with quote
SSH update, no issues, fast reboot. All features working as expected. Thanks BS!
_________________
Netgear R9000 X10
DD-WRT v3.0-r50963 std (11/28/22)
Gateway, AP, DNSMasq, Clock 2000MHz
VAP on wlan1 for internet devices
IPv4 & IPv6 (Prefix Delegation)
Static Leases & DHCP
CloudFlare, QoS Disabled, SmartDNS Disabled
2.4GHz: VANILLA Firmware, Airtime Fairness Enabled, NG-Mixed, ACK Timing 3150, WPA2 w/AES
5GHz: VANILLA Firmware, Airtime Fairness Enabled, AC/N Mixed, ACK Timing 3150, WPA2 w/AES
Xfinity 1.2Gbps/42Mbps
Ninjanoir78
DD-WRT User


Joined: 09 Feb 2019
Posts: 68
Location: Canada

PostPosted: Fri Mar 06, 2020 15:12    Post subject: Reply with quote
Router: Netgear R7800
Firmware: DD-WRT v3.0-r42617 std (03/05/20)
Kernel: Linux 4.9.215 #521 SMP Mon Mar 2 11:53:59 +03 2020 armv7l
Status: Working
Reset: No
Previous: 42335
Errors: No

Temperatures : CPU 50.80 °C / ath0 54 °C / ath1 47 °C

uptime: 8h
Working well after 2 reboots
Router mode : DHCP
SFE: disable
MasterGoa
DD-WRT User


Joined: 18 Jan 2019
Posts: 51

PostPosted: Fri Mar 06, 2020 18:17    Post subject: Reply with quote
Archer C7, V2 and V4, very snappy menu response, great overall experience.

I like that the wifi network light is now off when
a radio is turned off.
(V4 has only 5GHz on, 2,4GHz light was always on, now it stays off).
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1846
Location: WCentral Indiana USA

PostPosted: Fri Mar 06, 2020 20:08    Post subject: Reply with quote
BrainSlayer wrote:
bushant wrote:
R7800
CLI upgrade

The broadcom repeater won't connect to this 2.4GHZ.

R7500v2 WDS STATION
GUI upgrade

Will not connect to R7800 WDS AP.

Flash both back to 42478 for continued enjoyment.


fix your config. wds ap and wds sta is working. guaranteed


R7800 WDS AP
DD-WRT v3.0-r42617 std (03/05/20)
Linux 4.9.215 #521 SMP Mon Mar 2 11:53:59 +03 2020 armv7l
GUI upgrade over 42478
nvram erase+ manual config

R7500V2 WDS STA
CLI upgrade over 42478
nvram erase + manual config

WZR-HP-AG300H WDS STATION
CLI upgrade over 42287
No reset

WNDR3700V4 WDS STA
DD-WRT v3.0-r42617 std (03/05/20)
Linux 3.18.140-d4 #72410 Thu Mar 5 04:42:04 +04 2020 mips
CLI upgrade over 42078
No reset

BS is right wds ap and wds sta is working for everything except R7500V2.
All builds up to and including Feb-22 work fine. Feb-29 and later R7500 WDS STA will not connect to R7800 WDS AP with AC/N-Mixed 149 UU VHT80.

Tried NA-Mixed on all routers all connect except 7500V2.
Goto page 1, 2, 3, 4  Next Display posts from previous:    Page 1 of 4
Post new topic   Reply to topic    DD-WRT Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum