WRT32X Wifi Problems

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
WRT32X
DD-WRT Novice


Joined: 02 Apr 2020
Posts: 14

PostPosted: Wed Apr 08, 2020 8:12    Post subject: WRT32X Wifi Problems Reply with quote
Hi all,

I still have (and read a lot in this forum) Wifi issues.
Devices are get kicked out every few hours and when i try to connect them i receive the error: Wifi code in corrected.
Also in syslog i see errors coming every minute (errors about hostapd and deauthenticated due to inactivity (timer DEAUTH/REMOVE).

I read many try solutions but can this be fixed in the new builds?
And which build is error free, no Wifi problems, hostapd and deauthenticated problems?

Setup of my device is same as Flashrouter advised: https://support.flashrouters.com/setup-guides/wifi-setup/linksys-wrt32x-ddwrt-settings/

I test some newer builds of last month and i'm now back to build: DD-WRT v3.0-r42335 std (02/10/20)


Last edited by WRT32X on Wed Apr 08, 2020 11:51; edited 2 times in total
Sponsor
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7258
Location: Texas, USA

PostPosted: Wed Apr 08, 2020 8:43    Post subject: Reply with quote
Which build are you running?

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569

_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
WRT32X
DD-WRT Novice


Joined: 02 Apr 2020
Posts: 14

PostPosted: Wed Apr 08, 2020 11:26    Post subject: Reply with quote
DD-WRT v3.0-r42335 std (02/10/20)

kernel-panic69 wrote:
Which build are you running?

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569
James80
DD-WRT User


Joined: 09 Mar 2020
Posts: 121

PostPosted: Wed Apr 08, 2020 12:32    Post subject: Reply with quote
WRT32X wrote:
DD-WRT v3.0-r42335 std (02/10/20)

kernel-panic69 wrote:
Which build are you running?

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315569


The R42335 seems to be pretty stable.
How it goes?
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 7258
Location: Texas, USA

PostPosted: Wed Apr 08, 2020 12:59    Post subject: Reply with quote
In the WRT32X install thread I linked, there was some talk about disabling the ath2 device because it was specifically for DFS and has no external antenna, but there was a post about a build where all work. The thing is, if ath2 is hard-coded to only use certain channels or some such, then it should be turned off because it is of no use. YMMV.
_________________
Official Forum Rules, Guidelines, and Helpful InformationFirmware FAQInstallation WikiWhere Do I Download Firmware?
DON'T use Chromium-based browsersRTFM/STFW - TL;DR is NOT an excuse. • Why Should I Care What Color the Bikeshed Is?
Please DO NOT PM me with questions; Ask in the forum.

---------------------------------------------------------

Linux User #377467 counter.li.org / linuxcounter.net
WRT32X
DD-WRT Novice


Joined: 02 Apr 2020
Posts: 14

PostPosted: Wed Apr 08, 2020 16:57    Post subject: Reply with quote
kernel-panic69 wrote:
In the WRT32X install thread I linked, there was some talk about disabling the ath2 device because it was specifically for DFS and has no external antenna, but there was a post about a build where all work. The thing is, if ath2 is hard-coded to only use certain channels or some such, then it should be turned off because it is of no use. YMMV.


Alright, I have set it off. Thanks for your answer kernel-panic69!

If somebody has a suggestion, let me known!
WRT32X
DD-WRT Novice


Joined: 02 Apr 2020
Posts: 14

PostPosted: Wed Apr 15, 2020 11:50    Post subject: Reply with quote
I run some tests and I notice when I disable ATH1 (Wireless 2.4Ghz) I receive no more errors. All my clients are then off course connected to the ATH0 (Wireless 5Ghz).

So it has to do something with ATH1, the wireless 2.4Ghz band.
I did try to change this band to Mixed/NG-Mixed/N-Only but did receive the same errors.
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum