New Build 42681: 03-13-2020-r42681

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Goto page 1, 2  Next
Author Message
kernel-panic69
DD-WRT Guru


Joined: 08 May 2018
Posts: 4453
Location: Texas, USA

PostPosted: Sat Mar 14, 2020 5:45    Post subject: New Build 42681: 03-13-2020-r42681 Reply with quote
WARNING: DO NOT flash this experimental test build unless you know the risks and recovery methods. Report here to provide important info for developers and users. Always state your hardware model & version, mode (e.g. Repeater) and SPECIFIC build (e.g. netgear-r7000-webflash). Avoid discussions and create a new thread for specific problems or questions as this thread is not for support, and posts may be deleted or moved.

Downloads: if a link does not work, try another (alternative @DD-WRT website)
https://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2020/03-13-2020-r42681/
ftp://ftp.dd-wrt.com/betas/2020/03-13-2020-r42681/
Note: for wget (or curl) with CLI flash (`write {f/w} linux`), change the https to http, use `curl -k {link} -o {file}`, or ftp

Changelogs:
SVN* changelog since last build: 42617
Summary: (deprecated after 29739)
*Github mirror: https://github.com/mirror/dd-wrt/

Important: if reporting any issues, provide applicable info (GUI syslog, `dmesg`, `cat /var/log/messages`, etc.)
Or put into SVN ticket. For firewall issues, also provide "iptables" info (`iptables -L`, `iptables -t nat -L`, & the /tmp/.ipt file).

Notes:
1. SFE accelerated NAT is in 33006+ builds but only in kernel 3.2 and newer
2. 'KRACK' vulnerability fixes were completed in r33555 for non-Broadcom.
3. PBR/UDP with SFE working again since r40513 (see 6729)
4. CAKE scheduler changes "completed" with r41057 (see 5796) & FQ_CODEL_FAST with r41027 (reset first!)
5. Reset button was broken in 40571; fixed in build 40750.
6. CVE-2019-14899 VPN fix (r41784: applicability depends on VPN setup) and GUI toggle (r41812): ticket 6920, 6928, 6931, 6932
7. In-kernel samba now used and default min/max versions have changed, so change them if needed: 6954, 6957

Issues, observations, and/or workarounds reported:
1. DNScrypt is mostly only using v2 protocols now, but requires Golang that DD can't use (without entware): 6246

Template example to copy (after "Code:") for posting issues, be sure to include the mode in use (gateway, AP, CB, etc.):
Code:
[b][u]Router/Version:[/u][/b]
[b]Mode: [/b]
[b]File: [/b]
[b]Kernel: [/b]
[b]Status: [/b]

_________________
"Are you leaving anything out of the picture, or is your post complete with all information required for us to help you? If it is not complete, fix it now."
---------------------------------------------------------
E4200 v1 DD-WRT 42819 mega K3.x
R7000P DD-WRT 40270M kongac
R7800 DD-WRT 42819 std
E4200 v1 FreshTomato 2020.2
E4200 v1 FreshTomato 2020.3.development
R7000 FreshTomato 2020.3.development
E4200 v1 1.0.07.development
WRT3200ACM OpenWRT 18.06.8
---------------------------------------------------------
Linux User #377467 counter.li.org / linuxcounter.net
Sponsor
oliver44
DD-WRT Novice


Joined: 01 Jun 2016
Posts: 39

PostPosted: Sat Mar 14, 2020 7:44    Post subject: Reply with quote
Router Model
Linksys WRT1900ACS v2
Firmware Version
DD-WRT v3.0-r42681 (03/13/20)
Kernel Version
Linux 4.9.216 #1676 SMP Fri Mar 13 05:32:12 +03 2020 armv7l
Current Time
Sat, 14 Mar 2020 09:52:16

Connection Type 1Gbps PPPoE works
IPv6 Type DHCPv6 Prefix Delegation - works - But a problem I encounter and it persists on all versions, every change made in the web interface to router settings loses ipv6 allocation, after a restart everything works fine!

Wireless Mode AP-Mode:
5Ghz AC/N-VTH80(80Mhz)-Channel 36-country UNITED STATE WPA2 Personal CCMP-128 (AES)
2.4Ghz N-only -HT40(40Mhz)-Channel 9- WPA2 Personal CCMP-128 (AES)connection problems wifi Realtek 8822BE Wireless LAN 802.11ac PCI-E NIC, mobile phones work without problems on 2Ghz!!!

2.4Ghz N-only Dynamic (20/40Mhz)-Channel 9 country UNITED KINDOM WPA2 Personal CCMP-128 (AES)works on all devices!!!


Port Forwarding-works

Everything seems fine so far, I see a considerable improvement on the wifi side 5Ghz, stability on the web interface side seems much improved, thank you for the effort you put into everything you do!

_________________
Internet provider https://en.wikipedia.org/wiki/RCS_%26_RDS RCS & RDS 1Gbps
Linksys WRT1900ACS v.2 - OpenWrt/DD-WRT
WDR3600 rev.1.5 - OpenWrt


Last edited by oliver44 on Sat Mar 14, 2020 19:26; edited 8 times in total
M
DD-WRT User


Joined: 29 Dec 2012
Posts: 108

PostPosted: Sat Mar 14, 2020 9:54    Post subject: Firmware: DD-WRT v3.0-r42681 std (03/13/20) Reply with quote
Router Model
Linksys WRT32X
Firmware Version
DD-WRT v3.0-r42681 std (03/13/20)
Kernel Version
Linux 4.9.216 #1676 SMP Fri Mar 13 05:32:12 +03 2020 armv7l

CPU Model
Marvell Armada 385
CPU Cores
2
CPU Features
VFP VFPv3 NEON VFPD32 EDSP
CPU Clock
1866 MHz
Load Average
0%
0.00, 0.01, 0.00
Temperatures
CPU 66.0 °C / WL0 40.0 °C / WL1 41.4 °C

Test Objective
PPTP Server Only (without Wifi Test)


Results
I do not know that the memory of this firmware consume more than other routers.

Used
38%
196404 kB / 510856 kB


System Log (Red)
Jan 1 08:00:12 kern.err kernel: [ 10.631347] sdio platform data not available

Conclusions
No issues is found at this moment.
M
DD-WRT User


Joined: 29 Dec 2012
Posts: 108

PostPosted: Sat Mar 14, 2020 10:49    Post subject: Firmware: DD-WRT v3.0-r42681 std (03/13/20) Reply with quote
Router Model
Linksys WRT1900ACS <-- Correction: Linksys WRT1900ACSV2
Firmware Version
From DD-WRT v3.0-r42557 std (02/28/20) to DD-WRT v3.0-r42681 std (03/13/20)
Kernel Version
Linux 4.9.216 #1676 SMP Fri Mar 13 05:32:12 +03 2020 armv7l

CPU Model
Marvell Armada 385
CPU Cores
2
CPU Features
VFP VFPv3 NEON VFPD32 EDSP
CPU Clock
1600 MHz
Load Average
24%
0.48, 0.26, 0.20
Temperatures (With USB 12cm Fan)
CPU 58.9 °C / WL0 30.8 °C / WL1 32.3 °C

Backgrounds
200MB Fible Broadband

ath0 (5.8G Wifi)
ath1 (2.4G Wifi)

Testing with 5 Projectors play with 4K Videos which using ath0.1 in the Lab

3 to 6 IPCams are connected with ath1

PPTP Server (24h operation)

Print Server with USB (Brother)

USB 12cm Fan Installation with ESATA Plugin

Results
Linksys WRT1900ACS <-- Correction: Linksys WRT1900ACSV2
If the firmware is really using WRT1900ACS, I think some hardware is incomparable.

The signal of ath0 is too weak when the devices (including the smartphone). The distance is around 3metres. The result of iPhone products are obvious. The signal quality is dropped to 72%. I will tried to remove the fan for testing in the future.



Low network speed for projectors with speed test with Mixed Mode. I have tried to set the Wireless Network Mode is AC Only and encrypt mode is AES. The result is good but some device may not support.

Conclusions
Still waiting the result from technician.
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 88

PostPosted: Sat Mar 14, 2020 13:13    Post subject: Reply with quote
Router/Version: Linksys WRT1900ACS v2
File: ddwrt-linksys-wrt1900acsv2-webflash.bin
Firmware: DD-WRT v3.0-r42681 std (03/13/20)
Kernel: Linux 4.9.216 #1676 SMP Fri Mar 13 05:32:12 +03 2020 armv7l
Mode: Gateway and wireguard endpoint, WAN to 4G
Reset: No
Status: updated 2h ago, seems good.

Regarding above mentioned ~3metres, could only commence quick testing but was able to reach mediacenter/iptv at ~7m range on 2.4 and 5g.
But this needs no high throughput.
Need to test against iperf server...
M
DD-WRT User


Joined: 29 Dec 2012
Posts: 108

PostPosted: Sat Mar 14, 2020 13:32    Post subject: Reply with quote
Zyxx wrote:
Router/Version: Linksys WRT1900ACS v2
File: ddwrt-linksys-wrt1900acsv2-webflash.bin
Firmware: DD-WRT v3.0-r42681 std (03/13/20)
Kernel: Linux 4.9.216 #1676 SMP Fri Mar 13 05:32:12 +03 2020 armv7l
Mode: Gateway and wireguard endpoint, WAN to 4G
Reset: No
Status: updated 2h ago, seems good.

Regarding above mentioned ~3metres, could only commence quick testing but was able to reach mediacenter/iptv at ~7m range on 2.4 and 5g.
But this needs no high throughput.
Need to test against iperf server...



You mean 7m, I have tried. The signal quality drop to 34%
M
DD-WRT User


Joined: 29 Dec 2012
Posts: 108

PostPosted: Sat Mar 14, 2020 13:45    Post subject: Re: Firmware: DD-WRT v3.0-r42681 std (03/13/20) Reply with quote
Router Model
Linksys WRT32X
Firmware Version
DD-WRT v3.0-r42681 std (03/13/20)
Kernel Version
Linux 4.9.216 #1676 SMP Fri Mar 13 05:32:12 +03 2020 armv7l

Temperatures (With 12cm Fan signal quality 92%)
CPU 60.8 °C / WL0 33.1 °C / WL1 35.1 °C

Background of 2nd WRT32X
ath0
Client Mode with WPA2 Enterprise PEAP Mode

ath1 & 2

Disabled

Port1
Switcher

Port2
Router - WAN Connection Type: PPTP Client DD-WRT

Port3
Router - WAN Connection Type: PPTP Client DD-WRT

Port4
Router - TP-Link Archer C5 V2
DHCP Server Disabled
Provide the Wifi AP with 5.8 and 2.4 Band

Result
1. Normal Operation
2. Memory Usage is higher than other type of Marvell MVEBU based Hardware when boot up and operational

System Logs (Red Zone)
Jan 1 08:00:12 kern.err kernel: [ 10.546626] sdio platform data not available

System Logs (Yellow Zone)
Jan 1 08:00:13 kern.warn kernel: [ 13.105733] conntrack: generic helper won't handle protocol 47. Please consider loading the specific helper module.

Jan 1 08:00:14 daemon.warn dnsmasq[1331]: no servers found in /tmp/resolv.dnsmasq, will retry

Jan 1 08:00:18 user.err : usbipd: error: socket: :::3240: 97 (Address family not supported by protocol)





M wrote:
Router Model
Linksys WRT32X
Firmware Version
DD-WRT v3.0-r42681 std (03/13/20)
Kernel Version
Linux 4.9.216 #1676 SMP Fri Mar 13 05:32:12 +03 2020 armv7l

CPU Model
Marvell Armada 385
CPU Cores
2
CPU Features
VFP VFPv3 NEON VFPD32 EDSP
CPU Clock
1866 MHz
Load Average
0%
0.00, 0.01, 0.00
Temperatures
CPU 66.0 °C / WL0 40.0 °C / WL1 41.4 °C

Test Objective
PPTP Server Only (without Wifi Test)


Results
I do not know that the memory of this firmware consume more than other routers.

Used
38%
196404 kB / 510856 kB


System Log (Red)
Jan 1 08:00:12 kern.err kernel: [ 10.631347] sdio platform data not available

Conclusions
No issues is found at this moment.
steve2088
DD-WRT Novice


Joined: 19 Feb 2020
Posts: 12

PostPosted: Sat Mar 14, 2020 15:36    Post subject: WRT3200ACM ALL GOOD Reply with quote
Router Model: Linksys WRT3200acm
Firmware Version: DD-WRT v3.0-r42681 std (03/13/20)
Kernel Version: Linux 4.9.216 #1676
Status: Up 1 Hour
Upgrade went well. Did a erase nvram with manual config
All Functions as expected for my needs: 12 devices, 2.4 and 5 G, dnsmasq (cloudfare dns, local dns, dnssec), some extra IP firewall rules, cron script for reboots
scar1943
DD-WRT User


Joined: 10 Nov 2018
Posts: 264
Location: South Carolina

PostPosted: Sat Mar 14, 2020 16:04    Post subject: DD-WRT v3.0-r42681 std (03/13/20) Reply with quote
WRT3200ACM V1 r42681 Firefox 73.0.1 (64-bit) webflash

OpenVPN CLIENT seems ok (nordvpn server)
5GHz wpa2 CCMP-128 (AES)conditional 40MHz Mixed
2.4GHz wpa2 CCMP-128 (AES)conditional 20MHz Mixed
NAS via USB Samba 3.11 conditional

No special saves or <apply setting> needed after upgrade. So far, so good.

*** Edit 3-16-2020 - Wifi drop within 24 hours still happening any mode. Router reboot required to resolve. This has been happening since r42132. r42054 seems to be the last stable version.

*** Edit 3-17-2020 - NAS now requires an <apply settings> to resolve false credential request. Wanting a password when no password is present.


Last edited by scar1943 on Tue Mar 17, 2020 16:14; edited 2 times in total
SurprisedItWorks
DD-WRT Guru


Joined: 04 Aug 2018
Posts: 685
Location: Appalachian mountains, USA

PostPosted: Sat Mar 14, 2020 19:11    Post subject: Re: Firmware: DD-WRT v3.0-r42681 std (03/13/20) Reply with quote
M wrote:
Linksys WRT1900ACS <-- Correction: Linksys WRT1900ACSV2
If the firmware is really using WRT1900ACS, I think some hardware is incomparable.

There is a firmware version specific to the V2. Are you using that one?
Quote:
The signal of ath0 is too weak when the devices (including the smartphone). The distance is around 3metres. The result of iPhone products are obvious. The signal quality is dropped to 72%. I will tried to remove the fan for testing in the future.

I haven't seen that problem (older builds though) but I do keep the fan underneath blowing up through the case, just to keep the fan away from the antennas.
Quote:

Low network speed for projectors with speed test with Mixed Mode. I have tried to set the Wireless Network Mode is AC Only and encrypt mode is AES. The result is good but some device may not support.

I've always used WPA2-Personal and CCMP-128 (AES) and have never seen a device that could not handle it. Are your client devices really, really old? Edit: Ah. Not support AC. Indeed.

Also, sometimes certain modes have issues. I have always had good results with NG-Mixed on ath1 (2.4G) and AC/N-Mixed on ath0 (5G), but I haven't yet tried this build. (I'm still on 41954.)

Folks, sorry to be engaging in a touch of debugging discussion in a new-build thread, but the goal is to determine whether the issues are related to this build or perhaps are more ordinary config issues.

_________________
Six Linksys WRT1900ACSv2 (39144/40009/41954):
VLANs, multiple VAPs, NAS, QoS, client-mode travel router, OpenVPN client/PBR (AirVPN), two DNSCrypt servers (incl Quad9) routed through vpn.
SurprisedItWorks
DD-WRT Guru


Joined: 04 Aug 2018
Posts: 685
Location: Appalachian mountains, USA

PostPosted: Sat Mar 14, 2020 23:31    Post subject: Reply with quote
M wrote:
Zyxx wrote:
Regarding above mentioned ~3metres, could only commence quick testing but was able to reach mediacenter/iptv at ~7m range on 2.4 and 5g.
But this needs no high throughput.
Need to test against iperf server...

You mean 7m, I have tried. The signal quality drop to 34%

These range reports made me curious, so here's a data point: on 5g on build 41954, to get down to 34% signal quality showing in the GUI, I had to walk my laptop to basically the farthest point in the house, about 10.5m away from the router with four walls intervening. (US power level: 30 dBm on channel 149UU, AC/N-Mixed, 80 MHz, Single User Beamforming.)

Really makes me wonder what's up either with this new build or with your config.

_________________
Six Linksys WRT1900ACSv2 (39144/40009/41954):
VLANs, multiple VAPs, NAS, QoS, client-mode travel router, OpenVPN client/PBR (AirVPN), two DNSCrypt servers (incl Quad9) routed through vpn.
M
DD-WRT User


Joined: 29 Dec 2012
Posts: 108

PostPosted: Sun Mar 15, 2020 8:04    Post subject: Re: Firmware: DD-WRT v3.0-r42681 std (03/13/20) Reply with quote
M wrote:
Linksys WRT1900ACS <-- Correction: Linksys WRT1900ACSV2
If the firmware is really using WRT1900ACS, I think some hardware is incomparable.


SurprisedItWorks wrote:
There is a firmware version specific to the V2. Are you using that one?


In case of WRT32X, I seldom see router name is WRT600N in router but my router is WRT32X. It shows that router name is 'WRT1900ACS'.

5 years ago, WRT1900AC was flashed with WRT1900ACS firmware. It worked although I flashed a wrong firmware very un-carefully.

M wrote:
The signal of ath0 is too weak when the devices (including the smartphone). The distance is around 3metres. The result of iPhone products are obvious. The signal quality is dropped to 72%. I will tried to remove the fan for testing in the future.


SurprisedItWorks wrote:
I haven't seen that problem (older builds though) but I do keep the fan underneath blowing up through the case, just to keep the fan away from the antennas.


I will try but ath1 does not have this problem.

M wrote:

Low network speed for projectors with speed test with Mixed Mode. I have tried to set the Wireless Network Mode is AC Only and encrypt mode is AES. The result is good but some device may not support.


SurprisedItWorks wrote:
I've always used WPA2-Personal and CCMP-128 (AES) and have never seen a device that could not handle it. Are your client devices really, really old? Edit: Ah. Not support AC. Indeed.


The projector is the new model. The antenna is very high quality.

References:
https://www.mi.com/global/mi-laser-projector-150

You tube cannot play 4K Videos in buffer mode a long time although the apk is updated. Speed test is 7.4M / 200M.

SurprisedItWorks wrote:
Also, sometimes certain modes have issues. I have always had good results with NG-Mixed on ath1 (2.4G) and AC/N-Mixed on ath0 (5G), but I haven't yet tried this build. (I'm still on 41954.)


In case of my WRT1900ACSV2, the bugs are equal to Boardcom Brand DD-WRT router. Then, it seems to have overheat. if ath1 does not use mixed mode and 20Hz, some ipcam cannot support.

SurprisedItWorks wrote:
Folks, sorry to be engaging in a touch of debugging discussion in a new-build thread, but the goal is to determine whether the issues are related to this build or perhaps are more ordinary config issues.


If some people also have this problem, I believe that it is a firmware issues.
If no body repeat this problem, that is my hardware issues.
The router is coming from Linksys Factory. It uses around 2 years. The fan is installed around half an year. I had set the 12dbm. I restore the signal to 30dbm last night. It increases 6 times signal but the hardware does not see improvement.
M
DD-WRT User


Joined: 29 Dec 2012
Posts: 108

PostPosted: Sun Mar 15, 2020 8:10    Post subject: Reply with quote
2 year ago

In test of WRT32X, the 5.8G signal with 80Hz (Two Channel 149 and 161) can pass though 2 steels wall (314) in 30 distance.

In test of WRT1900ACSV2, it is the same result. Today, I do not know the reason. I worry about dust storage inside the router causing this problem.

SurprisedItWorks wrote:
M wrote:
Zyxx wrote:
Regarding above mentioned ~3metres, could only commence quick testing but was able to reach mediacenter/iptv at ~7m range on 2.4 and 5g.
But this needs no high throughput.
Need to test against iperf server...

You mean 7m, I have tried. The signal quality drop to 34%

These range reports made me curious, so here's a data point: on 5g on build 41954, to get down to 34% signal quality showing in the GUI, I had to walk my laptop to basically the farthest point in the house, about 10.5m away from the router with four walls intervening. (US power level: 30 dBm on channel 149UU, AC/N-Mixed, 80 MHz, Single User Beamforming.)

Really makes me wonder what's up either with this new build or with your config.
Zyxx
DD-WRT User


Joined: 28 Dec 2018
Posts: 88

PostPosted: Sun Mar 15, 2020 9:04    Post subject: Reply with quote
My above tested 7m were fully functional, no error description like "only range of 7m".

I cannot see any decrease in range at all.
Currently I'm pleased with the results, since smb is also working finally and everything is snappy.

@M:
If I'm not mistaken one major difference between acs and acs v2 is handling of wifi parameters.
Since some countries urged the manufacturers to prohibit some useres exceeding allowed signal strength via custom firmware, linksys did fix some parameters in hardware (?). Need to read things up for more details, but this was mentioned I'm sure.
So flashing non v2 firmware might be one cause for your observation.
PIZZEDMEOFF
DD-WRT User


Joined: 12 Dec 2017
Posts: 194
Location: FL

PostPosted: Sun Mar 15, 2020 11:00    Post subject: Reply with quote
i flashed this 7 hours ago when i got in from work and all seems to be good on my hunk of junk the best i can tell this morning. KP and Wened i know you guys take notes around here so this ones for you. I did notice if i turned the switch off it does in fact turn off hope that helps Shocked Very Happy
_________________
Downloads:
ftp site: ftp://ftp.dd-wrt.com/betas/2020
SVN Timeline:
https://svn.dd-wrt.com/timeline
Commands:
Misc: sleep 10;stopservice nas;stopservice wlconf;startservice wlconf;startservice nas
samba: { sleep 30; stopservice samba3; startservice samba3; } &


WRT1900ACv1:

WIFI: 2.4ghz: NG-mixed, 20mhz channel width, channel follows AP, WPA2-CCMP-128.
WIFI: 5ghz: AC/N mixed, 40mhz channel width, channel 100+upper, WPA2-CCMP-128.
Misc Info: Wireless Mode: "Client" WPA2 Personal: "CCMP-128 (AES)", VAP "2.4ghz (currently broken as fuck)", Static IP's VIA Mac+Host, SFE Enabled, No Rebind, Strict, no-resolv.
Goto page 1, 2  Next Display posts from previous:    Page 1 of 2
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum