Kong 36440 & 36070 problems...

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware
Author Message
Pandora-Box
DD-WRT User


Joined: 09 Mar 2008
Posts: 218
Location: USA

PostPosted: Mon Aug 13, 2018 10:18    Post subject: Kong 36440 & 36070 problems... Reply with quote
Hi,
My Router Netgear R7000.
Long time dd-wrt user.
I would like to report some issues I did encounter with these Kong's builds 36070M & 36440M:
1. when I try to run "opkg" I do get "permission denied" error (both builds).
2. Similarly, when I try to run /opt/usr/sbin/iptables -v
-sh: /opt/usr/sbin/iptables: Permission denied
These opt iptables used to work, it was ver 1.42.x or something.
Similarly with ip6tables.
Permission to these files are set as 0755 or 0777, so they are executable.

With build 36440M no modules load at all (lsmod lists only 1 module loaded), while in ver 36070M a large number of them are lsmod listed, despite large number present in lib directories of both builds.
Does anyone know what is happening here?
Thanks for any constructive info.
Sincerely,
P-B

_________________
Netgear R7000
Sponsor
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 3988
Location: Netherlands

PostPosted: Mon Aug 13, 2018 11:35    Post subject: Reply with quote
Just some thoughts: assuming you have /opt on an attached USB stick, have you set the permissions on the USB setup page to read/write?
Regarding opkg, have you started with the bootstrap command to get the package?

I am using Kong's latest and have no problem with opkg (just checked and installed Iptables (which is now at version 1.4.21, instead of the default iptables which is at 1.3.7)
However at my setup files are located in /opt/sbin and not in /opt/usr/sbin Smile )

lsmod is broken on the latest build, it has been fixed in 36565, see https://svn.dd-wrt.com/changeset/36565
So should be working again in the next build hopefully

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Pandora-Box
DD-WRT User


Joined: 09 Mar 2008
Posts: 218
Location: USA

PostPosted: Mon Aug 13, 2018 12:49    Post subject: Reply with quote
Thanks egc for your quick answer.
Bootstrap command resolved opkg issue.
I have been using Kong builds and opkg for years, so I do not know what happened to that "bootstrap(-ing)" (whatever it does).
I have the same USB HDD attached since the very beginning. USB permissions are set to read/write, and I do not have any problems accessing it from anywhere, including dd-wrt.
Anyway, there are still issues with opkg packages.
When listed, they show up, but when I try to execute some packages (eg iptables or ip6tables) I still get "permission denied" errors:
/opt/usr/sbin/iptables -v
-sh: /opt/usr/sbin/iptables: Permission denied
root@dd-wrt:~# opkg install ip6tables
Package ip6tables (1.4.21-2) installed in root is up to date.
So, what could this be caused by.
Once again, I the past I did not have such issues, everything was working as it should, on the same exactly equipment.

THX.
P-B

_________________
Netgear R7000
egc
DD-WRT Guru


Joined: 18 Mar 2014
Posts: 3988
Location: Netherlands

PostPosted: Mon Aug 13, 2018 13:58    Post subject: Reply with quote
In my setup packages are installed in /opt/sbin and not in /opt/usr/sbin.
Check where they are installed, or just try:
Code:
/opt/sbin/ip6tables -V


my output:
Quote:
root@R6400:~# /opt/sbin/ip6tables -V
ip6tables v1.4.21
root@R6400:~#

_________________
Routers:Netgear R7800, Netgear R6400v1, Netgear R6400v2, Linksys EA6900 (XvortexCFE), Linksys E2000 (converted WRT320N), WRT54GS v1.
Install guide Linksys EA6900: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=291230
OpenVPN Policy Based Routing guide: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=321686
Install guide R6400v2:http://forum.dd-wrt.com/phpBB2/viewtopic.php?t=316399
OpenVPN Server Setup:https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=318795
Install guide R7800: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=320614
Pandora-Box
DD-WRT User


Joined: 09 Mar 2008
Posts: 218
Location: USA

PostPosted: Mon Aug 13, 2018 14:37    Post subject: Reply with quote
Thanks egc.
I will try to re-format my USB drive (it is a standard 200 Gb HDD, and not a pen-drive), and re-install opkg packages, and I will see if this will remedy the issue.
FYI, I did remove and re-install one opkg pkg and it re-installed again in /opt/usr/sbin sub-dir.
Thanks again.
P-B

_________________
Netgear R7000
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum