WRT1900ACSv2 VLAN bug?WAN IP 0.0.0.0 upon Apply Settings

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.)
Author Message
davidmoore
DD-WRT Novice


Joined: 05 Mar 2018
Posts: 4
Location: Internet

PostPosted: Wed Jul 22, 2020 6:49    Post subject: WRT1900ACSv2 VLAN bug?WAN IP 0.0.0.0 upon Apply Settings Reply with quote
I'm running DD-WRT v3.0-r43652 on a Linksys WRT1900ACSv2 router.

I'm trying to add a virtual wired subnet to my network such that I can isolate a router that serves as a VPN client to a paid service.

If I click on Setup > Switch Config (http://192.168.1.1/Vlan.asp) I end up with a screen that looks like this:



Note, this is how it looks withou me making any changes whatsoever to the router. If I do absolutely nothing except click "Apply Settings", the router does its little refresh thing, and suddenly the WAN IPv4 address turns to 0.0.0.0. This persists across reboots of both the modem and router.

I can figure out no way to get the router to adopt an IP thereafter except to factory reset or upload a backup, after which the problem returns if I do the steps outlined.

As a bonus, here's my Setup > Networking (192.168.1.1/Networking.asp) page without touching any settings:

Sponsor
SurprisedItWorks
DD-WRT Guru


Joined: 04 Aug 2018
Posts: 934
Location: Appalachian mountains, USA

PostPosted: Wed Jul 22, 2020 14:05    Post subject: Reply with quote
Don't use that GUI page for these Linksys/Marvell routers. The reference you want is this Marvell-forum Sticky Post: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=317199.
_________________
Five Linksys WRT1900ACSv2's on 42926, 44048
VLANs, multiple VAPs, NAS, client-mode travel router, OpenVPN client/PBR (AirVPN), wireguard/PBR (AzireVPN), two DNSCrypt servers (incl Quad9) routed through OpenVPN.
davidmoore
DD-WRT Novice


Joined: 05 Mar 2018
Posts: 4
Location: Internet

PostPosted: Thu Jul 23, 2020 3:10    Post subject: Reply with quote
SurprisedItWorks wrote:
Don't use that GUI page for these Linksys/Marvell routers. The reference you want is this Marvell-forum Sticky Post: https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=317199.


Oh, thank you! I did not even consider that DD-WRT builds might include unusable features.

_________________
Linksys WRT1900ACSv2 (DD-WRT v3.0-r3652) | Netgear WNDR3700v4 (DD-WRT v3.0-r34777) | Linksys WRT54Gv1 (DD-WRT v24 SP1)
SurprisedItWorks
DD-WRT Guru


Joined: 04 Aug 2018
Posts: 934
Location: Appalachian mountains, USA

PostPosted: Thu Jul 23, 2020 15:23    Post subject: Reply with quote
It is surprising, right?

There are other features that have issues also, that maybe work for some people and not others, depending on the details of what they try to configure, access restrictions and QoS for example. Some QoS setups work great for people. Other options that the QoS pages offer do not. People often use custom iptables commands in GUI>Administration>Commands in the Firewall section rather than deal with the Access restrictions page. This sort of thing is what makes it a good idea to browse over the forums (at least the Marvell forum and Advanced Networking) now and then. You gradually pick up things.

_________________
Five Linksys WRT1900ACSv2's on 42926, 44048
VLANs, multiple VAPs, NAS, client-mode travel router, OpenVPN client/PBR (AirVPN), wireguard/PBR (AzireVPN), two DNSCrypt servers (incl Quad9) routed through OpenVPN.
Saico
DD-WRT Novice


Joined: 18 Aug 2020
Posts: 6

PostPosted: Fri Sep 25, 2020 15:03    Post subject: Reply with quote
Came across this topic after half of day fighting with this issue. Evil or Very Mad
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Marvell MVEBU based Hardware (WRT1900AC etc.) All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum