Unable to transfer to my WZR-300HP

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Author Message
BrakTalk
DD-WRT Novice


Joined: 03 Sep 2009
Posts: 6

PostPosted: Sat May 12, 2018 22:40    Post subject: Unable to transfer to my WZR-300HP Reply with quote
I believe I have everything I need to successfully transfer the pro enc base binary to my WZR-300HP.

File name: wzr300hp-pro-r30356.enc

I think the issue in transferring is I don't have the proper mac address for my router. I must be missing something so simple but I am unable to determine what this is. As it seems to be common knowledge, there is no hardware mac address printed anywhere. I read somewhere where the mac address is the SSID (which on mine is BUFFALO-6205DE).

I've tried at an elevated command prompt, the following:
netsh interface ipv4 add neighbors 10 192.168.11.1 BUFFALO-6205DE

Well, that obviously won't work. It's not a valid format and the resulting error message tells me so.

Desperately, after removing the previous neighbor I tried:

netsh interface ipv4 add neighbors 10 192.168.11.1 02-aa-bb-cc-dd-20

I've tried plugging the cat 5 into the WAN port and port #1. Same thing. Pumpkin gives up and says it can't transfer the file.

To summarize, I have done the following:

Set my ethernet adapter to:
192.168.11.2
255.255.255.0
Gateway is 192.168.11.1

Added the neighbor

Plugged in the ethernet cable between the ethernet adapter and the router.

Que the flash file in Pumpkin to send the file to 192.168.11.1

Click OK to "put" the file

Power on the router

Wait about thirty seconds and Pumpkin says:
Transmission of [filename] is timed out
Transfer of [filename] was aborted

My gut tells me it's that mac address. I need the actual mac address of this router but I can't find anywhere (googling, etc.) how to determine what that is.

Any thoughts on this? Is my WZR-300HP truly bricked. (Oh, it was working with a 2013 firmware and it was a router that I was setting up for my mother (hey, it's Mother's Day) so that she wouldn't have to rent her modem/wifi router any longer. I got it working and and then made the fateful decision to flash the firmware via the web interface. Everything seemed fine proceeding through the upgrade process but the router never booted up. It just has a persistent green power indicator and the solid red diag light. It doesn't even appear to be rebooting as it just sits there with differences in state.)

EDIT: Copy and paste error. I had "delete" instead of "add" in my original cite of the command I executed on the command line.
Sponsor
BrakTalk
DD-WRT Novice


Joined: 03 Sep 2009
Posts: 6

PostPosted: Thu May 17, 2018 15:36    Post subject: Reply with quote
I'm guessing there's no easy feedback available on this issue? Is there an important aspect of my problem description that's missing that I can provide in order to help spur some ideas?
Plebeian
DD-WRT Novice


Joined: 11 Sep 2009
Posts: 6

PostPosted: Sat May 26, 2018 13:09    Post subject: Reply with quote
Hi BrakTalk, having recently had to TFTP a firmware onto a WZR-600DHP (which is a nearly identical unit) I'd strongly recommend that you use Linux to do it, there's too many variables on Windows that can mess up the process and prevent the communication happening in the time frame required.

I tried for about 2 hours on Windows, failing every time, when on Linux it worked on second attempt. I was just about to give up too when I thought what the hell may as well give it a go.

Just remember that even on Linux, you still have a small window of time to execute the command, so you may have to take a few attempts at it. You should try varying the time that you wait before hitting enter on the TFTP transfer anywhere between immediately and up to 30 seconds later, it's hard to say exactly.

Here's thread I made in case you want to have a read for the commands etc

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315184

Both the DD-WRT wiki and the OpenWRT wiki say that the mac address for the bootloader is 02:aa:bb:cc:dd:20 so I'd say it's a safe bet that that's what you should be using when setting a static route for that process.

https://wiki.openwrt.org/toh/buffalo/wzr-hp-ag300h#oeminstallationusingthetftpmethod

https://wiki.dd-wrt.com/wiki/index.php/Buffalo_WZR-HP-AG300H#De-bricking_and_TFTP_Info

(Disclaimer, I wouldn't consider myself an expert at all.)
dpp3530
DD-WRT Guru


Joined: 12 Dec 2007
Posts: 514
Location: Pittsburgh, PA USA

PostPosted: Sat May 26, 2018 20:38    Post subject: Reply with quote
I've successfully flashed the WZR-600DHP a number of times using Windows 7 and Windows 10. I posted the procedure I used some time ago. Your router should be similar. It says Windows 7, but the process is identical in Win 10.

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=260550&highlight=

_________________
__________________________
Linksys WRT-1900AC
DD-WRT v3.0 STD 44340
Linksys EA6700
DD-WRT v3.0 STD 44340
Asus RT-AC56U
DD-WRT v3.0 STD 44340
Netgear AC1450
DD-WRT v3.0 STD 44340
BrakTalk
DD-WRT Novice


Joined: 03 Sep 2009
Posts: 6

PostPosted: Thu May 31, 2018 11:35    Post subject: Reply with quote
Thank you both for your replies. I'll review your information and if I have any questions, I will follow up.

Thanks again.

MWF
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum