New Build - 05/04/2018 - r35874

Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware
Goto page Previous  1, 2, 3  Next
Author Message
Antler
DD-WRT Novice


Joined: 05 May 2018
Posts: 1

PostPosted: Sat May 05, 2018 9:28    Post subject: Problem whit port forwarding TL WR841N Reply with quote
Firmware: DD-WRT v3.0-r35874 std (05/04/1Cool
When I forward any port internet stopping
In Log:
----------------------------------
May 5 09:11:42 DHS user.info : wland : WLAN daemon successfully stopped
May 5 11:11:43 DHS user.err : Caught SIGSEGV (11) at 0x7726f474
May 5 11:11:43 DHS user.err : Fault at memory location 0x00000000 due to address not mapped to object (1).
May 5 11:11:43 DHS user.err : Thread 1368: start_single_se
May 5 11:11:43 DHS user.err : === Context:
May 5 11:11:43 DHS user.err : ZERO:00000000 AT:00000000 V0:00000000 V1:00000000 A0:00000000 A1:00000000
May 5 11:11:43 DHS user.err : A2:00000000 A3:00000000 T0:00000000 T1:00000000 T2:00000000 T3:00000000
May 5 11:11:43 DHS user.err : T4:00000000 T5:00000000 T6:00000000 T7:00000000 S0:00000000 S1:00000000
May 5 11:11:43 DHS user.err : S2:00000000 S3:00000000 S4:00000000 S5:00000000 S6:00000000 S7:00000000
May 5 11:11:43 DHS user.err : T8:00000000 T9:00000000 K0:00000000 K1:00000000 GP:00000000 SP:00000000
May 5 11:11:43 DHS user.err : FP:00000000 RA:00000000
May 5 11:11:43 DHS user.err : === Backtrace:
May 5 11:11:43 DHS user.err : # [0x7726f44c]: stack size 40
May 5 11:11:43 DHS user.err : # [0x7726f354]: ra offset 36
May 5 11:11:43 DHS user.err : ???(+0)[0x7726f474]
May 5 11:11:43 DHS user.err : === Code:
May 5 11:11:43 DHS user.err : 7726f434: 02118023 8fbf0024 02021021 8fb10020 8fb0001c 03e00008 27bd0028 1000fff6
May 5 11:11:43 DHS user.err : 7726f454: 02208025 00801025 30430003 14600010 3c07fefe 3c068080 34e7feff 34c68080
May 5 11:11:43 DHS user.err : 7726f474: >8c450000 00a71821 00052827 00651824 00661824 1060000d 00000000 80430000
May 5 11:11:43 DHS user.err : 7726f494: 10600006 00000000 1000fffc 24420001 80430000 14600003 00000000 03e00008
May 5 09:12:58 DHS user.info : vpn modules : vpn modules successfully unloaded
May 5 09:12:58 DHS user.info : vpn modules : nf_conntrack_proto_gre successfully loaded
May 5 09:12:58 DHS user.info : vpn modules : nf_nat_proto_gre successfully loaded
May 5 09:12:58 DHS user.info : vpn modules : nf_conntrack_pptp successfully loaded
May 5 09:12:58 DHS user.info : vpn modules : nf_nat_pptp successfully loaded
May 5 09:12:58 DHS user.info : wland : WLAN daemon successfully started
------------------------------------------
Why WLAN daemon stopped???

What can I do ?
Sponsor
bushant
DD-WRT Guru


Joined: 18 Nov 2015
Posts: 1402

PostPosted: Sat May 05, 2018 12:45    Post subject: Reply with quote
Router Model:Buffalo WZR-HP-AG300H
CPU Model: Atheros AR7161 rev 2 (0xaa)
Firmware Version: DD-WRT v3.0-r35874 std (V-IV-XVIII)
Kernel Version Linux 3.10.108-dd #55184 Fri May 4
Status: good best lan speed in a while
Reset: No
previous:35831
errors:nothing new or important


comments:syslog time still wrong, remains a bummer
Kinda odd? log time is and has been correct at STATUS>OPENVPN screen

_________________
STUBBY DoT install guide----Tips-DD-WRT

Forum Guide Lines (Please read!)----How to get help the right way
jerrytouille
DD-WRT Guru


Joined: 11 Dec 2015
Posts: 1300

PostPosted: Sat May 05, 2018 15:24    Post subject: Re: Problem whit port forwarding TL WR841N Reply with quote
Antler wrote:
Firmware: DD-WRT v3.0-r35874 std (05/04/1Cool
When I forward any port internet stopping
In Log:
----------------------------------
May 5 09:11:42 DHS user.info : wland : WLAN daemon successfully stopped
May 5 11:11:43 DHS user.err : Caught SIGSEGV (11) at 0x7726f474
May 5 11:11:43 DHS user.err : Fault at memory location 0x00000000 due to address not mapped to object (1).
May 5 11:11:43 DHS user.err : Thread 1368: start_single_se
May 5 11:11:43 DHS user.err : === Context:
May 5 11:11:43 DHS user.err : ZERO:00000000 AT:00000000 V0:00000000 V1:00000000 A0:00000000 A1:00000000
May 5 11:11:43 DHS user.err : A2:00000000 A3:00000000 T0:00000000 T1:00000000 T2:00000000 T3:00000000
May 5 11:11:43 DHS user.err : T4:00000000 T5:00000000 T6:00000000 T7:00000000 S0:00000000 S1:00000000
May 5 11:11:43 DHS user.err : S2:00000000 S3:00000000 S4:00000000 S5:00000000 S6:00000000 S7:00000000
May 5 11:11:43 DHS user.err : T8:00000000 T9:00000000 K0:00000000 K1:00000000 GP:00000000 SP:00000000
May 5 11:11:43 DHS user.err : FP:00000000 RA:00000000
May 5 11:11:43 DHS user.err : === Backtrace:
May 5 11:11:43 DHS user.err : # [0x7726f44c]: stack size 40
May 5 11:11:43 DHS user.err : # [0x7726f354]: ra offset 36
May 5 11:11:43 DHS user.err : ???(+0)[0x7726f474]
May 5 11:11:43 DHS user.err : === Code:
May 5 11:11:43 DHS user.err : 7726f434: 02118023 8fbf0024 02021021 8fb10020 8fb0001c 03e00008 27bd0028 1000fff6
May 5 11:11:43 DHS user.err : 7726f454: 02208025 00801025 30430003 14600010 3c07fefe 3c068080 34e7feff 34c68080
May 5 11:11:43 DHS user.err : 7726f474: >8c450000 00a71821 00052827 00651824 00661824 1060000d 00000000 80430000
May 5 11:11:43 DHS user.err : 7726f494: 10600006 00000000 1000fffc 24420001 80430000 14600003 00000000 03e00008
May 5 09:12:58 DHS user.info : vpn modules : vpn modules successfully unloaded
May 5 09:12:58 DHS user.info : vpn modules : nf_conntrack_proto_gre successfully loaded
May 5 09:12:58 DHS user.info : vpn modules : nf_nat_proto_gre successfully loaded
May 5 09:12:58 DHS user.info : vpn modules : nf_conntrack_pptp successfully loaded
May 5 09:12:58 DHS user.info : vpn modules : nf_nat_pptp successfully loaded
May 5 09:12:58 DHS user.info : wland : WLAN daemon successfully started
------------------------------------------
Why WLAN daemon stopped???

What can I do ?


nightwind209 wrote:
mwchang wrote:
Please note that the Source Net column in Port-Forwarding canNOT be blank. Use "0.0.0.0/0" instead.

you sovle my problem.
I add "0.0.0.0/0" all works.
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Sat May 05, 2018 15:36    Post subject: Reply with quote
Some router firmware, including the more advanced DD-WRT will allow you to specify a “Source” value which is list of IP addresses you’re restricting the port forward to for security purposes. You can use this feature only IF YOU WISH, but be forewarned it introduces a whole new host of headaches as it presumes that remote users (including you when you’re away from home and friends who are connecting in) have static IP addresses.

Specifying 0.0.0.0/0 (any IP) makes no sense!
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Sat May 05, 2018 15:42    Post subject: Reply with quote
If you want to find out if it is a bug do port forwarding and post output of:

Code:
cat /tmp/.ipt


Code:
iptables -vnL -t nat
kartal
DD-WRT Novice


Joined: 28 Jan 2009
Posts: 41

PostPosted: Sat May 05, 2018 17:11    Post subject: Reply with quote
Is this a recent requirement? I never needed to do that.

mwchang wrote:
Please note that the Source Net column in Port-Forwarding canNOT be blank. Use "0.0.0.0/0" instead.
Mile-Lile
DD-WRT Guru


Joined: 24 Feb 2013
Posts: 1516
Location: Belgrade

PostPosted: Sat May 05, 2018 17:43    Post subject: Reply with quote
It is probably bug. I tested it, and after applying settings, GUI boxes (source net, ports etc) get mixed and DNAT rules are not created... But let's see what BS has to say Smile
Wildlion
DD-WRT Guru


Joined: 24 May 2016
Posts: 810

PostPosted: Sun May 06, 2018 1:06    Post subject: Reply with quote
Router: DIR-615e3
Firmware: dir615e3-firmware.bin (v3.0-r35874 std)
Kernel: Linux 3.10.108-dd #55216 Fri May 4 02:25:02 CEST 2018 mips
Status: Buggy on gui
Reset: No
Notes on configuration:

    DNSMasq
    Virtual wireless with bridging x2
    multiple DHCP server
    QOS

Errors:

    1. Apply settings on multiple pages does not work (for example Setup->Basic Setup, Setup->Network and Security->Firewall)
    2. Firmware upgrade button does not work (I have had to use command line to upgrade/downgrade)
    3. Factory Defaults (reset) does not work (apparently broken after 33006)
    4. Firmware restore button broken (apparently broken after 33006)
    5. Switch ports can not communicate with each other (see post https://www.dd-wrt.com/phpBB2/viewtopic.php?t=312371 ) [have not tested due to wanting isolation]
    6. user.info : Authentication fail after each http login




Router: DIR-825 rev B1
Firmware: dir825-firmware.bin (v3.0-r35874 std)
Kernel: Linux 3.10.108-dd #55198 Fri May 4 01:51:15 CEST 2018 mips
Status: Working
Reset: No
Notes on configuration:

    Media Network
    DNSMasq
    Port Forwarding
    DHCP reservation

Errors:


    1. user.info : Authentication fail after each http login

    Fixed with settings
    2. With no address in source Net of port forwarding (WAN fails) get:
    Dec 31 18:00:07 DDRouter user.err : Caught SIGSEGV (11) at 0x77b6f474
    Dec 31 18:00:07 DDRouter user.err : Fault at memory location 0x00000000 due to address not mapped to object (1).
    Dec 31 18:00:07 DDRouter user.err : Thread 684: startservice_f
    Dec 31 18:00:07 DDRouter user.err : === Context:
    Dec 31 18:00:07 DDRouter user.err : ZERO:00000000 AT:00000000 V0:00000000 V1:00000000 A0:00000000 A1:00000000
    Dec 31 18:00:07 DDRouter user.err : A2:00000000 A3:00000000 T0:00000000 T1:00000000 T2:00000000 T3:00000000
    Dec 31 18:00:07 DDRouter user.err : T4:00000000 T5:00000000 T6:00000000 T7:00000000 S0:00000000 S1:00000000
    Dec 31 18:00:07 DDRouter user.err : S2:00000000 S3:00000000 S4:00000000 S5:00000000 S6:00000000 S7:00000000
    Dec 31 18:00:07 DDRouter user.err : T8:00000000 T9:00000000 K0:00000000 K1:00000000 GP:00000000 SP:00000000
    Dec 31 18:00:07 DDRouter user.err : FP:00000000 RA:00000000
    Dec 31 18:00:07 DDRouter user.err : === Backtrace:
    Dec 31 18:00:07 DDRouter user.err : # [0x77b6f44c]: stack size 40
    Dec 31 18:00:07 DDRouter user.err : # [0x77b6f354]: ra offset 36
    Dec 31 18:00:07 DDRouter user.err : ???(+0)[0x77b6f474]
    Dec 31 18:00:07 DDRouter user.err : === Code:
    Dec 31 18:00:07 DDRouter user.err : 77b6f434: 02118023 8fbf0024 02021021 8fb10020 8fb0001c 03e00008 27bd0028 1000fff6
    Dec 31 18:00:07 DDRouter user.err : 77b6f454: 02208025 00801025 30430003 14600010 3c07fefe 3c068080 34e7feff 34c68080
    Dec 31 18:00:07 DDRouter user.err : 77b6f474: >8c450000 00a71821 00052827 00651824 00661824 1060000d 00000000 80430000
    Dec 31 18:00:07 DDRouter user.err : 77b6f494: 10600006 00000000 1000fffc 24420001 80430000 14600003 00000000 03e00008

    added 0.0.0.0/0 to Source and fixed

dannychow
DD-WRT Novice


Joined: 29 Dec 2016
Posts: 15

PostPosted: Sun May 06, 2018 8:58    Post subject: Reply with quote
nightwind209 wrote:
mwchang wrote:
Please note that the Source Net column in Port-Forwarding canNOT be blank. Use "0.0.0.0/0" instead.

you sovle my problem.
I add "0.0.0.0/0" all works.


Router: TP-Link TL-WR940ND v3
Firmware: 35874 std (05/04/18 )
Kernel: 3.10.108
Status: OK
Reset: No
Errors: None
Uptime: 19:21
*** But I also need to set the "0.0.0.0/0" for my port forwards. Otherwise, the local devices can't access the internet.
mwchang
DD-WRT Guru


Joined: 26 Mar 2013
Posts: 692
Location: Hung Hom, Hong Kong

PostPosted: Sun May 06, 2018 14:46    Post subject: Reply with quote
kartal wrote:
Is this a recent requirement? I never needed to do that.

mwchang wrote:
Please note that the Source Net column in Port-Forwarding canNOT be blank. Use "0.0.0.0/0" instead.

Previous builds always allow a blank Source Net. Maybe something's changed and accidentally introduced this bug if not feature.

OTOH, does those iptables scripts need "0.0.0.0/0" in its syntax? I frankly don't know. Maybe I should just keep using that string. Smile


_________________
Router: Asus RT-N18U (rev. A1)

May the Force and farces be with you! Live long and proper!

Facebook: https://www.facebook.com/changmanwai
Website: https://sites.google.com/site/changmw
SETI@Home profile: http://setiathome.berkeley.edu/view_profile.php?userid=211832
ta452
DD-WRT Novice


Joined: 03 Apr 2017
Posts: 4

PostPosted: Sun May 06, 2018 18:15    Post subject: Reply with quote
Router model: Asus RT AC66U
Firmware: DD-WRT v3.0-r35874 giga (05/04/1Cool
Flashed from r35531 with no reset

My router's 2.4GHz radio stopped working after upgrade.


Last edited by ta452 on Mon May 07, 2018 14:20; edited 2 times in total
labo
DD-WRT Guru


Joined: 30 Jan 2015
Posts: 675
Location: Texas, USA

PostPosted: Sun May 06, 2018 21:11    Post subject: Reply with quote
Router: Netgear Nighthawk X10
Firmware: DD-WRT v3.0-r35874 std (05/04/18v)
Kernel: Linux 4.9.98 #165 SMP PREEMPT Thu May 3 14:03:34 CEST 2018 armv7l

Router's 5GHZ radio stopped working after few hours of update.

Seeing many messages below:

May 6 21:00:04 durango-x10 kern.warn kernel: [24673.909232] ath10k_pci 0001:03:00.0: failed to read temperature -11
May 6 21:00:04 durango-x10 kern.warn kernel: [24673.915511] ath10k_pci 0001:03:00.0: failed to read temperature -11
May 6 21:00:14 durango-x10 kern.warn kernel: [24684.207440] ath10k_pci 0001:03:00.0: failed to read temperature -11
May 6 21:00:14 durango-x10 kern.warn kernel: [24684.213790] ath10k_pci 0001:03:00.0: failed to read temperature -11

_________________
ASUS RT-AX89X: Main gateway.
QNAP QSW-1208-8C 12-Port 10GbE Switch
Nighthawk SX10 10GbE Switch
1 X RAX120 WAP Bridge
1 X RAX75 WAP Bridge
Archer AX11000 WAP Bridge
2 X R7800 DD-WRT Mesh
2 X R9000 DD-WRT Mesh
78Mhz
DD-WRT Novice


Joined: 31 May 2018
Posts: 13

PostPosted: Thu May 31, 2018 18:51    Post subject: Reply with quote
Router: D-Link DIR-300 A1
Firmware: DD-WRT v3.0-r35874 std (05/04/1Cool
Status: No WLAN encryption does not work, no matter what you setup in the WebGUI
Reset: YES
makst
DD-WRT Novice


Joined: 24 Aug 2018
Posts: 2

PostPosted: Fri Aug 24, 2018 17:54    Post subject: Reply with quote
Router: Asus RT-N16
Firmware: dd-wrt.v24-36645_NEWD-2_K2.6_mega.bin
Kernel: 2.6.24.111
Status: LAN ports dead, WiFi works fine.
Reset: Yes
Errors: None

dd-wrt.v24-36645_NEWD-2_K2.6_mega.bin and dd-wrt.v24-36698_NEWD-2_K3.x_mega.bin have the same error.

dd-wrt.v24-33772_NEWD-2_K2.6_mega.bin works fine.
makst
DD-WRT Novice


Joined: 24 Aug 2018
Posts: 2

PostPosted: Fri Aug 24, 2018 17:58    Post subject: Reply with quote
Router: Asus WL-500G Premium v2
Firmware: 08-22-2018-r36698/broadcom/dd-wrt.v24_usb_generic.bin
Kernel: 2.6.24.111
Status: OK
Reset: Yes
Goto page Previous  1, 2, 3  Next Display posts from previous:    Page 2 of 3
Post new topic   Reply to topic    DD-WRT Forum Forum Index -> Atheros WiSOC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum