Kong Firmware and VPN connection problems. R7000

Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware
Author Message
James Greystone
DD-WRT User


Joined: 20 Nov 2011
Posts: 188

PostPosted: Wed Apr 18, 2018 1:08    Post subject: Kong Firmware and VPN connection problems. R7000 Reply with quote
I am currently running

DD-WRT v3.0-r33770M kongac (11/15/17)

on Netgear R7000 modem with privatevpn

Everything seems to function properly.

I like to keep the firmware updated however:

The next 2 available beta and non beta give me a problem with OPenVPN.

The VPN says connected however the
Local Address:
Remote Address:

are blank.

When I go to a site to check it confirms my VPN is not working.

I have tried most everything short of erasing VRAM since I never had problems with previous firmwares.

Would it help if I posted the Syslog?

Much appreciated
Sponsor
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 146
Location: UK

PostPosted: Wed Apr 18, 2018 2:40    Post subject: Reply with quote
I also use PrivateVPN with the OpenVPN client GUI. I only set this all up last week. I had a few issues to begin with, but soon realised that the Firewall Protection (in the OpenVPN client GUI) needs to be set to 'disable' for your VPN to connect.

I'm using Brainslayers latest build (R35681) on an R8500, and it's all working great...



OpenVPN GUI.png
 Description:
 Filesize:  41.33 KB
 Viewed:  2837 Time(s)

OpenVPN GUI.png




Last edited by buffalo0207 on Wed Apr 18, 2018 3:18; edited 4 times in total
buffalo0207
DD-WRT User


Joined: 30 Apr 2014
Posts: 146
Location: UK

PostPosted: Wed Apr 18, 2018 2:57    Post subject: Reply with quote
I also had an issue with the OpenVPN Client not starting up after a reboot. I originally had to keep clicking 'Apply Settings' on the GUI page every time after a reboot. However, Eibgrad (a Guru on here) suggested an OpenVPN Startup script to get the VPN to restart properly...


# OpenVPN Restart Script
(
if [ "$(nvram get openvpncl_enable)" == "1" ]; then
while ! ping -qc1 -w3 8.8.8.8 > /dev/null 2>&1; do sleep 10; done
killall openvpn && sleep 5
while ! openvpn --config /tmp/openvpncl/openvpn.conf \
--route-up /tmp/openvpncl/route-up.sh \
--route-pre-down /tmp/openvpncl/route-down.sh \
--daemon; do sleep 10; done
fi
) &



Just copy and paste this into the Administration > Commands window and click on 'Save Startup'

Also, make sure you have your PrivateVPN username and password saved as a 'Startup' too. Just put this above the 'OpenVPN Restart Script'.

# PrivateVPN Username/Password
echo "YOUR_USERNAME
YOUR_PASSWORD" > /tmp/openvpncl/user.conf


I'm assuming you have put the CA Cert file and TLS Auth Key in their relevant windows, and auth-user-pass /tmp/openvpncl/user.conf path location in the Additional Config of the OpenVPN GUI. This is all on the PrivateVPN instructions page...

https://privatevpn.com/support/getting-started/routers/ddwrt/openvpn-older-version

I hope this all helps...
James Greystone
DD-WRT User


Joined: 20 Nov 2011
Posts: 188

PostPosted: Wed Apr 18, 2018 12:11    Post subject: Reply with quote
buffalo0207 wrote:
I also use PrivateVPN with the OpenVPN client GUI. I only set this all up last week. I had a few issues to begin with, but soon realised that the Firewall Protection (in the OpenVPN client GUI) needs to be set to 'disable' for your VPN to connect.

I'm using Brainslayers latest build (R35681) on an R8500, and it's all working great...


Thanks for the tip.

I disabled the firewall and am using the latest Kong version and now the VPN connects again.

I will add and check the script you posted when I have some time.
pena1348
DD-WRT Novice


Joined: 09 May 2011
Posts: 24

PostPosted: Wed Apr 18, 2018 12:23    Post subject: Reply with quote
Sorry to throw a fly into the ointment, but I have firewall protection enabled (latest Kong) and OpenVPN connects without any issues. This may be strictly a 7000 issue.

P
James Greystone
DD-WRT User


Joined: 20 Nov 2011
Posts: 188

PostPosted: Thu Apr 19, 2018 0:26    Post subject: Reply with quote
pena1348 wrote:
Sorry to throw a fly into the ointment, but I have firewall protection enabled (latest Kong) and OpenVPN connects without any issues. This may be strictly a 7000 issue.

P


thanks :*(
mac913
DD-WRT Guru


Joined: 02 May 2008
Posts: 1766
Location: Canada

PostPosted: Thu Apr 19, 2018 3:12    Post subject: Reply with quote
pena1348 wrote:
Sorry to throw a fly into the ointment, but I have firewall protection enabled (latest Kong) and OpenVPN connects without any issues. This may be strictly a 7000 issue.

P


How do you draw that conclusion?

buffalo0207 posted he has R8500 and it required Firewall Protection to be Disable too. The common denominator is they are both using OpenVPN Services from PrivateVPN.

_________________
Home Network on Telus 1Gb PureFibre - 10GbE Copper Backbone
2x R7800 - Gateway & WiFi & 3xWireGuard - DDWRT r50963 Std
R7000 - Wired ISP 4K IPTV Gateway - DDWRT r50963 Std

Off Site 1

R7000 - Gateway & WiFi & WireGuard - DDWRT r50963 Std
E3000 - Station Bridge - DDWRT r49626 Mega K4.4

Off Site 2

R7000 - Gateway & WiFi - DDWRT r50963 Std
E2000 - Wired ISP IPTV PVR Blocker - DDWRT r35531


YAMon 3.4.6 | DNSCrypt-Proxy V2
mpouls1
DD-WRT Novice


Joined: 19 Jul 2017
Posts: 15

PostPosted: Fri Apr 20, 2018 23:38    Post subject: Reply with quote
I have the same problem with R7000 using NordVPN.

I used to do a scheduled weekly reboot until I realized my VPN kept disconnecting on start up and I would have to do as posted above. Disable OpenVPN client, save, then enable, save and apply setting and then it works. A real PITA.

I currently have firewall protection enabled.

Thanks Eibgrad for the fix and buffalo for posting that script! Going to try that.

edit: just tried out the fix and success!

_________________
ASUS RT-AX88U
- OEM firmware
Netgear R7000 (secondary VPN router)
- DD-WRT v3.0-r47596 std (10/25/21)
- NordVPN
Display posts from previous:    Page 1 of 1
Post new topic   Reply to topic    DD-WRT Forum Index -> Broadcom SoC based Hardware All times are GMT

Navigation

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum